Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Blazer GMC Jimmy Transmission Problems

2456719

Comments

  • Pull the codes and see what they are. Check the adjustment on the shifter cable on the side of the trans.
  • Pull codes from trans. Have filter replaced and pan cleaned - long time to sit. 97 (only) have a known ignition switch (name but actually the ign module in the column) that can cause many problems with many componenets.
  • gotta 99 blazer 2 door 4wd 4.3l The transmission knocks when stopped in drive but does not knock in neutral or park, whats going on?
  • You sure it really is the trans and not some engine part as thats when the rpms drop as the converter loads up. Check fluid and if you have never changed, as most, do the trans filter and fluid thats first and see whats in the trans pan. Then as a helper puts it in drive with foot on brake and e-brake on look under the hood and see if he AC compressor or alternator is dragging. Shut off and look under hood again at the belt and AC and alt. Then if its only when you first put it in drive thats a GM trait due to clearance in the rear diff, or u-joints if worn out, or transfer case.
  • ok ill try changing the fluid, gottanother one for ya, when turning at low speeds right wheel makes one loud pop every once in a while??
  • Lower ball joints are the #1 reason - jack it up and grease them and uppers and the other zerks on all the linkage and have to remove the front plastic skid plate to get to the idle arm front one - like 10 or so total. If that doesn't do it look at the CV axles are the boots ripped and any grease coming out. Then the hubs, brakes, or the classic hood shifting at the hinge bolts - yes GM added a spring washer to each side to fix so carefully place a rag in between the fender and hood and close (do not bend anything and see if thats it.
  • 99 blazer 2 wheel drive, never had a transmission problem until the intake manifold gasket leak was repaired. Immediately after repair transmission will not shift properly. Goes in and out of gears at will during all speeds. Occasionally wont start. We checked fluid level everything is okay. Not sure what was done to make this happen all of a sudden when I have NEVER had a trans problem. Any suggestions!! I am scared I am going to mess up my transmission. When I am on the highway I have to lift my foot off the gas in order for it shift gears. Also when I shift gears , it shifts real hard.
  • Probably they did not connect a sensor properly after the intake done so all lines and connectors need to be rechecked. Shop should do it that did the intake. Could be a vac line leak also. When was the trans filter last changed (every 50k)? 4L60E trans do have some known hard shift conditions due to dirty fluid and a TCC solenoid problem but often a filter change fixes. Finally any SES light on and codes?
  • I have a 1997 Chevy Blazer. Got it for a steal! Truck has 138,000 miles on it and was a highway driven vehicle I bought from a friend who I trust when he tells me he had no issues with it. soon after I purchased it the fuel level gauge stop working. I replaced the level sensor with a genuine GM part and the gauge works but bounces when I turn on the turn signals? First problem :(

    We towed my boat to and back from Canada with no issues other than the bouncing fuel level gauge and since then have driven the vehicle for approximately 5K miles. My wife broke the hazard switch and the heater core started leaking a little, no real problem that I can not deal with. Now the vehicle intermittantly stalls while driving just like someone turned it off however the electrical power remains? Most of the time after it stalls it starts right back but sometimes lately it is difficult to start. I really do not even know where to start? The fuel pump sounds normally at ignition start. I am confused please help?
  • repairdogrepairdog Posts: 948
    Again, see all the posts on the known 97 only problem ignition switch (the connector and wiring acually) in the column - not key/tumbler - so do that first. May solve all problems.
  • Great, where do I find those posts?
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,979
    Most of them seem to be in the Chevy Blazer/GMC Jimmy: Problems & Solutions discussion. Try using the Search This Discussion tool for "ignition" to break them out.
  • I have a 1998 blazer 4 wd automatic. It does not have 2nd gear or go into overdrive. I have replaced three of the soleniods, the 1-2 shift, the 2-3 shift and the 3-2 shift solenoids. This has not fixed the problem. Should I replace the govenor pc valve?? The oil was not burnt and no major amount of shaving found in oil. It does not shift hard or have any funny noises. I am stumped!! please help. :confuse:
  • repairdogrepairdog Posts: 948
    Hope I am wrong - did you lose reverse, 2nd, and 4th gears? If so thats the weak part in the 4L60E trans called the sun shell and the neck breaks off and trans rebuild time. See the tciauto site for pics and more info. If have reverse then suggest a trans shop attach their diagnosis tool and pinpoint the piece.
  • brenr3brenr3 Posts: 2
    I have a 98' Blazer with 75K miles on it. The transmission has shifted smoothly up until about 1 week ago. When I start the truck and begin to drive, it shifts smoothly. After a few minutes of driving, the battery light comes on and the airbag light flashes. They both go off after a few seconds. The next time I come to a complete stop and accelerate, the truck shifts very hard between 1st and 2nd gear and continues to do so until I turn the truck off.

    Example: Last night I began my commute home from work, the truck shifted smoothly. While waiting at a stop light, the brake and airbag light came on again. The truck shifted hard between 1st and 2nd gear the entire drive home. I parked the truck in my garage and went inside to get my wife. No more than 5 minutes later we got into the truck, turned it on and went for a drive. The transmission shifted smoothly as I drove through my neighborhood. This morning, I started it up, it shifted smoothly until the lights came on again. What is up with my truck? I have a hard time believing it's the tranny, it has been completely fine up until last week.
  • repairdogrepairdog Posts: 948
    Sounds like 2 diff problems. Get the transmission filter changed and that will get you 5 qts of new fluid and a clean pan (has a magnet in it to catch small shavings) which usually fixes this hard shift caused by a TCC unit that usually gets crap in it and then the pump goes to max pressure so hard shift. Also possible TPS on throttle body acting up - this tells trans throttle position to shift at.
    Airbag light could be from a bad connector in column, or on the two front under frame mounted sensors, or the fuse.
  • brenr3brenr3 Posts: 2
    You think it's two different problems even though the truck only begins to shift hard after the airbag light and battery light flash for a few seconds, then go away?
  • how do you get the darn thing out lol
  • Same answer as in the other post.
  • tmillsdtmillsd Posts: 2
    HELP, I have changed the transmission (new) all shift sensors and still have the same problems as the old transmission, will not shift into higher gears (automatic), does shifts ok in 1 and 2 but no higher.I am at a loss. So in other words it was not the transmission but something else.
Sign In or Register to comment.