Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Kia Sedona Starting/Stalling/Idling Problems

178101213

Comments

  • Did you ever find out what was wrong with your Sedona van, and what did it take to get it fixed? Mine is doing the same thing. When driving it will suddenly jerk and lose power then will resume speed when the gas pedal is pushed. It has also stalled completely at a traffic light. Sometimes the engine light comes on, but not always. The KIA dealer things the ECM (Engine Control Module) needs to be replaced with is a very pricey part (over $1,000 for the part). I'm very interested in finding out the outcome to your problem. Thanks.
  • I had a full service done at the time of finally getting it fixed. However, it seems likely that it was the TPS (Throttle Body Position Sensor). That was changed (along with new plugs, a new timing belt. Hope this helps. (mine was a '05 Sedona van, not the '04 mentioned above...and not same problem. my check engine light never came on, and would only stall at high heat situations when giving it throttle from slow speed or from a stop...but had to be very hot to happen...usually meaning a hot day and in bumper-to-bumper traffic).

    There was a service bulletin out of California that mentioned the TPS as the fix for this high-heat stalling issue; and it seems they were right. Why??? Don't ask me, and the guys at the dealer couldn't figure it out either.
  • sedona02sedona02 Posts: 3
    Not sure who I am replying too, but yes, I did find out what was wrong, at least it has not had the problem since getting fixed. A AAA mechanic thought it might be the crank sensor, and we asked kia to put it in, they did not really want to but did. We also asked them to check the throttle position sensor to see if was malfunctioning, it was not. They also replaced the timing belt at the same time as the crank sensor, as it had never been replaced. Ironically when we got the car back, one rear door that would not automatically lock anymore started working again. The car does not die out anymore and we are glad. Though last week the drivers power stopped working. This car is plagued with electrical problems, we have spent so much money on it, and for sure are getting rid of it soon.
  • I am glad I found this message board. I have a 2006 kia sedona. we have been having problems with it starting up for almost 2 years. It only has 64000 miles on it and has been in to their service dept too many times to count. They of course keep telling us they cant duplicate the problem. We have been forcing the dealership to put us in a rental car at their expense every time we take it in there. The last time they had the vechile was for the last two and a half weeks. To no avail they did not find anything they replaced the junction box assy this time. Big deal. We picked it up on Saturday at 12 pm and today Tuesday at 5.30 pm the vechile would not start. It has all power but the ignition switch was extremely hot and I smelled a burning smell. Needless to say I got on the phone with the dealership and they sent their service manager in a suit and tie out to inspect the van. As of right now 10.00 pm eastern standard time it is still in the parking lot of my children's daycare where a tow truck was suppose to pick it up approximately 3 hours ago. And yes again we are in a rental car at their expense because the service manager could not understand or get it to start. So much for them not being able to duplicate the problem now he has seen the duplication. Now they have it set up to be in a rental car so they can again tell me they cant find it. I am thinking of contacting an attorney to find out what can be done it is really crazy and I am getting sick of dealing with it. I am forcing my dealership to take this matter and fix it. I am tired of being inconvienced with this problem. I have five children and I was just waiting to get stranded with the youngest ones and now i am gonna blow a gasket so to speak. I have been reading these messages but cant seem to find the problem solver to this situation. Any suggestions before i go crazy?? :lemon: :lemon: :lemon:
  • I understand your frustration!! I have a 2006 Kia Sedona EX with the same intermittent no start problem going on for over a year now. Turn the key and all indicator lights come on, radio and a all accessories work but no response from starter. In my case if I wait 5-10 min it will eventually start. It acts as if it is not in "Park" when trying to start. I've had it in the dealership several times and they can never replicate. Dealer has replaced 2 IPMS, checked battery, starter, relays, connections etc. They refuse to check the ignition switch because Kia corporate says they have no record of this problem related to ignition switch. Dealer wants me to leave it in the shop indefinitely until they can get a DTC but won't pay for a rental car. I have 4 small kids and can't afford a rental or be without the van that long!! My wife is terrified she'll get stranded somewhere with the kids. I've been doing a lot of research online and this problem does not seem to be uncommon, especially with the 2006 model. No one ever posts a solution, though. Dealer has pretty much told me that unless they can replicate there is nothing they can do--aaarrgh!!. Getting ready to call Kia consumer affairs to see if I can make any headway. Would you please post if you find a solution? I will do the same.
  • tekkatekka Posts: 3
    edited April 2011
    Thank you for sharing this with me, last month I had fixed the problem myself, what I did is, I Install a cable bypassing every thing, from the battery to the solenoid and I waited till it happened when the starter will not turning, so I used that cable and still did not turn although there is a closed circuit, which means that the solenoid coil is leaking voltage when it is warm due to heat expansion, so I went a head and replaced the starter with solenoid since no body sales solenoids any more, since then I did not have any problem, please let me know If you need any help.
    Thanks again
  • mfoltinymfoltiny Posts: 1
    I have a 2004 sedona ex. It has been in the shop four times in the past four months , three times in past two to three weeks. two different garages different mechanics. the van starts runs for a few seconds/minutes and then stalls. the mechanics could not find anything, nor could they mimic the condition I pick up again, drive to work and it does not work that evening. fuel pressure is fine, starter is fine, replaced cam sensor, all major tests find nothing wrong. last time they found that air filter box was not connected below. if this does not work they think it is in the harness(wiring). I am tired and frustrated. I am afraid to take to work, especially with kids. the van served it purpose but feels like the lottery to win a car. if you put the key in and it starts you won. more frequently I wonder when leaving if I will have to wait over an hour for tow truck, find a ride and take a train. waiting for finances to change and get rid of. dealer too expensive to deal with. mine has 123,000 miles.
  • fdupmomfdupmom Posts: 1
    I have had a similar issue with my Kia Sedona 2006 LX. The engine light goes on and off I start the car then it shuts off on its own. Then when it gets going it rocks up and down the road. When I stop the car to get out it locks the ignition and keeps the key I have to unhook the battery to get it out. Tow truck on its way to take to dealer ship to check it out. No one will touch it because its a electrical problem that the dealer ships needs to reprogram. Kia is full of it if they say nothing is wrong with the ignition or any thing alse.
  • robin78258robin78258 Posts: 1
    I have the same problem too, I took it to a midus shop and he said he has seen the same problem with toyota and if you open the trunk and side door it will start...something with the remote control...my remote control key is out too, ordered two more and still won't work....my car will start after a min or so...i just key turning tell it starts,,,sometimes if i leave my window cracked I don't have that problem, I've found....but not always...but lately it's been nearly everyday now since the weather is warmer...Let's all write Kia and complain..as soon as possible...
  • Update...My 05 Kia Sedona Van has been fixed. The Kia repair shop returned the car to us to drive further before they replaced the costly ECM as the only codes it it had registered were P0154 and P0134 (these were in the memory and were only symptoms of the cause of the problem). The evening after we picked it up it stalled and died while driving. After sitting awhile it restarted and we got it home. However, it died while driving two more times before we had it towed to the shop on Monday. This was dangerous as one of these times it died at a busy intersection. This losing then regaining power problem had now turned into downright dead stalling. This time at the Kia repair shop it flagged a P0337 Code indicating it needed a new CRANK ANGLE SENSOR. Luckily, a part covered under the extended service warranty we had purchased. It has been over a month now and we have had no problems driving it since. Hope this update helps someone else who may be experiencing a similar problem.
  • thillierthillier Posts: 1
    i had have a 2004 kia sedona it starts and runs for 5 min then shuts off no warning it getting fuel checked that wonder if anyone else has one with same problem if so did you find the problem and how did you have it repaired thanks
  • gatottengatotten Posts: 8
    The fuel pump (in tank) has a filter screen on the intake to keep the pump from getting damaged. It can clog and cause the symptoms that you describe. Also, the pump can start - run - and then fail in a repeated fashion. The most likely cure is to have the fuel pump replaced. A good mechanic can check the fuel pressure while it's running so you can be sure that it's a fuel problem - not an electrical one.
  • cbooecbooe Posts: 1
    I have 2005 Kia Sedona. g">ot in van to leave for appt. friday key would not turn either way. I called my husband who is my certified Mechanic. It has just over 100,000 miles have had thia problem before but he always got it to start but not this time. he started taking apart and it released while he was taking apart. So how do we fix the problem . I can't afford to be stranded. My Parent rely on me to transport.
    Thanks
    Cindy
    :confuse: :mad:
  • jcarrerajcarrera Posts: 2
    there is a tsb from kia for your issue have your dealer look up ipm,
  • Hi,i too have the same problem with my kia.. If it doesnt want to start when you turn the key,hit the underside of the steering collum with the palm of your hand,you need to hit it hard about 3 times.. Then it should start right up.. What is happening is the security brain is inside the collum,and it thinks your tryn to steal.. So it interupts the ignition from engaging the starter.. And kia will not admit the problem,my friend is a service manager for kia.. To me of the simple fix.. It actually needs a new security brain installed,it cost around 350.00 and is simple to fix,but dealer does beed to install,after main computer needs to be updated... I hope this helps you guys.. I know the frustration that it can cause.. When you smack the underside of the steering collum it resets.. And will start up.. But dont look for your dealer to help you,kia has them on a no talk about it order.. But its a known update that you must pay for.if you have over 60,000 miles... Bob.. PS let me know if that helps
  • Bob,
    Thanks for the response. I've always suspected it had something to do with a security glitch but my Kia dealer wouldn't hear anything of it. I'm going to give this a try. I wonder why Kia wouldn't just fix this (at $350) vs. replacing 2 ipms costing thousands? Go figure.
  • Interesting, but how does smacking the bottom of the steering column reset and eletriacl component. If you turn the key and the starter won't engage sounds electrical to me. Plus the all the "brains" are electrical.
  • I have a 2005 Kia Sedona (133,00 miles) ... we recently changed the fuel pump sensor and now both O2 sensors needs to be changed. We are getting ready to take a 1200 mile vacation from texas to ohio. Does anyone know if it is dangerous to not fix right away? I have asked the professionals but no one has said its urgent... has anyone delt with this problem?
  • Hello,
    Our Sedona has about 107,000 miles on it. It started the stalling problem in September. I was leaving work and coasting to a stop out of the parking lot and it just shut off. I thought, that was odd, but continued to drive after restarting it right away. I drove a few more miles and while sitting at a red light, it stalled again. It started up right away and I drove a few more miles home. The next day, I set out for a 400 mile trip in it at 5 a.m. About 10 miles down the interstate it gave a good jerk. I thought I lost the cargo carrier of the roof of the van. What had happened was it stalled and restarted. It felt like it was bump starting. It did it again about 30 miles later, then again about 10 more. But, the whole rest of the trip it was fine. While I was at my destination, I started the van up in the parking lot and let it run while I was charging my cell for a bit. It stalled at one point, but then restarted right away. Then, the whole drive home (400 miles) it did not do anything and ran fine. About a month ago, I drove it about 100 miles away and it stalled at an intersection and would not restart. Tried and tried. It was cold (about 35 degrees) and the kids were getting pretty cold inside the broke down van as we waited 3 hours for AAA to show up. Ice on the inside of the windows cold. I'd try it every once in a while, but it wouldn't restart. However, on one occassion it did. It ran for about 10 minutes and then stalled and wouldn't restart. The tow truck brought it home. When I got home the same night, I got in it, started it, and drove it into the driveway. Needless to say, I'm afraid to drive it anywhere. I don't mind spending money to fix it, but I don't want to spend money on the wrong thing.

    I've had people mention the fule pump. I've seen people mention a crank shaft problem of some sort. Some have said maybe electrical... I just don't get it. What is the problem? Others on here have had the same exact problems as me.

    Also, a couple years ago, we started getting the check engine light. It seemed to be for no reason. The van ran fine. There were no problems. Took it to Autozone and they said the code was indicating some sort of sensor in the neck of the fuel fill that might be bad. But, I didn't worry about it. I thought maybe the cap didn't get tighted right or it was overfilled or something.

    Please help with the stalling issue though. I would really appreciate it!

    Thanks!
  • Congratulations you got 107,000 miles out of yours before it started. My 2006,even today, only has 16,286 miles on it and it has had me on the side of the road in Kansas for 4 days becuase it kept stalling and whne I take it to KIA they can not find anything wrong and are not really interested in finding it since it is 5 years old and out of warranty yet I paird $824 for the 120 yr 100,000 mile warranty. Next time I buy Buick at half the price I paid for th eSedona
Sign In or Register to comment.