Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Tahoe Electrical Problems

2456715

Comments

  • my cargo door ajar light will not go off, there is no obstruction and I dont know what sensors might be malfunctioning
  • Any ideas? I attempted to start my tahoe this afternoon. It barely turned the engine a smidge and then clicked a few times. I heard the vehicle speakers clicking, quickly turned off the radio, and it continued to click for a minute or so. Tried to start vehicle and got absolutely no power. With a jump, go it to start, pushed on break and put in reverse and it died before it started moving. Couldn't get a good start after that. I few hours later, came back with high quality(4gage) cables, started it, backed it out and drove it home (3 miles). I tried to reproduce problem with loading electrical (AC/ back window defroster, lights, etc.. It continued to work, but periodically the RPMs would drop by half and lights would dim. Then, suddendly died and absolutely no power. (battery is new and tests good.) It is as if a master switch of some sort was shut off. If I provide an external jump, I believe it will start or get power in the vehicle again...ran out of daylight. Any ideas would be appreciated.
  • kiawahkiawah Posts: 3,666
    The symptoms sound like either a bad battery, loose/corroded terminals or wires connectors to the battery, a bad alternator which isn't charging the battery up, or something is defective and is draining the battery down while it sits.
  • help22help22 Posts: 1
    I have an identical problem in my 03 Tahoe with only 49,000 Miles , HELP PLEASE , How did you correct the problem?
  • nwpnwp Posts: 1
    I have a 1999 Chevy Tahoe Z71. I recently replaced the 5.7 with a GM Performance HT383E engine. The engine is touted to have 322 HP and over 430 lb ft of torque when mated with OEM injection, exhaust intake, parts. While the engine is stronger, it is not representative of the claimed increases. I had already fitted the 5.7 with edlbrock headers, a flowmaster cat back system, an AEM Brutforce Intake, and a SUPERCHIPS power programmer. These additions made significant and noticeable gains on the OEM engine with 160K miles. When I put the new engine in, I was able to mate all those bolt-ons in the swap. However, it doesn't produce the neck snap one would expect with almost 100 more HP and 100 more lb ft of torque from factory specs. It just seems to be starving. It sounds really mean and has a noticeable lope with the stroker configuration, and it is a little more peppy, but opting for a $5k upgrade instead of a $2k upgrade is simply not being realized. I'm wondering if I need a high-output igntion system to aid in the burning of the fuel. I've noticed that the residue leaving the tailpipe is leaving a good bit of soot, indicating unburned gas escaping.

    Now...onto other new issues...the truck idles with a slight surge, sometimes elevating to a rise in RPMs, countered by a reduction that almost mimicks dieseling. In addition, my wipers only work randomly and start and stop on their own. My AC blower is also not working all the time. Sometimes all the settings work and sometimes only some of the settings work, and sometimes none at all. Also...my previous engine lost oil pressure and the gauge moved a bit back and forth for a few minutes. When the truck was returned to me after the swap , the oil pressure gauge was stuck on a wide open (far beyond the highest pressure reading) position. It does not fluctuate or bounce at all regardless of engine speed.

    So...that's about it... I love my truck. I was eagerly anticipating the performance beast I put under the hood. It seems I didn't get much of a bang for my buck and I now have "gremlins or ghosts in the electrical system". Any ideas?
  • I have a 2003 Tahoe and I am unable to turn off the headlights at night when the vehicle is parked. I have had people tell me to hit the dome over-ride button three times in a row and it will shut them off, however it does not. Someone also told me to set the emergency brake. I have done that as well and it still does not turn them off at night. I called the local dealer and they do not have any other information. Does anyone have any other suggestions?
  • kiawahkiawah Posts: 3,666
    Well not sure how you are keeping your battery from going dead, until you figure out the cause of this problem. Consider pulling the fuses for the lights, or the relays. Be sure to put them back before needing to drive at night.
  • Sorry I just realized that it seems as though the lights are staying on when the ignition is turned off, but that is not the case. What I am asking is how do I shut the headlights off at night while the vehicle is still running and it is in park
  • kiawahkiawah Posts: 3,666
    In our 97 Burb, that was done by putting the parking brake on. In our 07, you turn the headlight switch from "auto", counterclockwise to the "O" position.

    I think your 03 is more like the 07, but I believe it's written up in the owners manual one way or the other.
  • I have a 99 tahoe. my dome like , gauge lights headlights, pertty much all lights flicker all together very. any ideas?
  • 2007 Tahoe 20,000 miles doors lock on their own after I have left the vehicle. the low fuel light comes even if I have more than a half of tank. the radio lights go off. again this is not a regular occurence and don't happen at the same time. The dealer says they cannot duplicate the problem. I'm concerned these problems are symptomatic of a larger problem that won't show up until after the warranty has expired. For what it's worth this is the first American vehicle I've purchased in years and may be my last. The hassle of taking the car in and arranging transportation is really irritating
  • I also have 2007 Tahoe and experienced electrical shutdown of my vehicle traveling @ 70 mph and lost all power however lights and gauges remained on but in failure mode.
    Received warnings of drivetrain failure. Had to have vehicle towed to dealership with them unable to duplicate problem. They replaced my battery and said that was most likely the problem. Never had a dead battery experience while driving @ 70 MPH. Would seem if battery was dead how did it just die while on the highway for over 4.5 hrs and no warning of alternator or electrical issues other than just drivetrain shutdown.
    That was Dec of 2007 never got good reason.
  • ahpahp Posts: 1
    I have a 2007 Tahoe with 35,200 miles. A couple weeks ago, while driving down the road, the interior lights would come on and then the door locks would click. I took it to the dealer and was told that it was caused by the security system. The dealership we purchased the vehicle from, which is now closed, installed a "clifford system" to the car. The dealer charged me $100 to disconnect the clifford. This was not under warranty because even though we bought the car with it, they consider it an after market part. If the dealership was still open, they would have taken it off for free. Well they take that off and the car locks are still unlocking/locking while driving and now the interior lights will not turn off. The battery started draining. We had to get onstar out for them to jump start it. I go back to the dealership and now they say it is the door module. They order the part and I make my third trip back there. That didn't fix the problem, so they switched out the bcm module. They then proceed to tell me that it could be the DVD player, which they also consider as an after market product, could be causing this. Now they want $150 to disconnect the DVD player to see if that is the problem. Also, the engine hours were reset and the horn doesn't work when you lock the doors. Basically, the dealership doesn't have a clue what the problem is. My question to you all is, has anyone had issues like this before? I have called Chevrolet about this but they are no help. They keep blaming it on the dealership that is no longer in business. I feel like if I bought the car with the clifford and the DVD player, why shouldn't it be under warranty? None of the paperwork we had signed said anything about the parts being after market.
  • We have an 07 Tahoe with no aftermarket equipment at all. 52,000 miles We have the factory DVD player and are also having intermittent electrical problems. It started with the headlights and interior lights flickering. It has progressed to failure to crank or stalling while running and it will not restart. Sometimes accessories will stop working properly, the radio will not turn off, or we cannot call Onstar. All of this is intermittent and of course the dealership has no clue. We spent $150 for them to change a faulty ingition switch only for the trouble to continue. It leaves us stranded, requiring a jump start around once a week or once every other week. Damn thing has already lost half of it's value. I'd much rather fix the problem than have to trade it in. This is getting old though.
  • My daughters 99 tahoe/350 2 door dies sometimes while driving down the road. It will always restart and go on. I have heard that corrosion on an electrical harness or a sensor on the timing assy could cause this. Where is this harness and what would you try 1st? Andy
  • To any Tahoe/Suburban/Sierra owners who are experiencing undiagnosed or intermittent electrical problems involving the ABS light/Parking brake light /door locks/ message center/ 4wh drive buttons/ chimes/ etc etc I will identify the simple fix. This fix was suggested to me by a Tahoe owner who was experiencing the "Dashboard Disco" as I was on my 2003 Suburban Z71.

    The fix seems too simple to be valid but it has solved the issues on my truck so far.

    There is a black/yellow wire that is grounded to the top rear of the engine block on the passenger side of the engine. This ground connection evidently gets compromised by corrosion or oils over time, or it becomes loose. I cleaned the surfaces on my truck and reinstalled the ground. I have not had any electrical issues since doing this.

    Regardless of whether you believe this could fix the problems you may experiencing it is certainly worth a try.
  • steverstever YooperlandPosts: 40,153
    Great tip, thanks!

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Have you ever found out the problem? My 03 tahoe is doing the same thing and noone can seem to figure out the issue. thanks!
  • jayaveryjayavery Posts: 4
    Don't know if you solved this or not; I just started here. But on my 2001 Tahoe you have to hit the dome overide 4 times not 3 as someone else suggested. Its also how my manual explained it.
  • jarbaughjarbaugh Posts: 1
    2003 Chevy Tahoe...two days ago "sound" on the radio gone, yesterday door locks quit, now the ignition is down. Two more payments and it is ours and I had a knot in my stomach about this until I read this message and am hopeful it is my issue too.

    It is definitely worth a try as it is dead-in-the-water. If I cannot do the work myself I will take this suggestion to my mechanic.

    Thanks for posting a possible remedy.
  • i have a 2002 tahoe z-71. car runs fine and starts great. while going down the road, the dash goes nuts. the message center flashes battery,security,low fuel. the gas gage and temp gages go up and down. the airbag, abs,seat belt light flicker on and off. oilpressure gage and volt gage are not affected. voltage reads 14.5 all the time this is going on. the other day i tried to get a look at the ignition switch. i took 2 screws off the bottom panel, but couldnt figure out how to get the big lower panel off. so, i got the 2 pieces off around the key and got a look at part of the switch. i just tried to move things, and in the process the car would only run in the start position. as soon as you let go of the key, the car died. then it started and worked ok untill the dash went nuts again. it has done this intermitently for the last 30k miles.i think i want to replace the ignition switch, but dont want to make a $164 mistake. any help would be appriciated.
  • cruzntymcruzntym Posts: 1
    I have a 2007 with the same problem. Check codes and 22 came up. Told dealer keep it and drive it because Battery dies. They have had the thing for 2 weeks now and It been fine. They are waiting to see what pops up in codes again. The Biggest thing is the Dome lights come on and the door locks go crazy. You know the battery will be dead when you try and start it!
  • Did you figure out your problem mine is doing the same thing
    muzzy7089@hotmail.com
  • I Have a 2003 Chevy Tahoe z 71. the problem is that while driving the battery light will turn on and and all the gauges will go down and power right back up. The car will not turn off just seems like battery is trying to die. I replaced my battery after car once dying. But now it is a brand new battery and i still get my battery light to turn on and off. Another issue is my reader states i need it engine oil and i have 4qts still inside. Please Help.
  • kiawahkiawah Posts: 3,666
    1.) Check for corrosion on battery terminals, and make sure they are very tight connections. Check the ground cable connection.

    2.) Have your alternator (and battery), load tested. This will test that the battery is able to hold the correct voltage, and put out the current required, under both normal operations and maximum load. The alternator will be tested to ensure that it is charging up the battery to the correct voltage, and all the diodes and control circuitry are working to output its' rated maximum current. Most autoparts chains will do this test free of charge.

    3.) If both of those are okay, then you will need some more indepth diagnosis on the main power buss (key switch, security system, main power relay, etc).
  • Thank you for your help much needed.
  • I have a 01. It has only happened to me twice. I'm not sure if the problem has been solved. If I need to take it to the dealer will it cost me an arm and a leg Should you just start with a battery first?
  • abc129abc129 Posts: 2
    Has anyone been able to find out why the 07 Tahoe will just shut down when driving at 50mph? I have had similar problems and no one knows why. Any feedback would be appreciated.
  • I have a 1999 Chevy Tahoe 4dr 4wd that keeps burning up ignition modules. I have replaced it 3 times since January 1. Any ideas would help

    Thanks
  • eric69eric69 Posts: 2
    I have a 08 Tahoe and it recently did the crazy lights, door lock, and won't crank. The dealership replaced the main fuse. This seemed to fix the problem but NO. Know from time to time when you get in the car and it won't start. You wiggle the hot wire near the firewall and it finally gets a connection. I have been to the dealership 3 times and they can't replicate the issue. Any Suggestions?
Sign In or Register to comment.