Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Grand Am: DTC code P1404

arriearrie Posts: 312
Many GM built cars have a tendency to have the 'Check Engine Soon' light come on as a result of DTC code P1404. P1404 is described as EGR valve pintle stuck open, which in most cases is a false alarm. I had this happen with my '01 Grand Am. A little bit surfing on internet reveals that GM has a solution for the problem, a re-flash for the car's computer.

A software re-flash as a fix kind of indicates that the vehicles with this problem were built with it but I don't think GM will be re-flashing cars outside warranty for free. They will want their $100 for it.

Some hands on people I found had purchased a new EGR valve and changed it but the problem remained.

Possible reason (very likely) for the false P1404 code is that the plastic piston of the EGR valve position instrument (LVDT?) wears over time and starts reading a different position at valve closed than what it was when the EGR valve was first installed.

When the car was built and the computer circuits energized for the first time the computer learned the EGR valve closed position signal from the valve position instrument that is built on top of the valve itself. Over time, when the instrument wears, a slightly different signal is sent to the computer and when it differs enough from the 'Valve Closed Signal', that the computer had learned, the trouble code P1404 is set and the 'Service Engine Soon' light comes on.

Replacing the EGR valve with a new one does not necessarily fix this problem because the 'Valve Closed Signal' between valves is slightly different and it is just pure luck if your new valve would give a 'Valve Closed Signal' close enough to your original valve's signal not to set the trouble code. This is why the new EGR valve 'Valve Closed Signal' must be re-learned by the computer.

So, what this all means is that if the P1404 is a false code meaning that the valve pintle is not stuck open, then new 'Valve Closed Signal' can be re-learned by the computer using the old valve.

For fixing this problem the tool you need to have is a simple OBD II code scanner that can be used to erase trouble codes. There are many scanners of different price range on the market. I purchased one from AutoZone for about $90.

A code scanner is a very handy tool to have and I recommend everybody who is just slightly hands on type of a person to get one. It will end up saving a lot of money over time.

The fix goes like this:

1. Disconnect the wire harness from the EGR valve.

2. Turn key ON and erase the trouble code(s) from the car's computer AND TURN KEY OFF IMMEDIATELY WHEN THE SCANNER SAYS CODES HAVE BEEN ERASED. DO NOT TURN KEY ON BEFORE YOU RE-CONNECT EGR WIRE HARNESS.

3. Re-connect EGR wire harness and your problem should be fixed.

I learned this fix from OBDII.COM where carfixer and kozloski discussed it and I think kozloski was the one who provided the solution, so thanks to them.

There was also other people stating that this fix really works. Now I have joined this group of people as I got mine fixed using this trick also.

I believe erasing codes with wire harness disconnected and turning the key OFF right after P1404 code has been erased re-sets the 'Valve Close Position' reading in the computer and triggers computer to re-learn position next time the key is turned ON.

If you don't have an OBD II scanner and don't want to buy one some car part stores may erase the code for free, but if you have it done there you must tell them about turning the key OFF at the right moment. Other wise the re-learn process does not take place.

--Arrie--

Comments

  • This did the trick for my car ... at least to this point. Thanks for sharing the info.
  • This did the trick for my car. I had p1404 (I have my own scanner and know cars pretty well) on my 2001 Impala LS and it passed all electrical tests (it was getting proper voltage from the PCM and the battery) so I replaced the valve/sensor assembly and cleared the codes. The light relit within a matter of 10 miles. I made an appointment at the dealer to reflash and then found your post. Now, the EGR monitor reads ready with no fault codes. I suppose that disconnecting the battery long enough will do this, but then you have that issue with the theftlock radio. Awesome and thanks for posting the information from the OBDII forum!!!
  • This fix seems to have corrected my error also, many thanks for posting
Sign In or Register to comment.