Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda CX-7 Check Engine Light

11314151618

Comments

  • astegmanastegman Posts: 171
    zewiw1, it will be VERY interesting to see what happens this winter when the temps drop here in Connecticut (Fairfield County). The reason I thought my car was unique with regard to the CEL/cold weather was that no one else in this forum encountered the same experience last winter. In some ways, I am "glad" to read that you encountered the same occurrence...perhaps there was a particular batch of cars that all share this "problem" but who can say? I quickly learned to ignore the CEL all winter, since it went away as soon as the temps got over freezing. Knock on wood, I've had no other issues with the car, so the constant CEL all winter simply fell into the "annoying but harmless" category, thank goodness. My car had its first birthday on August 12th, and I'm still enjoying it immensely, no regrets!
  • aviboy97aviboy97 Posts: 3,159
    Hopefully we don't have to see you come in again this winter for the CEL. Has it been fine in recent months?
  • astegmanastegman Posts: 171
    I am happy to report that I've only had one CEL since the winter - and that was the one rare time I filled up with gas at a full service station - and the attendant did not screw the gas cap on very well. I should have told him to turn it more than twice! Once the light came on, I re-tightened the gas cap, and within a day or so (or at least by the next tank of gas, I forget), the CEL disappeared. I'm on my 3rd gas cap, but I always tighten it at least 6-8 times when I get gas.
  • rex10rex10 Posts: 24
    I left the car in long term parking for 5 days at the airport. When I got back I was welcomed with my 2nd CEL (I'm at ~9000 miles - I got the new gas cap last time at 700 miles). I made an appointment at the dealer, in the meantime the light went out after a couple of days. I brought it in anyway and they want to replace the fuel filler neck. After one week I got the car back because the part was on national backorder. I'm finally now taking the car back in again for the part to be replaced.
    At least the MPG's have gone up over the summer, but I still haven't ever gotten anything better than 22.4 MPG on a tank, even coming down from the mountains driving 65-70 MPH. They did re-flash the computer and the turbo lag is drastically reduced. I have to "re-flash" my right foot now to get used to it!
  • bigdadi118bigdadi118 Posts: 1,207
    I have a MPV and using Mobil-1 since the odo passed 10K. Some said that let the seal settled with regular engine oil for the first 10K mile. The mileage now is at 37.5K and the motor oil color is so clean on the dipstick. All mechanics saw it will give this a thumb up.
  • Got yet another CEL the other day (I've had so many I have lost count). When I went to fill the tank it looked like the cap had come loose. I usually click the damn thin 10 times due to the known issues. This is my 2nd cap. Maybe I need a 3rd?

    #$%!&^@*#&! !!!!!!
  • Ditto. Same here.

    -c92
  • bigdadi118bigdadi118 Posts: 1,207
    Noted last post was 9/1 ...

    Is there anyone has the CHECK ENGINE light issue for the past month?
  • I'm sure I've gotten a CEL in the past month, but if it's the loose gas cap code, I just clear it myself and tighten the gas cap...
  • Yes I continue to have intermittent encounters with the CEL. It's on right now. I am due for the 15K service, so I will have them look at it again (4th time or so.......)
  • bigdadi118bigdadi118 Posts: 1,207
    If the CEL is ON, can it pass to get the yearly inspection sticker?
  • So I got my 3rd gas cap yesterday and I noticed the difference immediately. 1st and 2nd caps I had felt the same when closing the cap. This new one clicks alot more than the previous 2. If you turn it 1/4 around you hear a ton of clicks. The old 1 would click only once or twice.

    Anybody else notice this? I'm guessing the 2nd cap I was given had the same exact flaw as the first one. Hoping this new improved cap will solve my CEL problem for good.......
  • vbbuiltvbbuilt Posts: 498
    Has the filler neck been replaced? You might want to ask. Same thing happened to me. Replaced the gas cap, problem went away for awhile, but CEL came back sometime later. Replacing the filler neck was the problem.

    Vince.
  • Anyone else get notice of this?

    Took mine in for a recall regarding the diagnostic system and actuator- shutter valve. I was told this should take care of the CEL coming on.

    Odd thing is I never had my CEL come on until a week after my 1st service interval(oil change, turbo cal for lag.) I'll let ya know how things are after awhile.

    My CX-7 born <11/06
  • aviboy97aviboy97 Posts: 3,159
    The shutter valve, gas cap, and IMRC valve were the 3 recalls they have had. All three set off a CEL. The gas cap and IMRC valve were fixed from the factory for MY2008. The shutter valve is a new one.

    In a way, thank God for a CEL indicator light, for we would never know anything was wrong. Many countries do not have CEL's in the vehicles, so, you never know of any potential problems.

    With vehicles today being so computerized, I can only imagine we will see more and more CEL's in every car as they become more advanced.

    My friend that is a service mgr at the Honda dealer down he street from me has already done 3 CEL's on the new Accord.
  • bigdadi118bigdadi118 Posts: 1,207
    My son wants the CX-7. I need updated info re CEL issue. Has it been fixed by Mazda yet? I test drove the CX7 before I can feel the bumps & holes on the road, a firm suspension for sporty ride.
  • Yes it's been fixed, it's either the gas cap or filler neck.
  • They were also known for the CEL coming on because a faulty IMRC valve. The code for the failure was P2006. I was lucky that by the time I had the problem it was a known issue and was just a matter of waiting for the replacement improved part. Some of the owners having the problem early on went through a variety of repairs to the original defective valve.
  • 1rubyred1rubyred Posts: 12
    Recently My ABS and TCS lights come on and go off. Yesterday another CEL light came on and now it's staying on. I've had my car in for the recalls so that issue should have been resolved. Now ALL three lights are ON and won't go off.

    It's Sunday and I'm taking it in first thing Monday. I'm really annoyed and hoping it's nothing too serious. I only have 7200 miles on this vehicle and am sorry I ever purchased it.

    I apologize for double-posting this (also posted in fears about buying 1st year), but I'm really disturbed by this quirks of this vehicle and all these warning lights. I'm also worried something is seriously wrong with this car. :lemon:
  • johnny__rfjohnny__rf Posts: 83
    Well I just got my 5th CEL occurrence in 2 years and I am ready to pursue the CT lemon law as follows:

    "the same nonconformity has been subject to repair four or more times by the manufacturer or its agents or authorized dealers during the period of two years following the date of original delivery of the motor vehicle to a consumer or during the period of the first eighteen thousand miles of operation, whichever period ends first, but such nonconformity continues to exist"

    Anybody else pursue this avenue?
    :lemon:
Sign In or Register to comment.