Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Ram Transmission Problems

1969798100102

Comments

  • skyy606skyy606 Posts: 1
    I am having the same friggin problem. I have to take it up to 3500RPM and let off the gas to 1000RPM and it'll shift to 2nd, and if I accelerate to fast it goes into neutral. I just changed both my trans speed sensor and the rear def speed sensor, didn't help. Let me know if you figure this out I really need to figure out what the hells wrong with the dang thing!
  • kizzar5kizzar5 Posts: 3
    I have an 07 Dodge 2500 with a 5.9. I've got about 99,000 miles on it. I started having problems with the trans shifting into 2nd and 3rd gears. I had the trans serviced and now it shifts to 2nd pretty smooth, but it starts surging/jerking back and forth between 2nd and 3rd. If I let off the throttle and feather it til it shifts to 3rd, it's fine. The problem is only between 2nd and 3rd gears. Any ideas?
  • Do you still have the check valve in your tranny coolant line? It looks like a little cannister thing and is hard to miss as it's noticably bigger around than the line itself. If you do this may be your problem. The solution is to remove it (you may have to cut the lines next to it on both sides) and replace it with a good grade fuel type hose that will stand up to transmission fluid using two clamps on each end. Make sure you cut the hose to the proper length so it doesn't kink.

    This check valve was a bad idea from the start and has caused many a premature transmission failures in Dodge Ram trucks due to it clogging up easily restricting fluid flow reducing pressure wearing out the clutches and bands. I have a 97 2500 V10 ext. cab long box. My trans is the 47RE HD, and the first thing I was told to do was to remove that check valve from my trans coolant lines and replace it with a piece of hose as described above.

    Hope this helps.
  • kizzar5kizzar5 Posts: 3
    Thanks for the response. Will give it a try!
  • Mine did the same thing I changed filter and oil and gasket. while your their check for a broken spring in the 3-4 accualtor Its only 4.60 spring
    they break all the time my transmission has 268469 miles on it ... Check the dodge forum... you will see alot of broken spring problems.
  • Thanks Millionareman good info and great to know. Right now my 97 ram's 47RE HD trans shifts perfect but I'll watch out for that spring if I ever have problems. My friend has a 2500 that at low speeds shifts between 2nd and 3rd back and forth but with his I know what it is. When the check valve was replaced they used too long a piece of hose and it is kinked. If fixing the hose don't work I'll mention that spring to him.
  • my392my392 Posts: 1
    I just bought a 2006 5.9 and am having the same issue.
    Have you had any help or solutions?
  • kizzar5kizzar5 Posts: 3
    I tried changing the governor solenoid and the pressure sensor, no change. Took my truck to the tranny shop and got a call yesterday saying he had to pull the trans out. He said there was no adjustment left on the band. If that's all it is, gonna be about a $600 repair. Crossing my fingers there's no other problems. Good luck!
  • mwkendall1mwkendall1 Posts: 2
    edited March 2013
    I have a 2004 Ram 1500 crew cab 5.7 Hemi, 5 speed 545RFE tranny.
    I was going down the highway 60 - 65 mph, went to pass someone, heard a clunk, then engine started to rev high, got to side of road, no gears at all. No reverse, low nothing, also now make a whining sound that sounds similar to a turbo when engine is reved up, even in park.
    No problems prior to this, none!
    Anyone got any ideas??

    BTW checked fluid, level was good, no apparent leaks etc underneath.
  • Sounds like you lost the front pump or maybe one of the planetary gear systems. How loud was the "Clunk?"
  • mwkendall1mwkendall1 Posts: 2
    edited March 2013
    not real loud, but definity audible and kinda jerked like going from neutral to drive at higher rpms while moving.
    If it was planetary gear systems or front pump, would it make a whining sound like a turbo when reved up in Park or neutral?
  • danlovindanlovin Posts: 1
    I had/ have the same issues with my 07 1500. I have also had issues with randomly the RPMs will go up, come back down, then go back up, and so on. When the RPM issue started about 2 weeks ago, I went up a hill and got above 4k RPM, then all of the above issues stopped. So if these issues occur, I have been giving it enough gas to get above 4k RPM and it stops it all, but I know it's just a matter of time before something serious happens, any idea would could be causing my issues so I can have it fixed for good?
  • jeffm14jeffm14 Posts: 1
    edited May 2013
    :confuse: The torque converter is locked on my 2000 Dodge Ram 1500. Truck will stall when coming to a stop as if clutch is engaged, Hard shifts, and jerky driving as if lockup is going in and out. Replaced fluid and filter. Replaced TPS (throttle position sensor) No change. Help!!
  • My 2001 Dodge Ram 4x4 will hardly move at all in 2 wheel drive. But when I engage it into 4 wheel drive it pulls like it always has. I checked the transfer case to see if I had any stripped gears but didn't see anything. Do any of you guys know what might be the problem. Thanks for your help.
  • dsalmonsdsalmons Posts: 1
    I have a 02 2500 ram with a 5.9 automatic I have lost reverse and it will not shift out of second lost it all at the same time just wandering if anyone could help tell me what it is. It shifts fine in first and into second but that is it please help
  • I went to back up and to just stopped. All forward gears work fine. Slight noise sometimes, but not all the time. Can anyone help with this? Thanks.
  • dirt85dirt85 Posts: 1
    I have a transmission question. I currently have a 1978 Dodge Pickup with 5.2L engine and auto transmission and a 1999 Dodge Dakota with 5.2L engine and 5 speed manual transmission can i put the 5 speed in my 1978 model and if so what all am I gonna have to do to make it work.
  • 95wingse95wingse Posts: 1
    03 dodge 2500 diesel, 268000 miles. truck seems to surge while going down highway with cruise set. The tach nor speedo indicate increase or decrease in speed or rpm, but can definately feel the surge. Any ideas as to problem?, fluid level is in the "hash" marks on dip stick
  • bobo1973bobo1973 Posts: 1
    Did u by chance to figure out the problem cause I just had the same exact problem but I came out of a stop sign left out of first n then nothing like you..... can you help me out pkease...
  • ddb2ddb2 Posts: 1
    I have a 2005 Dodge Ram145k miles, automatic, over the last couple of days I have notice when I first start from cold engine and put into drive, the transmission doesn't seem to engage. Engine revs, then engages. Once the engine is warm it seems fine again when I go from park to drive. Not having problems once I am on the road either. Any ideas what this could be?
    Thanks!
Sign In or Register to comment.