Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Ram Transmission Problems

196979899101

Comments

  • guythunderguythunder Posts: 19
    I had the same problem and this is what I did. It now shifts like a new trasmission. I odered these parts on line at www.CascadeTransmissionParts,com.....................

    Product Information
    Product Name Part No. Quantity Item Price Total Price
    Governor Housing Base Gasket 12328B 1 $6.88 $6.88
    47RE Governor Solenoid Borg 12432AB 1 $56.88 $56.88
    47RE Pressure Sensor 96-99 12415B 1 $59.88 $59.88
    Universal Drain Plug Kit 3020S 1 $14.88 $14.88
    47RH / RE Filter Kit (R) 88-97 22011GR 1 $16.88 $16.88

    Subtotal: $155.40
    I have had three other people do this to there Transmission and it worked for them to. Good Luck..
  • Thanks Guythunder for this info. Though at the moment removing the check valve has fixed my tranny problems in my 2500 4x4 V10 ext. cab long bed (47RE-HD trans) I may order these parts and install them as a preventative measure.

    My only complaint at the moment is that my converter lockup won't enguage until I am going at least 53-55 mph, but as far as shifting the transmission shifts fine for now and I want to keep it that way. I would like to get the converter to lock up at around 40 mph though. My truck has the 3.55 gears -not the normal 4.10's that come in these 2500's though which may be why my converter doesn't lock up until I hit 53-55 mph. At that speed when it does lock up though engine rpms go down to around 1300-1400, and at 65 mph rpm's are still only just above 1500 at around 1600 to 1650, and 1700 at 70 mph. I have to go above 80 mph to about 83 or so for rpm's to reach 2000. Could the higher gears in my truck be the reason my converter won't lock up until I get close to 55 mph?

    In any case again, thanks for the info and part numbers. :)
  • Did you ever get your trany problem figured out. I ran into a similar problem and audible clunk then nothing, but no whining...trany pan is clean, fluid does not smell burnt...

    Any thoughts...thanks
  • winni517winni517 Posts: 2
    hi, i've been reading a lot of the posts on this issue and it seems like it could be a relatively simple fix. however, haven't seen a post exactly like my issues and would like to know if we should throw in the towel or not due to the potential cost of repairs. we have a 1996 ram sport 1500, 2wd, 5.9, 4-speed hd auto trans, it has never been used to tow. back in 1999, while still under warranty, the overdrive would have a delay jerk shift between 35 & 40 mph, dealer said front clutches burned and they r&r trans, disassemble & inspect, replaced all discs, plates, low reverse band, torque converter, seals, gaskets, o-rings & lip seals: reconditioned valve body, flushed case & overdrive housing, flushed cooler & flow test. not too long after all that, but AFTER warranty expired, the overdrive started going out again. due to frustration and shop expense we still haven't fixed it yet since it hasn't been our daily driver. in 2009 had it tested for codes but it didn't have any. currently, all gears shift fine, overdrive will work for about 20-30 miles as long as the engine is cold then shuts off. fuel mpg has continuously declined without overdrive working to maybe 5 mpg at best, ergggg. also i think the torq converter is whining, not sure if that is related to the overdrive or not. so, since it has been messed up for so long do you think it's worth trying to fix and if so what would you suggest we do??
  • parker68parker68 Posts: 2
    After being in the auto repair shop for 5 weeks now, I am just a little frustrated to say the least. First it would drop out of overdrive and that is all. I parked it for 2 days and when I came back and tried to drive, it would not shift out of 1st gear. Would go in reverse and 1st but nothing else. So took it to the shop, of course they said needed an new transmission, I thought it was electrical but anyway it had 122,000 miles on it. So put new transmisson in it. I can shift but still drops out of overdrive and now trans temp comes on after about 15 miles of straight driving.. We have replaced about everything. Today after replacing the govenor plate and speed and overdrive soleniod again, still does it. At wits end, got any suggestions?

    :mad:
  • Get underneath and trace your transmission coolant lines from the transmission to the radiator, then through an external cooler if you have one then back to the transmission. What you are looking for is a check valve that looks a little like a cannister thingy. It will be wider than the normal coolant lined and easy to spot. Once you've located this, Remove it and replace it with a piece of hose double clamped on both ends. Do not use cheap hose -make sure it is high quality fuel or high pressure hose. You'll only need about a foot or so of it anyway.

    Once you've obtained the hose cut it to the right length to avoid kinks. Install the hose after removing the check valve. This will help correct some low pressure issues.

    Hope it helps

    Allyda
  • parker68parker68 Posts: 2
    So is the check valve just gets hot and shuts down? Learning as I go.
  • What this thing does is cause fluid pressure los resulting in erratic shifting and in many cases loss of overdrive. Even the tech bullitin from Crysler says to remove it and replace it with a hose. The type of hose is important though. Make sure it's a high pressure hose that can stand tyransmission fluid. You will also need 4 clamps -the screw tightning kind as you will want to double clamp both ends. For mine I just bought a hose barb that fit my transmission and came off of that (it goes in the same place as the quick disconnect for the check valve does. Your check valve may be in a differenyt place though. You won't miss it as is looks like a little cannister.
  • winni517winni517 Posts: 2
    i really want to see if this truck is fixable since we can't afford a new one. it would be a shame not to try if it can be something fairly simple. i think we will try the suggestions in posts #62 and #1871. it doesn't appear that any of those things were done during the warranty fix and maybe that's what caused it to go out again so soon. also considering the governor solenoid as well. i've also heard that there are sensors in the trans that controls the overdrive as well as fuel consumption, any idea what that is? anyone have any other thoughts or ideas???? thanks
  • guythunderguythunder Posts: 19
    I had the same problem and this is what I did. It now shifts like a new trasmission. I odered these parts on line at www.CascadeTransmissionParts,com.....................

    Product Information
    Product Name Part No. Quantity Item Price Total Price
    Governor Housing Base Gasket 12328B 1 $6.88 $6.88
    47RE Governor Solenoid Borg 12432AB 1 $56.88 $56.88
    47RE Pressure Sensor 96-99 12415B 1 $59.88 $59.88
    Universal Drain Plug Kit 3020S 1 $14.88 $14.88
    47RH / RE Filter Kit (R) 88-97 22011GR 1 $16.88 $16.88

    Subtotal: $155.40
    I have had three other people do this to there Transmission and it worked for them to. Good Luck..
  • glenm33glenm33 Posts: 1
    My 07 has developed a pesky problem, sometimes it will seemingly go into limp mode by decreasing speed down to 25mph even though the pedal is full open. If you turn key off, then on it will work fine for a day or two then back to 25-35 mph when it glitches. Dodge dealers (2) havent been able to find ANY problem....No Codes, cannot Repeat Problem etc etc. Any thoughts or suggestions?
  • hello I have a 1998 dodge ram 3500 truck with 238000 miles on it my truck has shifting problems it wont's to shift from 1st to 2nd back to 1st then some times it will shift fine then going down high way it will shift in and out of over drive then it will stay in 3rd then it will drop down to 1st and shift back to 2nd then shift from 2nd to 3rd back and forth.now let me tell you what I have replaced the alternator checked all the ground wires replaced the speed sensor on trans and just replaced the throttle position sensor I use to unplug the wire going in the trans the one by the shifter go down the road shifting manually stop and plug it back up and cut the key off and crank truck back up and it will shift right but now it still does the same as what I just said I like my truck but it gets very expensive on buying things and trying them I can do any thing to the truck just need to know what's making it do that trans shifts fine when it shifts right done changed filter and fluid still didn't fixe the problem please help ;thanks;
  • I have a 96 1500 5.2. We dropped this tranny last night and put a rebuilt one in. Drove it around the block, it ran perfect. We put in park to double check tranny fluid and the engine shut itself off and now won't start! Any ideas???
  • I have a 96 1500 5.2. We dropped this tranny last night and put a rebuilt one in. Drove it around the block, it ran perfect. We put in park to double check tranny fluid and the engine shut itself off and now won't start! Any ideas???
  • p_0_dp_0_d Posts: 1
    Hey Thumper,

    Do u by chance know the part numbers for the Gov solenoid and sensor...or could u send me a link for those parts. Having the same problem with my 99 Ram. By the way did the problem ever come back ?

    Thanks
    Doug
  • Hey bud,
    I am having the same exact problem as you were having. The transmission is working well in all gears except for reverse. When I give it gas it slowly reverses but not as it should...spudders almost.

    What did you end up doing to correct that problem?

    I would appreciate any feedback!

    Thanks
  • Hey guys,

    I have a 2002 dodge ram 2WD 5.9L

    I was driving the other day and the rear seal of my transmission went out. I was unaware of this until I got home and so naturally I replace the rear seal and dropped the pan to replace the filter and pan seal. Proceeded to put new ATF+4 in and now the reverse is sputtering and very un-responsive when i give it gas. The other gears work fine but reverse is just out for some reason.

    Any help here would be greatly appreciated.

    Thank you!!
  • Hey man I am having the same problem right now. Curious to see what you found out? Thanks
  • I had to redo the tranny 3rd was out.
Sign In or Register to comment.