Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Ram Transmission Problems

1606163656668

Comments

  • I would like to thank you for the advice I pulled my d[ground out of the harness today and put it in a hydrolysis hose with stainless beaded to shield the ground and it worked perfect i have never felt my trany
    shift so smooth
    Thanks again
    Phil
  • Thanks it worked like a charm,I ran mine through steel breaded hydrolic hose
    Phil
  • I have the exact problem discussed in this thread. I'm a little confused on the remedy: I have two wires coming out of the neutral battery post--one grounded to the front quarter panel adjacent the battery, the other grounded to the frame below. Where is the ground wire coming off the battery connected to the alternator harness? Their is a sensor wire at the air filter that joins another wire that is attached to the alternator; and then there is the hot off the battery connected to the alternator. Prior to this shifting problem, my tach was only periodically registering rpm's, so it seems to me it may be electrical. Any assistance would be greatly appreciated.
  • Did you get this figured out ? Im having the same problem ....
  • So I was looking through the transmission shifting problems and saw the one about electrical for shifting.

    About 2 weeks ago replaced both batteries all was fine. Then a day or 2 later I cleaned up around the posts with degreaser and coated terminals with anti-corrison treatment. The next morning after I did the clean up and treating the transmission wont shift correctly into 2nd. If I slowly accelerate all is good. If I accel to fast it wont shift until I back off the throttle and RPMs drop. Then it shifts. It goes up the gears just fine and stays in OD.

    Ideas before I take to Dodge dealer?

    Thx
  • im having the same issues right now took it to the dealership and they are trying to blame it on my after market programer and that my trany needs to be serviced and the band need ajusted but that not the problem did you by chance figure out what the problem was
  • im having the same issues right now took it to the dealership and they are trying to blame it on my after market programer and that my trany needs to be serviced and the band need adjusted but that not the problem did you by chance figure out what the problem was
  • just wondered if you ever figured out what the problem was with the tranny problem in your truck? I have a 1996 1500 4x4 that is doing the exact same thing, but really cant afford to take it to a garage if i dont have to.
  • Knock-on-wood, it just started acting normal one day and has been good ever since. I either got lucky or the problem is just waiting to sneek up on me again this winter. It didn't seem to be weather related however.
  • I have a business towing cars with a two car trailer and I just opened it recently. So I was driving through California and I hit some serious uphills! I had about 20k lbs total on the trailer but the truck barely made it up the hill at like 25mph. Then it started making a really loud noise from the engine or like a loud whine and the truck just wouldn't pick up speed even when the road evened out. It was just terribly sluggish. I parked for the night and it seemed fine in the morning but as soon as I hit more uphills, the same thing happened. what could be my problem and what could I do to fix it? is this normal for it to go so slow uphills? Please Help!
  • bry181bry181 Posts: 1
    is there any after market tranmissions out there that will be more reliable...... i have a 2001 ram 1500 5.9 2wd..... the trans is about done with 164,000 miles .... which i think i have seen my trans last longer than most.... just wondering if there is a more heavy duty out there....
  • dblinndblinn Posts: 1
    My 01 1500 4x4 is shifting hard, it doesnt do it every shift. its not slipping so were good there, but not sure if the transmission is just going or maybe needs a sensor or something. My last 318 was a stick so not much answers here.

    HELP PLEASE going on a long drive next week want to try and correct the problem. also my speedometer isnt reading the right speed any connection?

    thanx
  • i have a 2001 dodge ram 1500 with 99,xxx miles on it. its all the original parts on the truck. it has a 5.9l automatic with 4x4. im only 19 years old soo i dont know much about this and everytime i talk to a transmission mechanic around here they tell me to have them rebuild it for $2000 the transmission will only go in park and reverse.. all other gears act as tho its in nutruel. any suggestions on what i can do to fix the problem soo i dont have to rebuild it?? thanks... jonathan
  • two days ago i put my car into park, then it wouldn't shift back into any gear. it was very easy to fix my self. bought the part from the dealer and installed it myself. all is good again.
    any question?
  • I have a 2003 Dodge Ram 1500 Quad Cab Hemi. Reverse, 1st and 2nd work fine, but when it shifts into 3rd gear, the rpms raise rapidly because it does not engage into 3rd gear. I had to limp home in 2nd gear. No fun. Any ideas would be greatly appreciated.
  • vidicvidic Posts: 2
    my 1998 5.9 2500 4x4 has tranny problem. It happened while i was towing my camper while driving my o/d off light popped on the dash and would not shift off so needless to say the trans temp light came on too it would not shift so when i could find a safe spot to pull off the highway i did and when i crawled under there was tranny fluid coming from between the engine and the bellhousing and it smelled of burnt fluid let the truck sit for 20 mins then started the truck and the lights were off drove it about 1/4 mile then the same thing happened tried a couple times more then had to get it and my camper towed 50 miles home now just driving around town it just smells like burnt fluid and it shifts funny anybody got any ideas and does anybody know to find what tranny i have in my truck mabye i can get one at junkyard and have it rebuilt then out it in my self
  • when I start to drive it sometimes it wont shift out of 1st gear. and sometimes after a while it will shift and then run fine. the fluid looks good just bought the truck and it says the transmission was serviced in 2010.I disconnected the battery and hook it back up and it didn't help.Please if anyone has any suggestions let me know thanks.
  • My 1998 dodge ram 2500 is doing the same thing and i was told to have a tranny shop look at it but that costs money i dont have another person said it was a sensor. any ideas on it it seems like i am not the only one here with this issue
  • After going through an entirely too long of a list we found 2 main things with my transmission.
    1 - someone had put a slightly shallower pan on the transmission and when we changed from the 1997 tranny filter to a mid 70s (fit the same but thinner) that MAJORLY helped my shifting issues. The other basic issue with many vehicles is the connections. My mechanic sprayed PB blaster in the back of the connections at the harnesses and then dielectric gelled the connections themselves. It helped settle the computer down. Good luck
  • ct35ct35 Posts: 2
    did you ever find out what was wrong with your truck mine is doing the same thing?
  • ct35ct35 Posts: 2
    wondering if anybody could help me with my truck problem? to start it you have to hold the gas all the way down an when it starts the rpm's raise rapidly an when you drive it it don't know when to shift scared to drive it cause i don't want to tear up the transmission, but while its setting its got a buzzing coming from the transmission. someone please help don't want to out money into it an it not be whats causing it.
  • Apparently everyone that I have contacted, even Click and Clack the NPR radio show, says that it is without a doubt a tcm problem. In my case the tcm is built into the ecm. Since my problem was unusual I submitted the problem to them. They actually allowed me to tell my problem on the air. Both brothers agreed, tcm failure. I don't have the same issues since I cleaned the ground that is attached to the ecm.
  • I have a 1999 Dodge Ram 3500 with auto trans. While driving on hwy at 55 sometimes it starts shifting down out of overdrive and sometimes even acting like it is shifting down to second gear and then back. Starting off from a dead stop seems like it will never shift from 1 - 2. I have recently replaced the speed censor on the back of the trans. and that seemed to fix it for about a day and then it starts screwing up. If anyone has any ideas please let me know. I replaced the accelerator position censor a few months ago. I need help.
  • I have 2006 ram 2500 with a cummins and 6 speed manual transmission. A week ago while idling in neutral the transmission started making a low whine sound. I thought it was the throwout bearing. Took it to the dealer. They ended up dropping the tranny and splitting the housing and they found a bad bearing on the front of the counter shaft.The dealer said they just couldnt pull the bearing and replace it and that I needed to replace the entire shaft and gears at a cost of $1900. for the part. All the needs to be done is knock the outer race of the housing and get the bearing # and order it from Kaman. I think the mechanic would have easily agreed to this but it obviously is not in the dealers best interest. My questions are how or where can I find the bearing #? What do I need to do to get the dealer to do what I want them to do? The bearing is failing from not getting lubricated while the truck is idling in neutral as the gears are not splashing enough oil to keep it lubracated.
  • Yes, we call that not enough power!! or your turbo is lagging to keep up with the weight and the grade. Get some upgrades on the truck, like a straight pipe exhaust, a cold air intake, etc little stuff to help. then a tuner then a shift kit.
  • I own a 96 dodge ram 1500 4x4 w/ 5.9, auto/o.d. One day it started disengaging from gear while driving on the highway. Gradually it started doing it at slower speeds too, in any gear. It seems to only do it after its warmed up. I've replaced filter, some fluid but it didn't look bad to start. I pulled a line from the radiator and it seemed to have plenty of pressure. Someone has also put a trans. cooler nearly the size of the radiator! in it. It never slips; when working it works fine. When it lets go, its instant w/ no slip. It will re-engage after a number of seconds and me feathering the gas. Please can this be electrical and not need the trans. rebuilt or removed? Truck has 155,000. Please help!
  • 99dodge250099dodge2500 Posts: 2
    edited December 2011
    I was having the same problem with my 99 2500. I ran a ground wire from the ECM to the battery ground and it solved the problem. I didn't have that problem anymore. Here is what I did - - First thing you will need to do is remove the factory air box to get access to the PCM and disconnect the batteries as a precaution b/c you are playing around the PCM, you will notice their are (3) seperate connections going into the PCM w/ multiple wires in each one. The one you will need to work with is located furtherst right (3rd one over, closest to the drivers side) , you will find (2) wires which are both ground wires, they are black w/ tan tracers and are located right next to each other . Once located, use a "scotch-lok" type connector to attach to one (or both if you choose) to the wire that will run to the battery (i used a 14 awg wire, i do not think that is critical), they are small wires and you do not have a ton of room so be careful not to rip the wire from the factory plug, i pulled the plug from the PCM to make it easier . Run the wire over to the passenger side battery and make a good connection to the Negative battery post (clean ALL terminals of all batteries at the same time), you are done!
  • I was traveling on HWY 68 in MD and my transmission quit. I brought it to a local shop where he said it overheated and needed to be replaced. I had him rebuild it with all heavy duty parts and replace the torque converter with one rated for 5500 ft lbs. I picked it up and drove about 5 miles up Savage Mountain and the transmission hit 795 degrees in less than 2 minutes and quit again. The transmission shop said the truck couldn't handle pulling my 30' camper and that caused it to over heat and wants me to pay again to have another transmission put in. This doesn't make sense to overheat in 5 minutes of climbing a hill. Anyone have any thoughts or suggestions.
  • I have a 95 dodge 1500 with the 46re auto trans and I have to manually shift it or it starts out in 2nd gear and it will not go into overdrive and the torqe converter wont lock up. The overdrive and trans temp lights are always on. If I manually shift it it will shift fine until it gets into 3rd what could this be? Any answers appreciated.
  • I have a 95 dodge 1500 with the 46re auto trans and I have to manually shift it or it starts out in 2nd gear and it will not go into overdrive and the torque converter wont lock up. The overdrive and trans temp lights are always on. If I manually shift it it will shift fine until it gets into 3rd what could this be? Any answers appreciated.
Sign In or Register to comment.