Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Ram Transmission Problems

1626364656668»

Comments

  • glenm33glenm33 Posts: 1
    My 07 has developed a pesky problem, sometimes it will seemingly go into limp mode by decreasing speed down to 25mph even though the pedal is full open. If you turn key off, then on it will work fine for a day or two then back to 25-35 mph when it glitches. Dodge dealers (2) havent been able to find ANY problem....No Codes, cannot Repeat Problem etc etc. Any thoughts or suggestions?
  • hello I have a 1998 dodge ram 3500 truck with 238000 miles on it my truck has shifting problems it wont's to shift from 1st to 2nd back to 1st then some times it will shift fine then going down high way it will shift in and out of over drive then it will stay in 3rd then it will drop down to 1st and shift back to 2nd then shift from 2nd to 3rd back and forth.now let me tell you what I have replaced the alternator checked all the ground wires replaced the speed sensor on trans and just replaced the throttle position sensor I use to unplug the wire going in the trans the one by the shifter go down the road shifting manually stop and plug it back up and cut the key off and crank truck back up and it will shift right but now it still does the same as what I just said I like my truck but it gets very expensive on buying things and trying them I can do any thing to the truck just need to know what's making it do that trans shifts fine when it shifts right done changed filter and fluid still didn't fixe the problem please help ;thanks;
  • I have a 96 1500 5.2. We dropped this tranny last night and put a rebuilt one in. Drove it around the block, it ran perfect. We put in park to double check tranny fluid and the engine shut itself off and now won't start! Any ideas???
  • I have a 96 1500 5.2. We dropped this tranny last night and put a rebuilt one in. Drove it around the block, it ran perfect. We put in park to double check tranny fluid and the engine shut itself off and now won't start! Any ideas???
  • p_0_dp_0_d Posts: 1
    Hey Thumper,

    Do u by chance know the part numbers for the Gov solenoid and sensor...or could u send me a link for those parts. Having the same problem with my 99 Ram. By the way did the problem ever come back ?

    Thanks
    Doug
  • Hey bud,
    I am having the same exact problem as you were having. The transmission is working well in all gears except for reverse. When I give it gas it slowly reverses but not as it should...spudders almost.

    What did you end up doing to correct that problem?

    I would appreciate any feedback!

    Thanks
  • Hey guys,

    I have a 2002 dodge ram 2WD 5.9L

    I was driving the other day and the rear seal of my transmission went out. I was unaware of this until I got home and so naturally I replace the rear seal and dropped the pan to replace the filter and pan seal. Proceeded to put new ATF+4 in and now the reverse is sputtering and very un-responsive when i give it gas. The other gears work fine but reverse is just out for some reason.

    Any help here would be greatly appreciated.

    Thank you!!
  • Hey man I am having the same problem right now. Curious to see what you found out? Thanks
  • I had to redo the tranny 3rd was out.
  • Sounds like a broken snap ring in the overdrive unit. Check for pieces of the ring in the trans oil pan.
  • Thanks man I just finished pulling that apart and sure enough there were two small pieces of a ring that were being held by the magnet. What do I need to order and replace now?
  • I've been having problems with the transmission. When I'm in third gear and let off the gas, I start hearing a knock at my feet like something is loose. Can anyone help me out here?
  • pmowpmow Posts: 1
    edited November 2013
    Hi i have a 2002 dodge ram 1500 sport 5.9L 4x4 46re tranny. I have put 2 trannies in the truck. The first one, the check ball valve on the line set that goes from the tranny to the cooler got stuck and my overdrive went out and blew tranny fluid out of the torque converter. Got codes for torque converter, governor senser. Bought new tranny with 3 yr unlimited miles for 1500 bucks. Took out the check ball valve, put new tranny cooler, put inline tranny filter. Tranny worked awesome, shifted nicely, drove awesome. Let it sit for 3-4 weeks, now, when taking off, truck will go from first to 3rd then 4th at like 20mph, skips second gear. When i come to a stop sign, tranny won't down shift properly, gets stuck in what ever gear. Almost kills the engine, truck shakes like crazy, then right before i come to a complete stop, it down shifts to first. Got no codes coming up. If i put it in 2nd, before i come to a stop, tranny down shifts perfect. Over drive off not working. When im taking off i hear a winding noise. when i put it reverse, hear a grinding winding noise. I put new tps, cause when i had the pedal all the way to the floor, tranny didn't want to down shift. Put new and now it down shift when im at 40 and going up a hill. I called the tranny people for warranty, there sending me a new tranny. What might caused this? The tranny only had 3000 miles. I don't want this to happen to the next one. getting tired of taking out and putting new..
  • dmill120dmill120 Posts: 1

    Gents, I have a 1997 Ram 1500 Laramie with a 5.9L. My transmission works fine when it is cold, but when it warms up, the RPMs sky rocket and i lose power. I am not sure what the issue is, but if i can get it fixed by myself without taking it to a shop it would be great. Any and all help would be greatly appreciated. Thanks.

  • lenfracklenfrack Posts: 2

    @the7t1merc said: yes,because the trans gets no fluid until you either put it in gear or Neutral..the front pump doesnt activate in Park.best thing to do is to put it in neutral Before you put it in any gear..let it flow some fluid Then put it in gear....there is a way to redo the trans with a special valve to cure this/no fluid pumping in park/,but it is a rather expensive fix.G/L,rob

  • lenfracklenfrack Posts: 2
    edited March 30

    I have had the same problem in my 1997 2500 cummins for years. I did notice that if I shifted into neutral and then reverse or drive it would work fine, thanks. Now here is another question, ever since 2001 I will have intermittent problems of shifting between 2nd and 3rd along with in and out of overdrive. I had the transmission totally rebuilt including all electronics in 2002. The day I picked it up I had the same problem. But this comes and goes. I took it to another transmission shop last year and they assured me the problem was NOT internal. He asked several techs around the country and they knew of others who replaced every part and still had the same problem.

Sign In or Register to comment.