Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy S10 - GMC S15 and Sonoma Electrical Problems

KCRamKCRam Mt. Arlington NJPosts: 3,516
Here's the place to talk aboutr yuour S-truck's lack of electrons
«13456715

Comments

  • stormz8stormz8 Posts: 3
    Does anyone know why my seat would move on it's own. As I'm driving my seat will inch forward on it's own. Sometimes the seat will not move at all when I push the button to move it back to the position it was in. My truck is a 2002 GMC Sonoma SLS Crew 4x4 with power everything. Also, If I push both the 4 hi and 4 lo buttons at the same time, will it put the drivetrain into neutral/
  • Don't understand what happened or what to do. Ran fine, then won't start. Cleaned battery cables. Started right up. Let it sit for a few hours then dead again. Battery eye is green (which is supposed to mean good), but can't get the dome light or even the keyless remote to work. Makes no noise when key is turned. Radio goes on and off in a series of 3. Does the computer need to be reprogrammed once the battery has been disconnected? Does anyone know if this is a more serious problem than replacing the battery?
  • flipper3flipper3 Posts: 10
    im not shure what exactly your problem is but the computer does not need to be reprogramed after a battery disconection that i do know. it does sound like you have a short in your wires though. i only know of one way to find out. break out the test light. hope this helped
  • hoodlatchhoodlatch Mid-westPosts: 255
    Mine was/is doing the same thing. The cable is messed up underneath the plastersol coating at the battery lug. I can't see the corrosion but I know that's the problem. I can shake and yank the cable and it will work fine for a while. I've been carrying a replacement in the tool box but haven't got around to it yet.
  • annecrannecr Posts: 3
    I have a 2000 s-10. The wipers started wiping off of the windshield last week--as in way to the left. Tonight, they died. I want to try and fix this myself, any suggestions on how I might start this repair?

    Thanks in advance,

    Anne
  • hoodlatchhoodlatch Mid-westPosts: 255
    One winter the wipers on my 97 S-10 were froze to the windshield and covered with snow when I turned them on. They went haywire and I thought I messed them up big time. As it turned out they slipped on the spindle. All I had to do was loosen up the bolts that hold them down, reposition them, and re tighten the bolts. I think they were 7/16ths.

    Maybe your wiper arms got lose on their spindles and got out of kilter.

    Good luck.
  • annecrannecr Posts: 3
    Awesome! I'll give that a try this weekend.
  • I have an 83 x cab 4x4 and I bought a factory tach cluster, installed it and not the dash lights and gauges are going haywire when I turn the lights on, so i took that cluster out and put the orig back in same thing but they worked prior to any ideals.. i have replaced the headlight switch also..
  • I own a 2002 Envoy. The windshield wipers will not turn off, while the car is running, by the switch. The problem has been occurring off and on for about 6 months. Originally, if I turned the switch off and turned the car off, once I turn the car back on the wipers would stop. Now that no longer works. What is the problem? Which fuse controls the windshield wipers. Thanks, AFF
  • I have an 83 x cab 4x4 and I bought a factory tach cluster, installed it and now the dash lights and gauges are going haywire when I turn the lights on, so i took that cluster out and put the orig back in same thing but they worked prior to any ideals.. i have replaced the headlight switch also.. A friend has the same problem after a v8 conversion PLEASE HELP
  • I have a 97 s 10 and it will not start.. I think it is electrical because none of the gauges move when I turn the key on.. My sons think it is the fuel pump..I have checked all the fuses.. does anyone know what might be the trouble?
    :confuse:
  • hoodlatchhoodlatch Mid-westPosts: 255
    One of the things I did when I was trouble shooting my fuel pump was to give it a shot of starting fluid. It fire right up momentary as long as I kept squirting the ether. This let me know I had a fuel problem somewhere.
  • hoodlatchhoodlatch Mid-westPosts: 255
    Sound like a relay sticking. :)
  • Try your switch under the hood where your windsheild wipers hook in at. I have a 98 s-10 and sometimes my wipers work and sometimes they don't but my switch is messed up
  • I have a 1991 Chevy S10 and I am replacing the cruise control / turn signal / wiper lever. I have pulled the steering wheel and the turn signal plastic switch. I cannot seem to locate what holds the lever in place. Anyone have experience here that would help??

    Thanks
  • hello,
    I am new to the forum...I have a 2000 S-10 and just my dash lights went out today. I check the fuse and they are all fine..Anythought???

    Thanks
    :mad:
  • wjs4wjs4 Posts: 3
    I have a 98 S10 with the same problem. When the wipers quit I wiggle the electrical plug from the wiring harness where it plugs into the wiper motor & the wipers usually work fine for awhile. I checked & cleaned the electrical connections but there doesn't seem to be anything wrong. I took the cover off the wiper motor & found a printed circuit board. The printed circuit board slides out of the motor. On the back side of the printed cicuit board is 2 electrical contacts that slide on metal strips on the main gear of the wiper motor. Carefully clean the contacts & the metal strips on the gear and reassemble the wiper motor. I found that my contacts & metal strips where covered with grease from the gears. This solved my problem for awhile but recently the wipers have been acting up again. I haven't had time to check the contacts or printed circuit board again but would assume there is more grease on the contacts. Hope this helps.
  • I have a 1997 Chevy S-10. When I'm driving with the high beams on the lights flash off and on.. They don't do it when I swicth to low beam..any one know what the trouble might be ?
  • My 96' S10 headlights go out often when I driving on down the road. When they go off I hear a click click click coming from the glove box area. Daylight Driving lights are Ok, however the headlights are not functioning all the time. It's a problem because people think I'm flashing my lights at them. Any ideas on what it could be? :confuse:
  • The circuit boards on the wiper motor is usually the culprit on s-10's. the board under the cover on the wiper motor. Take it out...look for the BIG solder joints and reheat. That should solve the problem. Or you can buy a new board at auto zone or somewhere for a small fee.
  • hansiennahansienna Posts: 2,312
    i read about the problem you had with highbeams on your
    s-10. did you get it resolved?
  • No I did not. Headlights now do not work at all.
    Driving lights are fine however, when I switch on the headlights I lose everything. Any help would be greatly appreciated.
  • I'm working to fix a 1999 s10 with a headlite problem. By looking at the circuit diagrams in a Haynes manual 24071. here is an explaination.

    When you turn on the ignition key the Daytime Running Light (DRL) Relay back feeds power to the headlamps in series. This means that the power is fed backwards into the left side head lamp "ground" circuit and power flows through the left head lamps into the Right side head lamps to ground. When you turn on the head lite switch it provides power to the DRL module that turns off the running light function. This power line feeds the Head lite dimmer switch to direct power to either the high or low beams.

    Your description would seem to indicate that the DRL Module and Headlight switch may be working but power is not getting to or through the dimmer switch.
  • 92 S10 Blazer digital dash problem. I have good power at connector, good ground, speedo and trip light up, ses and other bulb powered things work. NO fuel, temp, oil, or volt indications. Checked refreence volt out of PCM which was good. Is there a pull up relay or what to provide a resistive load to the LCD displays?
  • dan85dan85 Posts: 1
    Tonight while driving with my windsheilds wipers, heater, radio and spedometer just stopped working and then every once and awhile they would come back on.I checked the fuses and jiggled all the wires but didnt seem to matter. Any thoughts?
  • check for a floating ground on the back of engine if W vin. Top front if Z.
  • mvolekmvolek Posts: 5
    U have a short in the switch of your seat. Replace the switch and should solve the problem. The 4 hi and 4 lo is supposed to do that cause its a safety feature so it doesnt rip out the transfer case
  • catdugcatdug Posts: 2
    I have a 1995 S10 and when the regular headlight's are turned on there is no light from the headlight's....the high beams do work when it is selected and when the light's are off the daytime running lights are working aswell, it's just when the regular headlights are turned on i get nothing. Can someone offer any advice????
«13456715
Sign In or Register to comment.