Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Camry Hybrid Navigation System Questions

1567810

Comments

  • navguy1navguy1 Posts: 181
    FYI - If your current audio system does not have the premium sound system (JBL logo on the radio) then you will have to add the amplifier to the system to get voice commands for turn-by-turn route guidance.
  • When are new DVD map updates available for the CAMRY navigation system. I have a 2009 Camry hybrid.
    ejelliston
  • navguy1navguy1 Posts: 181
    Toyota just released the new V9.1 DVD map disc. I picked up mine for $199! I bought one 2 years ago for $265.

    I also got the part numbers for all the Camry's:

    86271-GEN04-09 86271-33049 (2004-2006)
    86271-GEN05-09 86271-53024 (2007-2009)
    86271-GEN06-09 86271-73011 (2010-2011)
  • I just bought a 2008 camry hybrid. when i tried to use the GPS system i noticed that the disk in my car has maps to the USA and CANADA only(i'm not in the us or cananda i bought the car in USA and shipped it over to israel).
    So if someone here can tell me how i can get maps for my country and where can i find these part number for the toyota maps site if i didnt get the original dvd.
  • drod12drod12 Posts: 4
    I just want to make sure I'm buying the right one for my car. I have a 2008 Toyota Camry Hybrid so, to buy the most updated DVD, I should get the second one (86271-GEN05-09 86271-53024 ) right? I'm not sure if the years pertain to the year it got released or for the year of the car. Please advise. Thank you.
  • I just bought a 2009 TCH with Navi - whose disk is missing.
    Would anyone be interested in selling me your disk?
    Tamir - I would be willing to buy your disk with the USA/Canada maps since I live here.
    Thx,
  • Was this a new car or a resale? If new, why do you not go to the dealer you got the car from and get the missing disc for free? If a resale from a reputable dealer they should still provide it.
  • gfr1gfr1 Posts: 55
    The previous reply was good, but wherever you got the car, the disk should have been included, just as much as the manuals and spare tire. It's part of the vehicle. That being said, if you intend to keep the system up to date, the new disk probably just came out a couple of weeks ago. If you're trying to get an old one to save money, that's another thing, but otherwise, if you had received a '08 edition it probaly was just replaced by the '09 edition, so it'll be new. The year-date version reflects the year the disk was released, so I suspect that the '09 was new around the end of Oct., or early Nov. At least that's what my Lexus date is. It's worth a check, unless, as I say, you would rather get a previous version for less money. If th garage installs it, they will likely charge a pretty hefty fee. Initially, they installed my Lexus disk for $100. and I found out they just lifted the trunk floor, pushed a eject button and put the new one in! -- GFR
  • Ah...upon re-reading my post, I realized that I could have caused confusion.
    I purchased an used 2009 TCH model from a private party - and the disk was removed. Hence I am in need of an navi disk. I do not mind an older - 2008 version if that works, and is fairly cheap. I certainly do not want to pay a full price to the dealer for the 2009 version.
  • Thanks for the part numbers for the new discs. I have been getting the run around from the dealer who sold me my new 2009 TCH. It had the 2007 data V8.1. which was really a problem when we drove to vegas last month. No problem getting there but there are so many new roads in Vegas that I got lost a few times.

    I'm going to the dealer (Vernon Toyota, Vernon BC CAN) today and will ask them to supply me with the new part 86271-53024
    Wish me luck. :mad:
  • gfr1gfr1 Posts: 55
    I think you'll find that the dealer didn't do you dirt. The yearly edition usually comes out about the first of November, each year, or thereabouts. With that being the case, the 8.1 was good from November 2008 to Nov. 2009. The new one is 9.1, because it came out around early November 2009. Therefore, a new 9.1 ver. will be good until about November 2010. Your 8.1 was the current version until the new 9.1 was released in Nov., 2009, or possibly a little sooner. So, if you got your car before November of this year, you would expect to receive ver. 8.1. GFR
  • Has anyone tried connecting a rear camera to 2009 TCH Navi?
    If so, how was your experience?
  • I would hope the dealer would supply you the DVD. They keep extras around for just that purpose. If that is not possible, jhg@mris.com will get you a copy.
  • Where did you purchase your copy? Was it simple to install?

    thank you
  • navguy1navguy1 Posts: 181
    I picked mine up from Carson Toyota in Long Beach, CA. Simply eject the old disc and install the new one. I booted up in 2 minutes. Piece of cake!
  • scottr1024scottr1024 Posts: 3
    Hello,

    Did you find many changes in the new DVD? I have a 2009 Camry and was wondering if it is worth the $200.00.
  • navguy1navguy1 Posts: 181
    The official Toyota part number for a 2008 Toyota Camry Hybrid is 86271-GEN05-09. This is V9.1.
  • navguy1navguy1 Posts: 181
    The AM/FM tuner is for North America only. Thus, it only stops on odd stations... not even. This feature is fixed and cannot be switched.

    I would try to 'reset' the unit by disconnecting the negative (black) battery cable. Leave disconnected for at least 15 minutes. Reconnect and see if this resolves your issue. NOTE - Be sure to let the navigation unit upload the operating system! Don't turn off the ignition while it updates.
  • knarlydknarlyd Posts: 5
    I've read a lot of the emails about making a hybrid copy of the nav dvd. I made an original copy but have yet to try it cuz a few posts said that the negative lead needs to be removed from the battery for about 5 mins. I feel ignorant here cuz I'm used to seeing a standard battery under the hood and don't see anything on my 07 TCH. Is it hidden or is the only battery the one in the rear and if so, is it difficult to unhook the negative? I can do it on a "standard" battery, just don't want to screw anything up of course.
    Also, any potential damage that can occur if the DVD doesn't work properly? Can I just put the old DVD back in place and theoretically the NAV system should return to previous state? Burned the copy but afraid to try it till I get a couple answers.
    THanks!
    :confuse:
  • knarlydknarlyd Posts: 5
    I waited for a week for a response and then decided to try the disk that I burned on a DL DVDrom with DVD decrypter. It wasn't a hybrid disk, I backed up an original. Just had DVD decrypter make an ISO of the disk, then burned it to a Verbatim DVD DL+ dvd.
    I inserted it and now the nav screen just sticks on "checking the dvd" (or something to that verbage.) I can hear it spin up for a few seconds, then spin down, pause, then repeat over and over. Eject doesn't work, just beeps. Audio cuts in and out as it checks the disk (at least I think that's why it cuts out.) So, I'm not sure if there's any hope other than taking it to the dealer and have them perform some miracle at some ridiculous price to get the disk out.

    I just found and unplugged negative lead on battery while writing this email and am praying that somehow the system will "reset" and perhaps let me eject the disk?

    Am I stuck with a huge prob that only the dealer can fix? Please help!
  • knarlydknarlyd Posts: 5
    Well, thankfully I read a TON of posts here before attempting to burn a copy of the nav dvd. I read about disconnecting the negative lead to the 12v battery to reset the system. It worked, As soon as I turned on my car, I pushed the eject button to eject the map dvd and out it popped! Now my system is back to normal.

    I found a couple other threads on the net where dvds got stuck in nav systems that has happened to others but no one offered a solution to them.

    Perhaps this will help them.

    Thanks to members of this forum for the posts, even tho I never received any replies, at least it helped me a little bit.
  • The screen on my 2007 Camry hybrid navigation has gone black. The radio works but I cannot see the stations or anything. Navigation obviously does not work. CD player does not work. Bluetooth still works but cannot see the number. Toyota tells me I need a new unit ($2300)- forget it! There has to be an easier and cheaper solution . help!
  • analoueianalouei Posts: 1
    I recently got a 2008 Toyota Camry Hybrid, I was surprised that I had to load the NAV DVD for the sound system to work, is that normal?
  • On the fuel economy section of the screen there are 3 pages. The one with the energy flow diagram I understand. The one with the recent consumption I understand as well.
    Its the 3rd page that shows average fuel econ/consumption info that seems stuck.
    I bought the car on Feb 4 and there is a 2 bar entry for that date. Have driven it for 3 days since then and that page has not updated at all. Is something wrong? Do you have to go a certain number of miles or amount of drive time for it to register? Couldnt find a good explanation of this page in either manual. Thanks for any assistance!

    Joe
  • tld11tld11 Posts: 1
    I have an 08 model, the navigation sys stays on when we turn the car off, it seems to have ran our battery down, we charged it completely, a few days later it is dead again. Advanced Auto says battery is good, any ideas on what may be causing the problem? I manually turn the screen off now before turning off vehicle.
  • Hi, I have had this happen to my 2007 Camry Hybrid. I am in the process with Toyota to see what they will do. I have 56000 miles so it is out of warranty. I am not hopeful.

    What did you end up doing?

    Tom
  • Where can I buy a used hybrid nav cd player for my 2008 camry hybrid? I ruined the cd player by using home made discs with paper label.
  • contact me at repair156@yahoo.com and provide me the model number and maybe I can assist.
  • if you haven't solved this problem I might be able to assist. contact me at repair156@yahoo.com
    provide the model number
  • Yes it is normal. You must completely boot the system in order to use any function on the navi.
Sign In or Register to comment.