Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mercedes-Benz C230 Problems and Repairs

We recently purchased a basic C-230 (not Kompressor). After approximately 5,000 miles we noticed blue smoke from the exhaust upon ignition. We also realized from then on our car runs similarly to a diesel truck, a freight train (including all the vibrations), or dirtbike. We only use the most premium Shell or Amaco gasoline, and even purchase the highest grade fuel from varying gas stations to make sure an additive, etc isn’t contributing to the rumbling and smoke. The Leith Raleigh service department told us a variety of excuses for the problem ranging from the ‘head gaskets’ aren’t sealed the first 10k miles…to the blue smoke is really ‘steam’ coming out of the exhaust after the car sits all night. They also warned us against using Shell gasoline (which we don’t anyway). We are just wondering if anyone else has had this experience and what the possible REAL causes might be. Please help!!! Thanks!!!!
«1345678

Comments

  • Leith in Raleigh is supposed to be an awful service department from what I've heard. I would try another dealer and see what they say. Also, call Mercedes Corporate and talk with a customer service rep. I would bet Leith is giving you the runaround.
  • My 06 c230 sport has intermittent clacking noises accelerating in 2nd and 3rd gears. The Leith Raleigh mechanic wrote that I should buy better gas. Since I only use premium I asked exactly what better gas he recommends. They followed that up with a suggestion that I use a gas additive for three tanks. That did not help. Leith did a repair that fixed an a/c problem, which in turn seemed to solve the engine clatter. Now five months later the engine is clattering again and I'm on my third bottle of gas additive before giving it back to Leith again. Maybe the smaller six cylinder is inferior?
  • ray_h1ray_h1 Posts: 1,134
    There's nothing at all "inferior" about Mercedes 2.5L all-aluminum V6 engines. The same can't be said about some dealership service departments, though. ;) If the "clacking" sounds similar to what you'd imagine hearing when shaking a can containing several ball bearings, that's what's commonly referred to as "pinging" (technically, "pre-detonation") - VERY unusual for a Mercedes operating on 91 pump octane premium unleaded gasoline. Do you primarily purchase your gas from the same station? If so, you might try a different brand on the off chance your usual station is contracting with an independent wildcat tanker driver for fuel delivery - in some cases all the way from Mexico. If that admittedly unlikely scenario isn't the cause, I'd be looking to take the car to a different dealership. There could definitely be several mechanical possibilities for the pinging (which, by the way can do damage over the long term - best to have this problem attended to properly). If your current dealer isn't taking your car's problem seriously, keep in mind that you're not co-joined at the hip to that dealership's service department - nor are all dealerships created equal, either. A good sales department will close a car sale. A good service department keeps owners satisfied and coming back indefinitely.
  • lakepoplakepop Posts: 221
    Have a PO170 trouble code that showed up with my scanner.
    My question is....could this be related to the gas cap OR is directly related to air mass flow sensor.

    Feedback is appreciated. :sick:
  • rdf63rdf63 Posts: 4
    I am having problems removing the two front tires from a 2000 C230. After visiting a tire store, they stated that the Lug nuts are too rusted to remove. Does anybody have any suggestions to solving this problem and/or have you had a similar problem with the rusted Lug nuts.
  • The driver power seat (which enables the seat cushion to go up and down and driver's chair forward and back) is not working. The passenger's power seat works just fine. My 2004 C240 4Matic has 66,700 miles and just went in for service 3 days ago to change the voltage regulator and battery. However, the driver's power seat worked just fine when I got it back.

    Does anyone think it might be the fuse (which is located in a compartment on the left side of the dashboard)? Should I first try changing the fuse, and then the motor?

    Any feedback would be greatly appreciated!!!!!!!
  • cherdencherden Posts: 1
    Have a new c230 sport, 1600 miles, and it left me sitting. Turn the key all the lights come on, but will not start. Also started and the tranny locked out. Couldn't move. Started doing this 3 weeks ago. Has been at the dealer for 4 days, they have no idea, think it is a command error. Going to try the esp module, well see.
  • had anyone else had issues with your sound system? its been driving me nuts...after the first week my 6 disc wouldn't open then my reception was terrible on my FM radio..then my left speaker sounded busted...then my system would play and i could navigate through the system but no audio would come out....its about ym 8th week with the 2007 c230 and maybe been drivin it for about 3 weeks total becuase its been in service so much! they finally replaced my head unit and some speakers...it sounds a better...i guess.. im just tired of dealing with it.... HAS ANYONE ELSE HAD ISSUES WITH THIER SOUND SYSTEM?
  • Remember you have the only engine that Mercedes makes that runs on both Ethanol AND Gasoline. You know to use only premium fuel, so go to a gas station that carries Ethanol and fill up with Ethanol, be sure to ask for a 10% mixture, see if that clears it up.
  • The rust is from being shipped over from Germany, take it to a different tire store, preferably one with brains! Good luck.
  • Make sure you have you foot firmly on the brake before you try to start, but it sounds like there's something wrong with your key, it has over 20,000 codes in it for security, so if it even gets too wet, it won't work, good luck!
  • Go into your steering wheel button settings and go to radio settings, then set it to reception instead of scan, that way it will only get the stations with perfect reception.
  • cruzzzzzncruzzzzzn Posts: 3
    I had a similar problem with my c230 although earlier year. It did turn out to be a problem with the key in the end. You may want to start at the simplest point and move forward from there.
    Let me know what happens. ;)
  • cruzzzzzncruzzzzzn Posts: 3
    It would sound like your engine chatter was directly related to you a/c problem. The only moving a/c part would have to be your compressor / clutch assembly. It is quite possible that your a/c clutch is defective. You may want to consult another dealer with a specific direction of repair in mind.
  • cruzzzzzncruzzzzzn Posts: 3
    Try spraying them a couple times a day with a rust removing product, (ie. WD40) for several days or longer. Then you can try removing them once again. If you have aluminum rims, they will react with the metal bolts. You may want to coat the bolts with a grease before re-installing them.
  • mrummrum Posts: 7
    I got my 2007 C230 in November. My ABS light came on and I took it to the dealer to be fixed. I ended up taking it in 5 different times for the same problem in less than a month. I kept complaining to the dealer, but what I had to do was call Mercedes corporate. They were great and I am in the process of having them buy back my car. Just wanted to let you know that if you have a lot of problems, call Mercedes Corporate to see what they can do for you.
  • donb13donb13 Posts: 4
    The fuel gage on my 1998 C230 is stuck on full. Has anyone else had this problem? Any ideas on fixing this? It started after I filled up with gas. At first it register on empthy and the light came on that I was running on reserve. I shut off the engine then loosened the fuel cap. It went up to full and it has stayed there.
  • Mercedes Benz C230: On the driver side front corner has been hit and pushed in breaking the headlight damaging the bumper guard pushing the front quarter panel off and bending down the hood unnoticable to the human eye unless you tried to fit a new headlight assembly in there. The damage is extensive enough to be quoted at $4000. I have looked at family and friends in helping out but only so much can be done and parts are not cheap. This is the problem, if I am to fix the accident, the value to fix is about the value of the car. In stating that I am burning $4000 on a car that essentially could last me another two years or take that and put a lump sum down on another car. How am I to gain the most value out of this vehicle without extensively putting alot into it?
  • kufukufu Posts: 14
    PO170 trouble code is directly related to AIR MASS FLOW SENSOR /not enough air in engine/. If you change it by yourself, which is easy, you will save $ 250 for installation. Price of new AIR MASS FLOW SENSOR is $400.
    Good luck.
  • I recently drove thru a HUGE puddle & my car made it thru but stalled after I got thru the water. No water came into my car but it won't start now. All of the lights inside & out come on but it won't turn over. Its a 2003 C240 with low miles on it.
  • Did you check the fuse box?
  • Haven't checked that yet. Put a new battery in & that didn't work. Hoping that it is something simple.
  • lakepoplakepop Posts: 221
    Have a ABS light on a 98 C230. I'm guessing that it is probably a sensor but I am eliminating the easy stuff first.

    Battery.....good
    Brake fluid....full
    fuse.....................CANNOT FIND ??????

    Thats what I need for now....where is the fuse located? I've already looked under the hood in the fuse box....not there.

    Also need to know how many sensors.....1 per wheel or only the front ?

    How about on the differential ???

    I'll pull the wheels and get to the sensors soon. Plan on checking the connections and cleaning them up ......hopefully thats the problem.

    OK....any advice/inputs ?????
  • lakepoplakepop Posts: 221
    Code cleared..........DIY replaced Mass Air Sensor. A very simple <15 min job.

    Obviously saved a bunch of $$$$$ over the Mega Buck dealer.
  • nalaiqnalaiq Posts: 1
    HOW TO OPEN, MERCEDES 1998 C230, MASTER AIR FLOW SENSOR? I WANT TO CLEAN IT. CHECK ENGINE LIGHT IS ON.
  • I have 2000 C230K.(116,000 miles) I will try to describe my problem as best I can. When in D, it sounds like I am driving a 5 speed and changed to 5th gear when I should have changed to 3rd gear. The RPM's are very low (at slower speeds) there is a deep rumbling, and the only way to eliminate it is to a) step on it a little, or b) drop to the lower gear (which doesn't always help much if I am driving 15-40 mph). Nobody seems to have seen this before, one mechanic said he could charge me $2000 but he didn't know if he could fix it?!? Any ideas? Thanks.
  • kufukufu Posts: 14
    The air mass meter is located on the rear of the air cleaner cover on the right hand side of the engine compartment. Unplug the electrical wiring from the sensor by turning the union nut anti-clockwise until it is felt to disengage and then separating the two havles on the connector. Slaken the hose clip at the engine side of the sensor, then pull off the inlet ducting. Release the spring clips at the air cleaner side of the sensor and remove the sensor. Recover the O-ring seal.
    You can get Mass Air Flow Sensor Cleaner on www. performanceproducts.com
    Product Number #883593 Price is 9.95 plus S&H
  • slj333slj333 Posts: 4
    I own a 2005 c230 sedan. The car is great but as the warranty gets closer to expiring, I would like some recommendations on a good and reasonable extended warranty option.
    Thanks,
    Steve
  • hdoolabhhdoolabh Posts: 3
    I woned a c240 2004 model and recently decided to change it for a c230 sport and the only reason i did this was due to the warrenty expiring.

    I went to my local dealer (little rock AR) and traded my 240 for the 230. the 230 only had 10K miles on it and was used as a loaner car for others having work done to their cars. I got full warrenty on the 230 and am very happy with it. One of the keys had a crack on it and the dealer replaced it without any hesitation.

    I would consider doing a trade out for a 07 model the dealer may have in order to keep your vehicle in warrenty.
  • jtyler84jtyler84 Posts: 1
    My wifes 1998 C230 turn signal, power windows, and door locks stopped functioning the other day. I checked the fuse box under the hood and in the trunk and didn't find any blown or loose fuses. I disconnected the battery and reconnected it which seemed to fix everything, but after a day, the passenger side windows operate intermittently and the switch signals are crossed (IE I push the front passenger side window switch down and the rear goes down, or the front goes down but wont come back up unless I press the rear passenger window up or down). Any ideas?
«1345678
Sign In or Register to comment.