Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Rodeo Transmission Questions

2456

Comments

  • wy282wy282 Posts: 2
    I have a 93 Rodeo & the speedometer doesn't work. I want to replace the speed sensor but do not know where it is located.
  • I have a 2002 Rodeo 4x4 with a v6 engine. When I get on the interstate and go above 70mph, the transmission shifts real hard, then the check transmission light starts flashing and every gear shifts hard. however, if i turn the vehicle off for about 5 min, it will quit doing it! Also, when I let off the gas at highway speeds, the Engine RPM's fall completely off and when I push on the gas pedal again, it takes it a minute to catch up to how fast the car is going......can anyone help?
  • I have a 1999 Rodeo automatic, but i don´t find the hole to fill the transmission, is it sealed? Can I filled? What can I do? Thanks in advance!
  • Sorry to hear about your problem. Seems this year has allot of trouble with the transmission. I'd check to see if there is a recall on the trans.
    Me if I had to tow the car I would Have. I also would have rented a car. A couple of hundred in car rental is way cheaper than $4,000.00 also you just voided any warranty on the isuzu..
    It would have been way cheaper than the $4,000.00 you claim; you had a "new" transmission installed; not a rebuild???
  • jinnesjinnes Posts: 1
    1999 Passport has lost forward gears. In TS'ng I found that if I start the veh with a 60 AMP charger on it, I can get 2nd and 3rd to work. Once I remove the charger they go away. When they are failing there is a noise that sounds like something is attempting to engage but won't. I have a SanteFe that Input and Output Speed sensors caused 1st and 4th to act that way. The battery and alternator are good and there is NO check Engine light or DTCs on the scanner. Anyone with experience in this area?
  • can anyone let me know what rpm's thwy're running at 70 mph? Mine seems to be running really high...
  • I have a 2000 Isuzu rodeo V6, it has 85000 miles on it. It runs very good however when I get to the interstate and go above 75mph it shifts real hard and the transmission check light starts flashing however if I turn the engine off after 15 minutes the light stop flashing. I change the transmission switch mode, the fuel filter, the spark plug and the air filter but the light light still come on at 75mph and above. Please Help!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I know there is someone out there who knows how to fix this problem. Thanks
  • The Isuzu Rodeo has a GM 4 speed automatic transmission that is problematic. There is no dipstick. You need to put it on the lift and there are 2 plugs one a bit higher than the other. Open the top one and the fluid should be right at that level. If its not you need to fill it till it drips. If it is sluggish or overreving you should open the lower plug and drain, replace the lower plug and refill to the top plug level.
  • I have a 02 Isuzu rodeo - auto tran.
    Today, while driving city streets at 45mph, the trans light started flashing and the car was rough shifting. It continued for 10 minutes (i reached home). After 10 minutes with the engine off and after a restart, the problem was gone and the light stopped flashing. SHOULD I BE CONCERNED???

    ALSO, sometimes after putting the suv into park, it slips out of gear and starts to roll. I then have to replace it to drive and back to park then it stays in park.

    Please help!
  • tidestertidester Posts: 10,109
    SHOULD I BE CONCERNED???

    I would have it checked out - immediately. :)

    tidester, host
    SUVs and Smart Shopper
  • dachedache Posts: 1
    i have the same transmission, check under in the bottom will see two screws one is a little higher than the other, that's to fill it with a syringe or a manual pump need to lift the car to do so
  • I have the same Rodeo, started having the same problem last week so I booked it in for a "checkup"...too late! It blew on Wednesday, blew the seals and the 3-4 accumulator went AWOL, mechanic figures it's somewhere on the road. Have to have the whole thing rebuilt now, clutches are burned, new torque converter - everything! I recommend you get this checked immediately. Sorry I didn't have good news for you. :-( But you might be able to save it yet, I don't know.
  • fordfan_17fordfan_17 Posts: 175
    my experience with the 4L30E transmission during rebuild procedures make sure that they bore and sleeve the 1-2 servo a very common failure point in this particular unit causing slide bump 1-2 shifts after rebuild ESPECIALLY if the 1-2 band was burnt when the unit was dis-assembled for rebuild
  • I have a 99 Isuzu Amigo (which is now the Rodeo Sport). My local shop ran diagnostics because the "check trans" light was blinking. They got a code of P1843. They didn't know what it meant so I called a dealer. They told me it meant a "torque converter clutch" slippage was detected. What does that mean (he wasn't very clear) and how severe is this? We have almost 100k miles on it so it's probably only worth $3-4K. Fixing this issue sounds like it would require taking the transmission apart which I know isn't cheap. I'm guessing that it would cost at least $2-4K to fix. Is this true? Do I have any other options? We were planning on selling it and buying a new one, but it seems like it will likely be a wash or we'll loose money if we fix it. Should we find someone who will want to part it out?

    Thanks,
    Eric
  • fordfan_17fordfan_17 Posts: 175
    according to my mac mentor p1843 is "manufacturer controled transmission" code this unit should not cost over 2k to fix but it all depends on your financing wether you want car payments or repair the car you already have. I might suggest replacing the torque converter from a reputable rebuilder such as transtar who offers a 3 year warranty on thier products and the tcc solenoid at the same time if you are mechanically inclined you could do this yourself. If not pay a local shop to R & R the trans for you and replace the two items i mentioned. As long as the transmission still appears to function correctly replacement of those 2 items should cure your problem and should be under 1k costs
  • makes sense. Thank you very much!
  • soundrmssoundrms Posts: 3
    I have a 99 Rodeo that had a shift problem between lower gears and noticed every once in awhile it would happen at higher speeds. The shop I took it to replaced the throttle sensor and it stopped.
  • apintiapinti Posts: 3
    My Isuzu 2002 V6 Wizard Alive's (2WD) gearbox was recently replaced by a used one from an Isuzu Rodeo. The problem I'm getting now is that in Drive mode this "new" gearbox will hunt between 3rd and 4th gear. When switched into 3 it will switch through all gears as if it was in D mode. In range 2 and L it's switching as it is supposed to.
    The shop that replaced the tranny checked everything, the wiring, replacing the PCM, range sensor and there are no error codes.

    The strange thing is that when I bought the Wizard second hand a year ago the D light never came up on the dashboard, but the tranny was switching normally. Two weeks ago it started slipping between 2nd and 3rd gear, which ulitmately resulted in a burnt gearbox, without any warning. It now apppears that the cooler was clogged. In the current situation the AT temp warning is working but the D light still doesn't light up.

    So what could be the problem?
    Thanks for reading.
  • btrcoolbtrcool Posts: 1
    I purchased a used 02 Rodeo with an automatic transmission not long ago and tonight the gear shift went on me. I had been driving, went to put the car in to park but my dash indicator said I was still in reverse and when I took my foot off the brake, the car did idle backwards. I shifted all the way down in to low and then tried to go back up to park but to no avail. I tried a second time and then when I put the shifter all the way up to try to get in to park, my dash indicator said neutral. I shifted down in to what was reverse on my gear shift which put the dash indicator and the car itself in drive and I drove home just fine. I parked it with the shifter set to park and the dash indicator and the car itself in neutral with the e brake on.

    When I drove it the tranny seemed to shift just fine. The trouble is the disagreement between the dash indicator (which seems to agree with the tranny itself) and the gear shift which, as it is, is preventing me from putting the car in reverse or park. Any suggestions?
  • wlbrown9wlbrown9 Posts: 843
    Sounds like it could be a transmission mode indicator. A little box down under that indicates to the system where the shifter is and what gear it is in. These tend to get gunky and can be cleaned and re-installed instead of replaced. There are instructions posted on several sites for this.

    One thing that sometime happens is the tranny will upshift and downshift really hard instead of the normal smooth transition between gears. Sometimes you can kind of clear this up by cycling the shifter completely through the range of gears (while sitting still with the brake on) a number of times..this might clean the contacts at least temporarily.

    Pictures and description of mode switch http://isuzufaq.ibctech.ca/range.pdf
    earlier discussions http://forum.planetisuzoo.com/viewtopic.php?t=1707
  • I also have a 2002 Rodeo. When heated and driving 65+ on interstate the transmission shifts real hard and transmission light flashes. After turning the car off for a few minutes...it stops.
    I've had it checked out for over a year by many... and no one can resolve the issue. Does anyone have a solution??
  • alot of times a torque converter lockup issue could be as simple as dirty fluid causeing the lockup valve or solonoid to stick and not apply the converter clutch properly.do a transmission service check the resistance on the lockup solonoid while your at it and add 1 tube of doctor shudder and u might be good to go
  • I Have a 2002 Rodeo and having a problem with the trans, it feels like it's stuck in n gear while in drive gear with a high rpm of 4-6 and goes only about 25 mph this morning I was crawling back home over a little hill back to my house when I looked @ my mph it barely moved the gears all work fine, so I'm not sure whats going on with my Rodeo can anyone shed some light on this situation?
  • I have a 2002 Rodeo, and I was just wondering if there was a way to check transmission fluid levels without taking it to the dealership, and the process of doing so if doing it on your own? The dealership told me there is no other way, can someone help on this subject?
  • just got a rodeo man told me trans was bad no pedal pressure so i bled trans master cyl it got better but still not enough pressure to put in gear what is more common master or slave cyl
  • OK here is the deal. I got this truck from my sisters neighbor and I have a few issues with the transmission. First Im not sure what transmission I have because it looks like it has been changed from a manual to automatic. Second there was no tranny dipstick in the filler tube. Now for the fun. I do have all of the drive gears (L gear will give ya whiplash if not careful), but reverse will only work between 2500 and 3000 RPM. Then when it kicks in its off like a rocket.

    Any help with these problems im having would be awesome.

    P.S. It has the 3.1 TBI engine.
  • i have a 95 rodeo, 3.2. 132,000 miles. no leaks of any kind. just driving the other day on the breeze way when all of a sudden trans light comes on, goes off, comes on. air bag light comes on. and a few others too. pull over check all fluids. all good. start to drive off, trans starts slipping. stop, shut it off. go to start it. turns slow. wont start. battery seems low? never ever had any problems with this car, alway taken in for maintance. car sitting in a lot. i need to move it. any help would be kool. thanks great site.
  • Found the problem. The reverse band was mostly burned out :(.. So It looks like its time for a full overhaul.
  • NO OVERDRIVE,. AT 60 MPH RPM IS 2800.
    MECHANIC SHOWS NO READING THAT THE TRANNY IS GIVING
    ANY REPORTS. I DO HAVE A CHECK ENGINE LIGHT ON SHOWING
    FUEL SENDING UNIT / SENSOR. WOULD THIS HAVE ANYTHING TO
    DO WITH THE OVERDRIVE. OR ANY OTHER SUGGESTIONS.
  • I have a 1998 Isuzu rodeo with 211,000 miles how much should a rebuilt tranny go for installed?
Sign In or Register to comment.