Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Volkswagen Jetta Engine Questions

1910111315

Comments

  • bpeeblesbpeebles Posts: 4,083
    That is not "weird" at all... I told you several appends ago that I doubt that "low compression" by itself would cause a CEL (Check Engine Light)

    The new sparkplugs and injector-cleaner may likely have have resolved the problem. (or made it go away for awhile)

    A CEL will go out by itself if the detected fault is not sensed within 'x' number of "trips"

    "x" is oftnen defined as "50"... but may vary based on the type of failure detected.

    A "trip" is defined as starting engine cold and driving until it has warmed up.

    Perhaps you hit the magic "50 trips" and the CEL went out.

    (Official documentation for all of this is available if you want details)
  • ohbaobeiohbaobei Posts: 19
    I have been totally driven crazy by this 01 Jetta. Today the engine light is on again. but the car run smooth~~~ I have no idea what is going on with this car!!
  • bpeeblesbpeebles Posts: 4,083
    Read the codes.

    Many autoparts stores (Autozone...etc) will "read the codes" for free.

    Once you know wich "code" threw the CEL.... let us know what it is.
  • ohbaobeiohbaobei Posts: 19
    the light was off yesterday and remains off today. Well, i am speechless now.. want to get rid of it so badly!
  • stemsstems Posts: 1
    well i just recently bought this jetta from this dealership. within 2 days of getting the car the check engine lite came on and the car started throwing white smoke out of the exhuast. any ideas what it might be i took it to the dealer and they told me it was a sensor gone bad and for the smoke that started happening after they changed out the water pump.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,694
    So is the white smoke gone or not?
  • suttons5suttons5 Posts: 5
    The code reading is: P0011 Intake camshaft Position Timing Overadvanced (Bank 1). Any ideas of what is wrong?
  • bpeeblesbpeebles Posts: 4,083
    just a wild guess.... the camshaft-position-sensor is misbehaving?

    BTW: An inline 4-cylinder engine has only 1 "bank" of cylinders. A "V" engine would have 2 'banks" of cylinders. The Volkswagen W8 engine has 4 "banks" of cylinders.
  • aramraramr Posts: 1
    my jetta is having the same issues almost seems like you posted the same exact thing i was going to say. the semi steep hill and everything, just wondering if you were able to resolve the issue.....someone please help.
  • tcjettatcjetta Posts: 1
    I recently purchased a 2003 Jetta with an automatic transmission. When I first start it in the morning and come to my first stop sign, the car jerks/chugs throught the intersection. It only does it when the engine is cold. I also notice some shuttering when I am sitting at an intersection, but only on occassion. I took it to the dealer and they didn't know what it was. It doesn't give a code and the check engine light isn't on at this point. Any ideas what the problem could be? I want to get it taken care of before the problem gets worse. Thanks!
  • bpeeblesbpeebles Posts: 4,083
    There are only 2 possible problems

    1) Ignition system (sparkplug fireing issue)
    2)fuel system (injectors)

    I would bet that your ignition system is the culprit. I would start with new spark plugs/wires. (if you have the 2.0 engine)

    If you have another engine, there may not be sparkplug wires on it.
  • vwdawgvwdawg Posts: 162
    Hello: Does anyone know how to determine whether a 2.0 is an ABA vs. AEG? Thanks, vw dawg
  • bpeeblesbpeebles Posts: 4,083
    Please do not double-post your questions... this was already answered in another forum you asked it.
  • 2000 Jetta VR6 has freaky headlight problem. The Left Low beam headlight does not work when the weather has been dry a couple of days but works OK if the weather has been wet. :cry:
    I've replaced the headlight switch on the dashboard, tested the light bulbs and fuses and run conductivity on all the wires going from the light bulb socket. Any body else had this problem? What did you find?
    The left headlight is near the battery, but the seals on the box around the left headlight bulb seem OK.

    THANKS!!!

    Whit Gallman
  • no codes at ecm and VR6 is supposed tobe good car plenty of power to coil but cant locat ecm signal at coil plug when turning over .2002 jetta VR6 sorry forgot to mension what car my girl is driving. :mad:
  • bpeeblesbpeebles Posts: 4,083
    Is there a relay for the HI/LOW beams? Have you replaced it?

    Also, I have seen headlight bulbs act funky like you describe. Try SWAPPING the bulbs from side-to-side and see if problm moves. (this will rule out the bulb as the culprit)

    If that does not help... you may have to troubleshoot WHILE THE PROBLEM IS HAPPENING to isolate the failing component.
  • dp2226dp2226 Posts: 28
    2002 VW Jetta 2.0 4 cyl 135,000 miles

    Car started to sound like it had a bad muffler.

    Two weeks ago check engine light came on and flashed. Garage stated wires were bad and plugs fouled so I had them replaced. They recommended the ignition coil as well but at $400 for just the part I pasted. Car ran fine.

    2 days later the check engine light came on again. I replaced the ignition coil myself. Easy repair. Put the plug wires back as they came out, number 1 in A 2 in B 3 in C 4 in D.

    Car seemed to be running fine, expected the check engine light to reset after 100 miles and it did not. Still makes that sound if you hit the gas when it is in neutral like the exhaust has a chest cold (only way I can think of describing it)

    There was a recall on the catalytic converter and was replaced at 85K. Took the car to auto zone and they said the code was for a bad ignition coil still. Unless the garage put the wires back in coil in the wrong, order I am out of ideas. I have the single ignition coil unit not four separate ones like on a V6.

    Out of ideas...O2 Sensors maybe? I did recently change my brand oil of oil from Mobile 1 Full Syn to Castrol Edge Full Syn. Probably grasping at straws at this point
  • bpeeblesbpeebles Posts: 4,083
    What SPECIFICALLY was the code they pulled out of your car?

    I am not sure there is a code that says "Bad ignition coil".... It sure looks to me that all of these folks are mis-interpeting what the code is telling them.... As witnessed by the fact that none of them have successfully diagnosed the problem yet.

    You did a great job of describing the problem and the steps you have taken thus far... perhaps if you tell us the SPECIFIC code, we may be able to help troubleshoot.

    The MAF (MassAirFlow) sensor on your engine may be going bad. An easy way to check the MAF sensor is to pop the electrical connector from it and let it dangle. (yes - this WILL cause the CEL to light up) Then start engine and drive for a few days. If things are better, then suspect the MAF is bad.

    Also, check the color of your ECT (Engine Coolant Tempararure) sensor. If it is not GREEN, replace it. (about $15 and the Oring) The ECT of that vintage are KNOWN to go bad and VW came out with a better design which is colored GREEN so it is easy to tell if you have the newer one installed.

    You cannot tell if the ECT is bad by looking at the guage on the dash because the ECT has 2 sensors within in.... 1 for the dashboard and the other for the EngineComputer. If the computer "thinks" that the engine is always cold, your engine may run like cr@p.

    Also, you should make certain that the engine is MECHANICALY sound. A compression-test may be a good way to validate that you do not have troubles with valves. (which could also cause this problem)
  • you should not had paid for the coil there is a pending law suite against VW for the coils in jetta and golf also audi that uses same coil you should have done more research in the lemon laws.if you have any ?'s e-mail me. :lemon:
  • vwdawgvwdawg Posts: 162
    Hi dp2226: It sounds like bpeebles has a better grasp than anyone of the possible issues here, but I have a footnote to 77camaro's advice. I believe he/she is correct regarding the coil lawsuit, but I also believe that this was resolved with VW agreeing to a replacement of ALL coils of that vintage, and including reimbursement for repairs of defective coils previously replaced (with appropriate documentation). I had similar issues with my '02 Passat 1.8T. Get this resolved asap, as failure to do so could ruin your cat converter, a $700 repair item. Good luck. vwdawg/audiphile1
Sign In or Register to comment.