Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford F-Series Electrical and Lighting Problems

123457»

Comments

  • ok I have a 96' F-450 diesel powerstroke 7.3L 2 wd. My turnsignals were fading on and off randomly. Then y radio started going nuts quickly turning on and off. The next morning my batteries were dead. I suspected the alternator so I replaced it. I recharged my batteries that are both less than a yr. old, but my truck is not recharging my batteries. My battery guage is not up to where it needs to be and my batteres continue to die. I am no mechanic at all and don't know much at all, someone walked me through the alternator change over the phone, I am a self employed carpenter w/ just this one truck and am unable to work now and it's costing my family money, can someon please help me. If it's easier to call, my cll # is 267-481-0552, I appreciate any help.
  • We are having the same issue with one of our fleet trucks. Have yo been able to resolve the issue? What dealer are you using> Maybe we can get them talking to one another
  • hearnmikehearnmike Posts: 2
    I have a 2005 f350 6.0L, my interior lights wont turn off when the doors open and they wont turn on when i first enter the truck, all door switches have been replaced! any ideas??
  • hearnmikehearnmike Posts: 2
    did you find how to fix the problem? im have the same thing happen!
  • clint56clint56 Posts: 1
    Mt tail lights quit working. still have turn signals and brake lights. the trailer wiring plug has no power to trailer tail light either. there is only 1 volt going to the tail lights on the truck. I checked at the main harness plug at the back of the bed and only have 1 volt there also. they worked this morning.
  • I have a 2005 F-250 SD Lariet PS Diesel 6.0. The first year that they put the Automatic Temperature Contol System in trucks. Intermittently the power cuts out to the unit and panel goes black and the heat, fan, A/C, ext temp, Nothing works. I have been told to take it to a dealer when it is malfunctioning. Easier said than done. We are retired, tow a trailer and are often not near a dealer. The problem is that it resolves itself eventually. Usually before we get to a dealer appointment. It has lasted as long as 3 days and as short as 3 hours. Sometimes it will go off while we are driving, other times it will happen when we start the truck. Sometimes it come back on while we are driving, or when we start it. Stopping the truck and restarting it will not make it come on. Hitting it, hitting buttons etc doesn't do a thing to it. It comes back on when it feels like it. In a rain storm the defrost is necessary, so we have to drive with the windows 1/2 open. Sometimes it goes months without malfunctioning. I think the last space of time was 8 months. I don't know if it is a connection problem, but if it was it should go on and off when we pound on it or the dash ? Driving down the road it will just come on and work fine for months. Other times it will act up every week for a month and then stop for months. Driving me nuts! Please someone - tell what's wrong. All suggestions will be tried.
  • osofine, you're in the throes of lying cheats. Tell your mechanic to contact North County Ford in Vista, CA. I went round-n-round with these clowns over my issue, finally threatening to lemon law the truck ('08 F350 Lariat Crew 4x4 6.4 PS). They have the answer, just be resilient! I also had huge issues with the Sirius radio cutting out. Another major pain in the [non-permissible content removed] and I had to resort to threats to get it fixed. They know they have these issues but the Motor Co doesn't want to recall anything! Good luck, let me know how it works out.
  • I have a 2004 F-150 Heritage, XL Package. About a month ago I tried to start the truck in the morning. When I turned the key In the ignition, my dash board lights started to go In and out with intensity. ( Like a poltergist) The engine wouldn't fire. It would crank over, but that was it. I let the truck sit for @ an hour and retried and it started. I took vehicle to a reputable service center and they called back and infomed me that they were unable to duplicate problem. They had put on various diagnostic testing that revealed nothing. Since that time I have had this recurring problem about 6 times . No one has heard about this issue. Any suggestions or any one else with similar problems?
  • tonyetonye Posts: 9
    edited May 2011
    Just picked up a used 2003 f150. The previous owner mentioned that the cigarrette lighter was not working and it may be due to a blown fuse. Turns out there was no fuse (fuse/relay3) in the fuse box and it's the same circuit with the OBD data collector.

    So bought a new relay fuse (oem) from a local Ford dealer but that did not fix the problem. I've seen a few (handful) of similar threads via Google searches and but no solution other then replace the fuse.

    Anyone else run into this and is there recommended troubleshooting tip to try next?

    Thanks,
  • I'm not sure if you have found an answer. I've been researching this as well. I found this link that describes the same issue as we are having. They have concluded it is a bad instrument cluster. At a cost of $500 + labor, I am still researching. Another site suggested changing out the instrument circuit board first. I'm not sure if the '04 was included in the recall (electrical fires), but check into that as well.

    http://www.f150online.com/forums/electrical-systems/306610-1999-f150-starting-in- strument-cluster-problems.html
  • I had a similar issue and finally found that my Alternator was going out. Had it replaced and all is well so far.
123457»
Sign In or Register to comment.