Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





PT Cruiser Electrical and Lighting Problems

17810121316

Comments

  • ellzellz Posts: 1
    My 2006 PT Cruiser Route 66 edition is doing exactly what you described in this post. It has being having this problem on and off for a few months now and the dealer has not been able to find a fault. Today the problem was so severe that the car loss all power, including steering, causing me to nearly have a car accident. As I drive long distances everyday on the motorway I now feel like its too unsafe to drive. Please let me know if you find out what is causing the problem!
  • ptloserptloser Posts: 1
    Can anyone offer ideas on why when I touch my brake, the car won't start and the needles go wild on the dash? I can get the power to come on and off by messing with the brake pedal, but not long enough to get the car started. This problem was preceded by the occasional automatic door locks locking when I pressed down on the brake.....
  • crzywmn84crzywmn84 Posts: 1
    Mine did the same thing and it was the internal turbo charger. The dealership fixed it about 6 months ago and it was working great, but it has started happening again.
  • Around how much does that cost to have fixed? :shades:
  • jaball0jaball0 Posts: 2
    I’ll let you know if I ever find out. Still no luck with the dealership. Even contacted Chrysler but all they did was tell me to contact the dealership. Big help.
  • pt_nickpt_nick Posts: 3
    Thank you! there were a lot of helpful links that I am going to try tomorrow. If I run into any other problems or issues I will post responses. Also for anyone who has run into this I will let you know how I make out.
  • I recently bought a 2006 pt cruiser with 16000 miles on it and am very happy but something strange happened the other night while driving.I was driving home and the interior lights,radio,air conditioner stopped working.I noticed in the farthest right gauge a "no Fuse light" was on.I figured I blew a fuse and replaced suspected fuse but problem continues off and on.When this happens doors will not unlock from remote,ignition is delayed and it seems like the computer keeps reseting itself.P.S suspected fuse looked fine.Have an appointment with dealer Monday.Any ideas or suggestions.Thanks,Michael
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,854

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • Does anyone know whether there was a recall on Y reg Cruisers regarding the engine light. It has even been reset but still omes back on. Please help!
  • tedebeartedebear Posts: 832
    It has even been reset but still omes back on.

    If a fault still exists the CEL will keep reappearing until it is corrected.

    Have you had it scanned for any fault codes? Places like AutoZone will do this for free.
  • I had the same problem. When I put my headlights on I also saw smoke coming out of my steering column. There was also a burning smell. I took my car to the mechanic and he replaced the headlight switch. Because of the airbag my mechanic said he had to disconnect the battery. That problem is solved but my CD player has not worked since I picked up the car. The radio works and only displays AM & FM, the CD function is gone.
  • Hi,

    I'm experiencing this exact same issue and have had no luck getting the dealer to find anything. Did you figure out what the issue was?

    Thanks
  • Update to this post: Started having several problems with the car--first the fog lights and the drain on the battery, then headlights started burning out. At 94k miles, I took my PT into a local, trustworthy repair shop. They checked out the car and informed me that the computer chip in my car was faulty--something that they said was very rare. Sent me to the dealer because only the dealer can address that issue and program the computer chip. The dealer checked out my car and told me the fog light issue was a result of the "multifunction switch," which had to be replaced. Unfortunately, the computer chip was also faulty, so that had to be replaced too. Additionally, two of my engine mounts were broken. Thankfully I had elected to have mechanical breakdown insurance on the car. The insurance company had an adjuster come out to the dealership to verify all that was wrong with the car, and paid for about 50% of the cost of the repairs. Still, about $1,300 out of pocket for me. The problems I was having have been resolved.
  • I HAVE A 2006 PT CRUISER. THE CIRCLE AROUND THE A/C KNOB AND INSTRUMENT PANEL GET VERY HOT TO THE TOUCH. IT WOULD BURN A CHILDS FINGER OR YOUR OWN IF YOU LEFT IT THER VERY LONG. THE REPLACED THE INSTRUMENT PANEL AND IT STILL DOES IT. I'M AFRAID ITS GOING TO CATCH FIRE. IT SEEMS TO DO IT WHEN THE HEADLIGHTS ARE ON. ANY BODY ELSE HAVE THAT PROBLEM AND IF SO HOW DID YOU FIX IT.
  • We have a 2003 GT Turbo & so far have not had this problem. However I just had this problem w/2001 300M. My private mechanic along with a Driveability Technician and they determined it was probably a carbon buildup in the engine. They put some serious stuff (I don't know what) down the engine and also in the gas tank. After a day or so, it runs as smooth as ever.
  • I have a 2001 PT with 50,000 miles on it. The check engine light has just come on. What is the most likely problem?

    Thanks,

    Bill
  • I have 1 2002 PT Cruiser, and at 89,000 miles, the check engine light came on. In my case, it turns out the computer chip for the car had malfunctioned--apparently that's supposed to be very very rare. The computer chip needed to be replaced, and only Chrysler could do it.

    Good luck.
  • You folks saved me a bunch of money! Code 0601- needs new computer....and dealer fixed it under the 8 year, 80,000 mile warranty.

    I was about to spend $500.00 at the local repair shop.

    Thanks again!

    Bill
  • Hi, does anyone know what would cause the dashboard functions of my '06 PT to litterally quit. There are no overhead lights, no door lock function, the blinkers and headlights work but you can't tell because you can't see the dash light indicators. I tried looking for a bad fuse but the fuse guide is terrible.
    Any suggestions?
  • I have a 2002 Dream Cruiser. I bought this car about 10 months ago, and have had nothing but problems. Hopefully someone here can help!
    First thing that happened was that the fog lights would stay on. The only way to turn them off was to keep the blinker on. Then that didn't work anymore, so I took it to the dealer where I bought it from (not chrysler) and they replaced the Mass electrical switch (whole new blinker), then it kept having a dead battery, took it back again, and found "nothing" wrong. Kept happening, and then it wouldn't start. They replaced the starter selonoid. Then it wouldn't even crack over. Kept having to turn the key about 200 times (not joking, literally) and then it would turn over. So they decided to replace the starter. Still not fixed.... I had them remove the remote starter thinking that it could be the culprit, nope. Now I have this awful grinding noise coming from the alternator area. Still, the car won't start, or the battery goes dead. I still have to keep turning the key numerous times to get it started. As of today, I couldn't get the key into the switch. Had a service guy come out and he had to pound the key in to get it started. Took it to the shop, and got attitude cause I want a Chrysler dealer to look at it. Why is all of this happening?? Since the last time they worked on my car,( to disconnect the "remote" starter), my sun roof, tempurature, and directional gauges, and my left front speaker don't work. Called the dealer and they said that disconnecting the starter didn't have anything to do with those switches.
    Please, I need someone who knows what to do with this car!! I can't trade, cause I owe too much!! PLEASE HELP !! :sick:
Sign In or Register to comment.