Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Liberty Transmission Problems

1356

Comments

  • I have a 06 Liberty Limited the transmission slips when shifting from second to first when turning into a driveway or a slight uphill incline. It also shudders bad when in reverse going up a hill. Acts like it isn't getting fluid to the pump or sucking air. Has anybody else experienced this problem. The dealer said they can't find anything wrong, and the last time they re flashed the computer. It's did it since new and has only 14,000 miles.
  • I bought a Jeep Liberty 2006 Limited that was loaded, and I loved it for a while, but because I was never a truck owner before, I didn't like the loud noise the engine and transmission made. But it is truly beautiful vehicle, and my wife loved it.

    Now the bad part, I had the transmission lock up on me when trying to back out of my driveway,4 times when parked in front of my house at approx 6 & 8,000 miles. My driveway has a little incline, when I tried backing the vehicle out of the driveway, it locked up. I had a heck of a time getting it to unlock by moving it back and forth in all the gears and hitting the brake. It happened 3 of the times when I had the Select-Tract in the 2H Range for rain and light snow like it recommends. I took the vehicle into the place I bought it, and of course they couldn't duplicate the problem when I had it running. I had them make a notation in my service record about the problem. Also I really hate the bad gas mileage this vehicle gets, it's nothing like the 17 city--22 highway it reports it gets, I'm 74 years, and don't burn rubber.

    I want to get rid of this car, but will not take a $10,000 loss, the vehicle listed for $31,040, and it's like it just came out of the factor, but no one wants to give me more then $16,500 for a trade-in. Lou
  • I have a 2003 Jeep Liberty "Freedom" edtion Sport, 3.7L, with a 4sp automatic and 4WD. Today while slipping and sliding to work on rain-slick and mudddy roads I'd had enough and engaged the lever into 4WD High. She ran great until I hit normal pavement again and tried to disengage it. The indication light on the dash went off for a second and then back on again. And I could feel it was still in 4WD. So I pulled back up on the 4WD lever to fully engage it, and immediately the light went off, when it should have stayed on. I tried to disengage it again, but when the 4x4 handle is completely down (and it should be out of 4WD at that position) it's still engaged. Seems that the light has somehow "reversed" itslef but the 4WD won't dis-engag at all. Anybody got any ideas as to what it might be other than taking it in for a costly repair at the dealership? I'm out of ideas as I tried everything I could think of to dis-engage the 4WD. HELP!
  • My Jeep was purchased in June of 06. I bought the extended warranty and was very happy for the first 11 months. However, at 18K, the Jeep wouldn't switch from neutral to reverse. I took it in to have it repaired. Come to find out, there were recalls of sorts and the dealership told me the recalls would take care of the problem. Yay, right? Wrong. I continued having problems with it and returned to the dealership only a few weeks later complaining of the same issue and a new one to boot. When reaching the 3rd to 4th gear shift mark, the Jeep would stall for a moment, make a gassing-it-in-neutral-sound, then jump.

    The problem was not fixed properly and has been worsening since May. The Jeep started to lurch and die at stops. I took it in. The gears seem to grind when I accelerated slowly. I took it in. I have all receipts from the shop visits between May and early November. I'm no car guru, but it's obvious that there is an issue! The topper is a few days before Thanksgiving, at just under 27K, I pulled out in front of traffic and nearly got rear ended because it would not go over 40 mph. Second gear was the highest it would run. I immediately took it to nearby Jeep dealership service shop and explained the details of what I took as a transmission problem.

    The shop replaced the EGR valve and told me it was ready to go. When I went to pick it up today, I pulled out and couldn't go beyond 2nd gear again. I left it parked right in front of the service booth and left the key with the manager with instructions to have the service manager call me first thing in the morning. Honestly, I am becoming disgusted with my Jeep Liberty and Chrysler mechanics' skills in general. I'm thinking maybe a :lemon: complaint is in order.

    Have any of you had any success with a repurchase or replacement? I mean, I do pass the 4x test and the serious safety hazard test for the lemon laws in Texas, but I don't know if a stupid transmission is enough to go legal on their @$$. I'm leaning towards "one more shot," but what if it's still not repaired?
  • This is my third Jeep in a row...I traded off a 2003 Liberty that ran fine....However, this one is a total :lemon: ........I've only had it for 4 months and it has problem upon problem....The only problem is that with the lemon law it has to have the same exact problem 3 times in a 12month period.......I'm at 2 with the air compressor....I just wanted people to know.......DO NOT BUY a 2007 Liberty.........They are the worst car Jeep has ever made.........The worst dealership is Jim Marsh in Las Vegas Nevada........I told the saleman within the 1st week that something was wrong with it......I couldn't take it in until it totally died.......Which was the 3rd week.......Then they wouldn't give me a new car.......DO NOT BUY from the Jeep dealership in Las Vegas - JIM MARSH.......They are not a 5 star dealership so therefore, they don't care about repeat customers!
  • steverstever YooperlandPosts: 40,206
    Please check out Dealer Ratings and Reviews and post your experiences there too.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Suvlove,
    Forbes just released their list of the top 10 worst automobiles for 2007. Jeep Liberty, Nitro (Dodge's version of the Liberty), and Jeep Patriot made the top of the crappy list. So unfortunately, you may be looking at quite a few problems here in the near future. Sorry but you'll probably be joining the rest of us Liberty owners who wished that they'd have bought something else. I've been "repairing" my 2003 Liberty Freedom Sport for 4 years now. Always something "unusual" according to the Jeep dealer. But on line here it seems all too common.
  • wishnwishn Posts: 1
    I have the same vehicle, make model & year. And unfortunately, I have the EXACT same problem. My indicator light comes on, goes off then my car goes into 4wh drive!. When I take it out, the light comes back on. It will flash several times, off n on. I don't know what is up with this. I also have a loud noise (sounds like brakes releasing) every now & again. I don't know if its the 4wh drive disengaging or what???? :confuse:
  • Wishn,
    I would bet the bank that your 4WD vacuum modulator (I think that's what the service tech called it) is faulty. I spent $129.60 at Continental Chyrsler/Jeep in LaGrange, IL for the new part + labor. Service guy also told me that they have replaced a lot of these on 02-04 Liberty's at the 35K+ mark. My 2003 has 46K on it so I guess I've been been lucky. As this forum shows, any year Liberty is basically a dog. More problems than the average vehicle, crappy gas milege, poor trade-in/resale value. Even in mint condition w/low miles- nobody wants them unless you argee to almost give it away.

    That noise you're hearing is the 4WD engaging/disengaging while you're driving it with the bad vac mod. If you pay close attention to your fuel gage, you'll note a big drop in your MPG. I only drove mine some 100+ miles with the bad vac mod and burned over 3/4 of a tank of gas! I'd get it in for service real fast. Please let us know if that's what it turns out to be for sure on your '03. Good luck.
  • I have a 2004 Jeep Liberty Sport 4X4 with a 3 speed auto transmission with overdrive. The transmission seems to slip when backing up an incline. Also it up shifts hard, the RPM's will red line before an up shift. When driving on straight and level I can push the accelerator and nothing happens until I let off the gas and re-apply it to get a rpm rise. It also downshifts with a bang when slowing to a stop. I have also noticed a 50 mpg loss per tank of gas. Do I need a new trany? The fluid and filter were changed but no help
  • My jeep is still in the shop for transmission repairs. There was yet another recall on parts that did not eliminate the shifting/lurching problems. I don't know what else to have "fixed" on it! The diesel mechanic thinks it may be a loss of power but I don't see how that would affect the gears. I am at a loss here. Any mechanic ideas? I've already mentioned that my vehicle may be a :lemon: but I would still like to have my Jeep for a few years longer before I upgrade. Especially since I haven't had it in over a month now...
  • jaztaujaztau Posts: 2
    Hi Guys i have a Jeep Cherokee or(Liberty) as the Americans call it, i was driving and as i wanted to overtake someone i steped on the gas to gear back and i sudenly lost 3rd gear, ever since i only have 2 gears and as soon as it is suppose to go into 3rd the revs just go high and there is nothing....any idees?
  • caribou1caribou1 Posts: 1,349
    Hi jaztau,
    If you heard nothing falling on the road that day and the vehicle can still use two gears, I would guess you have a hydraulic / solenoid / shifting control issue. All gears are constantly meshed so if one breaks, the whole transmission gets "frozen".
    Try to inspect the rotary switch of the gear selector (driver's side) and the big connector of the gearbox control module located near the firewall on the passenger side. Are you getting an error code?
  • i have a 03 liberty with 55 thousand miles. i think the tranny is slipping.. when i am at a stop lite and when i take off on a hard acceleration it hessates to go and : then it finally kicks in and goes but when i take off easy it dont seem to slip.. is it my transmission or something else. has anyone else had this kinda problem.. i have taken it to 2 transmission places and they both drove it and said it was slipping bad i hate to spend all that money if it wasnt the problem... can anyone help me :cry: i had the transmission fluid changed about 3 months ago but it started acting up about 3 weeks ago is there a code that has to be reset after the transmission fluid is changed ?
  • I have te same problemhard acceleration it hessates to go and : then it finally kicks in and goes but when i take off easy it dont seem to slip//I have an extended warranty and they've already denied :mad: my claim for the broken valve. and i'm out of pocket 1300.00 :cry: i just don't want another problem and more expense. so is it really the tranny?
  • hp129hp129 Posts: 1
    Hey everyone. I have a 2003 jeep liberty sport with 100 k on it and my transmission goes into geer ans shifts just fine, but when it down shifts it seems as if its shift down too fast. When it finally is getting ready to shift back down into first is bangs really hard back in. It actually jerks my whole jeep. I took it to a place and they said it was a computer problem in the transmission and I was just wanting to know someone elses oppion. Does anyone think I should get another oppinion?Thanks!
  • ceashaceasha Posts: 3
    WHEN I'M SETTING AT A LIGHT MY TRANSMISSION JERKS REALLY HARD WITH POOR ACCELERATION, BUT WHEN IT KICKS IN IT'S MOVING LIKE IT SHOULD, I'VE HAD THE SERVICE TECH CHECK IT OUT, I'M TOLD IT NEEDS A TRANS ASSEMBLY AND SOME KIND OF PACK. BUT OTHER I LUV MY JEEP.
  • Good day all My 2006 CRD had tranny problems at about 37,00 km i noticed the tranny slipping and on the highway around 120 km/hr it would jump. So I brought it into Jeep and they said it was something to do with tranny lines. So after they said it was fixed it but they didnt after driving some more I found in the morning or just starting off I would have to rev up the engine to get the jeep moving but they looked at it again and put another torque converter in it. I talk to a guy online he said he had the same problem and they put a jeep commander toruge converter in it from what they said would take the power of the diesel engine. So knowing that now why havent they recalled the jeep liberity CRD and put a more powerfull torgue converter in it. But on a side note i got 930km one trip when i changed the oil and put a K&N air filter in it now i get about 830 km go figure eh.
    Spike
  • caribou1caribou1 Posts: 1,349
    I also get better mileage and torque (pull) with a dirty air filter and when it rains.
    I get less mileage when I put a new air filter or when I have the K&N on :confuse:
    Could our turbo be making the air/fuel mixture too lean?

    In my case, cleaning the Boost Pressure Sensor never made a change. Could be due to the mechanically driven waste gate compared to the variable vanes you have :confuse:

    Now that winterized diesel fuel is available, for the same amount of fuel (3/4 tank mark) I get 320 instead of 450 Km or miles, the ratio is the same :sick:
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,619
    If you have a CAI with the K&N, that can lean out mixture, yes.

    With just a drop-in K&N, you are doing absolutely nothing to the engine except at WOT, because you have a throttle plate regulating air flow anyway.

    Rainy weather creates a denser fuel charge, so that effect makes perfect sense.

    MODERATOR

  • So I have this error code, P0838 in the haynes book it say it means 4wd mode sensor low. I can not get my liberty to shift when then speed reaches 35. So basically i can not go faster than 35. I have had previous problems with my 4wd not disengaging in the past. I have no clue what to do besides dynamite. So if anyone out there can give me some suggestions, i would be grateful. Thanks... :confuse:
  • Hello Yes, I should have been here when I bought my CRD but its better late then never. I have had this 2006 liberty CRD and it looks like the front pump when
    after 26,000 miles. Its out of warranty by 1 month and has been great. If indeed I
    can not get jeep to fix this under warranty who makes a good 5 or six speed after market transmission for replacement? I really enjoy the gas mileage and performance I get from the CRD and have realized they is not a reasonable replacement on the market for less the $40,000. So what can I do to fix it so
    I don't continue to have problem.
  • bsitzbsitz Posts: 1
    Yesterday while driving my 06 jeep liberty i put it into part time 4 wheel drive...i backed out of drive way to drive to work and the truck just stopped.....it will not go into reverse while in part time 4 wheel drive. Later on i wanted to check it out again to see if something was wrong and checked the hi neutral and lo....whiel in lo i couldnt get it back into neutral...then once i got it into neutral i couldnt get it into hi....after about 10 minutes it finally got into it but i smelled tranny fluid......any idea whats up?
  • ">Okay where to begin....

    I have a 2003 5 speed manual transmission Jeep Liberty. My truck has been running good up until now. Wednesday driving was fine but thrusday not the same issue. Thursday I went on an errand and notice I have having problems shifting. I felt like I was working against the gears. I fought to get into gear. Sometimes the gears would grind or even pop out of gear or it would shift really hard. That day I took it to a friend that works at a dealership didn't know if he could help me. He wasn't sure what was wrong with it because it wasn't his expertise. I have an on going issue with the transmission mount. When I had my oil change the mechanic there explained that the one of the housings that the bolt mounts to is cracked and needed to be replaced. He told me is wasn't a must-fix-this-minute thing but SHOULD be fixed ASAP. They were suppose to call me about parts and $ but never did. Then I kind of forgot about it. Well my friend that took a look at my truck said that the crack mount could be a factor but doesn't know for sure. He did say the cracked part is a serious problem and needs to be fixed. Upon looking at the crack, I noticed it's the actual transmission mount/assembly and the whole thing would need to be replaced. Oh Boy! But would replacing that fix my problem. Then friday I went on an errand again and it was worse. I had to jam it into gear. I mean all my strength to get into gear. I decided it wasn't safe to drive and turned around to go home. At my last stop sign I put it in neutral and then I couldn't get back into gear. I tried 1st and 2nd and no luck. I ended up having to push my car down the street into my driveway. I really don't know how to diagnosis this problems. I have been told just in talking that it could be A. the cracked bolt mount B. sync rose C. transmission D. clutch E. throw out bearing. Can someone shed some light on this issue because I need my car!!! I am a college student that works full time and this is my only line. Needless to say I need to do something ASAP. Please help.
  • caribou1caribou1 Posts: 1,349
    If you have a 2WD, to check the gearbox you can put the rear differential/axel on jacks, remove both wheels and gently select all gears without using the clutch and engine stopped. Now there is no effort coming from the transmission line, so you can evaluate the accuracy of the shifting mechanism. At this point if you can't shift easily you need to worry :cry:

    Then start the engine without any gear engaged and check for unusual transmission noise. This will tell you the status of the clutch alignment with the gearbox. If the gearbox is severely misaligned you should hear a complaint from the bearings and the splined shaft that reaches into the clutch plate + mechanism.

    Then you try shifting gears using the clutch with engine still running. If you hear cracking sounds while you shift then you can incriminate the synchromesh 'roses'.

    All previous tests put no load on the transmission. When you are on the road you torque the transmission in both directions (+/-) and gears may want to 'let go' when they are severely damaged. This is different from synchromesh wear that has a function of putting two pieces at a same speed of rotation just before penetration of the annular splines/fingers/cogs machined on the gears that are engaged. The synchromesh is a 'consumable' compared to the gears.

    Bonne chance

    ps: the throw out bearing can only get noisier than usual but will not affect the transmission as such unless it explodes and permanently separates the clutch plates (not seen this yet!). If the clutch pressure plate is damaged, you will feel it with your foot when you press the pedal. A broken pressure plate mechanism will sound like a charm bracelet worn by a very old lady with Parkinson disease.

    By putting the truck on jacks, you simulate the usual 'stress' on the transmission and suspension elements; if a fixation element is broken, it will not relax into it's original shape.
  • Same thing happened to my daughter's 2002 Liberty. Driving down the road last week, for no apparent reason, the transmission locks up. Dealer did $300 worth of tests (eat doughnut, drink coffee, read paper, plug in test equipment, come back, read test results, go to lunch, etc..), and said car needs a $2,000 - $6,000 tranny rebuild. $2000 to "open up, poke around, replace gears," or 3-4 more thousand to replace transmission. Too bad, I just put 5 new tires on the jeep. Time to by a Toyota I guess. Too bad.

    Note: can't do a CARS clunkers trade in as jeep has to be in "running condition." Who was the stupid politician who though of that. This jeep is not just a clunker, it's a $10,000 flower pot :cry: .
  • My 2003 Liberty Sport has been running just fine UNTIL I took it in for the 60K service. I took it to a dealer that USED to be a Jeep Dealership, but lost that recently when Chrysler lost some dealerships. This dealership told me that even though they no longer sell Jeeps, they still service them and encouraged me to have my 60K service done there.

    So after I get the Jeep back I notice there's a harsh 4-3 downshift. I bought the vehicle NEW in 2003 and it NEVER did this before. I take the Liberty back to the shop and tell them to fix it. They say they take everything apart and re-check all of their work and that it's nothing that they did. They then tell me that there is a "TSB" about this problem but that they can't help me because they are no longer a Jeep dealership. They tell me I need to go to a Jeep dealership now.

    #1. Is it possible they screwed something up when they were "servicing" the tranny? What are the odds that this problem just happened to start at the very same time they "service" the tranny but the 2 aren't related? Give me a break!

    #2. Why should I have to pay for another shop to take care of a problem when this shop told me they could service the Jeep? Weren't they being dishonest?

    #3. I paid this dealership over $800 when all was said and done for the 60K service! Is it possible they did the complete 60K service when they can't fix this "software" problem that a real Jeep dealership can supposedly easily?
  • Do you ever figure this out ??
    We're having the same issues
  • My 2006 CRD now has 90k miles on it and I have never had any transmission problems that I know of. I don't recall having any warranty work or recall work done at the dealer either. Last week I experienced two (2) similar events that have me concerned. The first time I was in Full Time 4WD and slowing at an ice and snow covered intersection. The tranny failed to disengage, I heard and felt some noise/vibration and it started to drag us into the intersection until I really jammed on the brakes hard and it finally disengaged. The second time I was on drive pavement in 2WD and approaching an intersection. Again the tranny was pulling in idle against the brakes as I approached the intersection. This time I jammed on the brakes hard enough to stall the engine. Once I restarted, the tranny seemed to work OK. About a month ago I had the transmission pan dropped, both filters replaced, and new fluid at my local AAMCO Shop. Since my warranty is expired I try to avoid trips to my Jeep Dealer for service. Any advice or suggestions would be appreciated.
Sign In or Register to comment.