Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Liberty Electrical and Lighting Problems

11314151719

Comments

  • I have a 2009 Jeep Liberty , When I am driving my low tire light and security light blink at me it also reads low tire in the mileage counter . My tires are at the right psi as per the dealer , they are no help because the lights only come on at random . please help :cry:
  • I am having the same issue with my 2003. Where you able to figure out what shorted?

    Thanks for your help.
  • driver side parking light and tail light out also when putting on brake the front parking light comes on. is this a grounding problem. also no power in wire for tail light
  • tc8132tc8132 Posts: 1
    Hey everyone, I have a problem with my 2005 jeep liberty. What happened was the driver side tail light and license plate light stayed on after I shut the jeep off. So I started disconnecting the positive feed to the battery. After doing that half a dozen times, the tail light and license light stayed off. But then I lost the interior lights and radio. Then, I let my brother in law fool with it and I am back to square one with the radio and interior light working and the tail light and license plat light staying off with the jeep off.

    I checked the fuses and replaced a a few of them. I don't know what to do...

    Thanks
  • cableguy33cableguy33 Posts: 1
    allo have the same probleme enny idear what it is?>??? thanks
  • 04liberty04liberty Posts: 1
    I had the exact same issue. During heavy rain, my Liberty's horn blew all by itself, the lights flashed or stayed on and I had many other intermittent electrical issues. i tracked the problem down to water leaking onto and into the fuse panel on the drivers side. There was only a couple of drips on the outside, however when I blew compressed air into the fusebox, water just shot out! The floor on the drivers side was soaked too. 10 minutes with a hair dryer on it cleared out all the water. I had to get a leak repaired in the seal by the windshield and everything is good now
  • danswadanswa Posts: 1
    After cutting off the engine, the blower fan continue to run. I have taken the Jeep to the dealer and they replaced the fan relay switch. The problem continues intermittently. The dealer now has the Jeep back. Though the "check engine indicator" light on the dash came on, the dealer says they can find nothing wrong. No computer error messages, nothing. They say they are keeping the Jeep for one more day, but are at a loss for what is wrong. So, as it stands, when I drive it and this problem happens, the only thing I can do is remove the blower fan fuse to stop the fan. Not are real logical long-term solution. Anyone have any ideas? Thanks in advance.
  • ohjeep77ohjeep77 Posts: 1
    Did you ever find what the problem was? Mine is doing the same.
  • wezwewezwe Posts: 10
    No, I haven't. I don't use my brights and I swear this eliminates the problem. Has only happened a handful of times. My 2004 has 147,000 miles on it and I've had next to no problems with it. This light problem AND a hole in the radiator. I was told by the radiator guy that Jeep is known for it's radiators needing to be replaced. I love the liberty, but couldn't bring myself to spend the high amount of money they want for a 2011, while having concerns about what type of problems I might have. I'm angry that Jeep hasn't done something about these electrical or module (sp?) problems that everyone is complaining about. Stupid on their part, because I so wanted to be a fan. Instead, I went for a Ford Flex.
  • nnm212nnm212 Posts: 1
    Hi,
    My 2008 jeep Liberty Sky slider roof is broke and water start leaking into my car.when the temp outsides 80 or higher, all electrical on the dashboard cuts off and all warning signs are on , and the windshield wiper blades stays on. When the temp drops or when I drive my car a distance , all the electrical comes back on. Please help :cry: :cry:
  • rickc38rickc38 Posts: 20
    Sounds like something is shorted in your wiring harness(es) for the dash or contacts have oxidation on them; try pulling apart some connectors and clean them with switch contact cleaner or something similar. Rainwater has a lot of crap in it and will form a film and short wires in connectors out by bridging the gaps between pins.
  • deemcpeedeemcpee Posts: 2
    Has anyone experienced total electronics failure on their Jeep Liberty? I bought a brand new Liberty in September/October of '09 and last year at around 13K miles I started to experience all lights flashing, car puttering and stopping, all warning lights coming on etc etc. Spent 2 mos at my dealership trying to get it fixed and finally screamed long enough to have them agree to replace the electronics at their cost (Chrysler or the dealership - not sure which) wanted me to replace at mine - despite being under warranty. Fast forward one year and here I am again - exact same issues. All warning lights flashing, nav system "forgetting" my home address, MP3 connection not playing iPod correctly etc etc etc etc. I only have 25K miles on the car so obviously shouldnt be happening - has anyone else experienced it? BTW - been a loyal jeep owner for over 20 years and this is my first issue EVER...thought I had a lemon but they said I didnt...what to do? I'm seriously considering selling and leaving Chrysler completely.
  • We had similar issue where the car had crazy dashboard lights and car stopped running and wouldn't start. Got towed to dealer and the car started fine the next day, and they can't figure out what happened or what to fix. They found 22 communication error messages from the computer, so electrically it's like the car went crazy. Clearly reading these things, Jeep Libertys have a major issue going on electrically. Ours is an 09 that's less then 2 years old. We may lemon law this car if they can't come up with an answer and fix it.
  • you posted back in nov 10 about problems with your 08 jeep having abs. esp, bas, serv 4wd lights lit. i have same symptoms, with no cruise control. did you ever get it repaired.. and if so can you send me a message as to what was the "FIX" crrbsa@aol.com
  • took the 08 liberty into a local dodge dealer monday. they called today said the problem was the rotation detector on the left rear wheel. it is supposed to be ready tomorrow at nine am. i will pick it up in the pm. i had all your symptoms but the mirrors not working.. also my cruise control would not turn on. supposed to be just under 200 bucks . so we will see. from most of the posts i see.. this may be the first visit of several
  • Its so frustrating - my car is now - AGAIN - in the shop. Went to a new dealer in my town and they replaced the entire electronics module on the dashboard - took a week to fix and when I went to pick it up the fuel guage wasnt working so I had to take it back yesterday - now the fuel pump has to be replaced. I have someone at Chrysler that is now my "go to" person but I may be too late to lemon law mine..
  • crrbsa, Hope your local dealer was able to repair your Jeep Liberty. Please post an update once you pick your vehicle up.
    Lisa
    Top Care Specialist
    Chrysler Group LLC
  • Hello, my 2004 Jeep liberty lights go on and off without a reason. It seems to be happening more often. Sometimes when I turn on my high beams, the inside will light up, and vice versa. Meaning I turn on my high beams and the problem goes away. Sometimes the interior lights go off when I use my turn signal as well. Any ideas????
  • Hi there, i have the same problem with my 2002 Jeep Liberty when i decided to upgrade the map light and the cargo light to LED.

    Have you find a solution to that constant 5.3v that runs constantly ?

    Thanks.
  • My 05 Liberty control lights on the column won't work. Everything on the dash works fine though. At night I can't see to use the cruse control, wipers or light adjustment knob. I looks like these lights as well as the instrument cluster (which works) are on the same fuse...so I don't think it's a fuse. I have an aftermarket radio installed and so the radio control buttons on the steering wheel don't work with the new stereo. Could that open connection behind the radio have something to do with it?
Sign In or Register to comment.