Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Liberty Electrical and Lighting Problems

13468913

Comments

  • caribou1caribou1 Posts: 1,350
    Have your battery checked. Since I changed mine I have a totally different truck :shades:
    I think my battery was broken inside and not demanding charge at a steady rate. Since the battery isn't always getting charged, the engine can be "unplugged" from the alternator for a short time and stall.
  • The Ac went out about 3 weeks ago, a week before it went it stopped for a few minutes and started back again. the symptoms are:

    Will not blow A/C, fan, or heat unless car is moving
    Refrigerant level seems to be ok

    I've seen the posts about the resistor and relay replacement will either of these help?
  • angel63. I have an 06 Liberty Diesel. I wanted to have daytime running lights and found that the relay in the fuse panel, (next to the drivers door), was removed. I took one of the relays from the fuse box in the engine compartment and plugged it in. The lights came on and stayed on no matter what I did, so I took the relay out. The question is...is the relay for the DRL different than the ones in the front fuse panel? The dealer could not answer the question. The dealer did say that the stock headlights would work just fine and the power would be less than if the regular headlight was on.
  • The turn signals swithch on the OMIX Mult fuctional does not work but all the other fuctions work find on the main switch? Note: The 4 Way flashers work find!
  • same thing has been happening to me for 3yrs, no one can understand why, but its scary as hell.
    right now i have a different problem, grinding sound while backing up..not all the time.

    but i think the flashing lights has somehting to do w/the factory installed alarm/door lock key thingy....
  • My 06 CRD has an annoying radio issue: after a few hours of happy driving with my tunes, the radio cuts out, then immediately back in, then out, etc. Usually happens about 5 times in a row, then waits for another 10 minutes, then does it again. When it restarts, it begins playing the CD/radio station exactly where it left off.

    It seems to happen more often 1) a few hours into a drive and 2) when the car starts to coast (i.e. downhill, as opposed to receving power uphill).

    My dealer has already replaced the radio once, and the problem keeps happening. Is this a problem with:
    a) the battery? Will a replacement cure it?
    b) the alternator? How to check and fix this?
    c) the fuse (this seems unlikely, since the clock doesn't reset)
    d) the Jeep radio? If I install a 3rd party radio, will it stop? (but I'd hate to lose the radio controls on the steering wheel; those are handy)

    My dealer has expressed confusion. He can't fix it unless I can recreate the problem for him in the shop. My solution to date is to carry my iPod headphones with me to bypass the radio altogether until my patience returns - not an optimal situation! Since I live in Wyoming and it takes 5 hours of driving to get anywhere, this is a real drag.

    Ideas?
  • tidestertidester Posts: 10,109
    When your radio and CD cut out, do their indicator lights also go out?

    tidester, host
    SUVs and Smart Shopper
  • THe radio's display goes black and then restarts. The other electronics in the car do not seem to waiver.

    There is also a loud click each time that the radio turns off. I can't tell if it's coming from the radio on my right or the fuse panel on my left.
  • tidestertidester Posts: 10,109
    The symptoms seem to point to radio/CD unit as being defective. Yes, you had it replaced, but it's possible the replacement was defective too particularly if it was the same model and manufacturer. Perhaps someone else has better insights. Anyone?

    Incidentally, I've read a couple other posting describing similar problems. You may want to look at them though, unfortunately, no one seems to have found a resolution to those.

    Rodeo Alternator and different radio

    Changed Alternator Belt - Now No Power to Radio Only

    tidester, host
    SUVs and Smart Shopper
  • Intermitantly while driving or idling intrument cluster gauges bottom out, check engine light comes on. lasts for a few seconds then returns to normal light goes out gauges back. sometimes when this happens odometer says"no bus".
    noticed sometimes tach needle slow to catch up to acutal rpm. sometimes the headlamp brights indicator flashes when none of the other stuff is happening. Jeep dealership told me theres a problem with my bus line that about 7 different things use to communicate. they advised me to replace the ign switch cause they said it takes the most abuse. of course that didnt fix it. anyone else experience inst. cluster problems similar to this or bus line problems? if so what fixed it. Jeep dealership dosnt seem to have a clue nor do they seem to know how to test those things on the bus line. all they have been good for is hooking up there scanner and telling me the code. i can do that i have my own generic scanner!!! then they want to throw parts at it and had me replace ign switch to start. i could have taken it any place and thrown parts at it. my confidence in the Jeep dealership in regards to trying to find the source of the problem is gone. sure whens its under waranty they delve deep into the problems but when its customer pay they just wanna throw parts at it and not take any time to test the different modules on that bus line.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,116
    These things take patience but yes you are completely correct--the technician should be testing each module for a bad connector or for internal short. Now this type of tedious diagnostic isn't cheap but you really have no other choice. Sounds like your biggest challenge right now is to find a competent dealership or repair shop.

    MODERATOR --Need help with anything? Click on my name!

  • My wife was driving down the interstate about midnight, and the headlights went off, and came right back on. That happened 3 times in about 5 minutes. Never before, that she knew of, and not since. Any ideas of why, and how to locate the problem would be greatly appreciated.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,116
    I'd say a screwy headlight relay or loose wire to/from, would be my first guess, and my second guess a faulty headlight switch or loose wire to/from same.

    MODERATOR --Need help with anything? Click on my name!

  • similar problem in a 2002--- put out over $100 in diagnostics---
    to no avail---
    dealership had "no clue"---
    and it looked like hundreds to thousands to get resolved---
    Jeep "knows nothing about this.."--- although there is a lot on the internet and many other mechanics are aware of problem--- but do not have the expensive test equipment of the dealerships---
    finally fixed the problem by trading it in on replacement....
    peace,
    -t.
  • I have the exact problem on our 02 Liberty. Doing some reading & research with a factory service manual, I believe that I have a bad body control module. Will schedule a trip to the dealer for next week - and I will post here what the problem ends up being.

    As to your comment about the dealer having "no clue" I intend to find a competent delaership to diagnois this problem. These dealers have a ton of resources available to them, but I will admit there are some bad-apple dealers out there.
  • Feel rather silly asking how to replace a front parking light/turn signal bulb, but two things are against me, its my first Jeep product and I tried doing it at dusk. Passenger side, not much room to work in and not so easy to see around the hoses, wire harness and washer fluid tube. I can see the wire plug - it seems to have a red clip or red locking button on it?? Do you have to take the plug off first? Or can you just turn/twist it to open like on many other vehicles? I am assuming you replace the bulb from the back and not via the front lens cover removal?
  • Nevermind, got it, the lens assembly comes out from the front and then can change the bulbs easily.
  • I could have swore I saw this question before but I cannot find it now. Our '02 Liberty's dome lights have been coming on and going off on their own. Some times they will flash on and off and other times they're on for a bit before they shut off. There was a point where it didn't happen for a whole then the other day it started up again. Dealership is of no help. They look at me like I am crazy.
  • Did this problem ever get resolved? I have a 2003 Jeep and the same thing has been happening. My regular mechanic was not able to fix it. He said maybe it was a bad relay but they were not able to fix it.
  • I have read all the suggestions but am unable to get the wiring harness out from the resistor. The red clip was out. (now it's off) Are there clips or a release on the side?
  • i left my keys in the ignition on acc. all night after i had used it to lower the windows a bit to dry up some wet carpet. of course, the battery was dead the next day, so i jumped it. had a bit of difficulty starting but after 10 minutes of cables on, it did start. i drove it around for about 20 minutes and have had no problem with it since. but, the radio is now dead. no clock, no nothing. anyone know what could have caused this?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,116
    Hi---just visiting this topic and thought I'd intrude if nobody minds, to make a few comments regarding SAFETY!

    Your battery is not charged up by any means and this might be causing your problems. You should (next time!) never jump start a completely dead-dead-dead battery (extremely dangerous) and never use your alternator to charge up a completely dead battery, or you'll be buying a new alternator if you do that repeatedly.

    So put the battery on a charger (slow charge, overnight) and see how things are working. Your car's various computers and microprocessors will malfunction when the battery is weak.

    Good luck and I hope others here have more good tips for you!
    Visiting Host

    MODERATOR --Need help with anything? Click on my name!

  • nunsianunsia Posts: 1
    I have the exact same problem with my 2003 Liberty. My heat stopped working two days ago when I was at a light. As soon as I started moving the heat comes back on.
    Help! How expensive is this to fix?
  • pvan1pvan1 Posts: 3
    When I had this problem 2yrs ago on my 02 Liberty, it was the relay switch that needed replacement. In fact I think I found the diagnosis on this forum. The problem I had was that the blower fan was unpredictable. It would come on after an initial start but not blow after stopping for gas or for an errand. Then it would come on after driving a mile or so.The relay is located in the box near the battery --front left.

    If I recall correctly,the cost was between $13-$15. The part was available at a dealer. :)
  • MY DAUGHTERS 2006 LIBERTY KEEPS BLOWING THE RIGHT REAR TAILLIGHT BULD, WHAT COULD BE CAUSING THIS PROBLEM.
  • caribou1caribou1 Posts: 1,350
    Could the bulbs or the holder be loose?
  • hi there,
    I've been having some issues with my '07 Liberty in the winter months. Last year, at first frost the left blinker would turn on when starting the car. using the blinker would not turn it off, nor would turning left to get that " blinker off click" . After running the car for about 20 mins it would stop.

    After a trip to the dealer, they said they could not recreate the problem. it would happen sporadically for the next month, then stopped. This winter, first morning of frosty temperatures and it happenend again. I went right to the dealer, and they thought it would be the BCM, so they replaced it. the next day it happened again, so clearly not the BCM.
    This morning, the blinker and the "door open" dinging were going off ( neither the door was opened nor the blinker lever pressed). It is currently back at the dealer, but not confident they will get it right this time.

    Has anyone been experiencing these or similar electrical issues. The car is a lease, so honestly I don't car if they have to rip the car apart to fix it but it is a bit dangerous to be driving around with the blinker going and not really taking that left turn...

    Thank you for any advice!
  • I am having exactly the same problem with my 2002 Liberty. Automatic door locks, speedometer, headlights, interior lights and outside temp digital,do not work. (directional digital works, which is right next to temp digital, odd) . I checked the owners manual and it does not have circuit breakers listed. :confuse:
  • Having exactly the same problem. Did your dealer resolve it? :confuse:
  • Where did you find a BCM to replace your bad one? Is this a dealer only product?
    Thanks
13468913
Sign In or Register to comment.