Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Avalanche Engine Problems

24

Comments

  • I'm looking for a new car/truck/SUV and here is my dilemma: I like Avalanche’s look, but Tundra’s reliability. Currently I have 1999 Ford F-150, and never had any problems with it. I bought it brand new and now it has 140K miles on it. Once a while I need a pick-up truck, and I’d like to enjoy the nice look of it. The bed in a new F-150’s appears much bigger to what I’m used to and I don’t like it. I like the appearance of Chevy Avalanche, but I’ve read that people are having some problems with it. On the other hand Tundra would be more reliable, but it is rather a typical pick-up truck. I might also add that my teenage sons dream of Avalanche. Can you advise me please which car to choose from, or give me some thoughts to start with?
    Thanks.
  • Yep similar problem 2003 avalanche but dealer took down engine Bad news liffter out cam shaft out also Hmm 68000 miles never hot rodded I am 69 years over this stage oil changed before recomended used best amsoil on the market am told not worth fixing motor probably better to put in new crate engine would be more cost effective as new waranty 7 years 100000 milesI am going through GM motors to see if I can get some help on this problem but told do not hold my breath. Well have serious thoughts about GM and waranty. See what happens with GM customer satisfaction responce in the mean time on rental. Oh crate engine about $4500 and $1800 t0 take out install new motor with putting tin on new engine can"t trade off junker price only screwed Any answers??????????????
    farthur
  • ive got a 06' avalanche i bought used couple years ago and it was runnin good until
    today when the engine light on the dash came on. its got about 57,000 on it. and i cked the antifreeze level was low? umm. i leveled it off. also noticed the volt meter in the dash was showin alittle high 14.8 ? might be allright i guess. also the gas cap was loose so i retightened it. my wife drives it........everything seems allright.
    all the fluid levels, battery connections. no weird engine noises.
    any ideas????????? :confuse:
  • I have an 2003 Avalanche and replaced the motor at 53,000 miles. Talk about sick. Screw GM and American made if all I get is a POS that I had to pay over $7,000 to repair. It had been a good driving vehicle but I don't think I will buy another. Currently, the electronic display is stuck on whether I should select english, french, or espanol. In the name of technology I can't see how many miles I have without dropping more serious cash. I think I need to stop before I get on a ranting ti-raid.
  • cedenscedens Posts: 1
    I purchased a used 2007 Avalanche from a non GM dealer with about 29,000 miles at purchase it now has 35,000 miles 1,000 hours on it. The dealer I purchased from serviced the vehicle with oil change. Time for my first oil change the lifters started to make loud noise similar to a diesel at idle and check engine light came on then started to misfire on number six cylinder. I drove it to dealer for service and oil change and dealer stated error codes P0521 and P0300. During the oil change the dealer stated that engine sludge was the problem. Recommended pulling the oil pan replacing the oil pump all not covered by the warranty “due to lack of maintenance” and possible replaces lifters or total engine replacement. I gave the OK to pulling the oil pan and replacing the oil pump but wanted to see the pan before cleaning. I looked in the oil pan no sludge present pan was clean but some carbon flakes less than one fourth the size of coffee grounds in the sump. I also noticed some larger flakes in the oil pickup screen. I told the dealer to flush the engine two times and change the oil then try to see what happens. Lifters are a little quitter now but check engine light is on and still misfires on one cylinder. Any help would be appreciated.
  • tstotsto Posts: 1
    Does anybody know where the camshaft sensor is located on a 04' avalanche 5.3L? :confuse:
  • doboy90doboy90 Posts: 2
    My 2003 Avalache was idling in a parking lot and quit running which it never has before. Trying to restart it, it will turn over but not start. The check engine diagram is now on in the instrument panel which also has never done before?? Any suggestions?? I checked the fuses and disconnected the battery, still didnt work? After continuous attempts you can also smell gas so I am assuming its not a fuel issue. Help please!!!
  • drdave2kdrdave2k Posts: 2
    I have a 2002 Avalanche with 150k miles on it and have had only one mechanical problem with it and that is the front wheel bearing went bad. I love my truck and probably will never buy anything else. In fact due to the snow and ice I let my wife use it several times this winter and now she wants one so we are doing some shopping. Definitely would recommend the Avalanche.
  • drdave2kdrdave2k Posts: 2
    edited March 2010
    My 02 did the same thing right after an oil change, I went to Wal-Mart and bought a $2.50 bottle of STP oil treatment and it runs like a champ again.
  • I realize this is an older post but thought I would let you in on a current experience that I am having with my 09 Avalanche...I love the truck but have had the oil pump changed at 75K miles via the dealer warranty and had the same chirping sound...turned out to be the cam shaft and lifters...again replacedat 98K miles by the dealer warranty. I have owned the truck since 8-5-09 when I purchased the truck with 5 miles on it...I have driven over 93,000 miles in the 2.5 years that I have owned the truck..lots of highway miles...I have used Royal Purple 5W-30 oil as recommended every 7K miles... I just pray nothing else goes wrong....its still not paid for but the service warranty is about to expire...

    I have always driven a GM product...I own 5 other Chevy trucks with 5.7 litre motors but have never had these types of engine problems. I love the gas mileage...my AV is a 4x4 and has never left the highway...and I get 21.5 on the highway and 18-19 in the town driving...If the engine proves reliable I would like to own another Av as my dealer states that GM will discontinue it in 2013.
  • I am an auto mechanic with 32 yrs exp. I got my 07 avalanche with 30 thsnd miles on it, and have changed oil every 3 th with synt. oil. I service ALL my vehicles with top notch parts, no 2nd brand crap... The engine threw codes for #6 injector, i replaced, no difference, Took off head and #6 rocker arm didnt move. Took to GM and even tho they SEE the engine is clean, wont repair. 1 month outta warranty, just turned 60 000 miles, THEY know there is a problem, becasue there was also another 07 in for the exact same thing the same time as mine. I am going to fight GM for them to fix this. THIS is the reason i will NEVER buy GM again My Nissan pathfinder 225 thousands miles on it and you cant even hear it run.... has anyone gotten it fixed on GMs tab?? this is ridiculous. You pay 50 tho for a truck it shouls last more then 60 thous miles. And my truck doesnt pull anything, Godforbid i have to haul my horses somewhere, then what..... any help from anyone whose had this same issue. i am sure i am not the only one.
  • silver28silver28 Posts: 1
    I bought a new 2010 Avalanche that came with a 6.2 "cadillac engine"..I only have about 7000 klms on it..It sat for a few days and when I started it up a lot of blue smoke came out,,oil would be my guess,,has any one else had this problem??
  • otis4411otis4411 Posts: 1
    edited May 2012
    I have a 06 avalanche with the 5.3L It started that chirping a couple of weeks ago. Has 94K miles and I alway's changed the oil regularly. 5k miles. I'm going to look around and see what may be a better oil to use. I have been using castrol 5w 30. I'm going to buy a used engine from a friends salvage company and maybe rebuild my old engine myself. I'm going to have the heads done to boost horsepower and do a camshaft upgrade maybe from summitt. I can easily add 100hp by doing that. Seems a hydraulic roller lifter has messed up knocking a lobe off the cam. I had a lot of fine metal in my oil pan. So I know how you feel. It sucks.
  • Just had to rebuild my 07. Did you get anywhere with GM?
  • My Chevrolet Avalanche did same thing on 10/2/12. I was driving down the road and the motor started knocking like a jack hammer was inside of it. All the lights came on which were engine light,traction control, stability control and something else which i cant remember. The truck lost all power and i thought it blew up. My Avalanche is a 2007 LTZ fully loaded with a 6.0 motor. Called Gm and they were very helpful. Took to local chevrolet dealership and diagnosed with # 4 cylinder misfired and lifters were broke or locked up and cam was damaged. They are replacing all lifters and new cam in it. Had to show records oil changes but GM gave me no questions after that. Pick it monday. Goodluck and hope they paid for yours also.
  • Good morning badbrad74,

    We're glad to hear that your dealership is taking such great care of you! Keep us updated on how everything is looking when you pick your Avalanche up on Monday.

    Sarah, GM Customer Service
  • 02 avalanche very hard to start on the first start. acts as if no fuel...starts rough and after pressing hard in the gas, will finally lever out and run smooth. I'm guessing a bad cold start sensor, but what do I know. any ideas?
  • I got the same problem and my is only 57,700 miles. I bought it new.
    the dealer will pay half wich is close to 1,100.
  • I would like to get as many people with the same problem
    and try to get a recall on this issue. and for those who had
    paid get their money back. my Avalanche has only 57,700 miles. I bought it new.
    the dealer will pay half wich is close to 1,100. the noise is getting worse.
Sign In or Register to comment.