Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Avalanche Engine Problems

13»

Comments

  • I just had a problem with my 2010 Av, stopped in front of a GM dealer. It was missing and running rough. Dealer has had it for 5 days now and they determined today that #6 cyl lifter was bad and ruined the camshaft as well.
    Is this common for the 5.3 engine? I have never had any problems with GM until this happened. I experienced some ticking noise during start up when the veh sit over night. It would stop pretty quick so I didnt think any thing about it. Guess I better pay better attention. Hopefully I will get veh back tomorrow.
  • My 2010 Av developed a small crack just over the speedometer and progressively got worse. It is now cracked from the window to the speedometer hood. I wrote GM a letter (sent pictures), they contacted me and told me that they would replace the dash but it would cost me $200 because it was out of warranty.... Apparently they have had other issues with the same type of problem. One person at GM said they used the wrong materials in the dash for southern states where it is hotter. I'm in south Texas, its hot here in the summer.
  • gmcustsvcgmcustsvc Posts: 4,109
    Hey jack2330,

    Please let us know if there's anything we can help with during this process. Please keep us posted if you receive your vehicle tomorrow.

    Amber N.
    GM Customer Care
  • Funny I just got off the phone and GM customer service told me that this is expected in hotter climates. I have a friend who has a silverado and he has the same issue.
    This is my second dash. GM told me that they were willing to take off $200.00 for the $850.00 repair. I am going to be contacting BBB because there are so many issues and the company knows about them. I have never had a car or truck do this before. The Rep told me I should have protected the dashboard better.PATHETIC !!

    Tony
  • gmcustsvcgmcustsvc Posts: 4,109
    Hi tonybeth,

    I'm sorry that your case wasn't resolved to your satisfaction. If you would like for me to take a second look and see if anything else can be done please let me know. I can be contacted by email at socialmedia@gm.com [attn Amber].

    Thank you

    Amber N.
    GM Customer Care
  • Buffalobill, I just had the same problem with my 2011 avalanche with 24000 miles on it. Had the clicking noise and brought it to my dealership. They took the car and replaced all of the lifters. Seems to be running smoothly now. I don't know if they ran any tests, but as soon as the guy heard the noise, he told me it was most likely the lifters.
  • 68,000 Miles and already had to replace the Transmission at 48,000 miles. Had noticed for the last couple of oil changes that the engine was using oil. Had to add a quart 2-3 times before changes. Then one day....Check engine light came on, then the dash text read "Check Stabiltrak" and Check Traction Control", switching back and forth between these two warning messages. At the same time, the engine began skipping & felt like it was not running on all eight cylinders. And I could feel the upshift and downshift of the transmission while driving at all speeds. I assume the Stabilitrak & Traction Control msgs were just the computer spiking due to the engine failure. I took it to my local mechanic and he told me that there was a known factory defect in the cam shaft of this engine that caused damage to the valves and that the failure was well recognized and documented among auto mechanics

    Spoke to the local dealership, and they said that there was a common problem/defect with the engine rings (so not only the cam shaft, but also the rings). They contacted GM to ask if any "assistance" was available. Since my Avalanche has only 68,000 miles, they said they would "participate" in the fix; however, since it is out-of-date warranty, it would still cost me $2700.00. Indeed, not much because my mechanic wanted only $2500 to do the same thing without any "Assistance" from GM!!!! What a crock!!

    Engine & Transmission Failure under 68,000 miles.......What a LEMON!!!!
  • mcogs1mcogs1 Orland Park, ILPosts: 2

    Just happened to me too with my 2007 'Lanche. Just recently I had the CES light flash and stay on. Stabiltrack, Traction Control errors, and of coarse the engine missing. LOUD ticking noise on the left side near #1 cylinder. This is the same problem that everyone is mentioning with the 5.3L engines with AFM. Sometimes it will clear up and run normally, but will always come back after a restart. Now here is the kicker! I just turned over 100,000 miles. Like literally 100,016 today. I called the dealer and mentioned all the symptoms and they told me that GM will not cover anything if it is even 1 mile over 100k.
    I have been a loyal GM customer ever since I could drive. My parents always owned Chevys and Pontiacs and I followed too. Even in January we just got my wife an Equinox.

    It really seems unreal that a $45,000 vehicle would need this much repair at 100k miles.

    Either way, I have to get it fixed, we cannot afford 2 vehicle payments. Tomorrow I will make an appt with the dealer to see what they say. I'd hate to say it, but if I don't get any support from GM, I cannot support them anymore.

  • mcogs1mcogs1 Orland Park, ILPosts: 2
    Now it has been a few days and for the past 2, the problem is gone. This doesn't make sense that it is some oil shield in the oil pan, or the lifters, or the valve cover. If a lifter is sticking, then shouldn't it always be stickingThis looks like an electric problem. Something is actuating the AFM solenoid(s). I need to get a tech 2 tool to try to diagnose this when it is happening.
13»
Sign In or Register to comment.