Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Avalanche Transmission Problems

KCRam@EdmundsKCRam@Edmunds Mt. Arlington NJPosts: 3,497
The new place to talk about your Av's automatic.

KCRam - Pickups/Wagons/Vans+Minivans Moderator

«1345678

Comments

  • Does anyone keep having to replace the electric switching solenoid in their tranny? I am at 100,000 and this is my 3rd one! Any insight?
  • chadxchadx Posts: 153
    I've been having a problem with what I'm guessing is some type of trasfer case control/solenoid. Could you describe the symptom so I can tell if it's the same thing? I haven't brought mine in for servicing yet. But basically, sometimes when I start it, the 4x4 selector light shows the red dot in the neutral position rather than the amber 2x4 light. Also the dash flashes "service 4x4". Other times, when I start it, it goes to Auto4x4 rather than staying in 2x4. Other times I can't shift from one mode to another. Usually, I can get it to reset by shutting off the truck and restarting. Rarely, I have to also play with the buttons and/or shift into neutral while doing so. Sound like the same thing? Mine is a 2003 with 60k miles. The problems started around 55k. Thanks.
  • gilberb0gilberb0 Posts: 1
    To All,

    I have a 2004 and have had this issue numerous times. My brother is a Service Manager and he hate's when I call! LOL
    but he finally fixed it! After many encoder modules he found a update on the 2002 and did it to mine. It is a sensor that works with the encoder! Knock on wood it has worked well for several months now! Good Luck! :)
  • My 07 Avalanche transmission, bumps from a dead stop, and bumps several times going up to 10 mph or so, also seems to bump as if I accelerate fairly hard. Kind of like running over boards in the road. The dealer claimed they could not duplicate the problem, but anyone who drives or rides in the truck can definitely feel it. Any ideas? Thanks
  • tomainetomaine Posts: 1
    I purchased a used 2002 Avalache and it did not come with the owners manual. Does anyone know how I can get one?
    Thanks,
    Thomas
  • njbjjnjbjj Posts: 1
    I've been having recurring problems with my transmission leaking fluid...been taking it for service every year...getting gaskets replaced, etc. Been having this problem occur since it was purchased in 2004. They say they can't seem to find the actual cause of the leak...they just do some "bandaid" job of repair, a temp fix...as soon as I start driving it again, the leak eventually starts up again...any clues for a final solution...my driveway is starting to look like a Dalmation with all the fluid leak spots!
  • alc1588alc1588 Posts: 2
    I have experienced the same problems with my 07 Avanlanche also. My dealer says that it is normal and says he did not feel anything wrong, as if I was crazy. I know slipping when I feel it. Have you had any luck with your problem? I am about to just leave there until they find out what the problem is before my warrenty runs out!
  • transmission under lite load or steady speed between 45-60 vibration in rumble strips in road. Dealer found water in oil coming from radiator trans cooler. Truck has 60,000 miles. GM will pay half of cost to repair. Cost to repair before GM $3000.00. This vehicle has seen the shop 5 times since new March 2005 problems getting worst. :lemon: :lemon: :lemon: :mad:
  • I had the exact same problem with mine slipping. I have 8k miles on my 07 and was going to wait until my next oil change to have the dealer look at it. But the other day it wouldn't shift from 3-4. They are replacing the transmission right now. I baby my truck probably more then anyone and haven't towed anything with it. So there was for sure something wrong with the transmission from the factory.
  • My 06 same problem, my service guys told me it was due to putting 22" wheels & tires have to much bite as to the traction. The computer needs some wheel spin in order to controll the torque. They say because there is no wheel spin, it gives full torque which causes the wheel hop. They said I could a high performance forward sprag gear (called a 29 element sprag gear) in the tranny to be able to handle larger tire & wheel combo. It doesn't do it with the factory 17's only the 22's. The other thing they told me was to come to a complete full stop before shifting from reverse to drive & to lightly accelorate before mashing the pedal, but who the hell does that??
  • I also have and 07 AV that is having transmission problems. I have had to the dealership four times, each time the response is the same "It is within factory specs." Yesterday a GM rep drove the truck and said it was functioning according to gm specs. The tranny is designed to return to a zero pressure mode before allowing engagement. (drive,stop,reverse,stop,drive.) I have experienced anywhere from a slight hesitation to lengthy upon acceleration. I have also had the same experience setting at a light then accelerating with hesitation occuring. Now you know why GM offers the 100k drive train warranty. I would be interested in hearing other excuses offered by GM thanks
  • I just had my transmission go out completly on my 07 avalanche with 9000 miles. I just got off the phone with my dealer and he advised me that my transmission was shot and they were replacing the whole trans.. I had similar experiences as other. Sometimes when pulling from a parking spot I would feel like I hit a rock or something and would look and there was nothing there. It finally went out as I was pulling away from a redlight at low speed and kaboom, it was loud, I thought I got rearended. The trans then began slipping until I got home about 2 miles from where I was. Now I will have to wait a few days for a new transmission to be installed.
  • chadxchadx Posts: 153
    Update to my issue:
    "I've been having a problem with what I'm guessing is some type of trasfer case control/solenoid...basically, sometimes when I start it, the 4x4 selector light shows the red dot in the neutral position rather than the amber 2x4 light. Also the dash flashes "service 4x4". Other times, when I start it, it goes to Auto4x4 rather than staying in 2x4. Other times I can't shift from one mode to another. Usually, I can get it to reset by shutting off the truck and restarting. Rarely, I have to also play with the buttons and/or shift into neutral while doing so. Sound like the same thing? Mine is a 2003 with 60k miles. The problems started around 55k."

    Issue has been fixed. I had it fixed under extended warranty. It was the transfer case module that had gone wacky. It's been about 6 months and 8k miles since the fix (with plenting of shifting to Auto4x4 and high and low 4x4 now that it's winter in the mountains) and have had no problems.
  • WHEN is this going to be offered on the Avalanche? What year? WHAT are they waiting for? The new Tundra and 09' F-150 (due out early fall) have these.
  • I have had problems since I bought my AV. Blown transmission at 15,000 miles. Trips to the dealer several times before w/ complaints of slipping transmission and banging into gear. Many other problems as well. Starter doesn't disengage after ignition. Dealer says GM says I have to live with it. Dealing with Chevy to get a new truck. I have lost 14 days with my truck. Dealer very arrogant. Where is the service? brendanfay2001
  • I have an 07 Avalance I bought with 9400 miles on it. Between the RPM rage of 1300 and 1600 it shutters or rumbles. I had it to 2 different GM dealers and when they drive it they say something is wrong. So they contact GM and then they come back and say its normal. I have owned all types of cars threw the years and never had one act like this. I dont feel the people they have working at the dealerships know what to do to fix it so they say it's not abnormal.

    I am very unhappy with the dealership and GM customer complaint. What really upsets me is you buy a vehical close to home and then get this type of service. Also, when you call GM customer complain you have to speak to someone that cant speak english and you have no idea what they are saying. I have 6 Lemons to put on my Avalanche and going to leave them on and drive through the dealership and my home town.
  • patty_mcpatty_mc Posts: 1
    Have a 2004 Avalanche. Recently the transmission went out. Specifically the D(drive) gear went,I can still go from 1st thru 4th and then to the D(drive). AMCO offered to replace the transmission for $2300. The computer at the dealership said that transmission had nothing wrong with it.

    My question is, is there really anything wrong with the transmission or has GM rigged it so their transmissions check out o.k.? Obviously there is something wrong, any advice would be appreciated.
  • 2 years ago i bought a 05 chevy ava the first thing i did was put some 22'' rims on it ,and by the second week i started noticing this strange hesitation. i was at the stop sign waiting for the green light and when it was time to go, i put my foot on the accelarator then the engine reved up but it took a couple seconds too take off i heard a loud clank then it finally moved .now ive taken it back to the dealer and all they gave was bull and they were only going to take care of it untill it was broken down. Now its done this to me 4 times since the only sense i can make out of it is that the transmission is going out.can anybody tell if this has happen to you i appreciate it. :confuse:
  • hp995hp995 Posts: 2
    I purchased a new Avalanche in '05. The first problem I had was in the steering.
    The dealer replaced the steering arm in '06 under warranty. Last year '07, I was on a trip out west pulling a small 10' trailer and the trans. went out. It was 2000mi out of warranty, $2500 to fix it. This winter the tailgate handle broke inside, dealer wants over $300 for a new one, NOT ! I'll use a screwdriver ! Last week I took a trip to Canada pulling a 20' boat and the rear universal joint went out - $200 more. The rear end still makes a noise (clunk)when it's put in gear or sometimes when you take off from a stop. I was told by a friend that the rear universal was under recall, but I can't find anything about it it. I have been a Chevy guy all my life, I have '99 dully FWD pickup, '99 Tahoe (best car I ever had) and the Avalanche. I think I am changing to a Ford guy after this one!
    I like the Avalanche allot but it seems to be cheap made. Almost afraid to take it anywhere.
«1345678
Sign In or Register to comment.