Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Avalanche Transmission Problems

12346»

Comments

  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    That certainly sounds like your transfer case is failing and acting in a neutral state when in 2WD. In Auto-4WD, both driveshafts are engaged and you feel the trans working, but you may actually be sending power only to the front axle.

    kcram - Pickups/Wagons/Vans+Minivans Host
  • jwaymanjwayman Posts: 6
    I'll join the club. My 2006 Av with 87,000 now needs a new transmission. This is the third GM truck that I've owned that needed a new transmission before 90,000 miles. This will also be the last GM vehicle that I ever own.
  • wallace14wallace14 Posts: 1
    First off, thanks to everyone who posted on this forum with Avalanche tranny problems and GM customer support.

    My transmission went at 86,000 on my 2007 Avalanche. Pulling out from a stop sign I heard the loud "thud" lost overdrive, and limped home with manual shifting. I took it to the dealer, they quoted 3300 for a rebuild, 3800 for a replacement.

    I phoned GM Customer Support, we spoke several times throughout the process, and they ended up paying for the rebuild less a $900 deductible which I was responsible to pay.

    So while it still sucks the transmission went at 86K, at least GM made the effort to pay for some of it rather than making me foot the entire bill for a faulty part.

    So thanks again to everyone for the information.
  • lionmamalionmama Posts: 2
    That's one. Wish they would make good on replaced trannies for the rest of us.
  • My 2004 Avalanche's transmission just went only 56,000 miles. Is GM making good yet??? I see that GM took care of some but not others. What are the criteria to get them to fix the problem and who do I have to contact.
  • pdropdro Posts: 2
    My 2007 LT tranny just croaked with 67k mi three weeks out of extended warranty but under mileage. Lost 3 and OD with so hard my head almost hit the steering wheel. GM charged me a 1k deductible and four days later went on my way. The day I got it back on highway in ID it shuddered like crazy. Almost wrecked it, and the 4wd service light came on. Took it home and tried 4wd, screech! Was fine before. Parked it. Duh, the torque converter is bad. They are replacing that, but they say the transfer case is a separate $2100 issue. Isn't it directly hooked to the trans by the output shaft and not designed to take that kind of shock? Coincidence, really? I have talked to several mechanics stating it is no coincidence... Got a ticket thru customer service and waiting for dealer to call. Second time around without truck for 1.5 weeks because of initial mess-up. I am sure the transfer case got blown up by the bad trans and they missed that just like they missed the torque converter. Had to stay local on Thanksgiving weekend.. Good stuff... If no positive outcome I am going back Japanese. Fuel pump already done under warranty... Good luck!
  • Our truck has never driven the same since the transmission was replaced. It was never made right in our case and we were out of pocket way to much money for a 2007 car that still to date has under 40000 miles. Extremely dissappointed and went with Toyota in October for a new vehicle because we will not buy another Chevy after our horrible customer care. Nothing was done other than an offer of money towards another new vehicle and it was just over the out of pocket expense to replace the transmission. Our truck had been paid off and we buy vehicles as an investment to last us many years, we should not have had the issues we had so there was no chance of us picking up a payment on a vehicle with a company that did us so wrong.
  • pdropdro Posts: 2
    So the saga continues. After contending that no help will be given and there is no possible way a trans slamming out can damage the transfer case (which it is bolted to!), even though the trans was rebuilt and left with a bad torque converter, which has taken another week and a half to fix. Escalation in GM customer service has reversed the position and i will be getting help fixing the car. Hope to pick up tomorrow and will see how it runs.
  • It really is a travesty after reading about all these transmission problem posts. I have a 2004 - Z71 Avy, I purchased brand new in Sep 2003, ~$44k truck at that time, all the bells and whistles and upgrades. I bought the xtended warranty, and of course thats long expired. The passenger seat motor failed just before warranty expired, fixed at no cost. The transmission was hard shifting on starts, about a year or so after buying, almost like a "bang", dealer in Northern VA said it was common but should not be a problem, they actually pulled the driveshaft and put in what I believe was nickel coated splines to help it shift smoother - not!, had no effect. Since warranty expired, Ive had both driver window motors fail, then both rear window motors have slowed to half speed, the heater or air conditioner now only works when it feels like it (winter or summer), and the 6 unit CD player confiscated 6 of my favorites last year - and still wont eject them. Today, back out my driveway, put in drive, a clunk, and voila!! No overdrive, no 3rd, 2nd barely holds going up a slight incline, and basically only have 1st gear! This truck has been babied, Mobil 1 Synthetics from the start, required dealer maintenance (tranny flush and transfer case and rear end gear oil 2 years ago), cleaned and waxed, and planned to be my retirement vehicle. It only has 108,000 miles!!! These trucks are supposed to log over 250k without major problems, when serviced and maintained! I work for a major GM supplier subsidiary, and was so thrilled to own this for a decade, now this. Brought to local dealer today in 2nd gear, 1 mile from my home, and they found zero codes, bringing back this Thursday for a longer investigative visit. I can hardly wait what GM's input/response will be on this one, as I have seen quote a few here from GMCUSTSERVICE. I see theories on sprag, rebuilds, replacements, TCM's, solenoids, etc. Engineering design flaws??? Hmmmm. Standing by their product? I hope so...Will update here with shorter briefs, once I get new info, just wanted to get the background established.

  • baggedavibaggedavi Posts: 2
    I have an 03 avalanche, only has 19k original miles. The other day I was driving and it went into limp mode I checked the fuses and an ignition fuse was blown I changed it and all was good again. A few weeks later it went back into limp mode, checked fuse all were good, so I reset the computer and go for a test drive still in limp mode. While I went to reverse out I put it back in drive and all forward gears wouldn't work... So I did some research I changed the 1-2 and 3-4 shift solenoids and transmission filter. Still no forward movement.. So I changed the VSS because my speedometer quit working too. Still nothing. If I put the truck on jack stands the wheels turn in all gears... Can someone help me I am having a hard time believing I need a rebuild with such low miles... Also when I changed the fluid it wasn't burnt and looked good
  • gmvictumgmvictum Posts: 1

    I have a 2007 avalanche,with 66365 miles. I took it to a chevy dealership, they said it was the nature of the beast.(when I put the tranny in drive the universal would bang the rear then the tranny...I took it to another dealerhip...told me the same thing....Ask to have a GM rep come in, a week later he said the same thing...It's the nature of the beast..I told him that ..(You and two other dealerships told me the same thing....This all happened in 2011, still under warranty. Now the tranny went.... called GM. They told me can't help you sorry...2007 is when GM was going bankrupt...and nobody gave a crap...Now I got a $3200.00 bill to look at. Any thoughts?

  • ttjttj Posts: 1
    edited August 25
    I purchased a 2007 Avy in 2007 with 18 miles on it, this is the first vehicle that I can truly say that I Love, but at 32000 miles the Trans went out in April of this year, had it rebuilt and it went out again in July. Now I live in GA it went out in Mississippi, and by pure luck it went out again while I was in Miss at almost 35000, no torque, no power, would not pull the small hill at my moms driveway, but it would shift properly. Took it back in they did another rebuild this time only made it less than 10 miles this one would not shift into overdrive, took it back in they supposedly put a brand new from distributior, and last week as I went to put it in drive it is bumping very hard, now I don't do problem vehicles, but this truck was suppose to be my last vechile and you can't beat the gas mileage, I went from Kennesaw Ga to Natchez, Ms on less than 100 dollars in July 2014 even with 325 a gallon gas prices 480 miles give or take a few. My ?? Is, Could this be electrical??? And why has GM gotten away with this for so long? Can someone please post a phone# or an email address or something so that I can talk to someone about this? Will not be a happy camper if I have to get rid of my candy apple red baby!!!¡¡¡
  • I have a 2007 Z71. Today I was at a stop sign turning right. A soon as I turned the corner there was a load bang/clunk and truck felt like it was in neutral...drive and 3rd not working, 1st and 2nd okay. Local garage was just down the street so dropped it off with them. They are contacting transmission place to see if they can figure out the problem. 160,000kms. I am retired on a fixed income and finally have the vehicle I always wanted, loaded, leather navigation etc. I bought it in 2011 with 90,000kms. Have had to change both front bearings ($600 each), U joint, exhaust problems and a few other minor issues. I paid $24k for a used vehicle (in 2011) to get what I wanted, love the Avalanche but can't afford this.
  • My Avalanche is an 06 and after reading nearly every post here on topic, I don't feel as bad as most of you, although I have no idea of the owner before the guy I bought my Avalanche from had to change the transmission before he sold it. That original owner who bought mine new only kept it for 3 years and the guy I bought it from had it for 5. I bought it with 91,000 miles and it had no warranty left due to private owner sale, but I did have to checked out by a shop before I bought it, ironically, it was the shop the guy I was buying it from had taken it for all its service work. Well, I had it 6 months and while not even taxing the tranny in any way I lost overdrive and 3rd all at one time when I was backing it up to move it a few feet over at a part. I had only put it in 4wd twice during the time I owned it and I had to "limp" home shifting up from 1st and 2nd into 3rd and overdrive, but could NOT start out in drive or 3rd. When I got home, the shop guy acted shocked and mind you, I had just asked him at my oil change 2 weeks prior, if there were any major service work that needed to be done at 100,000 miles.. he said, no, just enjoy driving it because Dave, the previous owner had the tranny flush done right before you bought it... Well, you can probably guess how angry I was, and still am. I am going to talk to the shop today. I have 101, 000 miles on this thing and have only changed the oil twice!! I drive it to take my son to school and fishing and that is IT. Never took it back woods mudding and the guy I bought it from is in his 50's and I know he didn't either. I am getting ready to pay $2,200 for the rebuild and not at all happy about it, although I would have to say that at this point I am weary about even keeping the truck. Any feedback from forum members would be greatly appreciated. I don't believe my truck has had any other work done other than the transmission being replaced which I am doing now. To my knowledge, the previous two owners were older guys who did not overuse or abuse the truck. It was spotless with no dents when I bought it. Thank you for any feedback folks
12346»
Sign In or Register to comment.