Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Start Stall Idle Problems

1394042444557

Comments

  • Well, I have taken the both battery terminals loose and cleaned them, the battery stayed disconnected for more than 30 minutes, sprayed contact cleaner on all 3 plugs going to the new pcm, cleaned the ground for the wiring harness and still this thing will not start! I even put the old pcm back in just to check all the lights and gauges on the dash and I still have the 'skim' illuminated, volt, fuel, water temp and oil pressure gauges are inop, this dash indication is the same for both pcm's (old or new) . I used a handheld ODBII diagnostic checker with both pcm's installed and it displayed 'no link' both times. I'm at a loss..... :confuse: :cry: :mad:
  • Here's the update on fixing the jeep....on Friday, I talked to the service manager for the local Chrysler dealership and told him everything that I had done and all the problems that I was having. He told me to unplug every 3 wire sensor on the engine....cam position, crank position, throttle position, etc. When I had unplugged the shorted sensor, I would hear the fuel pump relay energize. I first unplugged the cam position sensor, nothing....then I traced the wire bundle back into the engine compartment and unplugged a connector that led around the engine and voila! I heard the fuel pump relay energize....as it turned out, the problem was the crankshaft position sensor. I got it changed out today and my wife and daughter are very happy to have the car running again. This sensor, though, was a bear to change out. most of the work was done from underneath and very tight space to do it in. BUT......it is done!
  • alby3alby3 Posts: 46
    buy yourself a new tool...............
    alan
  • I have a 99 Jeep GC Laredo (v6, 4x4). Recently it has been having trouble starting. When I turn the key it will take a while to catch, and when I can hear it beginning to engage I have to immediately give it a little gas in order to get it to catch. Once the car starts I have to keep my foot on the gas to hold the car at around 1000 rpms, otherwise it will stall out. I have to hold my foot on the gas like that for about 5 mins- basically until the engine warms up. Then it will be able to idle around 500/750 rpms and not stall.

    Is there any way this could be as easy as just changing the spark plugs??

    I will add that the car needs several parts (catalytic converter, muffler) of the exhaust replaced (exhaust is leaking). I didn't think that could be related but I don't know a whole lot about cars..
  • ucheuche Posts: 2
    i have a 2004 grand cherokee which refuses to start. Dashboard shows key cancellation symbol. Fuel guage is also refusing to rise. had this problem after servicing gear box.
    What should i do.
  • Hello all...

    This is my first trip in here and do hope that you will be able to help me out...

    I have a 99 GC Laredo V8 4x4 that just started having issues today.

    It WILL start right up, idle very low, then shut off every time. When I turn the ignition key everything lights up and I can hear the fuel pump run. When it starts, I can give it gas and it will rev up and then proceed to die once it runs out of fuel. I then turn off the key, turn it back on and the same thing all over again. I do not want to point anyone in the wrong direction however it just seems that once it runs out of fuel pressure it dies. I am by myself and cannot get under the jeep to listen to see if the fuel pump continues to run while it is at such a low idle... Any ideas???
  • Hi,

    I have a 2002 JGC, 4 cyl. It has about 140,000 miles on it. While driving last night the engine cut out while driving then started up again- felt a hard shake from the engine. It did it a few times until it completely lost power. I pulled over the the side of the road at one point and tried to start it. I heard a rapid clicking noise and then the car went totally out. Has this happened to anyone else? Or can someone tell me what they think might be the problem?

    Thanks,

    Rebekah
  • ucheuche Posts: 2
    i have a 2004 grand cherokee which refuses to start. Dashboard shows key cancellation symbol. Fuel guage is also refusing to rise. had this problem after servicing gear box.
    What should i do.
  • 2001 Jeep Grand Cherokee: intermittent no crank/turn over/start when turning key, but all electrical is okay. I do have an after-market remote starter/alarm system. Not sure if this is a contributing factor or not. Car will subsequently start on the 2nd or 3rd try when I do experience the no-start on the 1st try. Probably happens every couple of days. Any thoughts? Thanks!
  • Hi, sorry to hear you are having issue's. these jeep's are great but have been known to have electrical issue's. I had the same problem with mine. Now i alway's turn the key just far enough to turn on all the electronic's and listen for the fuel pump to run and stop then it crank's on the third revolution of the engine every time. the fuel will ease back to the point where there's no fuel or not enough to have the pressure it need's to start and if you let the fuel pump build the fuel pressure back up that may fix it. try it and see if that's the issue.
  • au80au80 Posts: 1
    Have a 2000 GC Laredo - first started showing key symbol then gauges going haywire - runs just fine. Found loose positive battery connection which seemed to resolve the gauge issue but key light remained on intermittently. On for a few seconds -off a few seconds. Dealer did not seem to have a clue - no codes found - at least they did not charge me.

    Today I tried disconnecting the battery completely and let sit for about an hour - hopefully to let computer reset. So far no key light and everthing works - crossing my fingers!!!
  • I do have the same problem on my 2004 gcl, it wont start and gauges dont raise, the cancelation key code comes up, according to owners manual this is an electric problem but I still trying to find it, does anyone have a solution for it? what can I do?
  • HELLO THERE., HAVE U FOUND THE PROBLEM YET? ANYTHING THAT YOU CAN SHARE WITH US??, MY 2004 GCL HAS THE SAME PROBLEM AND DOES NOT START AT ALL :(
  • are they the 2 screws that hold the mounting bracket on to the fire wall? on the right side and under the PCM its self?
  • what I did on my 2000 4.0 gcl, was to start unpluging all the 3 wire sensors on the engine (crankshaft position, camshaft position, map sensor, etc.). If any one of these sensors has shorted out, it will kill all the gauges. As I have found out since working on mine, the most likely culprit is the crankshaft position sensor. As soon as you unplug the bad sensor, the gauges will come back to life and more than likely you will hear the fuel pump relay in the fuse box in the engine compartment energize. I learned that a bad sensor will not kill the gauges, only a shorted out sensor.
  • alby3alby3 Posts: 46
    edited December 2011
    i have a 2000 gc v8 4x4
    well the dealer seems to have fixed my guages going on and off. skim light coming on and car dying.... always started back up but when the temp outside went below 50 degrees the skim light would come on and the guages would start and stop working. they ended up replacing the instument cluster, the pcm, the crankshaft position sensor and maybe the skim module as well..... when they put it back together they left the skim module disconnected, their idea and i was all for it...... $1600 but they seemed to get it right
  • :confuse: I've scoured the boards but never found a solution to this, so here goes:

    I have a formerly well behaved '95 JGC Orvis, 5.2L (remember when we called one of these a "318"?), 165k miles, which, rightly or wrongly, I love. :shades:

    It has developed problems, which may or may not be related.

    First, It has the relays clicking (repeated clicks, from the ASD and starter relays) before the CEL comes on, then requires multiple tries before it will actually start, but when it finally starts, it runs fine. If it stays warm, it starts more easily for the rest of the day, if it cools all the way down, it goes through the relay clicking --> CEL light up --> start process again...

    Second, it has a draw that takes the battery from fully charged to barely charged overnight that has thus far eluded testing to identify the cause.

    Finally, while driving over longer distances it has begun tossing a code 032 (EGR) which goes away on it's own, and the VIC has started complaining about Servicing the 4WD Switch. I have had it on an OBD scan tool and all of the numbers are in a range that seems ok once the thing is running and warmed up...

    I have pulled all of the fuses and relays, tested them, and cleaned all of the contacts. I have replaced the CPS, ASD and Starter relays, the battery and the ECM, none of which have solved the problems.

    Has anyone seen any of these issues / problems and found a fix that didn't involve a shotgun and a shallow grave? ;)
  • So I went to go start my jeep and turned the keep on and didnt hear my fuel pump coming on, like I usually do, and it wont start. So I went and bought a new fuel pump and new fuel filter and installed. Now when I turned my key to the on position, I hear a ticking noise coming from under the hood from the fuse box, where the relays are. So I went and bought a new fuel pump relay switch and installed. Turned key on and ticking noise coming from the Auto Shutdown relay switch so I switched that relay out and still makes a clicking noise for about 30 seconds. Even when I remove the relay switch from the box it still clicks for a bit then stops and still wont start, and also noticed that my rpm gauge is bouncing from 1 to 1 1/2 Rpms for about a minute then stops. If I spray starter fluid into the throttle body it will try to start but wont. Never had a issue with this jeep til I changed the fuel pump Yesterday. Please help, idk what else to do. Thank you
  • dana having the same problem with 96 jeep cherokee laredo. it stalls backfired blew the muffler out. checkeed the pcm and one screw was out. you are saying washers and wrap it in plastic. wrap the whole computer in plastic then screw it in. my catalatic converter is also plugged do you have this video. you can send
  • So I went to go start my jeep and turned the keep on and didnt hear my fuel pump coming on, like I usually do, and it wont start. So I went and bought a new fuel pump and new fuel filter and installed. Now when I turned my key to the on position, I hear a ticking noise coming from under the hood from the fuse box, where the relays are. So I went and bought a new fuel pump relay switch and installed. Turned key on and ticking noise coming from the Auto Shutdown relay switch so I switched that relay out and still makes a clicking noise for about 30 seconds. Even when I remove the relay switch from the box it still clicks for a bit then stops and still wont start, and also noticed that my rpm gauge is bouncing from 1 to 1 1/2 Rpms for about a minute then stops. If I spray starter fluid into the throttle body it will try to start but wont. Never had a issue with this jeep til I changed the fuel pump Yesterday. Please help, idk what else to do. Thank you
Sign In or Register to comment.