Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Dakota Electrical Problems

11112141617

Comments

  • Ok I forgot to turn off the head lights and they were on for long enough to drain the battery completly dead. I hooked up the charger and (the under the hood light) lit up I tried to start it it just turned over but it wont run turns over well and none of these work: dome light, under the hood light, and the radio but the fuses that go to them are all tested ok. Funny thing is instrument pannel works (gadges only no backlight),and power locks/windows work as well. Also the battery is fully charged now. I never ran into a problem like this any help would be great. 1996 4x4 Dodge Dakota v8 5.2
  • When I turn on the heater fan it does not run. The parking brake and ABS light under the tach comes on tho. Also, when in reverse the same light comes on, but no back up lights.
  • Blown fan fuse caused this, hmmmm.
  • kv4alkv4al Posts: 2
    Does anyone know where the 3rd brake light wire that goes to the back end of the truck is located and the color code of that wire. Right now the cap dealer connect the light to the left brake light and the HP is not happy with this arrangement.

    Any Ideas in Dakota Land?
  • clb86clb86 Posts: 2
    :confuse: If I leave my truck sitting for an extended period of time i.e 10+ hours i have to jump it when i want to go somewhere. But, if i come back after a short time it will start right up. I went to Autozone had them check the battery, alternator, and starter everything came out to be fine..
  • Check the light under the hood, Mine was staying on, draining the battery. Solution was easy, remove the bulb.
  • srs_49srs_49 Posts: 1,394
    Certainly worth looking at, but I wouldn't think that would drain a battery in 10 hours or so. Maybe over a week, but not 10 hours.
  • clb86clb86 Posts: 2
    i looked for the light under the hood... dont see one.. so theres got to be something else causing this problem... solenoid? spark plugs? fuses? i' have had the starter, alternator and battery tested and they all came out to be just in great working condition..
  • I have a '94 dakota. Just purchased. Ignition was punched out of it and was starting it with a screwdriver. Was working fine. Went to car parts store to buy new ignition switch and cylinder for it and the thing wouldn't start. Turn the key: nothing, not even a click. Ok, so I installed the new switch and cylinder, figuring the screwdriver fix finally crapped out, still nothing and now, when the switch is in the on position, I have no idiot lights, no directionals, no radio, no heater blower...pretty much anything that only comes on when the switch is on wont work.

    I found a blown fusable link over left shock tower. (very heavy gauge black wire). Cut out the link and with switch in on position, if I connect the two ends of the wire, still nothing. I even tested the plug on the switch with this wire connected and there is no power to any of the pins in the harness. This tells me that there is something going on between the switch and the battery, but what?

    Any ideas would be helpful.
    Thanks,
    Branden :confuse:
  • i have a 2000 dakota and i have replaced a lot trying to figure it out. My problem is it wont start all it does is clicks for a second and stops and clicks and stops. cam amyone help me out here
  • I have a 2003 Dodge Dakota. For some time I have experienced a problem when the headlights are on and I turn the wiper control on the multifunction switch to the 3rd and 4th position. The headlights work OK when the wiper switch is at other positions. I've read that the multifuntion switch may be causing the problem but I don't understand how the headlight switch and wiper controls are related. Can anyone help before I experiment replacing the multifunction control switch.
  • i have a 1996 dodge dakota sport v6 magnum engine. my dash electrical system is having trouble the dash lights go out sometimes with a buzzing sound that is constant along with the gauges all pin unless you turn the dimmer all the way down and the sound goes away and the gauges go back to normal . the radio works sometimes and sometimes it doesn't or the light in the radio area don't work but the rest do ??? is this a ground wire problem ? sometimes it does it every day and goes away for a couple of days and comes back out of the blue. or the radio doesn't work for days and just comes on from no where as you drive .
  • srs_49srs_49 Posts: 1,394
    Bad ground connection could cause your problems. The return current for lights, that come through the dimmer, may be finding a sneak path through the gauges.
  • jbrunnerjbrunner Posts: 3
    I see that no one replied to your post, I am having the same problem, did you figure out what the problem was?
  • jbrunnerjbrunner Posts: 3
    I feel too that it is a short somewhere. When I turn the light switch on, the abs,brake dash lights come on, when I push the switch off, I can hear a click coming from the cowl about in the middle of it. I guess the next step is to remove the cowl and see if I can locate it. Thanks for the reply.
  • jbrunnerjbrunner Posts: 3
    seeing as no one gave an answer, I went and had it fixed. It turned out to be bad corrosion in the bulkhead connector. Find out that this is fairly common as moisture collects in there. Look there first for your short.
  • sdpopssdpops Posts: 4
    I should clarify my problem. When the headlights are ON and I set the wiper switch to the third or fourth position, the headlights get turned OFF by themselves. The headlights work OK when the wiper switch is at other positions. Has anyone else experienced a similar problem?
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Almost definitely the stalk/switch. The reason it affects your headlights is because the switch is also the high beam dimmer and flash-to-pass toggle.

    kcram - Pickups/Wagons Host
  • sdpopssdpops Posts: 4
    Thanks for the info kcram. Can you tell me where the stalk/switch is located. Is it the multifunction switch in the steering column?
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Stalk = multifunction witch. Different names for the same thing.

    kcram - Pickups/Wagons Host
  • netpicker2000netpicker2000 Posts: 2
    edited March 2010
    Low beams do not come on. Nor will the high beams unless I hold the turn signal. Checked fuses and all in working order. When I activate high beams my lower driving lights go out. I think it is in the relay however, don't know where to look. Any feedback appreciated.
  • jd110jd110 Posts: 3
    I had the same problem on a 2000 Dakota. You will have to replace the whole turn signal switch, it is all one unit and they go for about $50-$60.
  • Does this require dismantling the steering column?
  • sdpopssdpops Posts: 4
    edited March 2010
    I had a similar problem that requires replacing the multifunction switch / stalk in the steering column (see message 416-419). Here are websites for disassembling the steering column and replacing the switch unit. Be sure to disable the airbag in the steering.
    http://dodgeforum.com/forum/2nd-gen-durango/83554-multifunction-switch.html
    http://en.allexperts.com/q/Dodge-Repair-809/2009/12/2005-dodge-dakota-multifunct- - - ion.htm
    http://en.allexperts.com/q/Dodge-Repair-809/2010/3/2007-Dodge-Dakota-Multi.htm
    http://www.justanswer.com/questions/4q1w-electrical-problem
    The part cost $66
    http://www.wholesalemopar.com/parts_catalog-small.html?gclid=CN_buqbjw6ACFQldago- - - dJUsPbA
    type in "combo switch" for the part description.

    You can buy a Chilton Manual at Auto Zone for @$25. It also has detailed instructions and is well worth the purchase price.
  • i have a 1991 1/2 dodge dakota 3.9 v-6 automatic. for the past week or two ive had the parking brake light turn on when i shift into reverse. Also, when i try to use anything to do with my cigar lighter( my blower motor is tied into this circut, not my doing, was like that when i got it). Ive checked all the fuses and everything. when disable the parking brake sensor the light still comes on when you turn something on. Really need help, got no blower
  • typhoontyphoon Posts: 4
    I have a 2002 with the 4.7. I have been having issues with the headlights on the truck. I seem to be loosing the passenger low beam. Highs work fine. I have replaced the bulb on a couple of occasions.
    When I replace the bulb it works for a while then stops . It has gone in and out intermittently . Any Ideas?
    I thought it was the socket connection .. I cleaned and expanded the socket terminals and it still happens.
    Thanks Dan
  • shadow37shadow37 Posts: 1
    tailight parking lights dont work new fuses ,new bulbs is there a relay or something else to check
  • talcol1talcol1 Posts: 2
    My 97 Dodge dakota 4X4 has a chraging problem. I have had the battery checked the altenator checked. The repair shop told me it was the PCM. Today I changed the PCM and it started to charge at about 13.57 volts. After driving it I came home and it is now back to the old 11.87 volts and declining. Seems like the PCM was working and now quit. any ideas why?
Sign In or Register to comment.