Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Dakota Electrical Problems

12022242526

Comments

  • I have an 01 dodge dakota, the cab lights wont go off. I start the truck drive it, park go to get out lock and close the door. cab lights stay on they are supposed to dim out. I have to reach in threw the sliding glass window and turn them off manually. after never having them manually on? Also my truck is a 2wd V6 ..the service 4wd light is on and has stayed on after i replaced my bad battery for 85.00. The guy at auto zone said this would fix the problem, it didn't. Please help
  • kburks60kburks60 Posts: 3
    edited June 2010
    I have a 2002 Dokata Sport V8 4.7L....Truck ran fine for years no major unforseen repairs...Was driving the other day and the truck shut off at a red light..check engine light came on, RPMs redlined, fuel pump comes on, fuel injectors start running all bells and whistles working but truck does not start....6 hours later after sitting truck starts no problem drives 60 miles home as soon as we pull in the drive it starts again, sits overnight, starts just fine after it reaches operating temp it turns off and goes stupid again, at one point we checked the codes it said the distributor, I don't have one, camshaft position module was the next one then the gas cap...Shade tree mechanic saids computer is going out...there are no rebuilt computers in this town checked auto zone they don't have my model, checked advanced they say check the dealer...could it be something else?
  • mopardanmopardan Posts: 1
    My son's 2002 Dakota has a problem with the lights. Key off, everything perfect. Turn key on and headlights, fog, interior, tail, dash, flash like a disco party! I changed the headlight switch, but didn't help. Checked grounds, trailer plug etc. Anyone have any ideas? Thanks
  • smorinsmorin Posts: 1
    Hello,
    All at once I lost the following in my vehicle:
    Power Locks & Keyless Entry
    Intermittent Wipers
    Headlights
    Foglights
    Interior lighting

    I've checked the fuses, and they are all fine. Has anyone seen/heard of this before?
    Worried about not having any headlights or interior lights.
    Thanks so much!
  • skrapper69skrapper69 Posts: 9
    edited July 2010
    OK my truck will crank but will not start all the gauges work except for the fuel gauge and the millage will blink then it will say NO BUS... I have tried putting new battery terminals on and the headlights work everything comes on except for what I said someone please help me out so I can have my truck for work
  • srs_49srs_49 Posts: 1,394
    I'm guessing that NO BUS indicates that there is something wrong with one of the communication buses (the CAN bus) between the instrument cluster and the PCM or ECU.

    This could be just a bad or loose connection somewhere, or a failed computer module. I would pull the instrument cluster, re-seat all the connectors, look for any obvious bad connections, and maybe even reflow all the solder joints on the instrument cluster.
  • the thing is it will not start it cranks over good but it wont start and the gas gauge will not work then the millage gauge will flash and say NO BUS and the box around the P R N D 1 2 will not appear ?
  • skrapper69skrapper69 Posts: 9
    edited July 2010
    OK the thing is it will not start it cranks over good but it wont start and the gas gauge will not work then the millage gauge will flash and say NO BUS and the box around the P R N D 1 2 will not appear...... I have tried putting new battery terminals on and the headlights work everything comes on except for what I said someone please help me out so I can have my truck for work please help me out
  • chunkeychunkey Posts: 2
    Last month I noticed my Battery getting weak, then day by day things went wrong. the door locks quit, the interior lights work on & off, then finally my headlights quit working completely. Also I can here a buzzing, and see the filament lit up very dim in the headlights. The ENG. light blinks too... I replaced the battery and the truck starts & runs fine but no headlights & no interior lights !
  • chunkeychunkey Posts: 2
    ??? Do you have to re- :confuse: set the main computer er something, because just alot of strange things have been happening in the space of 1 month.
  • stvbestvbe Posts: 3
    Well heres one for you, wipers come on when lights are turned on or right turn signal is used and on the das the right turn signal just stays on, no flashing or anything just on. Also right head light comes on but its so dim, you cant hardly even see it. So i completely removed the stalk/switch so nothing should have power but the right turn signal still comes on, it doesn't flash, just stays on...how is that possible? 2 days later my high speed fan goes out, and the idle control thing is not working right all of a sudden so the truck doesnt like to start................
    #%@& is about all I can say at this point
  • srs_49srs_49 Posts: 1,394
    edited August 2010
    Corroded or lost ground connection somewhere?
  • stvbestvbe Posts: 3
    not a bad idea, ill start looking, thanks
  • stvbestvbe Posts: 3
    Thank you very much. Found a loose ground wire, passenger side.. Oddly enough though when you move it makes the idle cntrl click, but it did fix my problem
  • djm17djm17 Posts: 1
    edited September 2010
    my Dakota sputters and some hesitation when first started and still cold, is this the start to serious problem?and what can i do to fix it. also truck dose not start on first try, unless it was just turned off
  • I have a 2000, with 265,000 miles :) I am having the same problem with my truck, I've been reading it may be the CTM module, I'm not sure, hoping you got yours figured out and can help me, ty
  • It turned out to the the high beam switch causing the problem with my truck. Replaced light switch and all worked fine until I turned on high beams again. It is all one unit turn signal stem and all. Easy to replace just remember to disconnect battery due to air bag just in case. Hope this helps you out.
  • headlights are working again, my problem was a melted connector, I was able to use speaker connectors to fudge it back together. Thanks for the help jd110. I could have spent big bucks on the ctm, instead, it just cost me about an hour of my time. think i can hit 300,000 miles?
  • bberthbberth Posts: 1
    Have a 1996 Dakota, the dome light does not come on when doors are opened (comes on with light switch), the bright light indicator stays on (even when brights are off), and the fan only has 2 speeds (new resistor just put on). Can anyone help with diagnosis ?? Thanks, Bob. :confuse:
  • dam104dam104 Posts: 3
    Is it new or reman? and recheck veh/ground one to block and one to body. was alt on engine or on a test stand? pcm may be bad or alt.? i had a bad ( reman pcm)one that made it one day! and a sec/veh.had a bad ground gave me the blues. got to have very good ground with this hi-tech veh's. good luck to you sir.:)
Sign In or Register to comment.