Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Grand Am Transmission

2

Comments

  • burdawgburdawg Posts: 1,524
    There's no dipstick. The fluid level is determined by removing a plug in the side of the transaxle and seeing if the fluid is at the bottom level of the plug bore while the engine is running and the fluid is warmed up. Until that level is checked it can't be determined if the problem is low fluid or something worse. If it wasn't re-filled properly then it's a real possibility that's all the problem is, low fluid. It should be checked ASAP.
  • Did you ever get that banging problem fixed, it so what was the problem and how much was it... I have a 2001 Grand Am GT and when I put it in drive or reverse it bangs and it's the most painful sound, its been doing it for a month and I'm afraid something will eventually break...It also bangs in first gear extremely hard, it bangs in the rest of the gears too, but not as bad as first, drive, and reverse. The car pulls like it is really weak since that started also... I know its not the transmission because the whole thing wouldn't act up at one time... Any advise would help a lot.
  • just wondering if you ever got this problem fixed if so maybe you could help me out because my 01 just started this yesterday. thanks
  • Hi Man

    i seam to have the same problem .. like the transmission is hunting for the next gear.. i need to floor it to hit the passing gear for it to stop. My buddy thinhks it might be caused by the knock down band and the adjustment is off a bit.. it feels like a engine miss but it is more defined like the tranny. only happends during excel. the RPM is bouncing up and down.. is this the same problem .. is so how did you fix it or was it related to the fluid level

    thanks
  • i changed my trans filter and filled up with b&m trick shift but that really didnt make a difference so i added some oil additives and some fuel additives i dont remember the name but i will go to the parts store and get the name then post it...
  • chad27chad27 Posts: 1
    Hello.let me start by saying thanks for any help in advance.Also nice work on the site design.I have a 98 grandam 4cyl.The problem im haveing is,The transmission started to mess up no 1st or fourth gear,and at the same time the cooling fan would come on as soon as the car is turned on regardless of temp.so i did a code scan the results were the shift solienoid 1-2,cooling fan relay was bad.so i replaced the relay still same problem with fan.I noticed in the chilton book these two parts are on the same circuit.The wierd thing is when i unplug the wires going to the trany the fan stops and the ac compressor clutch releases.Im wondering if there is an elec problem rather than the shift solienoids. :confuse:
  • i just purchased a 2002 grand am gt and i am having a difficult time locating the transmission dip stick.
  • burdawgburdawg Posts: 1,524
    It doesn't have one. The only way you check it if you suspect it's low is to remove the level plug on the side of the trans case while it's running. The fluid should to the level of the level plug hole when it's running at operating temperature.
  • My 2004 wont shift into gear. the button is really stiff as well
  • JswenJswen Posts: 1
    did you ever find out what the problem was my 99 grand am started to do this today rpms stay at around 2000 and I can put the gas to the floor and no response when I get up to 55 mph it starts to shift back and forth and when I go up hills I loose alot of power please help me out
  • hey guys i got a grand am gt year 2001 and every time i give it gas it doesnt hit the next gear right away...like it over revs, its hard to explain it but its as if its struggling to get into the next gear it over revs a little bit and then changes but this is only wen i punch it. I drove a civic and it would shift gears right away so i was a bit worried wen i drove my car right after and it didnt switch right away. hopfully u guys know wat i'm talking about and if not feel free to ask me to clear things up and let me kno if u guys know how to fix this problem. thanks.
  • i would like to know if transmission from a 2001 alero 3400 will fit a 2000 grand am 3400. thx
  • Hasler99Hasler99 Posts: 4
    i have a 97 grand am gt. i has the 3.1 with a auto. the problem is when you start the car the low trac light comes on, before even putting it in gear. then when you put it in gear it comes on and you can feel it slip just a little bit, then it drives fine. the car has around 180,000 on it. plus the gas mileage is lower than i think it should be, it averages around 23-25 i just think it should be higher...but maybe not. well i appreciate the replys and waiting. thanks
  • sofi299sofi299 Posts: 2
    Hello,

    I have a 03 pontiac grand am se 6cyl and I need a transmission. I have located parts for 1999 and 2001 grand ams. I wanted to know if I could use there transmissions even if it is a little older. Also I am in need of a power steering pump as well, so I would need that too from. Would those year cars work with my car???
  • burdawgburdawg Posts: 1,524
    The only difference I'm aware of for those years would be if the donor car was a GT or not, and then the difference would only be in the final drive ratio, which is lower in the GT.
  • sofi299sofi299 Posts: 2
    Ok. Thnks its not a GT its just a 4 door sedan SE. Great so really the transmission should be the same, do i need to worry about if it is a 4 cyl or 6 cyl. I know that has to do with just the engine but those that effect the transmission as well. I have a 6 cyl.
  • kat1955kat1955 Posts: 1
    I have a 05 Pontiac Grand Am (3.4 L) Periodically, it has a loud roar and the tack jumps up and it has a vibration, not all the time. Transmission may slip. Can any of you out there tell me what's going on and what to do? I appreciate any help!! KW
  • burdawgburdawg Posts: 1,524
    Has the fluid level been checked? There's no dipstick, it has to be done by removing the level plug on the right (passengers) side of the trans case, while it's warmed up and running.
  • foru2nv4foru2nv4 Posts: 1
    I due believe your problem is that you have a bad motor mount or transmission mount.
  • My transmission seems to be slipping. Between 1st and 2nd gear I have to feather the gas pedal to get it to shift. It seem to do ok after I get my speed up until I hit a hill and it downshifts. Then the RPM's go up to 5 k and I still loss speed. I have never had any problems getting up these hills in the past. Is my transmission going out or is there some other underlying problem? Also I had a brake issue when this first started happening. I had air in the line (front passenger) that I had to bleed out. I don't know if the two issues could be related in any way or how the air got in the brake line. Please help I really don't want to pay for a trany just before christmas. (Mileage is 140,000)
  • put my car in reverse and had nothing. would not move, felt like i had the brakes on and nothing. goes in drive fine but doesnt move in reverse. got home and tried reverse again and had nothing. i go to put it in reverse and it makes a grinding noise for a few seconds. is my tranny shot?
  • jdh9jdh9 Posts: 1
    I have the same type of noise. Very loud humming, increases with speed. I looked for the level plug. Jacked the car up, removed the tire on the passenger side and looked around. Could not see anything that looked like a removable plug. Is the level plug on the front, side or back of the case? Thanx
  • I have a 1996 Pontiac Grand Am SE. The only thing that's happened to it is the antifreeze has all leaked out from a small metal oval opening covered up by a metal covering near the middle of the car under the floorboards. The opening is no where near the radiator.Hanes manuals state the dex-cool antifreeze orange in color also cools the transmission. How do I repair the leak?
  • burdawgburdawg Posts: 1,524
    It's on the side near the front.
  • So I just bought a 2000 Grand Am SE, 3.4L....it only has 38,000 miles on it. Didn't notice this problem during the test drive because it only happens when the car is warmed up. I've read a few other posts on here describing the same thing but haven't really seen any definitive answers.

    When I accelerate hard from a stop the tranny seems to be slipping from 1st to second gear. It slips for a second or two then grabs second gear and goes fine after that. It shifts smooth into all other gears while accelerating. The second thing I have noticed is that when I'm cruising from about 45-55 miles per hour and come to a slight incline in the road and accelerate very slightly the car jerks between 4th and 3rd gears as if it wants to downshift. I have to accelerate harder to get it down into 3rd or it just keeps jerking slightly between the two gears.

    Any suggestions? Called the dealer where I bought it, they cover it for the first 3,000 miles. I'm interested to see what they say or do with it. If you know of this problem and have heard or seen a fix for it, please let me know!! Thanks.
  • My transmission knocks in park and when in gear. It also slams into gear. I have already had the filter and fluid changed. I did notice that when the engine was replaced that the mount on the driver side is missing 2 of the 4 bolts. Could that cause the problem?
  • I am having the EXACT same issue. Did you ever find out what the problem is?
  • I have a 2004 Pontiac Grand Am and I have recently noticed that it is leaking transmission fluid in reverse only and only when in reverse for an extended period of time. I am wondering what the issue could be and approximately how much I'm looking at spending to resolve this issue. Thanks for any feedback...
2
Sign In or Register to comment.