Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





BMW Z4 Audio System Problems

ClairesClaires Chicago areaPosts: 978
Share questions, answers, and observations about iPod interfaces, CD players, and stereo systems for your Z4.

MODERATOR
Need help getting around? claires@edmunds.com - or send a private message by clicking on my name.

Comments

  • Just installed an ipod interface from Dice Electronics. It plugs into the factory wiring harness for the cd changer and lets you control the ipod through the factory head unit. The head until also supports text from the ipod and the interface charges the ipod when active, Sweet!

    Once you locate the wiring harness, install takes minutes. Locating the harness on the Z4 is a little tricky, but I got lots of support from Z4 owners online.
  • z4luvaz4luva Posts: 2
    could you be so kind to share with me those sites? I've been looking for days on how to locate the cd changer 6 and 3 pin wires. I have a USA Spec Ipod adapter arriving monday and want to install it as soon as possible.
  • The harness is located under the storage compartment between the seats, but you access it through the trunk.

    Pull back the carpet on the back wall of the trunk, there is a cut out in the center of the sheet metal that separates the trunk from the passenger area. That cut out is the back of the storage compartment. Reach your fingers through the cut out and you can feel the harness down on the bottom of the pocket. You will also need the remove two torx head screws from inside the storage compartment which will loosen the bucket and allow the harness to come free. The harness is also taped down but if you work the wires gentle they will come free.

    The tricky part is that you have to do most of this by feel as you cannot completely remove the carpet on the back wall to do the pull for the manual override for the convertible top. But you will be able to feel the harness. And once you have it just keep gentle working the wires and the harness will pop out.
  • z4luvaz4luva Posts: 2
    Wow!!!! Thanks so much. You have no idea how much time that saved me. I was looking at another post and a guy had completly ripped out the passenger panel behind the seat. This probably saved me 8 hours of monkey business.

    Thanks again, I only hope that other looking for those wires will find this post

    Check out what this guy had to do.
    link title
  • alp8alp8 Posts: 656
    how much did the Ice interface cost?

    any problems with it?
  • I paid just around $160 for it. It works great, no issues. Its a great product and I wonder had I survived without it!
  • fgallofgallo Posts: 2
    I am sorry I must be a little dumb, but I tried to remove the capet in the back and I wasn't actually able to, although I lifted up a litlle and couldn't find the cut out.
    Is your z4 a 2006? If so could you try to help me some how.
    Also I have another question, my cd player doesn't read song's names, it always displays: track 01/02... do you happen to know how to fix that? Thank you evry much.
  • roadsterz4roadsterz4 Posts: 12
    The cut out is located in the center of the panel about 4 inches off the trunk floor. It is a large rectangular cut out in the center of the panel directly behind the front storage compartment between the front seats. My harness was taped down by the factory on the lower left (driver's side) corner. My is an 03, I'm certain that the location of the cut out has not changed but I don't know if the location of the disk changer harness remained the same. Check with Dice, they should know. Good luck!
  • fgallofgallo Posts: 2
    you don't happen to have pictures of the installation, do you?
  • esfoadesfoad Posts: 210
    I am adding satellite radio to my 2007 Z4 3.0Si. I found the two connectors in the rectangular opening in the trunk and connected them to the Blitzsafe adapter. I connected the adapter to the XM radio unit and installed the antenna. How do I enable it throught the factory radio? There is nothing when I seleect either the AUX setting or either of the CD settings from the MODE switch. Thanks.
  • esfoadesfoad Posts: 210
    I found out the real story. The Blitzsafe adapter is NOT made to work with cars that incorporate the factory Nav system. Apparently the display protocols are different for radios with Nav. So, the only other option is to put an after-market unit for XM subscribers. We put in an XM Commander and put the control unit on the center console just between the shifter and the handbrake. Looks great and does not interfere with any factory controls. It is connected to the AUX input, not using the FM transmitter, so the sound quality is as good as can be.
  • Hi Guys

    I have an 06 z4 with the standard business stereo. I recently bought a phatbox but have been unable to get this to work with my headunit. I have been looking around various different forums for an answer to this problem but so far have not come up with any diffinitive answer. I am begining to get the impression that the 06 is just not compatiable with phatbox so I would love to know if there is anyone out there who has a phatbox wired and working in a 06 z4 just now and if so what adapter they are using to connect to their system.

    I would appreiate any feedback regarding this.

    cheers

    Tony
  • I just bought the DICE silverline for my 04 Z4, and I have located the 3 pin plug, but not the 6 pin one. Any ideas on where it might be?
  • If you're still looking for the answer to this one, the six pin plug is attached to the same wire as the 3 pin. It's taped underneath the center console and is a bit harder to get at. If you remove the torque head screws from within the center console it will give you the extra wiggle room needed to gently work the harness out.

    If you've already solved this one, then do you happen to know how the heck to thread the cable through the console grommet? I've tried hangers and such but it's just too darn tight down there. I'm pretty close to just grabbing my drill...
  • I've noticed that my Z4 rear speakers don't work... :( This car is supposed to have about 10 active speakers but when I adjust the fader to the 'rear', nothing comes out. Hence does anyone know how I can check the wiring? I've read there's an access port via the trunk, would I be so lucky as to find a loose harness there? I don't want to bring it to the dealer at $200/hr to find it! I'm assuming there's not another radio 'setting' that would turn them off? Thanks everyone.
  • davegenetdavegenet Posts: 6
    I'm planning to buy a used Z4 (probably '04 or '05). Did these years have an MP3 jack in the car?

    Thanks.
  • jcl0007jcl0007 Posts: 1
    Did you get an answer to your question and get your rear speakers working? I have a problem and not receiving any audio from the radio or CD.This problem just appeared out of nowhere. The only thing done was the clock was reset the day before. I have checked all the fuses and they are good. Any suggestions?
  • i have a 03 z4 with the nav, I am trying to install the dice silverline with the dsp adapter. the store that is selling me this unit said thats all i should need. except the fact that they will like to know what type of cable I have. I have looked into this and found a 6 pin cable with 3 wires attached to it. how do I know if its coaxial or regular cable, and any suggestion about this whole unit. any recommendation as per unit and installation of the dice unit.
  • 330ximn330ximn Posts: 2
    I have a 2004 z4 3.0 loaded (except nav). How can I tell if the car's radio is satellite equipped (i don't have the original window sticker)? When I push the mode button it jumps to CD mode. It doesn't mention Satellite. If it has Satellite, would that come up as an option when the mode button is pushed?
    :confuse:
  • z4luvz4luv Posts: 2
    I just bought a 2004 3.0. Does not have a changer.
    A CD is stuck in the dash CD player. The CD will play and the radio works. But, when I press the eject button, the radio goes on and the CD remains inside the player.
    Any ideas on how to get it out?
    I tried disconnecting and reconnecting the battery, but still no luck. I managed to grab hold of the CD with a small surgical clamp, but it won't budge.
  • I have a problem and not receiving any audio from the radio or CD.This problem just appeared out of nowhere. The only thing done was the clock was reset the day before. I have checked all the fuses and they are good. Any suggestions?
Sign In or Register to comment.