Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Aveo Electrical/Lighting

124»

Comments

  • gmcustsvcgmcustsvc Posts: 4,139
    krystalb1,

    I apologize for the issues you are experiencing with your vehicle. Were you taking the vehicle into a GM dealership? Please keep me posted when the issue has been taken care of.

    Thank you,
    Caron, GM Customer Service
  • jimh52jimh52 Posts: 2
    The car has about 42,000 miles on it. We have had the plugs replaced, the throddle arm replaced. It has been in the shop mutilple times. It runs very rough at time. This has been going on since about 12,000 miles. I have been buying Chevy since 1971, and this is my first pile of junk. Anyone else seeing the same symptoms? Any solutions out there, before I tell the dealer where to stick the car?
  • advercyadvercy Posts: 1
    I just recently had this exact problem. As in, yesterday. It got all jerky whenever it would shift gears, the hold light would flash, and the check engine light would come on, then when it shifted it would be fine. Rinse and repeat when it shifted up again. It was an awesome drive home (30 minute drive). My 2009 aveo has 59,799 miles on it.
    I won't know until monday if my warranty covers it, and honestly i'm going to be seriously irate if it doesn't. I've owned this car for less than a year (it had 43,000 when i bought it), and if i already have to replace major components of the transmission that's a bit of a problem.
    I'm really considering selling it since the used car market is so high right now. Let someone else deal with Chevy and their issues... I miss my Honda :|
  • suzy89rsuzy89r Posts: 2
    ive been having the same issues with my 2009 Aveo5. i bought this car for the gas mileage... if i would have known that it was going to be significantly worse within a year, than a 95 jeep cherokee sport.. i woulda kept my jeep. my hold light comes on, flashes (but not actually preforming its function) the car gets really jerky and and its like it kicks back when its trying to up shift and downshift. i have taken my car into the dealership several times. none of the issues are covered in my warranty. My car is now 2 years old. i have had these and several issues with it for a year now. just hit 60k miles. The dealership changed out all 3 02sensors claiming that was the issue. (was not) Mass air intake sensor (not it) helped with my airflow issue massively though. spark plugs, wires and a total once over. still the issue is persisting. LEMON LAW! recall this car. I love my jellybean of a car but i will not buy another Chevy Aveo. ill stick to chevy trucks... If anyone finds out anything, let me know....
  • i just replace my third alternator today, a total of 4. the first one was just a month after purchasing the new car. it is a 2007 Aveo and it has 84K now. only one was cover under the warranty, the second replacement was in april of 2010. I'm getting good on replacing it. in april the car was dying, i replaced the battery first but it wasn't the problem - alternator fix it. both the battery and brake lights stayed on. this time, it goes in and out, most of the time it will stay on longer while putting a load on. sometime, while im driving, ill turn off the lights and ac, both indicators will go out. i do know that is a poor place to have an alternator there.
  • Has anyone else replace 3 alternator in their 2007 Aveo?
  • My wife and I just bought a used 2009 Aveo LT sedan from the Kia Dealership about a month ago and are already experiencing problems! The vehicle had about 20K miles on it when we bought it and we've put about 3K on it thus far. 2 weeks after we bought it, my wife went to start it up after work and I noticed it idling funny; I could feel the engine "bucking" and we could see the tachometer needle surging. We let it warm up for a little bit, but as soon as she put it in drive, the engine bogged down to approximately 200rpms, went back up to normal and then back down again, feeling like it was gonna stall. When she tried to give it any gas, the car would barely move.
    We took it to the dealership and they couldn't "replicate" the issue, but they were awesome and fixed the alignment and put on 4 new tires, which was kinda weird I thought, but hey, can't argue with new tires for free! I had also told them the suspension makes "creaking" noises when going over speed bumps or dips...at a slow speed of course...this way we can hear the noise. They couldn't replicate that issue either.
    NOW, the car doesn't start when turning the key all the way to the "start" position right away....we have to hold it there for a few seconds, then it starts.
    One major thing is, my wife's about 7 months pregnant and we needed something we could take the baby home in. I worry about this car breaking down if she really needs to go somewhere or get home!
  • The car started running rough again, so we took it directly to the dealer. They put it on the machine and had to replace some plugs and, most importantly, they replaced two coils for the cylinders. There is an individual coil for each of the 4 cylinders. It is now running fine, but for how long? Sorry that I ever bought this car. I put nytrogin in my new tires, though, and my mileage went from 29 MPG to 38 MPG. That is the only good thing I have found about the car. Chevy should be ashamed.
  • omar12omar12 Posts: 2
    I have an aveo 2008 / shiest number is iam experiencing fule is exceeding the rgular and while iam drivin the car almost stops and it turnds off. Service light is on always when it was blinkin at fiest
  • omar12omar12 Posts: 2
    I have an aveo 2008 / shiest number KLITD51738B. 45614 is iam experiencing fule is exceeding the rgular and while iam drivin the car almost stops and it turnds off. Service light is on always when it was blinkin at fiest
  • Same thing is happening with my 2009 aveo.... Took it to a real auto shop and told me the crank shaft and drive shaft are in bad shape... warrenty...3 yrs or 36000 miles.....5 yr drive shaft....I will let you know how much they will charge me..I tried to return the car...you know they had the 3 day no questions asked...would not take the car back and showed me I sighed a paper to gett 500 off my car instead....Im getting rid of this car
  • Mine just gave out. Was it hard to get to and replace?
  • akengstakengst Posts: 1
    I bought a 2005 Chevy Aveo sedan new from the dealership. I now have 130,000 miles on it. Through the years this car has all but tried to shut down everything. The clock stopped working (actually it works in the winter, if the temperature outside is over 60 degrees or so the clock goes on and off randomly throughout the day, then resets itself to 1:00 about every 5 or 6 hours, which basically renders it useless), the a/c does not kick on anymore even after checking the switch and the relay, the rear window defogger has quit (again not the fuse), the daytime running lamps do not come on anymore (not the fuse), I burn out at least 2 sets of headlights per year, the radio shorted out, and I had to have the entire head replaced ($2800) at 105,000 miles due to a bent valve and a crack in the head. Not the best car GM has ever offered, glad to see it go away.
  • zedd1zedd1 Posts: 1
    Addressing the thermostat issue, I have a 2006 aveo hatchback and the thermostat had a catastrophic failure. The PLASTIC (yes, i said plastic) thermostat housing sheared completely off dumping all the coolant. Fortunately it did this in my driveway. I went to Autozone and bought one a new one for about $45. It was made of cast aluminum and when I tightened the flanges they snapped at about 10 ft lbs torque. I returned it and used the cash going to 0'reilly's were I purchased a steel thermostat for about $35. Works perfectly. But really, plastic???
124»
Sign In or Register to comment.