Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mitsubishi Montero

13132343637137

Comments

  • brillmtbbrillmtb Posts: 543
    Mitsu now seems to have a wiring harness for a tow hitch that is a separate part for those of you who put on or are planning to put on your own hitch. I dont know if it has an advantage over a universal wiring job yet. Will have to take a look to see if it just plugs in.
  • sirpkpsirpkp Posts: 7
    Any ideas? I have the Montero ltd. After a long trip (or when warmed up), there is a whinning noise from the engine area. Noise more at about 1500rpm. Noise in park, noise if moving from a stop at around 1500rpm. More so when turning, and therefore I concluded that it has to do with the power steering. If engine is turned off and back on immediately, the whinning noise goes away sometimes. Any one have this or have any ideas what it may be?
  • viet2viet2 Posts: 66
    Yes, that is the power steering pump acting up. The power steering reservoir is probaly foamed up because of air in the system. My dealer replaced the pumb two times, and it only works after a new (redesigned?)reservoir is install. It now still whine a little bit when first start up.
  • rruck1rruck1 Posts: 91
    If you have power steering pump problems make sure that you get them repaired while under warranty. If you are out of the warranty period then you may be in for a surprise. When the power steering pump went on my 89 Montero the replacement part was $1600! I looked everywhere and couldn't find a new one cheaper. I ended up getting a used one for $500 and then sold the truck.
    This was one of the big turn offs about Mitsubishi for me. It was difficult and expensive to get parts after the warranty. Has this gotten better in recent years?
  • claybusterclaybuster Posts: 90
    sirpkp,
    What year & model Monte do you have? How many miles on your rig?

    It will be interesting if it is a reservoir problem that requires a new(re designed?)reservoir. I asked the dealer about a possible recall on replacing the reservoir and that they had not seen the problem. I hope it's not another cover-up and hope the rig makes it until the warranty runs out.
  • erubrighterubright Posts: 4
    How loud is the noise? Do you have to have the windows down and air/radio off, or is it loud enough that it's very noticeable?
  • brillmtbbrillmtb Posts: 543
    I dont seem to be having any problems. I dont know of any "cover up" that has occured with Mitsu or the Montero. What do you mean. I am aware that Mitsu in Japan was putting complaints in a "file" and addressing them in modifications over the years. What they failed to do was make these complaints public and thus people were concerned that they may not be getting important safety information or perhaps felt that they may not have developed a recall program for known defects. Since that story broke I have not heard any "real" concerns come out of it other than the flawed process they were using.
  • rbreauxrbreaux Posts: 1
    Recently brought my 95LS to the shop for the 60/120k which of course includes the timing belt replacement. The service shop (Palm Springs) called a day later stating problems of getting the belt off and said that they would have to break the crankshaft sensor and blade to accomplish the job and also stated that "I" would have to pay for those parts $84 and $34 plus the labor?!? LS still there awaiting...Comments, Suggestions? I don't think I should pay for a thing that they break...the are of course the Mitsu-pro's right? The 60/120k service is already costing me $955.00! and that's even when I did half of the regular maint myself before I brought it to them anyway (oil, rad-flush, air and fuel filter), but getting charged premium anyway...Whew! Terribly frustasting..NEED ADVICE/HELP!!!
  • kcook01kcook01 Posts: 2
    Help.

    I just bought a Montero Limited 2001. We have test drove and looked over the car many times. Apparently, though I did not test drive it on the right type of road conditions.

    When we drive in neighborhoods with slightly bumpy roads at 10-15mph there is a very loud resonation noise that fills the cab. It even makes your ear drums feel very sensitive after the car is stopped. I find it hard to believe this problem is only with this truck and not a design problem.

    Please help - I am thinking of returning the truck in the morning and I am sick about it because I love the handling and everything else about it.

    Thanks in advance...
  • phonosphonos Posts: 204
    Well, as you state in the thrid paragraph, it is a SUV based on a truck and not a car. Have you ever owned a "truck" before? Trucks are not as quiet as cars.

    That "wise a**" stuff said -- the fact that it only occurs on certain roads, I'bet dollars to donuts that it's the tires. I've noticed that on certain roads, at certain speeds, the H/T Yokohama Geolanders with the GO39 tread pattern will produce droaning resonate noise.

    I'm going to replace them with M/T or A/T tires when they are worn a bit more (16,000 miles currently). Then the noises will be louder but at least constant and consistant.

    If you don't drive off-road H/T tread tires from a different manufacturer might solve the problem. You can probably get some dealer to let you try out different tires on your "test road".

    PHOnos, White/Silver Limited, Rear A/C, July 2000 build date, $34,500, Orange County, CA.
  • brillmtbbrillmtb Posts: 543
    I think all tires can be loud on certain surfaces. Actually the Yok Geo's rated very well in a recent comparison so I dont think you will do much better.

    I have not noticed my vehicle being that loud. Going to the M/T or A/T tires is something I am considering on the next tire change but this will most certainly bring on more noise.

    Bottom line: more aggressive tread more noise, Trucks are louder than cars and the Montero is one of the most quiet full sized, serious off road SUV with luxury thrown in that I have been in so no complaints from me.
  • kcook01kcook01 Posts: 2
    Thank you both for your responses. I was just kind of surprised I didn't see any thread here about the noise.

    Yes, I do have a truck. The montero is my wifes and I have a F-150 that I love. She traded in a 97 Montero Sport on the Montero.

    After sleeping on it, I kind of figured out that it was the tires. The tire pressure was at 32 so I lowered it to 29 like it says inside the door and it helped some.

    More importantly I went back to the dealer and had them drive it with me. They heard the vibration and couldn't give me an answer why.
    I drove a XLS that had bridgetones and seemed to sound the same. I didn't realize and neither did they that all of the XLS had bridgetones and the limiteds had Yokos.

    I then decided to drive the Explorer and Expeditions to get a feel for what they sounded like. The explorer didn't compare and with the Eddie Bauer was the same price. Cheap and heavy feel. I could go on and on about why I wouldn't buy that one.

    The expedition was too big and even with an 8 didn't have the pickup of the Montero and the engine noise sounded like the old time trucks and felt like a tank. With a sticker of 45 - forget it.

    So, I am feeling much better today because in regards to quality of material (in particular the leather), handling and pickup the Ford's were not even in the Montero's league.

    I even had the Ford salesman ride with me in the Monetero and he loved the display and the layout. He heard the bass vibration as soon as we left - without me saying a word. But said that all of them have their unique sound but overall he was impressed with it.

    Does Mitsu only have Yokos and Bridgetones tires to offer or do you think there is another brand they could get their hands on that might be quiter?

    I will say, that it has been raining like crazy here and the Yokos cut through it like a knife.

    Thanks again for your time and responses...
  • sirpkpsirpkp Posts: 7
    Thanks for all the response. Here are answers to your questions and more.

    Viet2, Mine whinnes too when first started up. But more so when run for 1/2 hour or more. And only sometimes. Was that the same symptom you had? Do you know what is wrong with the current reservoir? Why does it foam up with air. Would you have a part # of that reservoir from your receipt I could give my dumb dealer so there are no questions. It seems like from your case that the dealer will upgrade to the new bigger better reservoir only for 2001 monte's that have the problem. I wish they would make it a recall.

    Claybuster,
    2001 Montero limited 4K miles only. I know what you mean about the coverup that's why I am hoping Viet2 can provide a part # or such that I can go with into the dealer and ask them to order it to fix my rig.

    Erubright,
    The noise is very noticable when at it's worst, with the windows up or down, radio on or off. You can even hear it if you were standing with the hood open. Ofcourse more noticable with the windows up, radio and air off. At idle, rev the engine momentarily to about 2500rpm and at some point it would 'whine' if it had the problem.
  • brillmtbbrillmtb Posts: 543
    OK guys, what am I missing here? What specifically was covered up? I know the Japanese story already where they were putting complaints in a file, not making it public but my understanding is that the changes were being made as needed to address any important issues. The concern was that in Japan they were not making the complaints public and that some safety issues may have been in the stack.

    What else do you know about?

    As far as the power steering pump, I have no noise. We should try to find out the part number of the affected part and see if there is any official recall on it. The dealer gets repair notices and we could ask if they have one on the pump. I will ask out here in my area and get back to the board.
  • sgbassinsgbassin Posts: 22
    I have had 2 harnesses go bad on me. The trailer lights just stay on or the signals don't work. Sometimes the doors lock automatically when I plug it in. Anyone know of some solutions or recall on the harness
  • doubleedoublee Posts: 1
    Anybody driven the XLS and the limited back to back. I'm curious as to the performance gains of the 5-speed auto in the Limited. I cant find any 0-60 times for the xls, only the limited.
  • viet2viet2 Posts: 66
    Your power steering pumb condition is similar to mine. Sorry I do not have the part number of the reservoir (they did not give me the part number). The "redesigned" reservoir is not bigger, it is the same shape as the "old" reservoir, but I believed that it has different internal. There is two tubes to keep the fluid from churning up and mixed with air. Some times it is hard to convince the dealer that there is a problem. What I did was video tape the sound and the reservoir foaming up and show to the dealer. while some one is turning the steering wheel. The video tape is handdy if later you need to file a lemon law suit if they do not fix the problem.

    re: Tire Noise by kcook01. My limited is very quiet at any kind of paved road. Off road, some road with lots off small road surface irregularity would upsets the chasis, but so far the car still feels very tight. The Montero is also quieter than my SVT Contour sedan and My Pontiac GTP sedan. Yes, the Montero shock tunning is better then the Pontiac!
  • rgreenbe1rgreenbe1 Posts: 8
    After dealing with the excessive whinning from last Otcober to present, I finally got my dealer to realize there was actually something wrong with the power steering. Here the part information from my Invoice:
    MR961246 Reservoir Assy, P/S Oil
    I drove the car alot today and it seems much better. The part looks much longer and not as wide. Hope this helps everyone with Whinning Montero's. Just give your dealer this part# as it is the "new" part.

    2001 Limited Silver w/Rear A/C

    HAS ANYONE EVER FIGURED OUT WHY THE A/C INDICATOR ALWAYS STAYS ON. IT WAS FUNNY SEEING A PUDDLE OF WATER IN THE MIDDLE OF WINTER, WHERE YOU USUALLY SEE IT DURING THE SUMMER AFTER THE A/C HAS BEEN RUNNING. TELL ME THE A/C ISN'T ALWAYS ON????
    HELP!
  • claybusterclaybuster Posts: 90
    rgreenbe1, Thanks for the information on the power steering reservoir part number. I don't understand why this reservoir problem is just showing up in some Monteros or do most people (like me) just have their radios turned up too loud to notice the problem. I think we all need to check for the problem, while they are covered under warranty. This is what I consider a possible "Cover Up" if there is a design problem (which it sounds like is to me) they should do a recall and fix it! Not deny there is a problem and hope it will run out of warranty.

    My A/C also comes on in automatic temperature control mode; but I just push the knob with the green light (indicating A/C on) if I don't need the A/C and it goes off.

    With the warmer weather I am getting a consistent 20 to 21 MPG with 87 octane; with an occasional fill of 89 octane. This is general driving to work and short trips, so this is a little better than I was expecting.
  • rgreenbe1rgreenbe1 Posts: 8
    I understand you can switch the A/C switch off if you don't need it. But that makes the automatic climate control somewhat pointless. Seems like a design flaw or I don't read my car manuals well enough.

    Can anyone add something here??????????
Sign In or Register to comment.