Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Hyundai Santa Fe Maintenance and Repair (2007+)

1363739414257

Comments

  • mmiillemmiille Posts: 2
    I put a full size spare under my SE and it fits ok, but how does the tire pressure sensor work? Will this work if I rotate all tires? Will an added tow hitch get in the way?
  • I had my car at Goodyear yesterday for an oil change. One of the things they routinely check with any oil change is the tire pressure. They informed me that my valve caps had 'seized' and that if they tried to remove them it could damage the tire sensor system. The service tech at Hyundai claims they have never heard of this happening, but Goodyear told me they have had 3 or 4 break in the last few months.
    Not sure, but it sounds like that might be your problem?
  • I have a 2007 Limited also. I had to replace two of my tires due an alignment issue back in November. I noticed a few months later after the replacement, all my vavle caps were now plastic instead of the "cool" looking metal ones. I'm thinking my dealer swapped them out without telling me. After reading your post, makes sense to me. I was about to call the dealer and complain that I want my "cool" looking metal valve caps back, but I'm actually fine with the plastic ones. Easier to find replacements.
  • nextmoonnextmoon Posts: 386
    I lost a few of my caps along the way and replaced them with the black plastic caps. The black caps aren't very noticeable. They are better and easier to grip to take off and on then the silver plated caps. The silver started to get worn off within a year. No big deal IMHO.
  • bolla67bolla67 Posts: 8
    Hi,
    I have an 08 SF LTD w/less than 2k miles. I seem to hear a whining sound go through the back, especially when sitting in the back seat. I can't pinpoint exactly whats causing it but it seems whenever the wheel is being turned to the right I hear this strange whining that almost sounds like an 18 wheeler's horn. I actually thought someone was beeping at my husband and I repeatedly when I was sitting in the back seat and it turned out to be this weird noise coming from underneath the car. Anyone experiencing this?
  • bolla67bolla67 Posts: 8
    Hi,
    I have an 08 SF LTD w/less than 2k miles. It seems after it has been sitting awhile (cold start) when I start to accelerate at about 20mph a strange sound (like running over a tree branch) comes from underneath the front and I can also feel a slight thud under my gas pedal. It only does it when the cars cold. It doesn't seem to do it after that, unless I don't drive it for a couple of hours then it does it again. Has anyone else experienced this? Also, my front passenger door seems to have a slight tremble and makes a slight friction sound (rubber molding rubbing). I've taken it to 2 service depts. and all they can say is "can't duplicate and we greased it". I can see that the door is slightly out of line, but I can't convince them of it. They only want to mess w/the rubber molding. Any suggestions?
  • I have also recently experienced the same sound/feeling when accelerating just after starting the engine.

    I purchased a 2007 Santa Fe SE AWD used w/11K miles about two weeks ago. I didn't experience any strange noises until yesterday when it was cold and rainy here in Upstate NY. The only time the sound/feeling in the pedal happens is after I start the car and shift into drive for the first time. Otherwise, no problems for the duration of my drive. However, if I shut the car off and restart, the sound/feeling immediately returns when beginning to accelerate.

    Has anyone else experienced this? I have an appointment to have the car looked at on Friday, but since I bought it from a non-Hyundai dealership, it is being checked-out by a KIA mechanic. Do I have reason to be concerned?

    Note that I put 89 octane fuel in last week (reached for the wrong nozzle). Could that have caused a problem?

    Thanks...
  • rick2456rick2456 Posts: 320
    It doesn't matter where you bought the car. If it is still under the factory warranty, any hyundai dealer will cover it. And no, putting 89 otctane in the vehicle would not cause a strange noise.
  • Thanks for the reply. I just find it strange that it was running smooth last week and it was only after I refueled that the sound/feeling started. I am hoping the KIA mechanic will be able to diagnose, otherwise I will take it to the Hyundai dealership.
  • bolla67bolla67 Posts: 8
    The strange thing is it doesn't happen every time I start the car cold. Based on other forums/threads I've read here it's the ABS engaging. I've owned cars before w/ABS and never had that happen. I brought my SF in yesterday to address the creaking sound in the rear quarter panel and didn't bother to mention it because it didn't happen all day and I knew when I picked up the car the mechanic would say couldn't duplicate. I'm going to wait to see if it happens when I get the car back.
  • somedai1somedai1 Posts: 416
    is your creaking noise at the rear driver side? try standing outside the car with the driver side door open - rock the car from side to side by pushing up on the door frame - does it reproduce your noise? that's what i have to do when i return to the dealer. they love to tell you they can't hear what you hear on a test drive - don't test drive it - check it like a mechanic is supposed to know how to!
  • bolla67bolla67 Posts: 8
    I actually found a TSB that Hyundai puts out. The first dealership I took it to said they couldn't duplicate the sound even though I heard it driving out of the parking lot. So I did research and found a TSB for this exact problem and now another dealership is working on it. Isn't it sad that people have to do the mechanic's job for him before he even looks at the car?
  • The TSB for the creaking sound is well documented in the "noises and sounds" forum here.

    I also had Hyundai perform the same service shortly after I purchased my vehicle in October 2007.

    Suffice it to say, without that TSB article in hand, I would have been met with shrugs and "I dunnos".
  • I have the same problem with my 2008 Santa Fe. We are walking in the same shoes. The brake fails from time to time unexpectedly.

    Now my car has 2000 miles and it did this few times in this last month. I took it to the dealership and the answer was exactly the same: "cannot duplicate"
    I do not know what to do. What happened to your Santa Fe? Did anyone repair it? Have you found any solution?

    Any help is greatly appreciated.
  • bolla67bolla67 Posts: 8
    Hi, I haven't experienced this yet and hope I don't. But, in the meantime, sign up on this site http://www.hmaservice.com and look up all the tsb's. I didn't see anything about brake failure, but maybe you could email them and see what solutions they offer.
  • geecemangeeceman Posts: 3
    My outside temp display on my 07 Santa Fe Limited AWD has been on 68 since I had the dealer check for water in the passenger floor board about 6 months ago. I live about 70 miles from the dealer and kept putting off going back after researching and finding this site and this info I called the dealer and set up an appointment. I asked them if the were aware of this problem they said yes. Are you aware of this fix? We'll have to run your vin and see what fix applies to your vehicle. After 2 hours yesterday I was told they replaced the sensor but it was still on 68 probably just where it is sitting in the sun. I asked if they had checked TSB #07-90-00. I was told that they had run my VIN and no TSB came back in reference to my vehicle. Never changed on the way home. Still 68. When I tried to tell the service writer about the TSB and that there was a fix I was told that they were unaware of any problems like this on Santa Fe's they had had problems with Azera's also I should stay off the internet, as too much information from the internet could get me in trouble.

    Is this a problem anyone else is having with the dealers. I am retired on disability. I have chronic back problems and was trying to keep my long trips to a minimum and now who knows how many times I'll have to go back. I know you all can't fix my problem. but are all dealers like this?
  • srmcsrmc Posts: 6
    This is a 3.3 L.
    I cannot get Hyundai to honor their warranty. The field representative verbally agrees that it is piston slap, but will not use those words in writing. The field rep says that this will not cause any permanent damage to the engine. My dealer has no other cases, but will not help me. The only option that I have is to use a lawyer.
  • Geeceman, since the problem you are referring has an objective result (fixed or not fixed), it may be best not to tell dealer about any TSB. Let them, FORCE them, to troubleshoot the issue. After all, you can bring a thermometer with you to the dealership and show them if the reading on your display is accurate or not accurate. Or simply check another vehicle's reading.

    Service Departments for whatever reason seem to get defensive when customers start using the term TSB or "Internet". I suspect it comes across to them as "I know more than you" and they resent that.
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,978
    That's the advice Edmunds has posted for years now:

    How Can a Technical Service Bulletin Help Me?

    But I wonder if that's changing. More people are researching everything online and trying to tie symptoms with known problems and dealers must be seeing more people walk in with print-outs of TSBs and forum posts.

    My furnace guy was a bit surprised when I called him out to recharge my heat pump, but a few web sites had narrowed the problem down to that being the most likely problem. And it was.

    The flip side is that the mechanic may just fix the obvious problem and overlook other things that would have been checked if you go in demanding that a TSB be performed. Better to simply go the service writer with "a complete description of your vehicle's particular problem ."

    Plus TSBs aren't mandatory, so the dealer has to confirm the problem anyway and you're paying for the diagnosis (at least until it becomes a warranty item).
  • somedai1somedai1 Posts: 416
    this just happened to me! how did they handle it for you? if they did fix under warranty - how old/mileage was yours at the time? If not - why did they say it could not be covered?
Sign In or Register to comment.