Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lost? Ask a Host for Help!

1242527293092

Comments

  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,871
    If you're at the board level, where you see the entire list of discussions, just go to the bottom of the page and you're find the Mark As Read link that will "catch you up". That way you'll only see "new" flags on discussions that get posts from that point forward.

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • tidestertidester Posts: 10,110
    The Talon ESI was virtually identical to the Mitsubishi Eclipse so you should find some help in Mitsubishi Eclipse 2007: Care and Maintenance and Mitsubishi Eclipse: Engine Problems.

    tidester, host
    SUVs and Smart Shopper
  • garnbgarnb Posts: 2
    I have a 1995 Buick Regal with a 3.8 liter engine. Recently my left side turn signal switch stopped turning off automatically once you had made a left turn. Later I noticed that my rear brake lights (with the exception of the high visability brake light) were not working on the left side. I took the entire rear light wiring harness out of the car and checked it and found it to work everytime I ran currnet thru it. I then put it back in and now none of the break lights work on either side--and it is just the brake lights that are not working.

    I have heard that the turn signal switch assembly is directly related to the rear break lights. Considering what I mentioned above about my left turn signal switch, could this be the problem?

    The only scarey thing is that turn signal switch assembly is embedded in the steering column and there is a lot in there when you look at a diagram of it.

    Anybody have any suggestions? It's kind of hard, not to mentions dangerous, to drive with no brake lights...

    -Garn
  • nsorrelsnsorrels Posts: 1
    :D i have a 1995 chrysler town and country 3.8 eng--and i am losing power steering fluid it is not in the lines or pump or resilver what else can it be can anyone help me
  • tidestertidester Posts: 10,110
    Try either Buick Regal: Brake Issues or Buick Regal: Electrical Issues.

    tidester, host
    SUVs and Smart Shopper
  • tidestertidester Posts: 10,110
    Check the topics in the Chrysler Town & Country/Dodge Grand Caravan group. You can use the "Add a Discussion" link at the top of the page to create a new topic if none of the existing topics match what you're looking for.

    tidester, host
    SUVs and Smart Shopper
  • grickergricker Posts: 1
    I have 02 rodeo LS auto. trans. The check trans. light and cruse set lights will come on the engine will cut out. Seems worse on rough roads.sometimes stalling at slow speeds. any ideas? thanx
  • steverstever Viva Las CrucesPosts: 40,560
    Try the My Rodeo stalls out randomly... and perhaps the Isuzu Rodeo Transmission Questions discussions. Just check out the whole Isuzu Rodeo group in fact. Good luck!

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • vernzevernze Posts: 1
    I submitted (i clicked on submit) a question needing a speedy replies from bloggers.

    my oil supply is blocked from the check valve on the oil filter to the head (valves).
    How do I remove the check valve, spring and clean the passage? It looks like there is a retaining ring held in by probably frition (tight fit). how do I get it out.

    Thanks posted in convertible, but unable to see it anywhere.

    Vern replies to e mail please
  • steverstever Viva Las CrucesPosts: 40,560
    Hey Vernze, for some reason your post didn't get posted over in Convertibles. You should have seen it immediately after you submitted it with the Post My Message button. Please try again and if there's still a problem, post here again or use the Contact Us form in the Help link.

    You can also see what you've posted with the My Recent Posts link on the left.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Edit: I'm trying to post this in the Maintenance/Auto Repair forum but am having trouble figuring out which buttons to hit to start a new thread. If anyone can help me move this message to that forum, I would appreciate it much.
    ------------------------------------------------------------

    Just purchased an used 2006 SUV from a type of car purchasing service. I have very little technical knowledge about cars, so please bear with me. Here's a bit more about the car:

    - Bought at a PA auction by the NY car purchasing service, so NY service took title from PA auction place
    - sold car to us and we registered it in NJ (where we live)
    - 2006 Land Rover LR3, apprx 12,000 miles at time of auction

    Anyway, I took it to my local (New Jersey) Dept. of Motor Vehicles for inspection and it failed the emissions part. Reason was DMV system was unable to read the OBD (On-Board Diagnostic system) of the vehicle, so according to DMV the vehicle's system is not ready to determine the status of the pollution control system. Spoke to Land Rover claims that this happens because the DMV cannot read the OBD because it is an "CAN enabled system" and that I need to have the DMV give me permission to let L/Rover's state qualified emissions technician provide a written statement that the vehicle's emissions system is OK and have the DMV accept this as proof enough to get the inspection sticker. In other words, the DMV's system will continue to be unable to read the OBD on the vehicle, but DMV will give me a passing grade any way because the dealer's techician says the car is OK. Also L/Rover says this is only a problem (that he knows of) with this particular model year and model. I had the L/Rover service dept test the vehicle twice and according to them everything looks good (after recharging the battery and rerunning the vehicle through all the codes).
    Do you guys have any ideas on how to handle this? I'm concerned about having a vehicle that has to get DMV clearance in this offline roundabout way, instead of the straightforward way I'm used to on previous cars. I much prefer to have the DMV plug in and be able to clear the car as usual. I'm also concerned in having to do this every year (annual inspection). How will I know that in some year in the future, the DMV won't tell me this is unacceptable and I'm stuck with a useless vehicle because it won't clear inspection.

    Should I keep going with this vehicle or proceed as if it is a lemon? Please help. Thanks.

    p.s. - I have also been told that sometimes the issue I'm having has to do with a battery being disconnected and that if I drive the car around for a bit (a week or so), that would give the car a chance to 're-learn' what it needs to clear all of these so-called codes. I guess I'm concerned about what to do if it fails again even after I do the drive-around. Thanks again.
  • lcm8lcm8 Posts: 2
    My 2007 Maxima exhibits significant engine breaking when I take my foot off the gas at speeds of about 40 or less. It will pull back for a few seconds and then all of a sudden feel like it is back in normal mode, and almost lurches a little sometimes. Has anyone else expereinced this? I like the CVT in general, but this is annoying.
  • tidestertidester Posts: 10,110
    Look at the Land Rover group to see whether any existing topics match your issues. If not, then use the "Add a Discussion" link at the top of the page to create your own topic. You may also want to look at Those Dreadful State Vehicle Inspections.

    tidester, host
    SUVs and Smart Shopper
  • tidestertidester Posts: 10,110
    You can get feedback from other owners in Nissan Maxima.

    tidester, host
    SUVs and Smart Shopper
  • Thanks for the reply. Are you saying you cannot start a new discussion in the Maintenance/Repair forum? I noticed that many of the general topic forums (maintenance, etc.) don't have that "Add discussion" button. Is the premise that most of our new threads should be started in the specific Makes (i.e., actual car/model) that we are inquiring about? Thanks again.
  • patpat Posts: 10,421
    You can ask questions in existing discussions on the Maintenance & Repair board. You are correct that you can't start a new discussion there, but generally speaking, the discussions there cover just about every situation that folks run up against.

    The links tidester gave you will be very helpful. It's always good to check in with other owners and the state inspection discussion seems to be just what you need.

    Good luck!!
  • Gotcha. Thanks again!
  • My elderly aunt's Toyota needed a jumpstart, my cousin did it, INCORRECTLY, and now the car will not start. The engine turns over, the battery holds a charge, and he replaced the main fuse. Any ideas on what the problem could be? Is it the relay? I am a total newbie at this, and have NO car savvy, as I do not drive, but we need to get her car fixed. PLEASE HELP.
  • steverstever Viva Las CrucesPosts: 40,560
    Check out some of the discussions in the Toyota Camry group, like Toyota Camry - Battery Questions or Toyota Camry Fuse and Electrical Questions.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • havsum33havsum33 Posts: 2
    I have a 99 Grand Prix 134k miles. Recently as it is in park idling it has become to idle up and down on its on as if I am stepping on the gas. Also the RPMs are increasing it never cuts off but it sounds as if it will and then it just stops doing it. Haven't taken it to the dealer yet wanted to try this first. Can anyone help. Thanks in advance!
  • steverstever Viva Las CrucesPosts: 40,560
    Try the Pontiac Grand Prix: Problems & Solutions discussion and check out the others in the Grand Prix group, like the Fuel System one perhaps.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • My 96 lumina will not start. No power to the starter, no crank no nothing. It has a after mrkt radio, and factory security system. Help
  • steverstever Viva Las CrucesPosts: 40,560

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • I have Nissan QX 2.0 manual V6 car with 120K mileage on it.
    I chnaged the battery 5 months ago and did servicing around 6 months ago.
    That day I was driving the car and it started showing battery exhausted warning (red battery symbol), then it stopped showing speed on speedometer. I stopped the car and I could not start the car. With the help of jumper and lead and friend's car I could start it. At some distance, it started showing ABS warning. I kept giving accelerator and it was not speeding up the car and came to an halt. I toes the car and it is now in my drive way. Can some one help if it us just ot do with some oil has run out or is it serious problem. If it is serious problem, then I may probably think of scrapping this car rather than putting pounds on repair.

    Quick reply is highly appreciated.
  • tidestertidester Posts: 10,110
    I would start in Nissan Maxima Electrical Issues and Nissan Maxima Maintenance and Repair.

    tidester, host
    SUVs and Smart Shopper
  • where can i post my questions regarding the broken crankshaft of my 95 nissan quest that just happened?

    thanks
    Brolandet :cry:
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,871
    Ouch! Sorry to hear that. head on over to the Nissan Quest Group and post your question there.

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • havsum33havsum33 Posts: 2
    Just found out about this site and wanted to ask a question and possibily get a solution to my 99 Grand Prix 134k idling up and down on its own as if I am pushing the gas pedal. A friend has suggested that it maybe the fuel pump. I haven't taken it to the dealer yet just wanted to see what I could get from here first. Has anyone encountered this problem?
  • steverstever Viva Las CrucesPosts: 40,560
    Pontiac Grand Prix: Fuel System may help; otherwise, browse the other discussions in the Grand Prix group and ask for help in an appropriate one.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Kirstie_HKirstie_H Posts: 10,876
    To add to Steve's suggestions, on our Maintenance & Repair board, we've also got a discussion called Idle or Stalling problems - all vehicles

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

Sign In or Register to comment.