Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jaguar XK-Series Electrical Problems

Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,615
Have you had problems with switchgear, lighting, audio, etc. with your XK series car? Post questions or solutions right here!

MODERATOR

Comments

  • I have some electrical problems with my XK8 couple, 1998. I've diagnosed to the extent that two control modules aren't functioning properly. The Electrical Manual nor the Factory Service Manual give no clue as to how to perform a test at the module level. Thus, the remaining option is to buy an expensive module, install it, and see if problems travel away with the old module, an expensive piece of guesswork. Is there a better way, one that determine whether or not a module is at fault? Can modules be reset, reprogrammed, or repaired in any way? Charlie
  • Electrical problems in my '98 XK8, traceable to control modules. Who can bench check these modules to verify problems, then to repair as necessary? I don't want to replace good items as 'shot-gun' attempts to cure anomalies. Or, maybe there is a procedure for testing individual modules for functionality? I'm a capable electrical trouble-shooter and have good diagnostic equipment.
  • My mechanic put an aftermarket tail light on my 2005 Jag XK8. The right one works fine, but the left one, the rear turn signal does not "blink" although it sounds like it is blinking in the car very rapidly. Also, the tail light stays on constantly. We thought there was a short in the bulb socket, so we changed it out with a new one and it still did not cure the problem. We checked the relay module and put in a new one - still no fix. We put back the original tail lights and that did not work. The tail light stayed lit continuously on that one, too. We checked all of the fuses. They are all fine. When I put the key in the door and locked the car door, all the lights blinked like they should when the alarm is initiated, except the left tail light. The dealer said to try and reprogram the main computer and that should fix it. Does anyone have any opinion on this? Are we on the right track? As an FYI, the new tail lights are lower in voltage than the factory orginals and again, the right signal works just fine.
  • markasmarkas Posts: 5
    A problem cropped up today in my 99 XK8 convertible. I was putting the top up and the latch went down before it grabbed the hook on the top. Now, the top will not go up or down nor will the back windows go up. I've tried the manual crank, but it doesn't do anything.

    Any ideas about what to do, or is it a "go into the dealership" thing?
  • svpsvp Posts: 2
    My 2000 XK8 has a strange problem. 4 or 5 times a year, the car stalls while moving and then will not start. No clicking, no grinding, just nothing. But all the electrical stuff goes nuts -- steering wheel telescoping repeatedly, gas latch popping open, trunk and hood lids popping open. If I tow it home & let it sit for a couple of days, it starts again. It's been to the dealership several times. They said it was the gearbox & changed that. No help. Now they say they cannot find any problem. Does anybody know what is going on with this car? Thanks.
  • tamirctamirc Posts: 3
    Hi Markas,

    I have a similar probelm with my 1997 XK8 convertible. Did you find the problem? Please let me know. My email address is tamirc@msn.com

    Thanks,
    Tamir
  • markasmarkas Posts: 5
    I finally took my car into the dealer and they said that the timing was off. The owner's manual said that you could open or close the roof up to 10 miles per hour. I was doing about 5 mph and that is when the timing issue happened. The mechanic said that just a tiny gust of wind could have prevented the hook from grabbing and pulling down the top. They acknowledged that the manual was wrong; you should be at a full stop.
  • I have the same problem on my XK8. :mad: Any idea what they did to sort out the problem at the dealership?
  • tamirctamirc Posts: 3
    The problem was quite simple - the machanic had to luricate the hood latch closing mechansim that closes the roof. What happened was it the latch mechanism closed partially before the hood latched in, so he manually pushed the roof latch into the mechanism, then luricated the mechanism quite a bit. But this is the second time that I have a roof problem, so maybe I need the flush the fluid as many people had advised.

    Hope this helps,
    Tamir
  • Hi Tamir,

    Thanks for the advise. My problem is that the roof is latching OK but the 'Convertible Latch Fail' message stays on and the rear windows don't go up. I am wondering where the latch sensor is located.

    By the way, any idea as to how to flush the fluid?

    Also, what sort of lubricant did the garage use and did they only lubricate the latch mechanism?

    Chris
  • Having the same problem with 1997XK8- hood latch failure, top is up, but won't go down and back windows won't go up...how did you resovle problem?
  • tamirctamirc Posts: 3
    Hi Chris,

    I did not have the same problem as you are having, so I won't guess how to fix it. I don't know where the latch sensor is. I also don;t know how to flush the fluid myself, I would refer this to a qualified mechanic. The lubricant the mechanic used on the latch was just something like WD40.

    Best of luck,
    Tamir
  • I haven't had a chance to fix it as yet. May have to take it to the agents to have it fixed.
  • my radio does not work on my 1998 Jaguar xk8 convertible
    i found the fuse box but the fuses are not marked

    i don't have the manual
    thanks
  • Hi Chris

    Did you get this resolved and how was it resolved? My XK8 has done exactly the same this week.

    Matt
  • donbldonbl Posts: 42
    The problem could be your battery has gotten old. When the voltage/current degrade you get some funny problems like the steering wheel telescoping not working correctly or intermittently.

    Have them test your battery.

    I have a 2000 xk8 and it had a few funny electrical problems and I asked them to check.

    BTW electrical engineer.
  • Matt,

    I am sorry about the late response. I had to have the top fixed by the shop. Apparently, one of the sensors were misaligned. Not sure which one it was but I guess it was the one on the back.

    Chris
  • rug34rug34 Posts: 1
    My 98 XK8 convertible has developed a new quirk. When I signal for a right turn the console lights go out (except the radio and climate control). When the signal cancels the lights come back on. It seems related to the signal switch. Is this something a home mechanic can handle? If so where can I find the repair procedure? Thanks in advance for any input.
  • my 99 xk8 conv, after setting all winter in the garage has developed a problem that the top will not open nor will the rear windows go up. the battery checks good but has a drag on it that runs the battery down with everything off. i detect a slight clicking sound when the roof down button is pressed but nothing happens, any ideas? could it be a relay? the fuses are all good.
  • My 2000 XKR rumbles under hard acceleration and has reduced power.
    Interestingly when this happens there is distortion in the radio followed by no treble for 30-45 seconds. Given this there appears to be a disturbance of the electrical system under load.

    The car had previously gotten some water on Coil #8 when the old owner washed the motor. The check engine light has not come back on since drying the coil but the rust seen on the #8 coil leads me to think it happened before and might be the culpret.
    Anyone had this set of issues? Coils? Alternator?
    Thanks,
    Brent
  • bigdbrentbigdbrent Posts: 3
    Rumble under hard acceleration gone and radio treble no longer affected by replacing the #8 coil and plug.
  • majorspud,

    I have a 99xk8 with exactly the same problem and symptoms. Did you fix it? What was the cause? Thanks.
  • The loss of treble on my radio and the rumble on hard acceleration were caused by water getting on at least one of my coils that are in the head. The engine had been washed by the seller and water had gotten under the coil covers. The check engine light came on within 30 miles of being driven after the washing. I dried the coil and was able to drive home 1200 miles without problems. Later I started having the treble and rumble problem. Since it must have been some some electrical disturbance to affect the radio, I made a lucky guess that it was the same coil (#8) that triggered the miss-fire code. Mine is a XKR and the vents in the hood are a likely suspect for why several coils had rusty discoloration.

    If you don't have any misfire codes to point you in the right direction I would get one coil and start putting it in different positions until you find one that has a positive effect. Try the most rearward or the most rusty ones first.

    Good luck,
    Big D topless XKR
    Brent
  • willntiwillnti Posts: 1
    This is a 1997 XK8 coupe with only 68k miles (endlessly troublesome!). Now the car won"t start in PARK and I can't remove the key. It does however start in NEUTRAL so I'm leaving the key in (maybe someone can figure out how to steal it!). I can lock it with another key but how long will this last?

    Any advice would be welcome,

    Another longsuffering Jag owner seduced by a beautiful body, Will
  • mac2064mac2064 Posts: 1
    door locks. when the key fob is pressed the lights go on and the alarm is activated but the doors do not lock. When locked by the key and open by the key fob the doors do not unlock
  • laurasdadalaurasdada Posts: 2,606
    Hi, Folks:

    New '09 XK Coupe owner. Does anyone know if when the passenger door or hatch is open, should there be a chime to go along with the IP notification. Driver's door chimes, not passenger or hatch...

    Thanks!

    '13 Jaguar XF, '11 BMW 535xi, '02 Lexus RX300

  • SAME ISSUE:

    my 98 xk8 conv, after setting all winter in the garage has developed a problem that the top will not open nor will the rear windows go up. the battery checks good but has a drag on it that runs the battery down with everything off. i detect a slight clicking sound when the roof down button is pressed but nothing happens, any ideas? could it be a relay? the fuses are all good
Sign In or Register to comment.