Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jaguar S-Type Climate Control Problems

1235

Comments

  • jamal25jamal25 Posts: 1
    edited June 2010
    Hey Jeff how r u? I am having trouble with my AC. I have a 2005 Jaguar S-type. I took it to the dealership they said I need a AC Control Module, which costs $1600. Please help me if you can.

    Jamal
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,404
    First thing I'd check is your coolant level.

    MODERATOR

  • sdemsdem Posts: 1
    Late build 2002 4.2L. Winter here, start car, takes ages before heat finally starts blowing. At random time, strange noise, sounds a little like when you just start to release foot brake on wet discs, then flow stops totally and restarts a few minutes later, usually. Very strange. Also initially no fan activity at all, even if manual mode is engaged. Can turn off unit, and back on, no change. I bought second hand a year ago and don't recall this type of behaviour then.

    Thanks in advance for any advice.
  • jaymzsjaymzs Posts: 16
    Yes I had a 04 4.2:L, they replaced what I remember was a heater control valve, not the control panel. That rattle, if it sounds like a gurgle once in a whileand a rattle other times , Well They replaced the vents in the center control , I knew it wasn't that! Comes and goes.
    with or without the fan on. I believe howerver its an air bubble in the cooling system I heard you could burb from below. BMW , same thing. Love the car but got rid of it since they couldn't find the squeal in the tranny, Yes that new FX tranny crapped at 70k . It was reprogrammed repeadily and fluid changed at least 4 times, never help.
    I think I had all the quirks, and didn't expect them being an 04 and all
  • edukeduk Posts: 2
    My problem is solved.

    Problem was electronical.
    The relais responsible for the AC in the fusebox under the motorhood was coroded and the contact points were burned in.
    This is replaced (18 euro).

    Furthermore the space between the magnetic plates on the airco pump was too big and was bought closer to each other.

    Hope this will be of any help for you.
  • katmandu3katmandu3 Posts: 1
    Jamal: We had the same problem with our 2004 s type. Dealer wanted $1600 for part. I bought it on Ebay for $85 and paid the dealer to install it. You might want to check it out.
  • Hey Jamal, the dealership gave me the same quote on the module, plus even more for the service. Mine was blowing hot on the driver's side. I google'd for the problem and found this website: jaguarclimatecontrol.com
    There is a lot of good information there. I followed their step-by-step module removal instructions and got mine out in 15 minutes with no cursing. I had actually bought another module on ebay and found out it had the same problem, only it was hot on the passenger side instead! Go figure. Anyhow, I just sent my module in to them in hopes of getting it repaired. Crossing my fingers...
  • I was wondering how you like your 2001 Jag. I am about to purchase one & am leary. Never owned one before. What do you think?
  • blogginsbloggins Posts: 1
    I have a 2003 Jaguar S-Type and the check engine light has been on for a bit. The first time I had a problem it was the coolant reservoir. I had that replaced after ordering the item from Ebay and having it put in. I have been hearing a noise that sounds like trash or a piece of plastic underneath the car but when I checked it was nothing there. All sounds seem to be coming from the left front side somewhere. I took my car to my repairman and thought that the check engine light was on due to needing spark plugs and an air filter. My car only has 62,000 miles on it and I really like it. My repairman told me that it is misfiring or that is what the computer is reading. He didn't have a Jaguar software and he wished he knew someone that did. He told me to drive it and see if the spark plugs were all it needed. He erased the code and the light went off. My car was due for inspection and it passed. I need to change my oil, but it isn't bad, but will do on next week. Well to my surprise 2 days later my check engine light came back on and the Restricted Performance light came back on, which goes on and off at times and when it does there is no accelerated speed. I do know that often times my coolant light comes on saying low coolant, but when my husband checks it isn't really low but needs some coolant put in. Would anyone happen to know what is wrong. Have you had this experience with your Jaguar. I don't have the specific code but will check by Autozone for the code and let you know. Please help.
  • Does anyone know where I can find an AC ECU for a Jaguar S Type 2003 4.2 V8 for the LOW LOW (cheap price)?
  • Hi to all... My wife's '06 S-Type 4.2L VDP (60k miles & still under extended warranty) has a chronic summer cooling problem: On hot Atlanta days with the Climate Control set on 'Auto' and 70F, the air blows cold fairly soon, but the blower fan doesn't speed up past level 2 to distribute enough cold air. She has to lower the temperature down to 'LO' and manually crank up the fan speed to max. If she doesn't do this, it takes 30 minutes to chill the car, which is ridiculous on a premium car. Also, the recirculation feature doesn't turn on in 'auto' and must be done manually. [My 2001 XK8 climate control system works wonderfully when set on 'auto' and 72F, and I never need to monkey the fan speed.] The Jag dealer just replaced the compressor and dryer, which definitely made the air blow colder, but the slow fan speed seems to be the reason the car takes so long to cool down on hot summer days. Does anyone have an idea if the fan speed control is related to bad sensor(s) or faulty climate control module? Help!
  • Hi, can you tell me were to find the climate control modual on my jag.v8 sport s type 4.2. 2004. thanks. barry
  • You can see pictures of where they're located on this website: http://jaguarclimatecontrol.com/repair-and-upgrade/
  • Jeffs, I have 2001 s-type 3.0 and valves + temp sensor replaced but still the same. Are you sure must be climat controll panel? Can you help me? psu@me.com
  • So, i took my car to the dealer because i couldn't keep a battery charge. They had to replace wiring and told me i had a radiator leak in the rubber hose? I just got the wiring fixed due to money issues (corrosion and rubber not covered under warranty). I then started getting low coolant errors. I filled it, no problem. Then I noticed in the summer that i was no longer getting air. I then started getting low coolant errors again. Filled and then within 5 days it came back on. Now i'm not getting heat. Still having to fill the coolant all the time. Also, my car fogs up, but wont defog for a while.. have to wipe and drive. Pile of crap. :) Dealer charges me $130 per issue that they check, so I'm trying to avoid it. Any suggestions or opinions on all that could be wrong? Is it all related? Someone told me i may have a blown gasket? Help appreciated.
  • I have a 2003 S-type as well and have had the check eng. light on many times. I have 188,000 highway miles on a V-6 and it still runs with plenty of power. My solution, though simple, works every time. I buy fuel injector cleaner or Octane booster or whatever they have on the shelf at the Dollar store not at the Auto parts and use one every fill up. It turns the light off and keeps it off for months at a time. I avoid Racetrac and QuickTrip gas recommended by my Mechanic. I have also had the "Restricted Performance" message on many times. I had to replace the coil on each plug average cost for each coil is $54.00 at the dealer. This may be your misfiring problem. It improved my performance even with all the mileage on my car.
  • debi42kdebi42k Posts: 3
    The Module is the whole thing that controls your AC & heat. Looks like your Radio. If you want to know how to remove, replace or test it, jaguarclimatecontrol.com is the place to go.
  • debi42kdebi42k Posts: 3
    I just had the CCV (Heater Valve) replaced in my 2006 S-Type 3.0L (under 50,000 miles). It was damaged from a previous leak in the coolant expansion tank but the DCCM itself, and all fuses & sensors were fine. When I picked it up this evening the display panel on the Climate control was flashing & would not stop. The only time I have ever seen this before was when the care was parked outside for any extended period and temperatures reached in the upper 90's during the day, meaning inside the car it was over 100. This was not the case today.

    I am thinking there is a "reset" that needs to be done since they had to remove all of the refridgerant to install the new CCV & then re-charge the system, or they didn't hook something up. The AC works great now - by the way.

    Anyone had this problem??
  • I have a 2001 S type with the same issue can you help?
  • As others have suggested, jaguarclimatecontrol.com has a lot of information regarding various issues. Check out the site.
Sign In or Register to comment.