Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jaguar XJ Transmission Questions

124

Comments

  • art18art18 Posts: 2
    My 95 Jag has 55,000 miles and I have had two tranny services (Non Jaguar shops)The internal wiring harness and selinoids (sp?) were replaced at both times and on last service the Tranny was "rebuilt".
    Three weeks following service the tranny dash warning light comes on and tranny clunks into the lower gears after the car warms up (in about 15 miles) My last service man tells me it may be the computer which only the dealer can check. The car was purchased at and serviced by Jaguar of Darien in CT but I am now in Florida and the local Jag dealer on Merritt Island tells me that he does not have the equipment needed to perform any diagnostics on this car. Any one know of a reputable Jag dealer in Melbourne Florida area or nearby that is qualified to service the transmission on an old XJ-12. Any comments would be weclome I have been fleeced by $2,700.00 so far with this problem
  • It could be anything but a major mechanical problem. Because it acts up after it warms up it could be the throttle needs adjustment/ cleaning.Or the speed sensors. Does it have fluid? its simple to clean the throttle, take the air filter off look down into the throttle and clean the carbon out. DON"T take it apart. You might get lucky!

    You could hook up to alldata and get some positive answers if you are mechanically inclined. They are pretty good source for info. You could get parts used from jaguar heaven in california. I've used both these companies and I have no complaints. Good Luck, I hope this helps.
  • kjpesqkjpesq Posts: 2
    My 2004 XJ8 with 30,000 miles on it has been in the dealer's service bay for nearly 6 weeks; I couldn't find an independent transmission specialist who would take it. I've been informed that the dealer installed a rebuilt non-Jaguar transmission (I think the delay was with their not being able to get the Jaguar transmission). How much should I expect to have to pay for this? And why do they tell me that the car won't be able to pass state inspection until it's been driven several hundred miles? Why do I feel I've been had. :cry:
  • Somethings not right! Why don't you know the cost? they should have given you the estimate and got your permission before they started? a non jaguar transmission?
    WOW i don't want to scare you but this seems creepy from what you said.
    YOu can fit a taurus transmission in that ford engine (I think) but you should bring some reinforcements with you if you aren't mechanical and get some answers.
    Good Luck!
  • waitswaits Posts: 17
    I'm in san francisco...obviously a pretty good place to get jag service.. But I stopped using British Motors, and now use John's Jaguar in the Mission district. It's a very small jag service and repair shop, and they get it right. The owner is there...and he's a classy guy. They got my rebuilt 2000 XJ8 trans from a center in south san francisco...It's true one isn't always ready to grab..I got a bit lucky...so the work took about four days. Guaranteed for one year...doing just fine so far.
    Why don't you call John up, tell him andre referred you, and ask him a couple of questions?
    415-8298480
  • ok i have a 1998 xj8l... when i start my car and put it in drive it will idle like its in neutral then it jerks very hard.. and starts to go.. it will not accelerate like normal until i'm over 30mph... after that its cool... now i can stop and go with the same slowed acceleration but every time i cut off the car and restart it... it jerks into gear..
    i've only had one diagnosis and they said i need to replace the transmission but i feel if its mechanical it would jerk every time i came to a stop... am i being paranoid or does it sound electrical?

    please feel free to email me at itsmepierre@gmail.com if you have an opinion or advise... :sick:
  • waitswaits Posts: 17
    edited March 2010
    The shifting mechanism can also be a problem, not engaging properly. When I needed a new trans, I also needed that assembly too. Funny, when they were done, some linkage to the drive shaft, (New part) failed...Free replacement done. How many miles on your car?
    Out here in south san francisco, they rebuild transmissions, and the rebuilt ones are supposed to have some parts that do away with some plastic parts that were prone to failure. I'm very lucky to live in san francisco, whre I have about four jag shops to choose from, but have settled on John's Jaguar...very close to my house...and I get to know the mechanics, as opposed to british motors, which keeps it all upper crust and mysterious. I bit the bullet on my transmission, but then again, I bought my 2000 XJ8 for 9000. Total transmission and shifter bill was around 5 grand.(Trans is around 3000, then you add labor, etc.) I resisted the fix for a while until it hit me, that instead of buying another used car with an unknown lifespan on it's trans, I fix my car, now have $14,000 invested in it, and I'm driving a gorgeous Jag ( Titanium with black Leather, and more wood than they have in the new ones) with a brand new transmission. First thing I did was drive it to San Simeon, down the California coast for a week.
  • jagernutjagernut Posts: 16
    Once the transmission slips, its doesn't get better with time. I agree with you. its something other than transmission mechanical. If it is the clutches slipping ( replace transmission) you will eventually not be able to move after a stop. Do you have anyone you can trust to read the error codes? Does the car ever warn you of a "transmission fault" on the dash board?
  • jagernutjagernut Posts: 16
    The bulbs are cheap. You have to remove, gently layers of fascia to get to the bulbs. Its a good idea to replace them all while you are in there.
  • I have a 2000 XJ8 with 60,000 miles. The car has been completely maintained by the dealer. Before this week, I have had about 10 occasions where the car would loose power and go into what people describe as limp mode. Most of the time I simply see a "Trac Not Available" message, but no amber or red transmission warning light. I usually just turn the car off, wait a minute and crank it up again. I usually don't have a recurrence for days or weeks, it's like rebooting your computer. It seems to happy on cold days. I took the car to the dealer when this first happened, but they were unable to see any diagnostic codes because there were no transmission lights or message were displayed. Then four days ago, I had to pull over six times on the way to work. This time the red transmission symbol came on and stayed on, so I took it to the Jag dealer. They say it needs a new Throttle Body and a wiring harness for $3,200. I would pay the price if I know that their diagnosis is correct. I think it's a sensor of some kind, because of how the problem comes and goes.

    I have read a lot of entries on different sites and the common theme seems to be that many issues are being misdiagnosed.

    Any feedback would be appreciated.

    Keith
  • waitswaits Posts: 17
    My 2000 xj8 also has the traction not available light come on, and I do nothing about it, and it's fine that way. British motors in san francisco wants to charge me 2000. bucks to fix that. But I leave it alone.
    I also got the limp home bit, and had to change my transmission and also some parts connecting to my shifter. No way out of it, and it happened in the high 60 thousands. A rebuilt transmission is supposed to have better internal parts...some of which were plastic, and now metal, I believe. I spent 5 grand, but now have a new trans....a good deal compared to trying to get rid of the car, and buy another used car. The ladies love the thing...I'm sorry I do not know what a throttle body is, but I recommend you call John's jaguar here in san francisco, and ask about it, and frequency of problems with the 2000 XJ8. They are great guys...and do great guaranteed work.
  • waitswaits Posts: 17
    This is my second comment...if it was just a sensor problem, your car would not go into limp mode. Try limp mode in san francisco, where the car is really in...what 2nd gear when starting...and you're going uphill...brutal.
  • jagernutjagernut Posts: 16
    I WOULD CLEAN THE THROTTLE BODY-ITS A PRETTY SIMPLE JOB JUST TAKE YOUR TIME. THEN I WOULD CHECK YOUR CONNECTIONS FROM THE THROTTLE. MAKE SURE YOU HAVE NO MOISTURE AROUND THE FIREWALL- TAKE THAT PLASTIC MOLDING OFF. CHECK THE WIRING TO THE ABS MODULE FRONT LEFT OF ENGINE. I THINK YOU HAVE A WIRING OR CONNECTION ISSUE. BECAUSE AS YOU SAID ITS INTERMITTENT AND DRIVE FINE WHEN NOT ACTING UP. TAKE THE GROUND CABLE OFF THE BATTERY WAIT A MINUTE THEN HOOK IT UP. IT SHOULD RESET MOST OF YOUR ENGINE TROUBLE LIGHTS. your DOING THE SAME THING THAT THE REPLACEMENTS WOULD DO BUT A HELL CHEAPER. Good LUCK!! THE SPEED SENSORS GO RIGHT INTO THE WHEEL HUB IN THE BACK. THER EASY TO SEE YOU CAN REACH THEM W/O JACKING THE CAR. MAKE SURE THAT ROD DEBIS DIDN'T KNOCK A WIRE LOOSE. THAT WOULD AFFECT YOUR "TRAC"
  • I have a 99xj8 I bought with 61000miles on it it drove fine for about a month,on a extended trip it cut out and went into limp mode, trans failure traction failure and ABS.lights came on after checking fuses I left the car and had it towed home(100 miles)when the car was returned it ran fine a month later same prob.pulled over shut it off for about 15 min.started up and ran fine for about a month now I have the same problem but more frequently,almost daily,tried disconnecting ground wire in hopes of rebooting computer,did'nt work'can anyone givec me a clue where to go from here besides a jag dealer?Al in Mass.
  • waitswaits Posts: 17
    THEre are sellers on ebay that sell repair to the computer unit for the abs system. That unit, when standing at the front of my 2000XJ8, is at the right and front. It's front half seems to come off...and I believe that thing gets sent to these guys, and they charge about $60. bucks to repair it. You need to cover the area that is exposed when you do this really well, to prevent dirt from getting into it...and also cehckto see that you have all other brake function still intact. I am about 80% sure that this may repair your ABS, and if it does, you'll save about $1500. You can drive with your ABS system down, and I have for two years. "When the car was returned" you say...returned by the tow company, or did you have it looked at? Hate to say it, but I had to get a new rebuilt transmission at 66,000 miles. Supposedly, the rebuilts have a better part that used to fail...labor and part will run you $4500 or more. But then again, I paid 9 grand for my car, and now have a new transmission. andre in S.F.
  • waitswaits Posts: 17
    Type in JAGUAR ABS COMPUTER REBUILD REPAIR on ebay and see if you get the folks that I checked out. My safari browser is acting up, or I would send you the exact url.
    andre
  • Hi Aaronburr,

    I presume that you would like to know how my situation turned out.
    I took my 2000 XJ8 with about 61,000 miles to the dealer after it went into limp mode several dozen times. They told me that the Throttle Position Sensor (TPS) needed to be replaced. On my XJ8, this means a $3,300 repair because the whole Throttle Body assembly has to be replaced, not just the sensor. The dealer would guarantee the part and the labor for one year. I asked them if the part could be re-manufactured. They said no, and that's when I told them that I found a company in the North East that would take my part, repair the TPS module, and send it back to me with a lifetime warranty for a $400! And that company guarantees that my Throttle Body assembly will be finished in two business days. The dealer did not seem to understand that I would gladly due without my car for about 10 days if I could save $2,200. The labor to take the Throttle body off, ship it, put it back on, replace a wire harness, and test everything was $700. So about $1,100 versus $3,300.
    The dealer was reluctant to send the part for re-manufacture until they found out that they already buy their Anti-lock Brake Sensors (ABS) from the same company. They claim they did not know that they "did" work on TPS modules.
    The car drove like it was brand new after the repair. Then a couple of months later, my car went into limp mode One time. I called the dealer and he said it might need to be done again. I could not believe what I was hearing. The only good news was that the dealer would not charge anything, but I would be without a car for more than a week.
    I then decided to go to a non-dealer auto repair shop that works mainly on Range Rovers as sort of a second opinion. They could not replicate the problem, nor could I. They researched the Jaguar tech bulletins and thought the problem was more likely related to something in the gear shifter (center console area) or where the wire connects to the transmission, or maybe an ABS sensor. So, they ended up cleaning a little corrosion off the connection at the transmission, drove it a fair amount, and charged me a $95 diagnostic fee.
    I have not had a single problem with the transmission going into limp mode since then! But there's one more thing that may have made a big difference. I have Stopped using the left side of the gear shifter that allows you to drive your Jaguar as if it had a manual transmission.

    Do you you ever drive your Jaguar in this manual transmission mode?
    You may also want to see if there is a Jaguar "club" in your area. If so, ask them where they take their Jags for service.

    I hope this was helpful.

    Keith
  • I have a 2000 Jaguar XJ8-L (77000 mile) that has been running fine with no issues. A few days ago I left home and drove for about 10 minutes. Everything was fine up until I got to a taffic light. Once I got the green light and started driving, I got a noticeable jerk that I thought something was wrong. I slowed down but did not notice any issue. So I drove for another mile and got to another traffic light and stopped. The light turned green and once I started driving, I received another slight jerk. At that point I knew something was wrong so I drove into a quiet street and came to a stop sign. Then I received an Amber alert on my dash “Gearbox Fault”. So I tried to shift the gear to drive. No problem shifting but the car was not moving, so I tried shutting the car off and started back up. I shifted it to drive and again, I got a bit of jerk but the car was not moving forward. There was no noise or issues changing the gears. I shifted the gear to Reverse and parked the car and had it towed to my Jaguar dealership. They called me back and indicated that they have received a c1095 diagnostic code but unable to resolve the issue. They told me they believe it is related to a broken front drum and that the only thing they could do is to replace transmission with a factory remanufactured transmission which would cost $6500. I was shocked since the car only has 77000 miles and in fairly good condition. The dealership told me that based on the year of the car new parts are not even available and that Jaguar does not allow them to get into transmission or change any parts. They told me that the only option would be to replace the transmission. As a second option, he advised me to take it to another transmission place that can rebuild the transmission. He referred me to Glen Burnie Transmission. When I called them, they told me the diagnostic code indicates “Hydraulic Pump Motor Circuit Failure” and perhaps an electrical issue that can be resolved. I was surprised why the dealer had a different story. They told me that they can do a diagnostic and be sure but most likely an electrical issue. If it turns out the problem is beyond that and if it requires a transmission rebuilt it would cost $3200-$3800 or somewhere in 4K range ($4500 or so) for a rebuilt transmission. They mentioned that the work would come with a warrantly of 12000 miles or one year. They also told me that the diagnotic would cost about $90, free towing for transmission rebuild or replacement, in which case diagnotic charge would be built in. I am leaning to have it towed to this place and get their opinion. I am open to other suggestions? On the Internet, I also saw c1095 may be to a bad ABS module. So I am really confused as to what is really the problem. Would anyone have any comments, suggestions or advice in this situation?
  • waitswaits Posts: 17
    WHen my 2000 XJ8 transmission failed..(with light).I could only drive in that lame second gear...when they (John's Jaguar in san francisco) dug in there, they said I needed to replace the gearbox...(It's been about a year and a half, so some terminology has been forgotten)
    You need to first find out if a rebuilt transmission has the updated parts, like mine does...the failure of the 2000 tranny is common around 70,000 miles. A rebuilt should have newer parts that do not fail like yours does.
    I bought my car for 9 grand. had 64000 miles on it. had it for a year, then spent 5 grand on parts and labor...it was a tough decision, but made sense..as selling a jag with a bad tranny is a nowhere deal, plus now having a jag with a new tranny at 75000 or so, is much better than buying a used car for five grand and dealing with that. ABS module error light happened to me...british motors wanted 2 grand to fix it. Some guy on ebay fixes the part for 60 bucks...you mail it to them....you have to find a way to cover the abs unit when you send the top half to this guy....and hope that's your problem. You also have to see if no abs computer at all in your car affects anything while it's being worked on. Ask yourjag guy to show you the abs unit...it's way up front on the driver's side....ask them to open it to show you the thing....and watch carefully....you don't want dirt getting inside there. Take a picture of it then and there, and then see if the pic on the ebay guys page looks like your part. I never followed through...I drive with the abs light on all the time.
    Don't ask. I can direct you to the ebay abs guy....CAll John's Jaguar in san francisco...he's a good guy.
  • Thanks for the info. I ended up having another mechanic place a junk yard transmission that only had 50K and with labor only paid $2000. He happened to be a friend of friend so he did not charge me so much for the labor. I believe the junk yard part cost $1500. Anyhow, everything went well and I did not have any problems. Since about a month or so ago, I have noticed something else that I think might be related to transmission. Occasionally around 30 miles when I am decelerating down to 25 and then accelerating back to 30 or 35, I feel a kick in the speed as if someone hit me from the back lightly, so I am trying to determine whether this has to do with bad shifting or what ? I could not recreate the problem when I took it back to the mechanic. He indicated that I should bring it there as soon as I notice it. Again, I get this typically within each drive or every other drive and it usually happens after the first 3-5 miles and it only happens once and it goes away and nothing happens for a while or sometime after 20 minutes it might happen again. So I am not sure how to diagnose this issue. I can certainly leave the car for the mechanic, but I am wondering if you have any ideas what this symptom might be related to? Again, the car ran very well for at least 3 months or so and I have not had any issue, but this problem scares me as if it might be related to another transmission issue, but may be something else. Again my Jag is 2000 XJ8-L

    Thanks for any inputs that you might have.
Sign In or Register to comment.