Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jaguar XJ-Series Electrical Glitches

Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,279
edited September 30 in Jaguar
Any stubborn electrical issues on your XJ that you'd like to ask about? Post your questions here:

MODERATOR --Need help with anything? Click on my name!

«13

Comments

  • Hi, I have a 1995 XJR 4.0 ltr X300 series. For some time now it has had an intermittent clicking noise from what sounds like a relay on the left hand side of the consul. It seems to be speed related as it seemed to happen once the throttle got a bit stiffer. I lubricated the throttle control body & it still did it. Today it actually stopped totally after the gearbox warrning light came on. This light has come on before very rarely but has never seemed to effect the driving,I know that it is supposed to limp home but it drives fine. If you have any suggestions or thoughts it would be greatly appreciated as I love this car & it is a shame to have this click be so annoying. I can only drive with radio at a certain volume?? Regards, Bruce
  • i have a 1999 supercharge and i dont have a book i need to know if someone can help me to find out what the codes mean
    i am a woman who needs help
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,279
    Did you try Googling the code? What are the codes you are after?

    MODERATOR --Need help with anything? Click on my name!

  • hi anyone got any ideas i have a x300 3.2 and if its not driven for a length of time it wont start in park you have to put it in newtral and wiggle the stick around then it starts!!anyone know a quick fix as i want to sell it or i have been told theres a selinoid you can adjust anyone know where or how or has anyone got a replacement they want to sell?thanks ian :cry:
  • The transmission connector has a bad connection and then it enters in limp home mode. You don't have gears, only third gear until you stop it and restart it. Check your trans mounts, excessive movement can cause problems with that connector(it is located on the driver's side of the trans).

    Manuals you can buy from Ebay.
    I bought mine for $36.(the whole leather binder with all the manuals)
  • rekrabrekrab Posts: 1
    Regarding my 1998 XJ8: I have 3 electrical issues, and have been told by the local electrical shop that they are all caused by a faulty computer. 1. The ignition switch does not activate in 3 tries out of 4. Starter checks out ok. 2. Seat does not automatically adjust to set position when car is cranked. All other memory components work fine. 3. Doors lock and then immediately unlock when the plunger is pressed. To lock doors, it is necessary to use the key or the FOB. If this is computer-related, what is the best way to get a good repair done with the least expense? Also, do you have any idea how to get the right part number, if it is a computer that I need? Thanks, Jim in FL
  • fduboisfdubois Posts: 9
    Driving a friends 2004 XJR today when yellow light and Air suspension fault message comes on. Checked fuse and its OK. Anyone ever seen this before? Thanks, Frank
  • We just yesterday purchased a XJ8 1999.

    We had windows tinted. There was water dampness inside car from process.

    On way home, one window automatically went down anf the steering wheel moved.

    Returned and dealer said it would be okay when it dried out.

    Today it is still doing these things.

    Has damage been done? If not, what should or can be done?

    Taking it back tomorrow to dealer.

    Appreciate your direction.
  • unable to find wiring diagram or repair manual for this model? any help?
    battery drains down over-night. belts squeal when first started each morning. battry (amp) guage shows charging.
    eventually goes away after driving.
    FIN control module has been replaced??
    belts are new & tight.
  • i have just purchased a p reg jag 3.2 exec i have an original key fob but was given another better one but the better one is not tuned in how do i do this please anyone thanks archie
  • Go to E-Bay. I found a CD for this there. $14+
  • I am having chimes go off while I am driving down the road.

    Five chimes five times.

    I have a light out on the rear-deck light.

    Could this be it?

    Help !!
  • adougadoug Posts: 6
    I am thinking of buying a 1999-2003 Jaguar XJ8 but have reservations because of the posts I have seen on this board. Can anyone tell me what to expect? I would appreciate any replies.
  • Hi. I have a 2008 XJ VDP. My parking sensors on the front bumper are extremely sensitive. I pick up traffic as it moves in front of and along the front edge of the bumper as cars turn in front of me while stopped. Does anyone know if they can be adjusted to be less sensitive. Thanks Neil
  • I assume they were the same way as the rovers and if they do there is a software patch that reduces the sensitivity of the sensors. Call your dealer and ask about it.
  • Thanks for the info. I'll give it a try.
  • Several months ago my blowers would stop working when running on low speed, but they would come back on and run without quitting when switched to medium. A few months later, they would stop running on medium but would run when switched to high. If turned off, they would have to be switched on several times before they would come on, but if left on between uses of the car, they would begin running when the ignition switch was turned on. Then more recently they will not run at all no matter what I do. Do you know a solution for this problem?
  • kbeerdenkbeerden Posts: 4
    Can any one point me in the right direction, I have a 2000 xj8 and the front drivers window is stuck up.I hear a clicking noise when I push the button but no movement, I have changed the switch and even plug the connection to a differant motor and still no movement,Strange thing my sun roof will not remain open and will close on it own after a few seconds ,are these problems related?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,279
    If you hear a clicking that is electrical (light click) and coming from the relay box, you could have a bad relay. You'd have to check your owner's manual to see if that relay also operates your sun roof, to determine if there is a connection between these two malfunctions.

    If the clicking you hear is deep with the door, and a heavier mechanical clicking, then I would say (like skipping teeth on a wheel, a sound you can probably feel with your hand against the panel) ) that your window regulator is broken and that there is no relation to the sunroof.

    Visiting Host

    MODERATOR --Need help with anything? Click on my name!

  • deadjagdeadjag Posts: 8
    I drove home in a bad electrical storm. Everything worked OK while driving. Next day I tried to startup. Dashlights, audio tones, and interior lights come on but engine just clicks. I get two system messages: 1) check engine and 2) stability control. Checked battery and have 11 volts -- seems OK. Also tried to jumpstart to no avail. I also turned traction control to 'off'. Still get same result -- just an electrical 'click' and 'check engine' message. Seems like I need to reset stability control or check engine in order to start. Any ideas out there? Bob in Chancellorsville :(
  • don
    PLEASE tell me that you found the (an) answer to this problem with the blowers. I have the exact problem just as you described it and as a result I have no a/c in my 1990 Jaguar xj6. Local dealer is no help and wants a fortune to just diagnose the problem.
  • I am having the same problems w/ my 2000 XJ8. Did you ever get this resolved? Mine has been in the shop for 3 wks now, in and out...mostly in. I started out just trying to get the module fixed in the rt rear door so the window would work. What a nightmare this has been.

    My problems are: 1. The ignition switch does not activate . 2. Seat does not automatically adjust to set position when car is cranked. 3. Doors lock and then immediately unlock when the plunger is pressed. To lock doors, it is necessary to use the key or the FOB.

    This guy only has a few hours left before I hang him from the highest tree. Thanks for you help.
  • Hi
    I did work out my problems, I change the front right door module. This module is the main brain for all of those items. Was a bit costly, over $300.00, easy to change. Make sure you get one with the right code the dealer can not reprogram the module. The code can be found on a sticker under the trunk matt on thr lift side, it will start with DDM ######## and don't buy a use one I tried that and just wasted money. Hope this works out sounds like the same problems I was having
  • deadjagdeadjag Posts: 8
    My problem turned out to be a bad battery which I replaced. I had tested the battery voltage which was OK but the amperage was not enough to turn the starter. (IThe battery was original equipment so I should have known!) In the process of finding this out someone told me how to reset the computer. Don't know if this would help you but apparently if you remove the black (negative) connection strap from the battery for 10 minutes, then reconnect, it will reset the computer. Good luck.
  • Just replaced a module in the back rt rear door and I'm moduled out! Sheesh! If I do it is it a tough job?

    Will the battery cause everything to go fritz on the car...?
    1) doors won't lock when pushed down
    2) interior lights stayed on
    3) seat won't set properly
    4) **and it won't start...

    Also, mechanic replaced the back door module w/ a used part that he swore would work. This guys been there for 26 years and I thought he might know what he was talking about.

    Thanks, guys...I'm about to lose my rosy disposition over this.
  • Four years ago, had a starting problem on this one. Would not start unless starting amps were topped out with a booster. Soln: cleaned oil from ignition module, replaced coil and distributor. No problem last four years.

    Now, same problem again. Cleaning module did not solve problem this time. Questi
    on:::: should I replace the module??? coil??? other???

    Other info: Starter turns over engine briskly. "Occasionally" I can get it star†ed by topping out the battery charge, and putting a battery booster on it, about 1 in 4 attempts. Runs great once started. (Until next attempt to start). Comments appreciated.
  • I have a 1998 XJ8L and love the way it looks - I just wish I could drive it. It won't start. My mechanic (not a Jag expert, but honest and good with cars generally) has been trying to figure it out, and is close to concluding the GEM module needs to be replaced at a Jaguar dealer, with a likely cost in the THOUSANDS of dollars. I only paid $6,500 for the car a year ago.

    When I said it won't start - everything lights up when the ignition is switched on, but when I turn the key all the way, nothing happens. I mean nothing. No sound at all, no engine turning over, no starter sounds, not even any clicking of relays. Absolute silence. Is it the GEM? Will it cost thousands of dollars? Can't we just cross a wire somewhere and bypass all this electronic crap?
  • Mine is a 99 XJ8. My starting problem turned out to be the battery. I had tested it with a meter and it had about 12 volts so I moved onto other problems, wasting time and money. Problem was that, although the voltage was OK, the amperage wasn't enough to crank the starter. If you have an original Jaguar battery (white color) and it's more than 3-4 years old, it's probably shot. Another possibility is the computer needs to be reset which can be done by removing the + battery strap for 15 minutes then reconnecting it. Good luck.

    Deadjag
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,279
    Good advice. Unless you "load test" a battery, just measuring voltage at rest doesn't tell you much about it's condition. And that's true, most batteries are pretty tired after 4 years of use. Some go longer but on average 4-5 years is plenty for optimum performance.

    MODERATOR --Need help with anything? Click on my name!

  • Thanks to both you and Mr. Shiftright for the responses. The battery had died back in February. That was weird. The engine would turn over and over, but never start. We thought maybe it was a fuel pump problem! But it was just the weak battery. Replaced it and everything was fine. For a while after that, I would try to start it and nothing would happen. Then I could switch it off, immediately try it again, and it would start right up. Or sometimes I would have to turn the key off and on two or three times before it would finally crank. That's what made me think it was some sort of simple relay switch problem. Obviously, the last time it happened, turning it off and on didn't work after trying it 20-30 times.

    It will be interesting to try disconnecting the battery though and let the computer reset. Thanks for that one.
«13
This discussion has been closed.