Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Subaru Impreza Transmission Problems

13»

Comments

  • robdog13robdog13 Posts: 8
    My daughter has a 95 impreza AWD in which the rear wheels are not driving.The front wheels are doing all the work.Is there a relay module or similar that could be the problem?I will tell you this we towed the car about 350 miles with the back wheels on the ground after we deactivated the AWD per the manual.The manual didn't mention a limit of miles to be towed so i really didn't know about a problem until i noticed the front tires worn but not the back. Any leads would be appeciated, THANKS, Rob
  • robdog13robdog13 Posts: 8
    Didn't mention that the drive shaft isn't turning out of transmission. Thanks
  • ateixeiraateixeira Posts: 72,587
    Manual or automatic?
  • robdog13robdog13 Posts: 8
    It is an automatic. Rob
  • ateixeiraateixeira Posts: 72,587
    Most automatic Subarus can be put in FWD mode with a fuse inserted, but unless you added the fuse specifically that couldn't be it.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,679
    No, but it could be that the clutch pack in the center differential is burned out, and it is certainly possible that this occurred as a result of the towing.
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • I was at one of those lube joints and they told me I have flecks in my transmission oil and water in my rear differential - each of which could be solved for just under $500.00 in total. I said no thanks and I have later verified that the transmission oil has little flecks in it. the Tranmission oil reserve tank is mid way cold and the fluid is clean.

    Can not check the rear differential they said water was in it.

    first of all is it possible the rear differential has water in it?

    Flecks in transmission oil is bad sign. I am 1500 kilometers from a dealership and they do not like to hear these kind of things when its on warrantly. How can I diagnos the problem/s if there are any? I mean transmission and rear dif wise?

    thanks for any input
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,679
    The rear differential is a simple enough thing to check... just drain the fluid! The water will sit below the oil, so if you just plan on changing out the fluid, pull the top plug FIRST, then the bottom plug. When you pull the bottom plug, you will see water pour out before the oil starts to drain. If you do have water, I would just drain all the fluid, top it off with a high quality 75w-90 gear oil, and check it again next year. If you have water again, you may be looking at replacing seals.

    At this point (unless the car is close to being out of warranty), I would do the same for the transmission - replace the fluid and filter, then watch it to see how it ages.
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • lilrdwgnlilrdwgn Posts: 1
    edited January 2011
    Was wondering if "econhonda" (or anyone) ever figured out what was causing the trans to leak...I have a 2000 Impreza RS with a similar problem??? Was it a breather hose??? HELP!!!! :confuse:
  • Hey there,

    Believe it or not, my gushing leak was fixed by simply replacing the external fluid filter located on the side of the transmission. I was so mad when I found that it was this simple!!! Seriously, spin the old one off, spin the new one on, and bingo. No more leak. I didn't even know my transmission had an external spin-on filter, but it did. Hope this helps.
  • ateixeiraateixeira Posts: 72,587
    Glad to hear you found a simple resolution.
  • I have a 07 Impreza with an automatic transmission, the indicator light next to the speedometer says its in 1st gear no matter where the shift lever is. I can move it thru all the position but the light says its still in first gear. Even though the shift lever is in park the car won't start because it thinks its in first. Is this a limit switch problem or a linkage problem or something else in the transmission. Any ideas? Thanks for any help.
  • ateixeiraateixeira Posts: 72,587
    Beyond what I'm familiar with, but is it under warranty? 07 covered for 5 years should go until 2011-2012 or so.
  • That would be great if its under warranty, I bought it used and the car is sitting up the street in a church lot and have not had a chance to get to it. We had a foot of snow and the guy that plowed the lot made it impossible to open the doors so I can't get in and get the owners manual.
  • paisanpaisan Posts: 21,181
    It is likely the transmission gear indicator switch. It won't be covered under the powertrain warranty but since it's external it shouldn't be too expensive to diag/fix.

    -mike
    Subaru Guru and Track Instructor
  • jsaf200jsaf200 Posts: 1
    I have exactly the same problem... Delay in drive (3-5 sec), reverse no problem, check engine light on, just annoying and kinda scary. My impreza is about 130K and its 2000. I just really hope its not a rebuild trany situation. Very interested how things go for you, let me know what you do to fix it.
  • nltexasnltexas Posts: 1
    I had engine work done and had a new clutch installed on my 2002 WRX. About a month after taking the car out of repair, I heard a loud noise and it felt like the engine dropped off the car while I was moving; my transmission got stuck in 2nd gear while I was driving.

    The repair shop claims that the new clutch they installed has nothing to do with this problem of the transmission being stuck in gear and not budging.

    I have heard from others that improper re-installation/mounting of the transmission onto the engine and connection to clutch can cause locking of the gear shift.

    Any thoughts/comments please? Thanks, Nick L
  • kpjiggakpjigga Posts: 1
    I have a 1999 Impreza with a crazy transmission light. It is the "at oil temp" light and it comes on at the weirdest times. Hot or cold the light will pop on and when I restart the car, the light is gone. I don't if it is a bad sensor or what. I don't what it means or how to fix it. Any suggestions? Thanks
  • subanoobsubanoob Posts: 1
    edited November 2011
    I was driving when suddenly I could no longer shift gears when the engine is running. I can shift through them when the car is idle. I can also start the car in first gear and drive through all the gears, but if I put it into neutral I cannot shift any more. I have been driving a few miles like this for the past two days, and now the clutch pedal is starting to stick. If I try to put it in reverse the gears are grinding. I can start the car in reverse no problem.

    A) Any idea what may be the cause of the problem and how much repair might be?
    B) And am I doing further damage by driving it this way?

    Thanks.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,679
    I can also start the car in first gear and drive through all the gears, but if I put it into neutral I cannot shift any more.

    I don't quite understand. Are you rev-matching to shift when you do not put it into neutral, or are you pressing the clutch pedal and shifting as normal, just going directly from one gear to another?

    I'm thinking you have an issue with your clutch fork, linkages, or similar. I suspect the transmission is fine.
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • kyfdxkyfdx Posts: 31,124
    Yeah... sounds like a clutch issue to me, too..

    I wouldn't drive it that way... If it is just the clutch, and the transmission is okay, you sure don't want to damage the transmission... that would add mega-bucks to the repair...

    MODERATOR
    Prices Paid, Lease Questions, SUVs

  • jphanjphan Posts: 1
    Were you able to solve this problem? I have same or similar problem. Was wondering what you did to fix.
  • phxmotorphxmotor Posts: 9
    This is why I never opened a shop of my own. So many shops just can't tell the truth. It's maddening and sad that so many shops knowingly mislead people just for the fun of it.They just can't help themselves. And why not, it's so easy to do. Heck; half of the driving public (no; it's more like 75%) can't change their own tire and go to bed every night thinking only a "shop" can read a code reader.
    It's fun to diagnose car related things, and it just isn't all that hard to do. I'm at a loss to see how many people are just ripe for the plucking. But after reading one posting like this after another I'm going to have to start avoiding this activity. It's not fun anymore. It just convinces me how lame and guilable many people are. Kinda like our legisltive uberclass. They sure act like they are worthy of respect and trust, but in reality...
  • how hard is it to rebuild a auotmatic transmission for a 05 subaru impreza rs 2.5
  • took car out today on a long trip, noticed abs light on at traffic light, shut car off and restarted light was out, 30-40 miles down the road it started vibrating then stopped then did it again then stopped. I pulled of off the highway and the trans started to slip pretty good. Pulled into a lot and noticed the A/T trans light was on, the ABS light was on, the cruise control light was flashing. I checked the trans fluid and it seems to be dark and a little foamy but the level isn't low. Let the car sit and cool down completely. It slipped as I backed out of the spot but other wise seemed ok going back home till I got back of the highway and to my first traffic light. The trans slipped bad in first gear and just a little in 2nd gear. Then the lights came back on and the engine revs but car will not move. anyone experience this? its an 09 Impreza with 98k on it, never changed the fluid and I dont think it will help now
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,679
    Don't sell your car short.... a flush is a LOT cheaper than a new transmission! While it is possible that irreparable damage is done, try cleaning out the badly sheared fluid, remove the varnish on the clutch plates and other channels and surfaces, and just see what you see in terms of results. I had some luck with Lucas transmission oil in a badly worn AT a while back.

    It's been nearly a month since your post, though. How are things now and what have you done in the interim?
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
13»
Sign In or Register to comment.