Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Volkswagen Cabrio Warning Lights and Problem Codes

«134

Comments

  • jesslsu1jesslsu1 Posts: 1
    Just bought a 98 Cabrio yesterday from a dealer 124K miles on it, but I got a good price.

    1. Took it through its first car wash (VERY minor leaks...YEA!!!!) but the check engine light came on immediately afterward. I let it dry out for a few hours and the light is still on. It was just checked by a mechanic yesterday and everything was fine. I guess I need to go have the codes run, but has anyone else had this issue?

    2. Where can I find an Owner's Manual? It didn't come with one...

    3. Does anyone have a maintenance schedule posted online? I can't find one.

    Thanks!

    Jessica
  • nnyluhnnyluh Posts: 5
    Jessica,

    I am wonder what you paid for your Cabrio. I have a 98 with 52K miles on it and I am thinking of selling.

    I have had the check engine light go on several times since I bought my Cabrio new. The first time the fix was taking off and putting on the gas cap a couple of times. Apparently if the seal isn't tight it triggers the light. Have you tried that?

    Thanks,

    JD
  • wiltshirewiltshire Posts: 1
    I own a 2001 VW GLX. My Malfunction Indicator Lamp (GLX) keeps going off & on. Is this happening to anyone else, I know little to nothing about cars. I don't want to keep running to my mechanic. HELP.
  • rtc1rtc1 Posts: 4
    I have a 1984 VW Rabbit Convertible with ~130,000 miles. At 123,000 miles, it was burning some oil and I decided to have the heads replaced since it was a relatively low mileage vehicle for its age. During the last couple of months, the oil pressure warning light on the dashboard (next to the oxygen sensor) has come on intermittently, always with the oil dipstick showing the oil being full and the oil pressure gauge by the stickshift showing good pressure. The first couple of times, the warning light was flashing for a couple of minutes but then stopped. The last two times, however, the warning light stayed on and made a hissing noise. Both the warning light and the hissing sound stopped after about five minutes of driving. As this problem had disappeared by the time I drove the car to the garage, the mechanic could not find the problem. He was thinking that it was probably more a panel light problem than an oil pump problem as there was no knocking sound coming from the engine. Curious if anyone has run across this problem before or might know what is causing this problem.

    Trying to decide whether this is likely to be a major expensive repair issue or not and whether to finally give up on this otherwise trusty runabout.
  • kukelkukel Posts: 1
    I have a 1996 VW Cabrio. I had an oil leak a few months ago. I had to have both (there's two) oil switches replaced. A few days after they were replaced, I noticed that the oil light would flicker intermittently, as well.
    BUT, as I further studied it, the warning light would flicker when I was idled. And as soon as I tapped the gas, the light would stop blinking.
    It just does it randomly now.

    I was reading online about vanagons the other day, just for kicks, and I happened to come across an oil pressure related problem that someone else posted. I don't know if this is any revelation to MY problem, or the problem you have encountered. But it seems to make sense. It might just be sending a wrong signal out.

    Here's what the other poster wrote:

    Problem: Oil pressure light comes on under 2000 RPM
    I recently experienced a problem with my Vanagon that seems fairly common. When the engine is hot and I stop at a light, the oil light begins to fade on. It doesn't go off again until the engine revs above 2000 RPM. (An explanation for this behavior is given below.)

    EXPLANATION: While there is a "high" pressure switch and a "low" pressure switch, they both cause warnings when the oil pressure drops too LOW. Since "too low" is a bit of a subjective thing in an engine, VW decided to implement two standards. The higher the engine RPM, the higher the oil pressure should be. If you have just one oil pressure switch with a setpoint low enough (say 4.4PSI, 0.3 bar) to not engage at idle, that leaves way too much slack for when the engine is at high RPMs when the engine should have at least 13.2 PSI (0.9 bar) . The "low" pressure switch is used to alert the driver if the oils pressure dips too LOW while the engine is running at less than 2000 RPM and the "high" pressure switch is used to alert the driver if the oils pressure dips too LOW while the engine is running at more than 2000 RPM.

    Mine seems to peculiar in that it comes on solid, not flashing. Nobody seems to be able to explain this.

    There are 2 categories of causes:

    Incorrect oil sensing system - Your low pressure switch may be bad. According to Ron Salmon of the Bus Depot, there are 2 specs of sending units from VW and one has a lower tolerance than the other. Your oil pressure may be hunky-dory, but the sender doesn't think so. It could also be a bad connection somewhere.

    Also, check the connections on the oil pressure warning systems. Sometimes connections to the idiot light and from the sending unit can get weak and cause a false alarm.


    Real oil pressure problem - don't panic yet, it may be simple. Some people have reported that Fram and other non-VW oil filters cause higher pressure drops because of restrictive flow. Try a VW "Autobahn" oil filter. Also, I was running SAE 30 oil; try 20W50. Another common problem is the oil pressure relief valve may be sticky.

    Does this make sense to anyone else?

    My car runs fine... it's just randomly the light blinks.
  • cabriobebecabriobebe Posts: 1
    Help! I just bought a 2001 Carbrio and the check engine light won't go off. The brake light will come on and the milage and clock by the speed o meter will go off while I am driving. I have trouble starting it and often when I put it into park the car will stall out. I have had it in the shop 4 times already and it isn't fixed. It goes in again next week. Has anyone found a soulution to this?
  • I recently bought a 2001 Volkswagon Cabrio. It has 42,000 miles on. .. The car runs very well but there appears to be some problems, but i'm not 100% sure.. From what I have read here, i'm not sure if I have made the right decision to buy this car. The engine light comes on (this is two weeks after I bought the car).. One of my friends says that it could be the oxygen sensor. Also the brakes are working very well, but are squeaky.. and sometimes when I start the car after about a day or so of not using it; there is a noise for about 20 min and then it goes away... I was just wondering if any of these things, could be major problems in the future... if anyone has owned this car and knows more about it, I would like to know .. . .thank you very much !!!!
  • i have a 2002 cabrio purchased brand new and for 3 out of the 5 years ive owned it the check engine light remained on. i took it to two different vw dealers and an after market mechanic, no one could fix the problem. last year, in ny, it became mandatory for a check engine light to be off to pass inspection so i was in big trouble. they kept telling me it was the gas cap. after changing the oxygen sensor (twice) they eventually changed a $10 hose connecting the sensor to the vehicle...no more check engine light, that was last year.
  • thank you for your feedback . ..
    I was just wondering, what hose it was that had been replaced to get rid of the 'check engine'. ? .
    actually my 'check engine' light went off now, and the 'air bag' light came on; but i just want to know for future, in case it comes on again . .seems that it's just playing games. ...
  • Hi,

    I have a 1998 cabrio that i bought used from the original owner. when i bought the car she told me that after it rains or if the car has been sitting for a while (a couple of days or more) the first few times that you press the brake, the car will make a screechy, grinding sound. And, yup, it's true. i've owned the car for 3 years, and it does make a scary sound after rain or sitting. i've been told that it's due to either a little bit of dust or rust on the brake pads. nothing to worry about. the brakes also squeak frequently, but that's b/c the rims get really dirty and the dust settles on the brake pad. if i am diligent about cleaning the rims, the sound disappears.

    hope this helps.

    -sambhavi
  • thank you for your feedback :) ... was just wondering because it sounded like a belt or something.. but the weird thing was that the car was running very well . .that's why it was suspicious. .
    thank you again ...
  • Also, I was wondering. .. how has the car been running since you bought it ? .. I mean did you have any major problems. ..
    I bought this car over a month ago now.. (it's a 2001).. and it began making noises (as you have mentioned after rainy days usually).. the brakes were squeaky, the car engine light came on, and the airbag light came on.. then after reading some of the comments made by different people, i became worried that i might have got ripped off.. your feedback really helped me though. ..i feel better..
  • Does anyone know whether any of these things below are suppose to prompt the check engine light to go on?

    Headlight blew out one bulb
    The reading lights don't work
    The radio needs to be activated (new battery de-activated it)

    I hope it's gone on for one of these reasons nothing mechanical.

    Thank you!!
  • Hi:

    If the radio is in safe mode than you need to go to a Volkswagon dealer so they can give you the code for it.. .
    It's a safety option, so thieves can't steal it..I had to do it for mine. ..
    My engine light and airbag light is also on.. the car has been running very well though..
    hope this helps :)
  • It certainly does, thank you very much.

    The coolest thing happened yesterday, the check engine light WENT OFF! WooooHoooo!!
  • Hey:

    My check engine light has been off for a while, but sometimes it comes back on again :mad: .. fortunately right now it's been off for a while...:)
    the airbag light doesn't seem to wanna go off though. .
    These lights just play games sometimes you know . .
  • It turned on last night after driving it for about 2000 miles since i bought it. I have a 2001 Cabrio with 67,000 mile. I check this forum last night ang got some ideas. This morning before i started the car, I opened the gas tank and let the pressure go out. I started the car and the check engine light is gone. I hope this will work.
  • thank you very much .. ..i will try that. .:)
    The engine light goes off and on 7 or 8 times a day on mine sometimes. ..
    umm... i've been having more of a problem with the airbag light.. it's been on forever..that's definitely gotta be a defect... I don't think it's an electrical problem..
  • mikkiwmikkiw Posts: 1
    I was trying to sell my 96 cabrio and it was working fine until i had someone test drive it and when they came back turned it off and went to turn it back on it would not turn over. So we went out a purchased a new starter thinking that was it but know it still doesn't start. :cry:
  • nemesis5nemesis5 Posts: 8
    i had the same problem with mine.. sounds like it could be your alternator.. but mine was just the battery that needed replacing.. .and now it works fine .. i haven't had any problems since.. :)
«134
Sign In or Register to comment.