Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Venture Electrical Problems

179111213

Comments

  • 442dude442dude Posts: 373
    There have been issues with the sockets that the tail lights are in...seems that he heat of the bulb causes them to melt and short out...maybe this is your problem?
  • lb71lb71 Posts: 2
    I see Ventures have quite a bit a electrical problems. I am having similar problems with tail lights overheating the bulb sockets. What is the solution? though it didn't look like the license plate lights are over heating. I have a 2002 venture
  • rlp50rlp50 Posts: 13
    Smoother the end of the bulb and socket with di-electric grease. That worked for me.
  • lb71lb71 Posts: 2
    thanks there I will try it out
  • I have a 2007 Venture Van. The problem is as stated in the title. Once I was told to disconnect the (positive) post for 1-5 mins to reset the computer. To my surprise it worked!!! Wait before you jump for joy. It only worked for about (2) on, off cycles of the ignition. It only worked that once and I've been frustrated since.

    Is there anyone who has had this problem, and how did you resolve it?
  • Can anyone help with this one? My power side vent windows have stopped working.
    I have checked the fuses and they are good. I had a spare switch from a parts van and installed it and they still do not work. Any suggestions would be appreciated.
    Does the wiring run through the headliner or under the carpeting?
  • al55al55 Posts: 1
    I have a 2000 Venture that is having flickering lights trouble. I see that an earlier post it was solved by replacing the earthing bolt on the alternator. Is that just a fancy term for the alternator bolts that hold it in place? Or is there actually an earthing bolt that is not part of the securing bolts. If there is such an animal where in the world is it located? I know somewhere on the alternator itself but where? Any help out there for a weary traveler?
    Thanx in advance :cry:
  • I decided to pull the motor on the rear vent window and replace it with the one from
    the parts van. This solved the problem. It wasn't a wiring problem after all. The moter is very small and not heavy duty at all.
    Hope this helps somebody else.
  • 442dude442dude Posts: 373
    I had trouble with flickering dash & exterior lights on our 2000 as well. I just replaced the alternator and the problem went away. I figured if I was going to go through all of the trouble to get to it, while I'm there I might as well just replace it.

    If you do it yourself, plan to spend at least 4 hours - there's a lot of stuff to remove & replace - might as well take your time. The quote I got from the mechanic was $ 750 to replace it due to all of the labor. The part was about $ 150 is I remember right.

    Good Luck
    :shades:
  • i have a 98 venture that blinks interior and exterior lights as well. sometimes it will do it, sometimes it wont. also, my abs light was always on, now when i start it, its off, when i go to drive it the motor hesitates like a stall, than the light (abs) comes back on.
  • jhdjhd Posts: 20
    I posted it in a Chevy Venture string, but this is a better place for it.

    I have an intermittent ABS light coming on after driving on the wet roads or thru the slush. Then sometime it goes off while driving. When engine is stopped and restarted, it goes off. I would think if wires was damaged and salt/water would short the sensor, it would not reset after restarting the engine. In anticipation of this problem, I have RTV sealed the connector wire seals in the summer when I also changed the rotors. It was giving the same problems last year in the winter. Convoluted tubing is done but I used electrical tape to protect wires. Maybe there is a buildup on the surface and can not read the rotor signal? Can the sensor be cleaned?
    Thanks in advance!
  • I am having all kids of problems with the electrical system on my 04Venture. Passenger window won't work, electrical in nature, gas gauge won't work, left tail light board blows all the time and the headlights are crap! Engine is strong and nice running vehicle other than that.
    Keeps going i'll have to drive at night with a flashlight.
  • It's supposed to do that. you have SCV (speed control volume). you can turn it off, refer to your manual as to how to do that.
  • Belucas66 see my post #61 in this thread for a simple conversion to brighter headlights. Hope this helps.
  • already replaced brake switch on pedal all bulbs and both light strips 3 times. what do i do now
  • I have a 2003 chevy venture. It miss fires randomally but fairly often. When it does it throws a code for crank sensor. I replaced the crank sensor and the harmonic balancer. Still hasn't fixed the problem. Also the speedomoter will also randomally work then occasionally not work. With these two problems being sparatic and seem to have no rhyme or reason it makes me believe I have an electrical issue. Any ideas?
  • hunter06hunter06 Posts: 16
    edited March 2010
    I have a 2001 Chevy venture with 148K miles. Works great but suddenly a few days a go while starting the car, I noticed that the lights did not come on but was able to get the high beam.

    Need help to solve the mystery of why the low beam or daytime running lights(DRL) do not work but if I toggle the stick I get the high beam. I have been using the high beam for the past couple of days.

    My panel lights and the front amber lights do work but the headlight does not come on.

    I checked the fuse but could not see anything. Also since the fuse has multiple functions like panel lights etc they seem to be working.

    I need some clue or direction to try and check for possible causes before I spend money at a repair shop.

    HELP !! :-)

    :confuse: :confuse: :confuse:
  • 442dude442dude Posts: 373
    edited April 2010
    I'm confused...

    On our 2000 Venture, the DRLs were the front amber lights, not the low beam headlights.

    I would pull & check the bulbs for the low beams 1st to make sure that they're both OK. Might be as simple as 2 blown out bulbs
  • I'm having the same problem with my 02 venture door ajar hatch ajar and low brake fluid lights are on wondered if any one ever found a solution for this problem
Sign In or Register to comment.