Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Grand Caravan Steering

12357

Comments

  • dodgeman7dodgeman7 Posts: 17
    Watched your video and I believe it is your reservoir. I had the same noise in the beginning and after a few week got worse and started to shutter a bit. Don't know about your heat issue though.
    One more thing, a while ago I had a strange squeaking noise coming from my engine and though it was the belt tensioner. After replacing it the noise was still there. I then thought it was then the alternator pulley but I didn't want to go that route yet so I decided to buy a new belt to replace my old cracked and worn out belt. Changing the belt solve my squeaking and found out that my old pulley was just fine.

    Change the reservoir and it just might fix your problem.
    If it does, I would go back to the dealership and ask for a refund on the pump. These guys know it's the reservoir and don't fix the simple fix but nail you for a new pump and rack and pinion.

    Good luck,
    Tim

    :shades:
  • dericm02dericm02 Posts: 1
    I have a Dodge Caravan, 2000 i beleive and i had issues with the power steering making noises. The noise wasn't a whining like alot of other people have, but it was more of a groaning and at certain points in the turn radius, it would groan really loud and actually shake the van alittle bit. So i first replaced the resevoir after looking at the screen and having it been clogged. I put ATF in it like it says and the shake and noise went away. About a month after i fixed it, it came back, the groaning and shaking. Today i took the fluid out of the resevoir to look at the screen and the screen looked nice and clear, fluid looked good as well. It was alittle low on fluid, i added 3/4 of a cup of fluid, not alot. Turned the steering wheel to get all the air out but the noise still didn't go away. My first thought was the screen clogged, but its not, my second thought was it was alittle low on fluid so i filled it up and got the air out, but that didn't help. With the leaking, i thought maybe it might be leaking slowly out of the rack under heavy pressure or something, but im not sure. Has this happened to anyone else? The pump and rack seem to be working good, its just making alot of noise when im turning the wheel at slower speeds and reverse. Making a long trip to visit the rents soon, so i just wanna either get it fixed or make sure its safe to keep driving it. Thanks for you help!
  • mikep15mikep15 Posts: 1
    UGGH!

    This vehicle is driving me crazy. Only 68000 miles on it.

    Here are my problems:

    1) Power Steering: Squeals like crazy and is difficult to make turns most of time. Forget parking in a spot where you would need to back out of. It is too difficult to turn wheel. I checked fluid level and it is full.
    2) When driving my battery light comes on from time to time (related to power steering?)
    3) Heat: Front fan will only turn on if I turn it all the way on. First three settings will not work.

    Any suggestions? I have spent so much money the last two years at the dealer, I don't want to take it there. I want to keep this vehicle for a while because I can't afford a new car payment right now.
  • sbradshawsbradshaw Posts: 13
    I put 2 power steering pumps on mine b4 mechanic realized the rack and pinion was bad. Symptoms were whinning noises that seem to get worse depending on the temperature and stiff steering. I replaced it 2 weeks ago and all is well again. It costed me about 500 total parts 170 (rebuilt at Advance Auto Parts) and 175 labor.
    As for the air only working on high...removed the glove compartment door so you can see the blower motor cover. To the left you can see where the blower motor plugs into the "resistor". The resistor is bad when this happens. Replaced that last week. Takes about 5 minutes. Could only get it from Auto Zone. Costed $23. Only 2 screws hold it in. The new one I ordered didn't look anything like the one I pulled out but it worked.
  • My power steering pump is whining right when I start the vechicle. It seems to go away when the vechicle warms up. Do any of you think that it could be a clogged screen or need the resiviour replaced.

    And if so how do I do it?
  • I have a 2000 Grand Dodge Caravan and it started making noise from the engine compartment, so I started investigating the problem and thought it was the pulley by the alternator so I replaced that and it wasn't that. So I asked around to some of my mechanic friends and they it was the alternator and so I replaced it...it wasn't that either. Now a couple people thought it's the bearings in the a/c unit. It gets very loud when started and driven until you get to about 45 mph. It sounds like it could be bearings or something like that. Anybody have any ideas or similar problems? Thanks!
  • More than likely, it is the bearings in your A/C compressor and it is just a matter of time before it seizes up and burns through your serpentine drive belt. It just happened on my 2000 T&C LXi. It began as a rattle type noise, and progressed to a "graoning, roar" type sound, for lack of a better description. I spent alot of time chasing the source of it, even with a stethescope, and finally just gave up. I didn't actually suspect the compressor as the source, because it did it without running the A/C. Also when listening around, by ear, with a stethescope, and with a piece of tubing to my ear, I was not able to isolate the noise as it seemed to travel into every part on the engine it was so bad. It finally seized up and burnt thhrough the belt. I replace the belt and compressor, and it is noiseless now. My only problem is I have to change the new compressor again, because it is defective, and when the A/C or defroster are turned on, it makes a very loud whining noise that actually sounds the same as the whining made by a bad power steering pump, or transmission.
  • Newt08Newt08 Posts: 3
    This is my third and last Dodge. I've taken exceptional care of my 2003 SE Grand Caravan and am experiencing several problems. When the odometer hit 80,000 miles, all hell broke loose. I’ve replaced the transmission, ignition switch, thermostat and now the computer is dead -- this all happened in a four month period. Whenever I turn the wheels, the front end squeals and it sounds like a can of loose change when I hit a bump. I've owned Dodges since 1988, but this is my last.
  • kitkate420kitkate420 Posts: 1
    I have an 01 dodge caravan, its been making these crazy noises since the march break this year. the noises also dont happen all the time, they are happening more frequently now though. sometimes i get this 'power steering' noise when i turn and break but when i accelerate it goes away, also i can feel the vibration in my break pettle and steering wheel, it is not hard to turn a corner either it just makes the noise and vibration. its getting louder also im worried im going to turn a corner one day and something bad will happen. the power steering fluid is right where it should be not too low and not too much.
  • I know this may sound a bit crazy, but having owned many C/D/P minis from model years 85 and up, have your A/C compressor checked out and eliminated as the source of the noise. I have had several, where the pulley bearings have gone bad and the noises it makes can have you chasing the source of the noise and vibrations as a power steering problem, steering rack and even transmission problems. For some reason it seems that isolating the source of engine compartment noises in these vans is quite troublesome. They can make some very strange sounds that usually sound like they are coming from somewhere else under the hood. I even have a mechanics stethoscope that I use and even with that or a pice of tubing held to your ear, and moved from component to component under the hood, it is sometimes very hard if not impossible to isolate the bad component that is actually make the noise. My "steering noise" on my 2001 T&C, actually turned out to be the compressor pully bearings. When I couldn't narrow the source down, I decided to just let it go for awhile and try again later. Instead of it getting worse, it got very quiet, then the bearings seized up and it melted and snapped the serpentine belt. I then bought a rebuilt compressor, and as soon as I chrged up the freon on turned that one on, I got a whining noise that acted and sounded like a transmission "whine". Had to do that job over again! No more noises, and it sounds and runs better then it ever did since I owned it. Turned out the problem w the first rebuilt compressor, was that the parts store gave me the wrong weight(PAG 100) compressor oil, and also only gave me 8 ounces to put in, but it calls for 13 ounces of PAG 46 !
    Like I said, may sound crazy but I have owned enough of these to know better. Good luck.

    Just thought I should add for clarification, in case anyone was wondering, that when the bearings were going in the A/C pully, it was definitely isolated to the main bearings and not the clutch, because it makes the noises and vibrations without the A/C or defroster turned on. Also, my comments on the LUCAS Power Steering STOP LEAK ADDITIVE: when you get momentary stiffness or steering loss in the power steering racks on most cars, you may also get a popping feeling and/or sound as well. This is usually from wear on the seals inside the rack. While I do NOT believe that any "leak stoppers" actually stop leaks, I will say this for the LUCAS, I use it as a lubricating additive, not a leak stopper, but it does appear to stop or slow down these internal seal leaks in the rack enough to avoid replacement of it for several years, or all together. This is of course based on my personal use and results of it in my own vehicles, both Chrysler and GM.
  • I have used the LUCAS Power steering additive on several of my many vehicles over the years and highly recommend it! In 2 of my vehicles, I was told needed the steering rack and pump replaced, put in the Lucas and surprise surprise, no more problems. The only Lucas additive I do not reccomend using in any chrysler vehicle, is the transmission additive! Chrysler trannys are much to eccentric and susceptible to problems, so use nothing but the MOPAR ATF+4 in them!!!
  • Sounds like one really big load of crap to me !!! They screwed something up!
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,504
    I put Amsoil Universal transmission fluid in my van last summer at 185,000 miles. After another ~15,000 miles, the transmission continues to run like a champ. We have about 201,000 miles on the van now.

    I went with the Amsoil fluid for two reasons: first, it has much better cold weather characteristics than ATF +4; second, it was easier to acquire and less expensive (the local dealer must think ATF +4 is refined from gold) at my location (Fairbanks, AK).
  • Sounds more like a belt problem.
  • Should not be any clunking noise at all! Did you check/replace the bushings?
  • Hey X, you know, my neighbor went w the Amsoil in his 06 ram Pu as well and says he has had no problems w it either. But after some of the expense and problems I went thru w my mini trannys, I am afraid to take the chance on anything but the ATF+4 they recommend. I am just not convince that you and my neighbor are the excepition to the rule on this or what. :confuse:
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,504
    Yeah, I absolutely understand your hesitancy. I felt the same way. Actually, after reading about the vans, I was very hesitant to even buy the thing. I picked it up two years ago when it had 170,000 miles on it. But, it was owned at the time by a well-respected mechanic and was used regularly by his family. The price was also right, so after trying it out and looking it over, I decided it was worth the risk. I wanted two years out of it, which I got, and now I would not mind two more! All told and gremlins aside, I am very pleased with the van.

    The only major problem I had with it the first winter was just trying to get it to move during the very cold days. Even with a heater on the transmission pan, it was terribly sluggish. So, when I was ready to change the fluid at 185K, I looked at alternate fluids. Amsoil, which I use for all my vehicles' engines and change once per year, makes a "universal" ATF that claims to be compatible. I contacted them to inquire for assurance purposes and they supported their claim. I figured if I changed the fluid and the transmission immediately failed then it would be their liability. I took the chance and came up smelling like roses. And, it behaves much better in frigid temperatures.
  • sbradshawsbradshaw Posts: 13
    I was looking up some information in the manual about the (BRAKE) light that periodically comes on and read something simiular that could accure. You might want to scan the manual just for eliminations too. :)
  • I have a 2001 DGC and it has been leaking ps fluid for a while now, but it's getting much worse. I have to add ps fluid at least once a day to keep it from whining and getting stiff. The resevoir is empty eachday so the leak is bad. I need to replace the rack and pinion and need to know how to do it myself and how difficult is it to do?

    Anybody got step by step directions? :confuse:
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,504
    No, but you could do yourself a huge favor (and inexpensively) by picking up a Haynes repair manual.

    I noticed on my '98 Caravan that the steering hydraulics underneath the van are leaking. I suspect that is probably where yours is leaking as well, even though mine is not yet as bad as you report. I do not have the details for the full repair as I have not performed it, but access on my van is relatively simple, requiring only the removal of a massive skid plate that is mounted under the steering and transfer case. Once removed, the area containing those hydraulics is very easy to access.
  • Are you sure it is the rack and pinion leaking. Are DGC had a powersteering leak and it was a bad line. The vehicle had 100k on it and was 9 years old. There is a tab welded to the line to mount it to the undercarriage and it rusted at the weld. Three weeks later I had to repair the coolant lines that run to the rear of the vehicle for the same issue.
  • I've read many posts where the moaning noise goes away after the vehicle warms up but I have the oposite problem. After an hour of driveing, the moaning is load and clear during turns. If it could be the compressor pulley bearing, then could it be any one of the pulley bearings? Any thoughts, anyone?
  • I replaced the power steering pump twice on my 2001 G Caravan Sport. It made even more noise, wheel started ramdomly sticking, then finally froze. I replaced the rack and pinion. It was only quiet for about 3 months. When the weather heated up it got louder. I bought a used/rebuilt r&p from Advance Auto so It may have been a faulty one but it had a lifetime warranty so they will exhange it. I can't help but think there is something else the 3 mechanics that did the work is missing that is causing it besides the r&p and/or pump. Please post your fix. I'll try it too.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,504
    What about the reservoir? I have heard that there is a filter at the base of them that can clog, causing poor fluid circulation that can starve the pump and cause the whine....
  • Dodgeman thans for all the advice. Plan on getting a new PS Res. this weekend. Got another question. My check engine light is on and got the code P1494 (Leak detection pump switch or mechanical failure).. Do you happen to know where the pump is located? I have a 2001 DGC.
    Thanks,
    Bill
  • could be that your cooler is getting plugged and causing alot of backpressure u might want to bypass it or replace it
  • thanks to everyone on here. I went to dodge to order a new reservior and they did not have a part # for it so I came home and went back to this sight and got the part # for them but by that time they had found it. It is listed under hoses. I was prepared to change the pump and rack and pinion. But luckily I stumbled onto this website(thanks to google) and changed the reservior ,fixed a few problems.
    thanks again all
  • Thanks to everyone who wrote in.My 2003 GC with 91000 miles was driving me crazy with its whinning.Since it was sunday and this seems to be a dealer part only all I did was remove the reservior and soaked it with degreaser in hot water flushed and reverse flushed it several times then dried it out Its been two days and all is quiet. Hope this helps
  • Hey all thanks to the info on this forum I replaced the reservoir on my 2005 T&C 3.8L.

    As others have mentioned, the rear (large) hose was a pain in the butt.

    Since I was having trouble I unhooked everything (top bolts, back bolt, small hose, so I could twist the reservoir and the hose in opposite directions...still no luck.

    mine was frozen until I spritzed some WD40 around the seam at the end of the hose where it butted up against the reservoir. Then I sipped on a beer for 2 mins, and after light-medium twisting, it broke free.
  • My Dodge Grand Caravan with 118,000 miles, the steering will stick at times then come back. At first I thought it was the R & P, but the people at steer & gear tell me that is not a R & P symptom. I am iin the process of changing the rear heater hoses and tubes, any input would be greatly appreciated
Sign In or Register to comment.