Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Transmission Problems

1272830323335

Comments

  • gcat1gcat1 Posts: 2
    I am SOOOO disappointed in Chrysler with this problem. This shuttering occurs at exactly 17 MPH in my 2011 GC Limited. They have rebuilt the entire valve body in the transmission, replaced the drive train control module and updated the software as well and I also have lost about 3 MPG!

    I have spoken with Chrysler customer service a couple of times and they have told me that they have left my file open on this problem (supposedly that means that they are working on a fix), but nothing yet. The dealer said that they have this with all the Limited models and offered me to drive others (I really don't care if the trucks in their lot shake, rattle and roll --- I just want mine fixed) to feel it for myself and they told me that the cause is that the torque converter is engaging at that speed and this is the cause -- If this is the cause it can be fixed and I think I am being told a load of crap so that they don't have to have a recall and replace all the transmissions in this model (which is something that they have done with overseas models)

    As an aside, if you change the drive control between the seats to SPORT vs AUTO, this will cause the shift pattern to change a little and it won't be as noticeable, but that damn vibration is still there ...

    LET'S GO CHRYSLER, these are $35 - $50,000 vehicles that you make a ton of money on --- If you cannot afford to get this done right, have FIAT give you the money to fix this problem correctly NOW!
  • rwengrrwengr Posts: 177
    Make sure there are no fluid leaks. It affects the pressure. Pay special attention to transmission cooler lines. They should be bone dry.

    Next, check all electrical connections between engine and transmisssion. Make sure no wiring or connectors are contaminated with oil. Sometimes the engine leaks oil and it blows back over the transmission.

    If you don't find anything, then I think you have an electrical-mechanical component like a solenoid inside the transmission with an intermittent fault. Unless somebody can diagnose the problem, you will have to do a rebuild.

    If your transmission has a computer, check with the dealer about any Tech Service Bulletins or firmware upgrades.

    Transmission problems are the worst.

    Once you fix the problem, please update the post
  • Hi Iam having the same problem only worse it is now stuck in crawl and wont advance through the gears. have you made any progress in diagnosing the cause as where i live it is going to cost a fortune to get it to a garage that can diagnose the exact problem. the OBD codes that show up are P0700 and P1652
  • Try Dr. Tranny's Shudder Fixx. It is awesome. I buy it inexpensively off eBay and put it in all my vehicles. I have a 2003 Ford Windstar company van - that model of which is known for transmission torque converter issues. Dr. Tranny's has stopped the issues with my Ford and both my Jeep GC and Commander rough shifting. The company responds quickly and thoroughly to any question you have about their extensive and unique product line. Dr. Tranny is perhaps the best kept automotive secret. I learned about it from a transmission expert.
  • unsure_jeepgrlunsure_jeepgrl Posts: 1
    edited January 2012
    i have a 2000 jeep grand cherokee laredo; 4wd; 4.0L; i don't know what kind of transmission i have. the codes that came up are: cylinder misfire detected on cylinders 4, 5, and 6; govenor pressure sensor, offset voltage too high/low;
    it explains the codes that came up and the probable causes, but i am unsure what to do first, and i don't want to blow my engine up. please help me.
  • I'm having the same problem. I have a 2007 jeep grand cherokee lardeo. I have everything working fine other then it won't start and says transmission over temp. Has anyone figured out what it is or has it been fixed? Please feel free to send me a email at clebrn37@aol.com thanks.
  • nnealnneal Posts: 72
    There is a discussion about similar symptoms on this page. Hope it helps.
  • Does anyone know if we will be able to order the 8 speed tranny in June for the 2013 MY.
  • shifts fine from 1 to 2. as it goes into 3rd it either revs engine as if in neutral or holds gear and tachs out. after a sec either way it shifts into 3rd. it does not always do this. sometime it shifts normal. changed tps, input and output sensor. are there anymore sensors besides the tcm that might cause this? or is it the tcm? any suggestions? if it is the fluid is it alright to change filter and fluid. always heard that would tear up trans if you have not changed it at specified intervals.
  • I recently purchased a 2011 JGC Limited, in 2 months have put about 7K miles on it. I have been noticing what feels like a studder or shudder when slowly accellerating - like the transmission is slipping or something. I've cancelled a couple of appointments with the dealer - I'm sure these folks won't be able to "notice" it or feel it like I do. It seems to happen when the vehicle is slowly speeding up, or trying to maintain speed at any speed. For example, cruise control at 55, going up a gentle slope - it feels like it's misfiring. I also feel it slip when pulling away from a stop - almost feels like something sliding to the back of a pickup truck bed and hitting the tailgate. If anyone has a solution, or have had success diagnosing this - please post. At this point, I'm just waiting for the tranny to quit - then they can fix it....!
  • Is this 2011 GC a v8 Hemi with the shudder?
  • Yes, sorry, it is the Hemi V8 engine.
  • input or output censor. about 35$ and 10 min to replace.
  • Hey guys i was driveing on interstate, in rain, suddenly the cruise control went out. the light
    in the dash stays on but won't engage. At the same time my overdrive stopped working.
    Any ideas?? no blown fuze and all connections are good.
  • Hi, I had the same problem with my 95 Grand Cherokee and went through
    hell and back before I found the problem.
    First thing to do is cycle the key three times and then look at the overdrive
    light and obeserve if it flashes or not. If it does it is indicating trouble codes:
    eg: 2flashe pause 5 flashes would be code 25.
    Try that and let me know what you get.
  • I borrowed computer from freind showed a code that came back to be TPS,
    with high voltage. But will try the key thing now.
  • Ok tried key thing, i don't have an overdrive light.
    Or it's not working.
  • Ok replaced TPS, everything is working again.
    All it took was a little water in it to short it out.
  • nnealnneal Posts: 72
    Thanks for letting us know what fixed it.
  • Hey guys. I am interested in buying a used 1996 Grand Cherokee however I would need to buy a transmission for the car and also a new battery. I have no car experience and was wondering if you guys could help me out with maybe some ideas on how much this is gunna cost me?
  • Hi Christopher301, A quality used transmission for a 96 Grand Cherokee shouldn't cost more than $300-$400 plus labor. For the labor, I would go with a small-time local mechanic to save you money. Steer clear of the dealerships and larger auto-mechanic businesses. They will most likely charge way more and do unnecessary "repairs" to charge you even more.

    I've owned 4 Jeep Grand Cherokees and had to change the transmission on 3 of them. So trust me when I say "I know".
  • I'm having the same problem with my 2011 JGC where it feels like the Jeep has trouble going from 1st to 2nd gear. Any ideas? I've looked and am unable to find if the new Jeeps have a TPS.
  • I'm having the same problem but mine is the V6.
  • I have about 9,000 miles on mine now, and it seems less noticeable in the past few days, but I felt it again today. Have you had yours looked at yet? I have an appointment with the transmission guy on Thursday morning....I'd not holding my breath that (1) they will be able to feel the same thing I feel, and (2) have a solution.
  • drewwooddrewwood Posts: 1
    i have a 2000 jgc and i was having shifting problems. hard shifts into drive then drives fine through1st and wont shift into second and forces it self into 3rd, put a new trans in and got it all put back together tonight and its doing the same thing. can anyone help with my issue. running out of money slowly especially with the new trans and trying to figure out why my jeep isn't driving right. from park to drive it kind of jumps forward, like a big jerk. and from drive to reverse it grinds like hell. it seems like its not disengaging properly or something. we thought it was the shift cable. unhooked it and did it manually and the problem still acures. no leaks or whining noises. took it for a drive. and slipped hard from first right into third. . feed back would be greatly appreciated.
  • nnealnneal Posts: 72
    Check out the Throttle Position Sensor (TPS). When bad it can cause shifting problems.
  • gbeesjeepgbeesjeep Posts: 21
    My 2011 JGC Overland (V6) has the same problem. When you are slowly accelerating from a stop it shudders as it shifts from 1-2 (watch as you get to 2000rpm) The dealer has done some initial work with no solution and now think it is a drive shaft or other drive train problem other than the tranny. I also have a humming sound at highway speeds from the drive train (not a tire problem). It seems to be all the same problem. As I have said to Chrysler, I expected problems on a first year model and will live with this but I wont live with the poor service that has been provided so far in dealing with this problem and the reoccurring rattle in the rear suspension.

    Side note - they sure need to fix the lousy shift pattern they have, it jumps to a higher gear way too quick in order to try and get decent mileage at the expense of poor performance. Running in sport mode helps but who is going to use that in the middle of winter conditions.

    Love the look, the ride, the quality of the interior, just fix the problems fast when they come up and Chrysler would have a happy customer.

    Good luck....
  • kigginskiggins Posts: 5
    I finally got my 2011 JGC Limited with Hemi into the dealer for the shuddering transmission problem. They drove it for about 3 minutes and determined that they needed to update some software. The software was supposed to address shuddering upon accelerating, or decelerating, in the 40 to 60 mph range. They were sure that this was the problem.

    The made the update, and I left thinking that maybe something changed, but 1000 miles later, the problem still seems to be there. Maybe it's just in my mind and I have to get used to it. May wait a while and try to have it checked out again. At the rate I drive, I'll be through any warranty period pretty quickly.

    I too experience a growling sound from the driveline at highway speeds - specifically 73/74 mph. Fades in and out, and does not appear to be road noise, but to be coming from the transmission or other drive line components.

    gbeesjeep - who are your talking to at Chrysler? Is it a dealer, or someone with the company?
  • jason_tjason_t Posts: 1
    Hi all,

    I was hoping somebody had a clue on my problem and can help, it's kind of urgent. Today when cleaning my 2002 jeep grand cherokee, it started up and was running fine. Even was driveable. While the jeep was on and running, I had put the shifter in neutral so I could clean in that area. After that I left car in neutral and tried putting the other shifter from 4 wheel all time drive to neutral and it was fine. I then tried to put the shifter from neutral to 4-low and when i did that, the car made a grinding noise and jerked. Even after that happened though, the jeep stayed on and was running fine. After I turned it off and tried to restart, i won't start. I can turn the key to on position and hear radio and everything is fine there so it's not a battery issue but the jeep wont even turn and try to start.

    Now, I am able to push the car like it's in neutral even though I have it in park and on 4 wheel all time. When I try to move the main shifter from reverse to neutral, to drive, to 2nd, it moves fine. But when I try to go all the way to the number 1 on the main shifter, it wont budge. No matter where I put either shifter, the car will not start. I have no clue what I have done to the jeep and hoping for an answer.

    Please!!!! someone help!!!!!
  • gbeesjeepgbeesjeep Posts: 21
    I sent an email to the CEO of Chrysler Canada (his 2 assistants) last month about my frustration and disappointment with the level of service being provided and things started to get moving. I have this guy from Chrysler monitoring the problem. I would recommend you do the same in order to get these guys off their [non-permissible content removed] otherwise you are going to have this dragged on forever.

    They tried the same software change, did NOTHING. The dealer wants to start changing out parts one at a time, I said I am not going to make repeated trips to do this (I have been there 3 times already just for the vibration problem). They said they can't offer a free rental car. I have a contact at Chrysler Corporate with an open file on this. I have contacted them about leaving my Jeep with the dealer until they get this fixed and I want a free rental while it is done. Paid over $50K for this thing I am sure as hell not going to let them treat me like another number. Chrysler is making a huge mistake jerking around the JGC owners. They have brought out a totally redesigned product that has huge sales but they are not providing the level of support that owners deserve. Like me, anyone that bought the 2011-2012 JGC are taking a big chance because any first year vehicle is going to have growing pains. I can accept that but do not accept the poor customer service.

    Good luck.
Sign In or Register to comment.