Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Transmission Problems

1333436383953

Comments

  • Can anyone tell me what to check on this one.
    140,000 on a JGC 1993 6 cyc full time 4x4. Just had the transmission fluid changed (not a full flush) and the filter. Nothing changed with this problem;
    Shifts just fine until it has been driven an gets hot but normal temp.
    Then it starts to not downshift into first when you come to full stop. Sometimes it will and then jerks in and out a few times before shifting to 2nd and then 3rd and overdrive. All the other shift points are fine. When it does this I can manually drop the lever into first gear and it grabs just fine and then I can manually move it up to drive and the rest of the shifting works just fine.
    One person said it needs a new shifting module.
    I keep seeing people talk about a first gear band adjust but I do not see this in any manual for this car. I would think that if that was the problem it would fail if I manually put it into first...it does not.
    Could this be something with a speed sensor or the computer? No error codes show up or anything.
  • Thanks for the tip xelvis66x.

    The last thing i could think of is...

    I replaced my trans (42re inline 6cyl) out of a 98 into my 2001 Laredo.
    I believe prior to 99 the internal transmission solenoids had a 3 pin connector vs a 4 pin connector after 99. It connects on the inside of the trans into the 7 pin trans control connector on the outside of the trans.

    I am about to go in and see if this makes a difference.
    Thanks for your help.
  • darcysdarcys Posts: 5
    edited October 2010
    Just purchased a used JEEP Grand Cherokee Laredo, 3.7L. Engine runs great, problem is the tranny labours a lot when changing to a higher gear, when rpms are at about 1500.
    Purchased last friday, always wanted a JEEP, can someone help
    Oh yes and it has 295,000km on it, apparently all highway, was a bussiness man last owner.
  • rwengrrwengr Posts: 177
    Be thankful it's changing gears.
  • tuggajbtuggajb Posts: 646
    dose the tach bounce around when trying to change gears?
    if not could be the lock up for the converter is not disengaging
  • darcysdarcys Posts: 5
    Yes the tach does bounce around, about 100rpm each way.
    T
  • tuggajbtuggajb Posts: 646
    could pos be the lock up solenoid not releasing might have to take to stealer
  • darcysdarcys Posts: 5
    Okay, thanks. Going to get tranny filter and fluid changed tomorrow, may not have been changed before. Will start with that and go to stealer about the solenoid.
    Thanks again
  • tuggajbtuggajb Posts: 646
    try and drive for couple days before taking to stealer see if gets better

    tony b
  • I have a 2005 GCJ 4x4 I have read my problem on here a few times. In the mornings I pull out and my truck jerks hard and drops into 3 gear. It will not go back into drive. It will go into all others. If i shut it down and re- start it's fine. The check engine also comes on. today it did it again, this time the check engine light would not go off. I have taken it to the dealer before. They can never find a code and tell me its fine. Today I took it to auto zone and got the code P0700. Then went to the dealer. They said there were many inactive codes and had no clue. Told me to drive it till it happens again. I am not sure if that is safe. Can any of you tell me what ended up being the problem with yours?
    Thanks so much,
    Jeepgirl
  • tuggajbtuggajb Posts: 646
    do a google search for jeep code p0700

    trans trouble code
  • i have a 1996 jeep cherokee country and out of no where when i put it in drive in has little to no power but when i put it in first and shift it my self while driving in is just fine....i can even put it in drive after taking off and it drives fine until i stop and have to take off again. it makes no since to me for it to be a spur of the moment thing. what could this be????? can you please help
  • I have a 1993 with a 6 cyc and it does the same thing but not that bad. Mine only fails to go into first sometimes and I have to manually shift it and then the other gears work fine. It is as if the electrical signal did not make it to the solenoid to say go into first because if you do it mechanically it works. Not sure if it is the computer or not. Mine does it more when it has been run awhile. Short trips it works fine. I had the transmission serviced and it did not change a thing. Someone told me to check all the electrical ground connections since it could be as simple as a bad connector..? Have not had a chance to check.

    If you figure it out let us all know as I think there is something common about this
  • nnealnneal Posts: 72
    I have a 1998 Cherokee with an AW4 transmission that was doing the same thing. Bringing it in to a transmission repair shop AND a Jeep dealer resulted in both of them telling me I needed a rebuild. With nothing to lose, I pulled the pan off the bottom and checked the solenoids (3 of them) to see if they were within the right Ohms specs. One was out of range (doesn't take much) and it turned out to be what was causing the problem. That was in 2009 and I'm still driving with the same transmission today! According to the service manual, when you put the shifter in 1st, it manually (bypassing solenoids) places the transmission in first gear. Hope this helps.
  • tuggajbtuggajb Posts: 646
    what he says solenoids need to be looked at inside trans have to drop pan and filter the pack was sold on ebay for bout 100. bucks
  • That is also what I have heard is that to replace the solenoids is really pretty easy and way cheaper than a new tranny. Besides if that does not fix the problem then it is way too complicated for any home fixing. I will suggest this fix to the shop I go to and see what it costs. I would rather pay them than deal with all the fluid and junk to do it in my driveway.

    Thanks for the replys
  • First thing, check your transmission fluid....
  • Fluid is fine and new along with filter. Did not change a thing as the problem was there before the servicing.
  • darcysdarcys Posts: 5
    Well took JEEP to stealer, flushed tranny, new filter, new fluid, conditioner and works well. $395CA later, no more hesitation in shifting, good solid shifts.
  • tuggajbtuggajb Posts: 646
    glad to hear that trans is ok now

    lot cheaper than new or rebuilt trans
Sign In or Register to comment.