Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Transmission Problems

1404143454653

Comments

  • This is what the problem is that the trans shop or stealership wont tell ya.
    Nobody on these forums can figure it out because i had the very same problem and all they can say is rebuild. Bullcrap!
    What it is,is a pluged trans line and or radiator. On one of the lines between the radiator and the trans lines is a check valve that gets plugged. Which causes the radiator to also plug. It is a very easy fix with a air compressor. I changed every sensor and silinoids and still the same problem. The OD light would come on and about a couple of miles later the trans overtemp light would com on. The reason is the fluid isnt flowing through the radiator and it takes a while to overheat the trans.

    So undo the trans lines at the radiator and on the trans a
    nd aslo take that check valve off the line and see if that little ball bearing is stuck. blow air through the lines and through the radiator and also the check valve and you will find why your trans is throwing codes and overheating!!

    I spent alot of meaningless money to find this out. Hope this helps dont rebuild
    ,rethink!! Mark
  • I bet you burn out anther speed sensor because mine was doing that also.
    That sensor is burning out because the trans is getting to hot.
    from Mark
  • This is because when he replace the radiator he bypassed or took out the little check valve thats in the one of the two lines that goes to the the radiator, Im willing to bet because thats what that valve is for. Or its a bad check valve. Transmission shops will take that little valve out when they rebuild and upgrade your shift kit
    It is right up front and easy to get at . And causes alot of trouble as you can see on this forum. Mark
  • does anyone know if the new 8 speed transmission will be used for JGC and if so when? TIA
  • Ahhh, I never would have thought of that, I am going to look at this tonight if it does not chill down too much! Spent all of two hours getting a coolant sensor off and finding out it was not that either! Uggg, never another non-Jeep person again! Thanks for the info, I hope it is the valve, I am getting sick of this issue!
  • when im in idle and i go to take off my 93 jeep grand cherokee into first gear my jeep does a shake hard if i hit the gas to hard but if i back of the gas its fine does anyone know what this might be i'm thinking transmission but thats the only problems it does tranmission wise it shifts fine runs good picks up speed so i'm kinda losr
  • i have a 02 grand cherokee 2.7 crd. it will not come out of first gear, after a mile run when it happened the gearbox is to hot to touch, plus the park light is staying on.
  • Does anyone know specifically which of the hoses coming into the radiator house the tranny check valve on a 1999 4.7?
  • I have a 02 Jeep Grand Cherokee Laredo with 130k miles. There have been some issue the past couple months. The transmission seal leaked. Got the seal and the filters replaced. Then, the front crank shaft seal sprung a leak. Got that replaced too. Now, the transmission is not engaging while shifting into reverse or while in drive. For instance, when I am stopped at a light, in drive, light turns green to go, pushing the gas only causes the RPM's to raise. I have to let off the gas, put it back in park, back in drive and then the transmission engages. While stopped, the transmission acts as a manual, I roll back when letting off the brake, instead of creeping forwards.
    Any ides???
    Thank you!!
  • To add to the above...on my way home from work, I was stopped at a light when it turned green, I gave it gas to go and the transmission didn't engage. As I left off the gas and the RPM's got to about 1200, the transmission slammed into 1st. Check engine light came on with code P0700. With doing some researching online, it could be the transmission control module or the electronic shifter module. Any ideas?
    Headed to the dealer in the morning...I suppose.
    :confuse:
  • nnealnneal Posts: 72
    This is from the wjjeeps website on code P0700:

    "This code indicates that the EATX (Transmission controller) has an active fault and has illuminated the MIL via a BUS message. The specific fault must be acquired from the EATX via a DRBIII tool. (Input or Output Speed Sensor failures often cause this code and are a common failure part on WJ Grand Cherokees)."

    Mainly it means the transmission control module has sensed a bad part hence setting a trouble code. Normally the dealer would read the TCM to learn more about what codes it picked up.
  • Hi Everyone

    I have got a 95 Grand Cherokee Limited 5.2 awd. I am having trouble with my transmission releasing when i am coming to a stop. sometimes i have to kick it into neutral to get it to disengage. Then when i go from a stopped position it doesn't want automatically engage. I have to punch the gas to get it to move. The transmission will also sometime disengage when stopped. Any thoughts would be great Thank you
  • nnealnneal Posts: 72
    Once it's locked and you move it to 1st gear, does it release and take off? I had a similar problem on my 98 Cherokee. Apparently when coming to a stop it wouldn't release from second gear and felt like it was "froze up". In my case it turned out to be a bad solenoid valve in the tranny. Would be worth checking the speed sensors too. Beware of dealers or transmission shops as my experience with these resulted in being told I needed a rebuild. I'm still driving that non-rebuilt transmission today.
  • Hello!
    Thank you for the reply.
    The cause was the filter in the transmission. It was loose after being replaced at a different shop. The dealers did a transmission flush and replaced the filter and the seal. The first shop used a after market filter which didn't fit right.
  • jeepboy01jeepboy01 Posts: 2
    edited December 2011
    Hi all, I have a 96 grand cherokee with the 4.0l. The problem is when you take off it seems to launch in second and i was going probably 5 mph when i saw a car crawling up on me, i gunned it and it stayed in second. Can anyone help? I don't want to take the tranny apart to get to the shift selenoids if that isn't even the problem. Any suggestions would be appreciated.
  • i have 2000 GC which is same tranny and dif Trans Control module. I believe I'm having the same problem. stalls if i stop sharply. i think it's either the torque converter staying locked. Please post if you find out anything about this problem and I will do the same
  • The 2012 with the 3.6 liter V6 does the same thing! LOL I have test driven 3 different cars at 2 dealers and they all hung up in 1st gear and then after about 20 seconds, slid into second. This was under modest throttle pressure pulling away from a light with the salesman in the car. He said that was normal. What??? I kept my 2004 Grand Cherokee. I am not paying $30K for this performance.
  • I have a JGC 2004 Limited Edition and lately when i go down the highway and hit a bump or dip like when you go over a bridge my tranny slips for a couple seconds??? it seems to be getting worse, anyone have any ideas???
    thank you
  • I own a 2008 Grand Cherokee with the 3.7 litre engine. The vehicle has 32k and has been running fine up until a month ago. About once a week the transmission will not shift out of second gear upon a normal acceleration. It appears to happen more frequently when the first is "cold" rather than after driving a while. If you stop the vehicle and resume driving again the transmission will shifting normally. Can anyone help?
  • I have a 97 jeep grand cherokee that is doing the same thing, only mine does it from 1st to 2nd and 2nd to 3rd. No limp mode, no codes, no check engine light. Have driven it at interstate speeds with the problem. Did a filter change, and a tranny flush. Changed the vehicle speed sensor, also changed the $140 pressure sensor in the pan. Still same problem. No shift until 3500 out of first or second. After that it runs great. Doesn't matter if the vehicle is stone cold or after 100 miles of driving 75. I have no clue what it could be, the dealership looks at me like they are second graders doing astrophysics. I am at a loss, I guess my next step is to take it to a tranny shop. I am sick of messing with it.
Sign In or Register to comment.