Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Venture Engine Problems

11416181920

Comments

  • I have an overheating problem with my 2000 Venture also. I have replaced the water pump, thermostat, changed the radiator cap to a vented one in case it overheats again, flushed the system, and when that didn't work, I clean out the system and used blue devil for the head gaskets. The radiator is building tremendous back pressure that backs up into the reservoir when it gets really hot. If you look down into the radiator while it is running, you can see a little rust circulating in the new antifreeze, so I know there is sludge down in the system, how much? I don't know. At an idle, the radiator starts pumping water out where the radiator cap would be, but if you increase the RPMs the water sucks back down into the radiator and you can see the vents in the radiator circulating. The thermostat checks out fine, fans are fine, circulation flows through the water pump and out to the radiator so water jackets seem fine in the engine. Could it possibly be the catalytic converter clogged with the sludge? I'm at my wits end! :confuse: :sick:
  • AJGWHEELSAJGWHEELS Posts: 10
    you need to purchase a Special GASKET KIT design for VENTURE , its by VICTOR FLINTZ ( hope I got the name right) if it was never done , you need to replace the PLENUM GASKET & THE EXTERIOR GASKET & the rest of the kit parts that come along so you can have Piece of mind , If your good with tools then
    buy the HAYNES REPAIR MANUAL for this vehicle , it should take about 2 to 5 days to complete this project. AJ
  • james1967james1967 Posts: 1
    this issue sound similar to mine, i have 98 venture ..had a head gasket changed, after it was overheating, found hole in the gasket.. now the engine seems ok except there is air or pressure in the hoses.. the the needle stays low, except for idle.., i took it in and mechanic fiddled with the relay fuse and put another used one in, and the engine check light went out and the pressure was fine, until i took it on the road for a test..after i gave it some gas couple times..the engine light returned with a little power loss on the accelerator and pressure came back in the hose again and remains that way.

    this issue is kind of screwy,;mechanic said pump is working but he didn't test it and i changed a new thermostat before i got the head gasket changed (prior), ( used a stop leak product for the rad before i changed head gasket also) there's no leaking of fluids and nothing contaminating the oil, rad been flushed too.
    Only other thing i can think of is the AC light stop working short time ago and couple other electrical issues hasn't worked for a longer period.
    and when i accelerate putting more load on the engine..(like up hill) the check engine light flashes and power is reduced on the accelerator.
  • ace14uace14u Posts: 1
    Hey everyone,I have a 99 venture check engine light comes on so I check it and got the codes p0171 p0300
  • 442dude442dude Posts: 373
    edited July 2010
    Try this: replace your PCV valve and make sure that the hose is in good shape...

    I got the same 2 codes on ours and that was the fix...I can't guarantee it will fix yours but its worth a $5.00 try...my mechanic couldn't even figure it out, a friend suggested it and it worked...
  • fleastifffleastiff Posts: 51
    About how much would replacing a PCV valve and hose cost?
  • I know mini vans are not racers, but I'd like a little tighter ride in my Silhouette. Would the struts from a Montana be better, or are there any other suspension options?
  • 442dude442dude Posts: 373
    Talk to your local auto parts guy. He can check right in their catalog to see what fits and tell you which ones would be stiffer and would fit your van. There aren't a lot of options but there are likely a couple.
  • 442dude442dude Posts: 373
    You're under $ 20 for both at your local auto parts store
  • My venture is starting rough or taking 30 seconds or more to turn over. I pulled battery and it is fine. What can it be next?
  • have a loss of power/acceleration on steep hills but goes like hell on the level and/or downhill? what say somebody that knows chev venture 2003 mani80@netzero.net
  • I have a 2002 venture. If it idles it slowly goes to red, driving, after five minutes. When in red, heater blows barely warm. The radiator cap and top of engine just warm. In red the engine will preignite and stall. Once stalled it has to sit for fifteen minutes before it will start again. When this happens water vapor comes out of the air cleaner box and water droplets are on the surface of the maf screen.
    I have taken out the thermostat, vented the cooling system. I have taken it to a radiator shop, they are not sure. No exhaust gases in radiator. Where is the water vapor coming from. Could it be a bad manifold gasket? Thanks
  • With you vehicle running open the hood and check to see if both cooling fans are running. If not turn on your A/C and check again. There are 3 resistor switches inside the fuse block that drive the cooling fans. Turning on the A/C overrides the temp sensors
  • Thanks for the reply. The fans are working and sounds like the correct speed.
  • Iam the previous owner of the above problem,but. I found it. I pumped up the cooling system to fifteen pounds. Hissing came from the intake manifold near the throttle body. This is critical, since lower cooling system pressure the lower the boiling point, check it out. Anyway, will order the manifold gasket kit from GM.

    Tha
  • Hey everyone, im hoping i could get a little insight on a car im working on. I purchased the car and the seller told me it had started overheating and acting like the head gasket was starting to go bad but not blown, there was never any oil-coolant contamination, and he gave me the full gasket set for the engine with the car. I drove the car home, had to stop twice to add coolant because it was all pouring out the coolant overflow, and then tore the engine down. The head gaskets did not look that bad, the lower intake gaskets looked ok, and the upper intake gaskets looked like crap. I replaced all of them since i had them, also replaced the following, spark plugs (gapped .060), plug wires, thermostat, coolant resevoir lid, power steering pump, valve cover gaskets, pcv valve, throttle body gaskets, exhaust manifold gaskets and bolts, fuel injector o-rings, air filter, and oil/ oil filter. After i did all this i put the engine back together and started it up, it started right up but is not idling smooth and also is still spitting all the coolant back out the overflow. Ive flushed the system and burped it 3 times for 45 minutes each time and it still does it. I also ran a compression test and got 130psi from 5 cylinders and 120psi on the #5 cylinder those numbers sound low but im not sure what they are supposed to read. Also the small vacuum tube connected to the pcv valve is collapsing when the engine is idling and the engine seems like its stalling out. Ive had suggestions that the heads where warped and now i need to redo the head gaskets, the heater core is bad, something is wrong in the vacuum system, and the water pump is bad. So with all this info can anyone tell me what it sounds like im hoping i dont need to redo the head gaskets but that looks like where its heading. Thank you to anyone that helps.
  • Hey everyone, im hoping i could get a little insight on a car im working on. I purchased the car and the seller told me it had started overheating and acting like the head gasket was starting to go bad but not blown, there was never any oil-coolant contamination, and he gave me the full gasket set for the engine with the car. I drove the car home, had to stop twice to add coolant because it was all pouring out the coolant overflow, and then tore the engine down. The head gaskets did not look that bad, the lower intake gaskets looked ok, and the upper intake gaskets looked like crap. I replaced all of them since i had them, also replaced the following, spark plugs (gapped .060), plug wires, thermostat, coolant resevoir lid, power steering pump, valve cover gaskets, pcv valve, throttle body gaskets, exhaust manifold gaskets and bolts, fuel injector o-rings, air filter, and oil/ oil filter. After i did all this i put the engine back together and started it up, it started right up but is not idling smooth and also is still spitting all the coolant back out the overflow. Ive flushed the system and burped it 3 times for 45 minutes each time and it still does it. I also ran a compression test and got 130psi from 5 cylinders and 120psi on the #5 cylinder those numbers sound low but im not sure what they are supposed to read. Also the small vacuum tube connected to the pcv valve is collapsing when the engine is idling and the engine seems like its stalling out. Ive had suggestions that the heads where warped and now i need to redo the head gaskets, the heater core is bad, something is wrong in the vacuum system, and the water pump is bad. So with all this info can anyone tell me what it sounds like im hoping i dont need to redo the head gaskets but that looks like where its heading. Thank you to anyone that helps.
  • I have replaced the thermostat on my 1998 Chevy Venture and filled the coolant resevor; however, the car still is overheating. I have checked for leaks and have found none. Any suggestions on what could be the problem? The thermostat does not seem to be opening up at all.
  • 98 Chevy Venture overheated replaced thermo,hoses,& rad. cap.. Still don't seem right heater blows cool then hot then cool again what the problem? :(
  • russ23russ23 Posts: 25
    Had all that on my engine. I am presuming you did not install thermostat upside down and that it ran hot even without the thermostat. Consensus of IATN (major mechanics website) is blown headgasket. You check that with block tester abt $50 at NAPA. Install in radiator cap opening and check for change of fluid color. You might be able to fix it with just the intake gasket set, but that is a gamble. A word on anti-freeze. I do not like the DEXCOOL GM uses. Turns to mud and clogs everything up and there is no good cleaner to clean it out. If you know one let me know. Also possible the radiator is clogged up with DEXCOOL mud. No way to clean it out, have to replace.
Sign In or Register to comment.