Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mercedes-Benz C240 4matic

2»

Comments

  • Folks,
    I am considering buying a 2004 MB C240 4Matic with 43,000 miles on it.

    What, if any, negative experiences have people had with this model?

    What is the most frequent repair issue that has come up with this car?

    All responses appreciated!

    Thanks.
  • dear friend buy a bmw there much stronger and could be beat to hell and still purrrrr
  • speddy1speddy1 Posts: 5
    I own a 2004 C240 4matic . When i hit panic on my key the lights blink on and off but no alarm.I was told by a friend the siren may be bad.Hes not sure.Any ideas?
  • tony103tony103 Posts: 4
    maintenance and appearance contact me ...
  • tony103tony103 Posts: 4
    speedy it may be your key itself try using your spare remote if not try new batteries
  • tony103tony103 Posts: 4
    if that does not work let me know
  • patpat Posts: 10,421
    Hi there.

    Why don't we just talk here on the boards? :)
  • speddy1speddy1 Posts: 5
    I just joined the board yesterday.I dont really care to chat on this board.I'd like someone to answere my question though.Doesnt seem like too many people have been on lately.
  • patpat Posts: 10,421
    Hi speddy, I was actually addressing my post to tony103. And he did post a thought for you, did you see this post? tony103, "Mercedes-Benz C240 4matic" #26, 3 Mar 2009 11:03 pm
  • speddy1speddy1 Posts: 5
    Hey thanks for the reply tony.Sorry for not getting back sooner. Its not the key or batteries.Still wondering what it may be. Also is there a way to adust the sensors for the lights?The lights dont automatically go on like they used to when it gets a little dark or cloudy.
  • kathygioiakathygioia Posts: 1
    Hi, just wodering if you ever found out what was wrong with the car. I just recently purchased a 2005 c240 from a relative, in what I thought was in like new condition (with only 14,500 miles). All was fine for about a month and then a fter about a week and a half of constant rain ithe back seat, driver's side is soaking wet. Not only the bottom part of theseat but all the way up the back and into the ceiling header. Mercedes Benz has had the car for 5 days and can't figure out what is going on! Help!! :mad:
  • speddy1speddy1 Posts: 5
    I have 53,000 miles on my c240.No i havnt figured out whats wrong with it yet.Its like pulling teeth trying to get an answere here,lol.My car doesnt have any serious problems other than the panic alarm.It sounds like your rear winshield or the driver rear window arent sealed properly.Let me know if they ever figure out what it is.
  • Hello all !
    New here...figured it would be an intelligent place...
    Wife looking to buy a used (2004) AWD Sedan. Each has about 68,000 miles on it.
    Prices are apparent differences, will deal with that later.

    Looking at:

    Mercedes c-240
    AUDI A4 1.8 Quattro
    Infinity G35x
    BMW 325xi


    Not looking for a 'race car'. Standard wife car; comfortable; good in snow. She likes these styles, so the Subarus are not a consideration.

    Looking for opinions on each.
    Maybe a quick summary that you may have on each.
    Seeing that it is an Mercedes forum - please feel free to let me know why I should get her the Mercedes rather than the others.

    I look forward to all your help.
    Please be as lively and opinionated as you'd like to be !

    Thank you !!!

    Tooky

    (Will post in the other forums also)
  • kelfkelf Posts: 83
    How much does it cost usually where you service your C240 car for B service?
  • Eventually bought a 2006 AUDI A4 Quattro.
    Very happy with it !
    Sorry I wasn't much help to you...
    .....but continue to have a great weekend !!!
  • I have a 2002 CL. I bought it used with 17,000 miles. It currently has 54,000 miles.

    The transmission fluid is cooled by the radiator. This past Monday (10/18/10) the transmission burnt out. The Mecedez dealer stated I need a new radiator, transmission and gear box, ($7,100.00). I'm looking to see if there has been any class action lawsuits filed for this design error.

    I've been on line and have discovered the standard radiator "Valeo" will break down and allow glycol to mix with the transmission fluid.

    I believe Mercedez should be liable for the correct repair for this car.

    Mike
  • I have read numerous accounts concerning the faulty Valeo radiator that seeps an insidious contaminant, glycol, into the transmission of the 2002-2003 built C class. My 2003 C240 has had numerous problems with this. At 44,000 miles MB put in a new transmission but did not replace the radiator!! Fortunately it was under the extended warranty at the time.
    Now 30,000 miles later at 78,000 miles I had a glycol test performed and I had "LOTS" of glycol in my transmission. Unfortunately now my car is out of warranty!!
    MB dealership finally changed the radiator, torque converter and flushed the system..and the service advisor said "I would fix it and sell it"!!
    I was hoping to drive this car for another 10 years..it is in excellent shape!! However there is no guarantee that other parts of my tranny will give out!
    I've seen many posts concerning this issue and to my knowledge no class action suit has been pursued! If anyone has any information to the contrary, please let me know. I feel a class action suit should be filed because us consumers are getting a very raw deal!!
  • Hi all,

    How can you know the used cars have been reduced odometer? :confuse:
  • Kirstie@EdmundsKirstie@Edmunds Posts: 10,676
    I think you're more likely to get a response in our Odometer rolled back discussion. Just click on my link to post your question there.

    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.

  • Hey everyone I just purchased a 2004 C240 4matic with 101,000 miles on it and it drives great but im already having some issues with it..... I keep getting 3 malfunctions lights on the dash saying that the rear right taillight is on and the right side reverse light is on and the last one is to check the right side brake light now i checked all the bulbs and one was blown out but after replacing it it still doesnt go on so im thinking maybe a short and all the other bulbs work great but i still have the warnings can anyone give me some advice on what it could be
2»
Sign In or Register to comment.