Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Navigator Electrical Problems

245

Comments

  • For the last 3 weeks, my 98 Navigator will sometimes not start. The starter will turn but the motor won't fire. I brought it to both the dealer and a good mechanic, and of course, it started for them. They found no problems with it. I went out this morning after trying to start it again after work yesterday and now the back end is squatting down. It seems like the car is just about to roll over and play dead. I've checked all the fuses and battery and all is good. Any suggestions?

    Thanks, Mark
  • I have a 2004 Navigator and since New Years Day I have had to be towed to the dealership 4 times and they can't seem to find the problem. Something in the electrical is completely draining the battery if it sits for 24 hours or more. They have replaced the battery and several sensors, cleaned conections on the running boards, door mirrors. They have hooked up to the computer which says nothing wrong. When I get a boost as soon as they hook up the cables it starts usually if its drained it should take a few minutes of being hooked up before there is power but not with mine there is power instantly which tells me its not draining the battery but its gotta be something electrical. Does anyone have any ideas cause Ford Lincoln can't figure it out. :confuse:
  • I am unable to find the fuse for the dash lights on this vehicle. I can locate the fuse box, just don't have the location of the fuse for the dashboard lights. Any help would be appreciated. never got a manual with the used vehicle.

    Thanks
  • I was having the same problem with my 04 Navigator. I came back from a trip and had to get a boost from the airport parking lot. Took it to the dealer and they said it was the alternator, but it wasn't. Changed the battery, but it still drained the day after. I had to take it to a shop to get diagnostics and a load test and it was a ground wire from the negative terminal of the battery that was causing all the problems. Does your panel lights come on on their own? This was the first thing i noticed when I came out my house to check on the car. All of the lights in the car and the side mirrors were on but the alarm was still on.
  • MY FRIEND GAVE SOMEONE A BOOST BUT PUT THE CABLE BACK WARDS AND NOW THE TRUCK HAS NOT STARTED SINCE. THAT WAS ABOUT 3 WEEKS AGO. IS THIS TRUCK FRIED?

    image
  • cfbtxcfbtx Posts: 3
    #1-I was warming up my Navigator Friday morning to go to work and my rear sensors went off but the truck was still in park. So I got off to see if anything was behind me but nothing. #2- Sometimes when I open the rear side windows only one opens, so I close it and push it again and then they both open.#3- The rear passenger door only locks/unlocks sometimes.
    In the 3 years I've had it I think it was way over priced and not worth it because they have too many problems but from the looks of things I guess I'm not the only one that has to put up with these headaches. :confuse:
    Good Luck
  • I own a 2001 Navigator with factory Alpine radio system and having recently returned from Iraq, i noticed that i had no bass from the woofer.
    How do i go about troubleshooting this?

    thanx in advance!
  • the last few days the light that indicated that the 4x4 is on start to flash the the off light on the overdrive switch starts to flash too.what may be causig this?
    please HELP!!!!
  • ok i got this car in OCT of 2008 and everything was fine until the starter went out and once that was fixed the car was running smooth with no problems.....but the last two weeks have been horrible the car wont start after being at the dealership ( bout to go MOnday for the third time in one week) they get it to start then as soon as i get home the car wont start......HELP ME I REALLY NEED ADVICE im spending so much money on this what could be the problem?
  • jwallyjwally Posts: 71
    "tired of this overpriced piece of junk"
    I feel the same,I WILL NEVER BUY A POS FORD/LINCOLN AGAIN!
    My 01 has the same problem from water getting in dash from possible windshield,roof weatherstripping or roof rack, water flows in drivers pillar handle. damaged my GEM modular costing hundreds last year and having same problem now again. SOME ONE SHOULD GET A CLASSACTION SUIT AGAINST FORD WITH SO MANY ON HERE WITH SAME PROBLEM.
    i don't exactly know where waters coming in but have seen drips on handle and under dash.
  • jwallyjwally Posts: 71
    "Lincoln to get it fixed, but now they say it is not due to the design of the car and Lincoln has no responsibility. "

    How can so many people on here have the same problems and not be their responsibility? I have an 2001 with 70,000 miles and nothing but probelms
  • i have a 2000 nav with the same problems you have and mine is leaking water fronm top can't find where from but is going directly to the braim box behind the sterring wheel i'm mad and don;t know what to do
  • I just started having the identical issue with my '03 truck. Blew fuse #3 which controls power seats, mirrors, and memory seat settings. Changed the fuse many times. I then took the mirror switch out and changed the fuse. This provided me power to me electric seats and my memory presets were restored. I thought I needed to replace the mirror switch, but after $100.00 that was not the problem. Please let me know if you solved your problem, and what you did o get it fixed.
  • cfbtxcfbtx Posts: 3
    My navigator still has the same problems. I took it to the dealer and the excuse they came up with was that the computer might have gotten wet, which is a bunch of BS..... So they said they would recommend me to get a new computer. So I just gave up and tried to trade it in for a Escalade but the Cadillac dealer wouldn't take my navigator so I'm stuck with it.:(
  • 2003 was obviously the worst year of all since it was the year they updated the older style. Searching a bit, you'll find this model year was notorious for the windshield leak defect which caused numerous electrical headaches. Particularly since the GEM module was at the core of many random electrical mishaps. This module is "i believe" located behind the fuse panel. A few corroded inners and sudenly your elctrical system parties in the middle of the night while the truck is off.

    There are many defects in the TSB's and being such an expensive purchase only adds to the headache.
  • MY 2006 navigator a/c quit 2 weeks ago. I checked all fuses listed in manual and all are good. Is there something I may have missed, like a relay box under the hood or something....
    Besides that, best SUV i've ever owned.......
  • jv_ictjv_ict Posts: 2
    HELP!!!!!!! We have a 2005 Lincoln Navigator and have run up against an issue that the dealership is even having trouble with. Our Navigator will begin unlocking itself repeatedly and will not stop for long durations of time. (20 + minutes). This is happening frequently enough it has now broke one of our door locks. The dealership replaced a security module about 1.5 months ago the problem ceased until recently. It is sporatic and we haven't been able to pin down what is causing it or get it to keep doing it long enough for the dealership to determine what is causing it. The dealership has ran through everything and they can't figure it out. They are supposed to send Lincoln technical suppport down to look at it but none of the dealerships in this area have ran up against this. We tried using the remote to lock and unlock it, opening and closing doors, and starting and stopping the engine. It will start unlocking itself day or night to the point it has ran our battery down several times. The crux of this problem is it has happened every where except for repeating itself long enough at the dealership so they can figure it out. HAS any one came accross this?
  • livemoorelivemoore Posts: 1
    Ugh! We're having the same problem. It's already run down our battery once. Did you ever get it fixed?

    Thanks!
  • jv_ictjv_ict Posts: 2
    Yes we got it fixed,

    after the dealer ship replaced the security module, we were fine for over two months...then the problem fired up again. It would happen, then not happen, it would happend for 45 minutes, then not happen, then for 5 minutes, and so on with no pattern whatso ever. We figured out that after leaving it with dealership a few days (and the navigator was in the shop right next to someone the whole time)...it finally acted up in front of them. They figured out we had a defective remote...that was unlocking the hell out of it. It even broke one of our back lock cylinders. My suggestion to you if this sounds like something you are experiencing, would be throw all your remotes away and start fresh. They are about $50 a pop and its not terribly hard to reprogram the navigator. This frustrated the hell out of us because we couldn't figure out and neither did the dealership until they hung out with car for a few days. If you need more feedback, please post another message.
  • ratedr1ratedr1 Posts: 2
    I purchased a 2001 Navigator in 2003 and have had nothing but problems, 1 thing after another , worst vehicle i have ever owned, as well as the most expensive, most of the parts are made out of cheap plastic and 2x the price. The rubber on the parts is the lowest quality they could possibly use. In the Last 2 months I have had to spend $550 to fix a problem with the air ride suspension , $280 fuel sensor, $720 fuel pump, and today the stereo completely died and all the fuses are still good, DO NOT BUY A NAVIGATOR!!!! i am going to put signs on my vehicle and every saturday park it outside a different Lincoln dealership warning potential buyers to stay clear and save there money and sanity , anyone interested in starting a P/O Navigator Owners group email me at rrmontani@hotmail.com . I spent 4.5 yrs making $600 a month payments to find out i would get less then $5000 on a trade...IF YOU ARE THINKING ABOUT BUYING A NAVIGATOR YOU WOULD BE BETTER OFF SPENDING YOUR MONEY ON CRACK!!!! It has caused me nothing but stress in my life, save yourself the agony and buy GM
  • tdawg14tdawg14 Posts: 1
    i got a 06 lincoln nava. with rear lift gate problem at first it would open on it own now it wont open at all. i have change da remote batt. reset the main batt. and nothing seems to work also checked all the fuses and relays nothing shows a short tested motor seem to be workin great rear door latch will not close tight as well everything else on the rear door works lights and all :mad:
  • rb62rb62 Posts: 2
    I have a 01 nav and the check susp light comes on every so often the ride seemes bouncy and there is a clicking sound comming from under the rear of the vehicle and the door ajar light comes on at times and know the radio lights flicker but radio plays fine, ????????
  • jueneorejueneore Posts: 4
    :confuse: my driver seat isn't working!!! like the other guy posted, im tall my wife is short! there is nothing under the seat and the fuse keeps blowing out!! what can i do???? o, i have a 2004 navigator
  • navdadnavdad Posts: 1
    I'm wiring up a Pioneer DVD/Navi head unit in my '04 Navigator and am trying to add a license plate mounted back-up camera. I ran a wire back to the rear hatch and tried to pull power off of the reverse light, but it kept blowing the fuse when I would put it in reverse. I double checked for a short, and could only determine that the wire I used was to light and the resistence was blowing the 10A fuse. (???) Has anyone wired up a back-up cam...any ideas on what is blowing the fuse or a different power source I could use?
  • ed1969ed1969 Posts: 1
    i have a fully loaded 2003 navigator and just started getting an error message when i start the vehicle stateing " prndl error, no park assist". Any one encounter this problem and if so, what needs to be done to fix it? Any help would be great.
  • I have the same problem do you found out what fix that problem yet.
    Let me know thanks.
  • Before i bring my truck in to have this prob. looked at, i figured i'd try here. Out of nowhere, my driver seat stopped working. It won't move in any direction, or inflate the lumbar system. When i try any button, there seems to be a slight click coming from the front motor under the seat. Any ideas? Fuse, computer brain??? Would 1 problem cause all of the features to stop working?

    Thanks
    *oh, also, hitting the preset buttons dont make the seat move n any directions....THANKS
  • I found out that my problem was that when I put the seat all the way down, it would pop the fuse, I must gone through 20 fuses and as I'm sure you know, those are not regular fuses. I just don't go that low anymore, and problem solved! I know that there is something wrong with the seat, but right now I cannot afford to pay hundreds of dollars @ the dealership.
  • It's the fuses, I had the same problem. Alot of the acc. go out too, like the power pedals... I unplugged the computer under the driver seat then I replaced the fuse, plugged it back and it worked,... U still have to get ur seat checked because it'll pop again..
  • Battery is constantly dying. Then the clicking relay sound in passenger compartment. Then the door lock/unlock phenomenon. The driver side door switch (for interior lighting) seems to set it all off (at least the door unlock/lock part). Where is the door switch? Additionally, are there ground wire issues to be made aware of? Navigator is garaged and rarely in the rain.
Sign In or Register to comment.