Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Navigator Electrical Problems

123468

Comments

  • How do I check to see if compressor is froze? I was thinking it may be a relay as well. Went to auto part store to try and buy some. When I got there I noticed smoke from engine compartment. Passenger side behind the battery but can't see exactly where.
  • polo4polo4 Posts: 7
    edited September 2010
    OK I have had an issue and it is getting worse. The relay that controls, what I know so far, power running boards, possibly ignition or starter, as it does not start when this relay is stuck. The relay just buzzes until I wiggle it. Wiggling has always fixed in past, but now..

    I noticed the center prong is turning black and the relay is getting hot to touch. Relay is only hot while car is in use not overnight when battery is being drained

    Now I have something draining the battery overnight.

    My heating and cooling on driver's seat does not work (just in case this helps)

    My sunroof seems to leak during heavy rain falls and is staining my pillars between windshield and front doors (both sides) Could this be getting to fuse panel? I did not see water during a rain.

    I figure I have a short somewhere, where is the best place to start? Is there a manual that shows me what other items relate to this relay or does any know?
  • hi, i have an 03 navi and ive had electrical problems for awhile like the cursed head unit. i got tired of going to the dealership and them sayin that there is nothing wrong with it so i went out and bought a 7 inch flip screen and since then have not had any problems with the head unit. but ive have sum electrical stuff stop working and work only sumtimes and ive been reading that alot of people got a fuse box and it has solved all their problems.. i have one question though ive read that alot of people got their fuse boxes from junkyard. has anyone gotten a new fuse box from the dealership and have the problem fixed or do u need to get the older fuse boxes or can i just get any new 1 and it will work ? please help me ive been trying to figure this out because i have a nice aftermarket stereo system nothing stock all new aftermarket seakers and subs and 3 amps pushin 2650 watt and i dont want this electrical problem to mess al my stuff up please help me out with some information thanks
  • jwf4jwf4 Posts: 5
    I have a 2001 Navigator. I've gone through three batteries in the past month. Something is draining the battery, but the dealership can't determine what it is. After I jump start it, the car runs fine for a few days, then won't start due to a dead battery, usually after sitting overnight or all day. Doesn't seem to be related to rain or moisture. This has been going on since May '10, at first about once a month, more recently a couple times a week. Dealer tried disconnecting external entry keypad, without success. Test meter shows only .01A draw, but obviously it's not catching the problem. Any suggestions would be appreciated.
  • samgabsamgab Posts: 1
    I have a 2008 Lincoln Navigator. I bought the car new 20 months ago and I have had 4 new batteries. Something is draining the battery but the dealership can not find anything wrong with it. They have completed 5 diagnostic tests and tell me everything is just fine. They say the alternator has been checked but there has to be something wrong if my battery keeps being drained within months. It's causing major corrosion around the battery area as well. Any suggestions would be appreciated.
  • ben68ben68 Posts: 3
    Hi, don't know if it will help but here goes. I had a 2001 with the same problem. Dealer could not figure it out and told me to take the Nav home, they did not want to deal with it...go Ford! Called Ford Corporate- they all of a sudden could not speak english:)

    Dove in and with the help of a windsheild guy I know, found a tiny leak in the left side of the windshield. The control module is convienently located under a channel the water follows once inside and then the control mod or GEM I believe they call it, was shorted out until it dried. It would turn the car on without the key in it at night and drain the baterry. So if this is the case with the 08 it might be the cause.
    Hope this helps :shades:
  • jwf4jwf4 Posts: 5
    Thanks for sharing your experience. I will have the dealer look into this the next time I stop by for a new battery. My battery often dies overnight when parked in my garage, so moisture isn't a problem, but there could be some residual damage that is causing it. I appreciate your help.
  • jwf4jwf4 Posts: 5
    It sounds like we're having the same problem. The dealer had my car in the shop for a full week and couldn't get it to malfunction, and they tell me that unless they can actually observe the battery drain, they can't locate the cause. You might want to look into the "Lemon Law" in your state. These laws vary somewhat from state to state, but typically they say that if your car is still under warranty and you take it to the dealer a specified number of times (usually 4) or they have it in the shop a specified number of days for the same problem and they can't fix it, they have to give you a new car or a refund. Of course, the dealer won't tell you about this, so you have to be proactive and demand your rights under the law. But it sounds like you might qualify. Unfortunately, my car is too old and the warranty period has long passed. In the meantime, I'd suggest you go to Sears and buy a booster battery for about $70. I carry mine with me all the time so that I don't get stranded. You plug it in at night in your garage after each use, and put it in the back of the car. It's not a permanent solution, but it might help.
  • Last Thursday 2007 Lincoln Navigator would not start, dead battery, I jump started the vehicle and it started and ran fine. Later in the day I noticed the power tailgate would not operate properly, then the running boards ceased to function when the drivers door was opened and closed, the running board worked OK when the driver side rear door was opened and closed. The radio would not turn off when turning off the ignition and exiting the vehicle. Can anyone help to identify the problem or do I have to take the vehicle to the dealer.
  • jwf4jwf4 Posts: 5
    It sounds like you have a similar problem. I'm on my fourth battery and the dealer has not been able to find the cause. They tell me they need to hook the battery up to a test device and observe an actual drain on the battery. Then they will unplug one component at a time until the drain disappears. So far, they haven't been able to observe a drain. It happens only a few times a month, on average, so that's not surprising. Apparently there are electronic modules that regulate the various components of the car that can malfunction, turning things on when the car is turned off. But wouldn't you think they could test those independently, without having to wait until one caused the battery to go dead?
  • The windshield leaks after a while...have it resealed and you should be fine. happened to my expedition and my navigator!!
  • It's your windshield!!! The seals go bad after a while and water leaks down the A-arm and onto your fuse box and makes it do weird things!!

    happened to my navi and my expedition!!
  • I am wondering if you found out why this happens. I have a 2000 navigator and mine just started doing the same thing.
    Help?
  • jwf4jwf4 Posts: 5
    No, I haven't been able to find out what causes this problem. The dealer's service department tried several tests, but they claim the problem must occur while they have the test meter hooked up, and they haven't been able to make it happen. It doesn't appear to be the windshield, at least not on my vehicle, as the problem isn't related to weather. Most of the time it has happened when sitting in the garage overnight. My solution has been to buy a jumper battery at Sears for about $70 and keep it in the back. When it won't start, I jump it, then recharge the jumper battery overnight. Not a perfect solution, but it keeps me from getting stranded.
  • I was wondering if you ever got this fixed? I am having a simular situation. I have a 03 navi and one morning i went out and battery was dead so I was like ok I guess i left something on but then it kept happing and happing after I charged it. The auto shop can't figure it out please let me know if anyone has a answer so i can take it to the auto shop. Thanks in advance.
  • Have you checked all the door seals. Had the same problem and had door jams checked to make sure they were closing properly back seat wasn't which drained the battery just a thought now i just put liquid silicone on door lockmake sure it connects smoothly every time haven't had a problem
  • berginbergin Posts: 2
    I have a 2006 Lincoln Navigator which has run well up until yesterday when the battery went completely dead. Called out the breakdown people who diagnosed a 9amp drain on the battery every 3 seconds and thats with everything turned off and doors shut etc. Does anyone have any suggestions as to what might cause such a big drain? Many thanks
  • have a 99 navi...i had a same problem back in may 2010...had the alternator replaced and havent had any battery draining problem since...but have had many electrical problems due to old windshield seal and water leaking into fuse box...running board lights and all interior lights were not working...radio would not work windows would not work...i couldnt shift out of park air conditioner would go without key in ignition...starter just went out last week on sunday because it rained again and caused the car to try to start by itself which in turn burned out the starter...had to wait until the rain stopped and replaced it...i used an air compressor to blow out any water collected in fuse box and everything went back to working properly ...i resealed the windshield myself hopefully it passes mother natures test...
  • berginbergin Posts: 2
    Thanks for the response. Usually theres a quite distintive sound from the engine when the alternator is not working properly, is that what made you replace it?
    Have to say the car seems to have a mind of its own at the moment, tried to turn it on the other day and the battery was flat but the back tailgate opened..!!
  • jrclipjrclip Posts: 1
    edited April 2011
    I have a couple of strange issues, 2003 NAV

    First : My door lock switches do not work if I push either one up or down by itself, but if I push the driver side up and the passinger side down (or vice verse) at the same time, then it works (need two people to do that)

    Second: my instrument panel light take about 20 minutes to come on.

    Third: I have a wet driver side carpet after it rains and I don't see a leek

    HELP PLEASE
Sign In or Register to comment.