Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Ram Radiator and Cooling

124

Comments

  • Just replaced the water pump and noticed a leak from one the bolts just under the water port inlet. Pulled the pump off and I seem to have water in the bolt hole. Concerned I might have punch through to the water jacket. Same pump and same bolt??? any suggestions??? If I am right how is this repaired?
  • have had my Dodge for some time, during the winter when i turn on the heat, get this steam looking and radiator smell coming out of the vents, also fogs the wind shield up even after truck runs for awhile, doesn`t seem to go away, checked fluid and a/c ran low on refrigerant this summer. Any info ?
  • KCRam@EdmundsKCRam@Edmunds Mt. Arlington NJPosts: 3,496
    The radiator smell in the vents is usually a sign of a bad heater core. The window fogging is a result of low AC refrigerant - the evaporator runs during defrosting to remove moisture in the air... if there's no/low refrigerant, the evap won't cycle properly and the humidity collects on the windows.

    kcram - Pickups/Wagons Host

    KCRam - Pickups/Wagons/Vans+Minivans Moderator

  • did you ever find out what was the cause of the overheating issue. I have the exact same problem with my 05 ram same motor. I replaced my thermostat trying to fix it but then I read this post. I was told the radiator was the probable cause by my dealer as well. thanks

    Sam
  • bigdog18bigdog18 Posts: 3
    actually, i haven`t had a problem with it since i flushed the system, only prob i have now is no a/c and the 4 wheel drive wont engage or dis-engage when when i try to shift out, something screwed. sorry i couldn`t help ya
  • rogeliolrogeliol Posts: 1
    Thats your heater core. its broken and leaking
  • bigdog18bigdog18 Posts: 3
    mine not broke nor leaking and don`t have over-heating problem. My problem is A/C and Transfer case.
  • saferebelsaferebel Posts: 1
    I have a 1999 Dodge Ram 2500 4x4 with a 5.9L Cummins turbo diesel engine (174,000 Mi.). When I run the a/c and am driving 55 mph or faster, it runs fine. If I run the a/c and get into trafic or even at a red light, it overheats. If I pull my trailer (33' 5th wheel), it overheats. I have changed the fan clutch, thermostat, water pump, serpantine belt and have had the radiator flushed twice. It still overheats. Any ideas?
  • djkansasdjkansas Posts: 1
    edited August 2010
    My truck is overheating badly... I have replaced the following... Thermostat, water pump twice.... Also have had whole cooling system flushed by a pro mechanic shop... There are no leaks... and nothing is plugged up... Only thing left to do is replace radiator...

    Its looking like the fan may be on backwards, for I did buy the truck used... thinking maybe someone did some repairs and installed fan backwards, but not sure...

    Any idea's on what could be the problem is appreciated...
  • my 02 ram had the same problem pretty much did what you did ended up being a plugged radiator found this out after i brought it to a radiator shop could also be a cracked head gasket or air in the system good luck
  • tallpaintingtallpainting Posts: 1
    edited August 2010
    I have a 2003 Dodge Ram 1500 pick-up 3.7 engine. I am at the point of nausea to this point I have replaced the top radiator hose (The beginning of the over heating) thought it was just a worn hose so I replaced the hose, and thermostat since I was replacing thermostat I thought go ahead flush the system and replenish with fresh coolant. Did all this work in my garage on a Sunday drove to the neighborhood store and back to garage total of about 3 miles. Monday morning on my way in to work i noticed my temp was running high about 3/4 to hot "Oh no!" :cry: Just as I arrived at work it over heated. Since this time I've replaced (in order) water pump, 2ND thermostat, clutch fan, condenser fan-relay and after each replacement continued to over heat thus the reason for each replacement .. :confuse: At this point I am out of clues what could possibly be wrong now I am assuming the radiator is the only thing remaining in the cooling system what else could it be. I don't have any symptoms of a cracked head gasket although I have not had it confirmed or denied just no obvious signs that would lead me to believe otherwise. I am really concerned I have 138xxx miles on this typically well maintained truck i. e. routine oil changes, tire rotation etc,ect, ect. If anyone has any feedback or experience with this problem plus help , and second what if at all possible detection is there for determining a bad radiator before I replace it. I am of the understanding that this particular radiator is both aluminum and plastic is there a way to repair it or is replacement the best option
  • i have a 03 dodge ram with about 120xxx miles on it had same problem mine was the radiator brought mine to a radiator shop he tested it and also showed me that the bottom half of the radiator was pluged once the truck is hot feel the radiator in different spots if it feels cool replace it or take it to a shop and have it tested good luck
  • Replace your fan clutch! It sounds like you have an intermittent issue with it locking up. It should slip when cool and start becoming louder as the radiator temp heats up (moving more air). I recommend allowing a minute or 2 at least when you first start the truck in the morning before blasting off. They aren't designed to go from zero to 5000 RPM cold iron in an instant. My Durango Hemi will "zoom" for a minute or so when first fired up, but calms down and works flawlessly the rest of the time. My 4.& L Ram only "zooms" when hot under a load.
  • have a 05 dodge 1500 v6 4.7L that overheated out of the blue the other day pulled over added 1 gallon of water got it home hasnt overheated since but have to constantly add coolant after short or long drive...never any puddles on the ground no splashing on underside of engine or frame rails...any help be appretiated thx
  • hamp1hamp1 Posts: 1
    i have 2002 dodge ram 1500 5.9L V8. I have replaced the waterpump and thought it had leaked again. As i was about to change it. I noticed it wasnt leaking. The leak is coming from behind the waterpump. If your looking straight at the waterpump its on the top left. Its leaking bad and is getting worse. I'm put a gallon of water in it everytime i start it. Can somebody anybody PLEASE HELP ME. Its the only vehicle i have.
  • janap1janap1 Posts: 6
    edited November 2011
    My boyfriends 2002 Dodge Ram 1500 V6, with 74,000 miles radiator coolant leaked into the engine oil and siezed up the motor. This is after a 68,000 mile fuel injection service at the dealership. The dealership wanted $8,500 to replace the motor. He was on the spot so had to buy another truck, a 2011 Dodge Ram 1500 V6. The tire sensor light keeps coming on from the spare tire even after refilling.
    My Dodge Durango Hemi 2005, had been in the shop at the same time with a problem lunging and sputtering. After 6 trips to the dealer and over $1,600, I still had the same problem. Took it to a transmission place, had the transmission oil changed and no longer have the problem.
    I would suggest to everyone to not take their cars to the Dodge dealerships, apparently they have no clue how to work on their own vehicles. Or maybe it is so you will have to buy a new one every 60,000-80,000 miles.
  • I've replaced my water pump a few months ago (in the shop) and last week i replaced my radiator by myself. the reason i replaced my radiator was because of a huge crack along the plastic-to-metal end of the radiator. It was spewing coolant all over the place. A few days after replacing this, the heater doesn't work at all and whenever I am coming up on a red light or any stop and put my truck in neutral to coast, the truck dies. Also, whenever I got home tonight, the truck began spewing again. I pop the hood to get a look and there is a huge crack in the same exact spot as the replaced radiator. It seems that the problem that caused the radiator to break last time caused it to this time. Any information at all about this problem would be fantastic. Thank you. If you would like a video of the "leak" in the radiator, e-mail me at hookscrue2009@aol.com and I'll send you it.
  • my ram 1500 with 212k miles started losing water. replaced pump, thermostat and fluid. oil begining to foam in fill cap. is this an inherent problem with this motor? my 86 ram 360 with 384k has no problems. could this be heads? putting in around half gallon of antifreeze every three hundred miles. help
  • Hey guys is my radiator supposed to be hot on both sides? B/C one side is hot after running and other is cold. Didn't know if that meant the radiator needs to be replaced. Also the truck makes a bucking motion when driving after heated up and when I stop and pop hood open my overflow reservoir is bubbling like its boiling!! Ive replaced water pump, thermostat, and even took it to local radiator shop and had it flushed.... Temp gague is between 1/2 and 3/4 so its not over heating?? Does anyone have any idea on what it might be??? Thanks
  • jdudekjdudek Posts: 1
    I have the same issue and have had 3 different diagnosis. Noticed a leak in the dagasser ( reservoir on top of radiator that holds overflow ) and attempting that first. $ 60 dealer part.
    Would love feedback as this is getting extremely frustrating to troubleshoot.
Sign In or Register to comment.