Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





VW Golf Engine Problems

I had a new engine put in my tdi golf 2001.
Was working fine.
Now the heater is not working and the engine is overheating. I found out there was no antifreeze in the radiator. Any ideas?
«1345

Comments

  • cchristoucchristou Posts: 2
    I have a Golf MK3 GTI. The car likes to switch off while I'm driving. Whether on the motorway, roundabout, traffic light it just switches off. You'd think it will start if you put your foot on and off the clutch but it doesn't. It feels like its an electrical fault. I think this is a common problem as I have been told by others that they have had the same problem but not sure what it is.

    Has anyone had the same problem? Is it a common fault or do I need to change different components until it stops?
  • Sorry to hear about your problem. Try asking your question in the volkswagen Golf III and Jetta III forum at www.vwvortex.com

    If it is a common problem with the car, they'll know about it.
  • jimvwjimvw Posts: 2
    im having the same problem. Did you manage to resolve the problem ? If so can you please let me know how my email address is eileenshields50@aol.com Thanks
  • chenerchener Posts: 3
    You may find that it is the relay for the engine management system. I had the same problem some time ago. It would cut out and if you switch off and on again all would be OK for a while.
    The relay is probably about £30 and can be changed in about a minute. All relays are behind the fuses inside the car.
  • jimvwjimvw Posts: 2
    Hi,

    Thanks for getting back to me. I was wondering if it was the relay with the number 30 on it ? If not what one was it.

    Thanks
  • ecgtiecgti Posts: 1
    Hi,

    I've been having trouble with my Mk3 Golf GTI 8V consuming 1 qt of oil every 500 or so KM (about 300 miles) so I had the engine rebuilt. The problem persists even after the complete rebuild and I can't seem to find what's causing it. I've heard of VWs burning a lot of oil, but this is ridiculous. Any ideas?
  • lthlth Posts: 2
    my car was running fine and then just quit. i checked the fuel pump,fuse and relay. all are fine. the fuel pump is not getting any power to it. help......
  • Hi

    Right, the problem your having is simple, i dont know if you have sorted it due to the date on the last post. Anyway, what you need to sort out is the crank shaft sensor. Mine did the same thing, would cut out while on the motorway. I tried the exact same thing...replacing the fuses, believe me when i say it does not work.

    Hope you get it sorted

    Cheers
  • Check your oil an see if there's any water or antifreeze in the oil.(will look cloudy or milky if there's water in it) If there is water in the oil I would think you have a cracked head. Could also be a blown head gasket causing you to lose water( you should see steam coming from under the hood)If none of the above are found then you've got a leak somewhere. Hope this gives you a place to start.Also check the thermastat.
  • I have a 2001 VW GOLF with a 2.0l engine.
    I am considering getting a turbocharger on it, but all i can find on the internet is turbochargers for VW's with a 1.8l engines.
    Can i get a 1.8 turbo and use it on my 2.0 anyway?
  • ssilvassilva Posts: 6
    i have a golf 1.8 turbo.. but idk if the turbo is working or what.. you can't hear it when i step on the gas..
  • bpeeblesbpeebles Posts: 4,080
    The 1.8T engine is an AUDI engine that has a turbocharger from the factory. Thus, the kits you see on the internet improve upon the factory trubocharger design.

    The 2.0L engine is a VW engine. There are SUPERCHARGER kits for the 2.0L engine. ... but I am afraid you would need some engine-building experience to add a turbocharger to the VW 2.0L engine.
  • Hi I have 1999 VW Golf Old Body
    100,000 Miles. 2.0 Engine

    And my check engine light is on. I got it looked at the local garage and they said its a Evaporated Emissions code. I changed my vacuum tubes, and it still didn't turn off.
    I also started to notice that when i start it up, theres like a slight squealing noise from the engine area, and its coming from a pump of some sort.
    Also sometimes when idling at a stop light, instead of the RPMs being just below 1000(like it usually is) it bounces up and down above 1000, could this be involved? Can someone try to tell me what else i should do?

    Thanks John
  • p2jennp2jenn Posts: 1
    I have an '02 Golf 2.0L. At idle, the temperature stays normal. When I start driving, the engine overheats. I changed the thermostat, I changed the temp sender, new coolant, all fans work and as far as I know, changing the water pump is the last option. I need help. AutoZone has let me down yet again!!
  • frusurffrusurf Posts: 2
    my friend has a 03 golf 2.0L with the 5 speed manual. the heat just blows out cold air. at highway speeds or about 3500 rpms the temp will start to climb until the temp sensor goes off. the coolant looks fine, nor does motor steam or have that hot engine smell. i suggested thermastat? this just happened recently and engine was running perfectly fine before.
  • fionahfionah Posts: 1
    Over the past few weeks I have had problems with emissions light on-garage tested and eventually swopped coils round in the cylinders to check. Lasted about a day then light came on again, took it back and they replaced coil also cleaned throttle body. Again lasted about a day then emissions light AND EPC lights on now. Car actually runs OK, but may be doing underlying damage to eg. catalytic converter. Reluctant to keep spending on it, had already cost over #200! and no improvement. Car has done about 76k, I do about 60 miles a day, quite a lot of motorway driving. Help??!!
  • I just got my car back from a body repair shop and was very happy till I saw the Engine Light turn on. I havent taken it to the Dealership or any other European Car Repair Shop but wanted to throw it out there so maybe I could fix this myself. I have read something about an Evaporated Emissions issue?What is this code?What does it mean?Does the dealership or your repairshop tell you what needs to be done when this happens?How much has it cost you when you do whatever needs to be done to correct this code?

    Appreciate your help in advance. I must say..I am the first owner of the car, its got only 62K on it and it has been largely reliable...be it winter or summer...this is the second time I have seen this Engine Light on ..the first time was long back.

    Cheers.
«1345
Sign In or Register to comment.