Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Suburban/Tahoe Rough Idle and Stalling

14567810»

Comments

  • So, at 1:42pm on the 23rd of January, I did finally receive a call from a supervisor. Unfortunately, I was out of the office. He left a voicemail, but said that if I wanted to talk to someone I needed to call back to my rep (the one that doesn't call back). I called my rep, left a voicemail. Late that evening, there was another call back, after I had left my office.

    This is why call scheduling is important. I cannot sit by a phone for 12 hours a day waiting for a call.

    Apparently, email is not an option either, I have requested email addresses to no avail.

    I will be scouring the net to find someone at GM that has an email address that can look into this. If anyone has any emails, please, let me know. I suppose I could contact my local news channel, they have a consumer representative type section each day just for problems like this.
  • Some advice on dealing with GM Customer Service:

    If your representative will not do his job (mainly, communicate with you), keep calling, keep trying to speak with his supervisor, and document EVERYTHING.

    Today, I found out that my district representative has been suddenly moved from the department and is no longer handling any cases. I do not know if this has anything to do with the way he handled (or rather didn't handle) my case, or the other case he was assigned to at the same dealership. I know that I am not the only one to lodge several complaints against him.

    The new rep is out of TX, and seems to be genuinely concerned and invested in my problem. Even if he isn't, good on him for acting the part. I hope that we can come to some form of resolution. With this being my 3rd GM SUV/Truck purchase, and my family owning 8 other GM SUV/Truck products, I hope to continue my relationship with them.
  • I have a 04 tahoe with the 5.3 (non-flex fuel) , when coming to a stop it will occasionally die or when shutting engine off and restarting in park will run then die unless i have my foot on the gas pedal, this also happens when i put it in reverse . I have had some diagnostics ran but they show no error codes . the check engine light does not come on and the only message ive seen and rarely comes on is "tighten fuel cap "
  • Why Would Your 2003 Chevy suburban Engine Die While Driving can it be the fuelpump going
  • katiedkatied Posts: 3
    I have a 2009 LTZ Suburban and it has been a nightmare truck. At 6 months the the transmission was replaced - car would not come out of 1st gear. Then at around 30,000 milies I started to have partial/ intermittent loss of power - loss of steering, loss of brakes - all while the SUV was running. Took it to the dealer twice and they ran computer testing and said it showed no ERROR CODES so there was nothing they could do. It has been tested a total of i believe 3 or 4 times for this and with the same result - No error codes so nothing they could do. They drove it and of course the truck would not fail while they had it. My Suburban also has a OIL Consumption issue which at 1000 into an oil change i ended up stranded on a dangerous highway in PIttsburgh with my kids in the car. The car just stopped moving forward had no foward motion...would only go in reverse. It was towed to the dealer and they found it was 6 qts low on oil. Where did it go? Makes you wonder if they replaced it after the oil change. At any rate they replaced the lifters and barrings and said all fixed. Less than a year later on that same highway my Suburban lost power - I lost my steering and brakes and had to use the emergency brake to stop the car, again with my kids in the car. .. on that same highway. I waited 10 minutes and restarted the car - It seemed fine so I drove my last 3 miles home. It was towed back to the dealer and of course - There are no ERROR CODES. Will it take a dangerous accident before GM/ Chevy will realize there is something seriously wrong with this truck? From what I have read mine is not the only dangerous vehicle on the roads. I told the dealer I will not be driving it ever again and that they need to find me a solutions since I did not get the SUV i paid for - I got a dangerous death trap instead. What ever happened with your truck? Do you know anyone else who has experienced this through forums? I am trying to gather info - just incase i need it.
  • gmcustsvcgmcustsvc Posts: 4,001
    Hi katied,

    Sorry to hear that you've had these problems with your Suburban. Your dealership is best fit to diagnose and repair your concerns. If you would like for us to document your issues within our system for future reference please email us at socialmedia@gm.com [attn Amber]. Please include your full name, VIN, mileage, contact information, dealership and reference this post.

    Amber N.
    GM Customer Care
  • leirleir Posts: 2
    just bought this today and when the misfire begins the guages all jump in sequince with the misfiring. theres no smoke out the exaust nor ant backfire. when i try and restart it eventually refuses. after 20 -30 cool down, it starts right up as if it never happened. no check engine light etc. once its fully warmed up, does it all again. like to think its a fuel pump but would that cause guages to freak out or operate normally when cold? also, gas guage is stuck or failed as is temp guage.. any help PLEASE
  • katiedkatied Posts: 3
    They say it cannot be repaired because they cannot diagnose it. They believe i should drive it...are they nuts> It's not safe. Dealership of no help...they have strung me along since the transmission failed at 9,000 miles - which prior to the car being suck in first gear - it would lose power going up hills - they claimed they fixed that problem when the trannie was replaced - NOT THE CASE! it's a total lemon. 21 different things have been replaced - in the shop at dealer over 45 days and counting....
  • gmcustsvcgmcustsvc Posts: 4,001
    Hi katied,

    Again, I apologize and understand how much of an inconvenience this has been. We'd like to try and help with your problem. Please email us, and we can work towards finding a resolution to your concerns.

    Amber N.
    GM Customer Care
  • clay18clay18 Posts: 1
    had the same issue, found a tip on youtube! used crc mas air flow cleaner and crc throttle cleaner from autozone. truck running like new again. 2003 burban w 120000.
  • Update on my situation. Now looking back, I think the cleaning of the Mass Air Flow sensor was a short term fix for the real problem. The real problem being the Fuel Pump. I had all the symptoms of most of the comments in here. Sudden stalling, especially on quick acceleration or going up a hill. Sometimes stalling for no reason at all. The best explanation I have read is that with a older fuel pump the intake filter gets a "clod" in it which when under load is sucked up and blocks fuel from flowing. Once the load is removed the debris falls away and lets the vehicle run again, at least for a while. I ordered a replacement from Amazon which was a refurb for $80. I replaced it myself and have not had ANY problems since. It is NOT an easy job. Routine checks of the fuel pump indicated no problem, which is what makes this so hard to diagnose and repair. If you can't do the job, have it done for you, it has been a Godsend and has let me love my Suburban again.
  • My extended warranty just ended on 11/18/2013 and on 11/22/2013 my car's dashboard lit up like a Christmas Tree while driving home at 1:00 a.m. after a fundraiser. The car has under 79,000 miles and has been very well cared for. We nursed the car home with every light blinking = the oil gauge fluctuating and OnStar running a diagnostic test while we prayed we'd get home. The report from OnStar was a misfiring of the engine and recommended we park the vehicle and have it towed to the dealership immediately for review. So we had it towed, the dealership is now telling us that one lifter is gone and the others have to be repaired as well - $4,000+ repair. We had complained repeatedly throughout the years that the car idled rough and occasionally an engine light would come on, but since it was not replicating at the dealership they could not isolate the issue. Love our dealership, been a Chevy owner for 20+ years, but this is unbelievable for a $65k+ MSRP vehicle. So one month before Christmas, I am going to have to scrape together $4,000. Wonderful. So much for Christmas. A GM Bulletin has been issued for this situation - #10-06-01-007 - but of course a bulletin does not warrant a recall obviously given the expense of the repair. Very disappointed. Planning to speak with the dealership more tomorrow, but just so disgusted. I have praised Chevy for years and to have this happen is just inexcusable. If Chevy knows this is an issue with these engines, then step up and pay for the mistake. Cars are one of the most expensive items anyone will buy and who has $4,000 in their wallet to pay such an expense.
  • Answer: Accelerator Pedal Position Sensor!
  • We have had repeated issues with the engine on our Suburban. Replaced all (8) AMF lifters and VLOM at 27,000 miles and again at 32,000. We documented everything and filed a compliant with the district office. Our GM dealer mechanic was great - he continued to run oil consumption tests which identified the repeated issue. At 40k, when the issue appeared again, he was able to ask GM to replace our engine. Since we've had it replaced, we've had 30k miles without an issue. Continue to call and document your issue. Your dealership should be advocating for you!
  • Our dealership stinks! They have replaces all the lifters - but only after my car was 6 gts low on oil 1000 miles into an oil change - i belive that happened at 36k. but prior i had my transmission replaced at 9k miles. mine will lose power to different areas of the car while driving...like no brakes or steerling but the engine is still running. had that happen with kids in the car in a dangerous construction zone and had to use my emergency brake to stop from hitting a jersey barrier. My suburban when taken in will show NO ERROR codes so they say nothing is wrong . And of course when they have it in their possession it never malfuntions. They say no error codes means they cannot fix it. I think there is an issue with the computer but who knows. We are suing GM and Dealership at this point Dealer ship will no longer fix things since I am out of bumper to bumper. My Suburban had 70k now. THought I would get at least 150k out of it! Bummer.
  • Hey all, new to this forum but at the same time I share a lot of what I've been reading! Here's my story. We bought a 2007 suburban 5.3 AFM used about 4 years ago. It ran perfectly, with the obvious Chevy issues such as a transmission shift "flair". Oil consumption sucked about a quart of oil every 600-800 miles...but only really noticeable on highway trips. I think the AFM was definitely to blame, and after inquiring and submitting to dealership, they said it fell under "normal" category. After researching online, it most definitely was the AFM and GM had since put a shield to help reduce the oil consumption.

    Anyway, I stayed on top of the oil consumption to make sure that there was always fresh oil in the engine. Then, one day about 3.5 months ago, blinking lights, stabilitrack failure, check engine, etc etc all hell breaks lose on the highway at 65mph. I immediately pull over. Fast forward to now - all said and done, after two diagnoses by independent mechanic AND chevy dealership, I have a flat camshaft lobe that causes the misfire, which then causes everything else to go awry in the computer system. Long story short - I need to rebuild or replace my engine. WTF?? And it's only a matter of give or take $500 difference to buy a new engine installed than it is to rebuild it. So rebuilding it is out of the question.

    I pursue GM in good faith, as my family and I have always been GM people. I ask for some type of assistance as I'm out of warranty but an engine with 95% highway miles should last longer than 160k. I get the same type of runaround for nearly 3 weeks, waiting and waiting dfor a call back from the rep. I'd call every other day to touch base as I hadn't heard from her, and then finally called back to speak with another rep only to find out that the orginal girl had closed the case, stating that she couldn't get a hold of me. Um what? I called many many times , leaving the correct phone numbers to reach me, including email address! It was an obvious brush off. I couldn't believe the complete and utter disregard called "customer service". It's one thing to say no, but another to blow me off. I'm still pissed, and as I write this being a business owner myself, my mind is still blown how someone could be so blatantly rude.

    I spoke with another rep and she elevated the case to a specialist, who then couldn't help me and pointed me to the "touch point' specialist - which is my dealership!!!! WHAT? All this rigmarole to just end back up where I started - where my suburban had ben siting for nearly 3 weeks! Oh, and then they say that they can't help me with the engine, but offer $500 off the $7,000++ cost to replace it.

    GM Customer service is a JOKE! I don't know how any business, big or small, could survive with such BS. Thank God GM took my tax dollars to help stay in business, eh?

    So where do I stand? With an expensive decision to replace the engine with either a GM engine or a Jasper engine. Meanwhile, my pregnant wife (now just had our 3rd baby!) is waiting to have her car back. Do any of you have any suggestions on which ave to pursue with either engine? Experience, opinions etc?

    New GM engine or Jasper engine? Thanks!!!

    Mike

  • Read through all of this!

    I have a 2003 suburban with 316,000 miles and maybe my experience will help your diagnosis.

    At 226,000 miles my vehicle lost power on the highway and would not start. Sat for a few minutes and then it would start but then die again.

    Brought it to my mechanic and he said it was the fuel pump going out. $880 later it ran great.

    The funny part is my wife's 2001 suburban (212,000 miles)lost power while driving. Same thing, the fuel pump and another $880. Ran great after that but we sold it due to a handful of other issues.

    Now with 316K on mine I'm having an occasional idle issue and it's stalled once. I haven't had a tune up in 100K so I'm going to do that today. AC Delco plugs and wires, clean the MAF, and change the oil.

    Side note....I also add duralube to every oil change which is about every 5,000 miles. I do have to add 1 qt of oil after 3,000 miles though as it burns a little. Typical of a high mileage vehicle though.

    Only 2 other issues I've had so far is I had the gauge cluster rebuilt because the power supply was going in it and it kept cutting the gauges off and on while driving. I had all the stepper motors and lights replaced too. The second is the AC/heat blower doesn't work, or shall I say it blows a little only while the vehicle is driving highway speeds. If I'm stopped, no air comes out.

    It's been a great vehicle so far(knock on wood) with multiple trips from Atlanta where I live to Colorado 3 times, Texas a dozen times, Oklahoma 5 times, and a few dozen trips to LA, MS, and AL for work.
  • Changed the plugs and wires myself. I used AC/Delco wires and NGK TR51X plugs, used CRC MAF cleaner, cleaned my K&N air filter, and did the oil change.

    Still has the idle issue so I took it to get the belts replaced and have the altinator checked. Alt is putting out 14v and I'm going to replace it next as it was stumbling a little when the volts would dipped below 14 so I think that could be the problem. I'll respond if that fixes it.
14567810»
Sign In or Register to comment.